Subject: RE: [Rserpool] ASAP and ENRP drafts - suggested modifications

From: Johnson Walter-CWJ002 <[email-masked]>
Date: Fri, 17 Dec 2004 09:12:19 -0600

On Friday 17 December 2004 13:26, Goyal Anurag-A20942 wrote:
>> I see the need for a server identifier  (Server_Id parameter could do the
>> job) in the message ENDPOINT_KEEP_ALIVE(eka). This is required as the 
>> asap draft (version10, section 3.4 point KA2.4) says that, on receipt of >> this message, the PE should adopt the ENRP server as its home enrp 
>> server. The eka message currently has just one parameter namely 'Pool 
>> Handle Parameter', which does not carry any information about the ENRP 
>> server sending the message. Hence, it makes sense to send Server_Id as 
>> another parameter in eka.

> Yes, this makes sense.

> Furthermore, a Server_Id parameter should be added to the ASAP Server 
> Announce to make it possible for a PE/PU to find out who the PR sending 
> this announce is.

Yes this is a good idea for adding this type of information IMO for ENDPOINT_KEEP_ALIVE. 

Thomas - Server ID was recently added in ASAP draft 10 to the SERVER_ANNOUNCE message on your behalf for similar types of reasons. 

Since there is no server identifier parameter defined currently in the RSerPool drafts, I want to be clear on what we plan to add to the ENDPOINT_KEEP_ALIVE and SERVER_ANNOUNCE messages. Are we adding a server information parameter, a server ID, or a newly defined common parameter called Server Identifier parameter to the ENDPOINT_KEEP_ALIVE and SERVER_ANNOUNCE messages? I would lobby for either of the latter cases.

Walter  

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 21 Dec 2004 16:02:39 -0600

Walter,

....
> Since there is no server identifier parameter defined currently in the RSerPool drafts, I want to be clear on what we plan to add to the ENDPOINT_KEEP_ALIVE and SERVER_ANNOUNCE messages. Are we add…

I'd say either the existing Server Information TLV or the 32-bit Server ID should be used. 
Adding a new similar param may cause confusion, unless one can show that the existing params 
won't do the job.

regards,
-Qiaobing