Subject: [RSN] Fwd: I-D ACTION:draft-culler-rl2n-routing-reqs-01.txt

From: JP Vasseur <[email-masked]>
Date: Mon, 9 Jul 2007 16:27:26 -0400

Dear all,

We have updated the generic requirement document:

1) Editorial changes
2) RFC 2119 language
3) New sections: Terminology, "Route over versus Mesh-under",

In the next revision, we'll cover the security (particularly  
important due to the MP2P traffic
nature in some L2Ns such as Sensor Networks) and manageability aspects.

Comments very welcome.

Thanks.

JP and David.

Begin forwarded message:

> From: [email-masked]
> Date: July 8, 2007 6:15:02 PM EDT
> To: [email-masked]
> Subject: I-D ACTION:draft-culler-rl2n-routing-reqs-01.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: Routing Requirements for Low Power And Lossy Networks
> 	Author(s)	: J. Vasseur, D. Cullerot
> 	Filename	: draft-culler-rl2n-routing-reqs-01.txt
> 	Pages		: 11
> 	Date		: 2007-7-8
> 	
> The need for high quality routing for Low power and Lossy Network
>    (L2N) such as sensor networks comprised of highly constrained  
> devices
>    (CPU, memory, ...) in sometimes unstable wireless environments is
>    critical now and will continue to increase.  Interest in this class
>    of applications has grown dramatically in recent years and a  
> routing
>    solution addressing the specific environments of such networks is
>    highly required considering the numerous, incompatible open-source
>    and proprietary routing protocols as well as several industrial
>    forums.  The aim of this document is to define the routing
>    requirements for Sensor Networks at the IP layer.  Such routing
>    protocol(s) would need to address several unique aspects of this
>    class of embedded devices and would operate in networks comprising
>    links of various nature.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-culler-rl2n-routing- 
> reqs-01.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-culler-rl2n-routing-reqs-01.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-culler-rl2n-routing-reqs-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
RSN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rsn

---

From: "Dominik Kaspar" <[email-masked]>
Date: Tue, 10 Jul 2007 11:15:08 +0900

Hi JP,

It's good to see the new section "Route Over versus Mesh-Under" in
your draft. We have also just updated our "6lowpan Routing
Requirements" draft, including more clarification about "mesh-under
routing". Hopefully, that will lead to a better separation.

As RSN/RL2N is currently collecting different scenarios of
applications and deployment, we hope that 6lowpan's view on routing
may also serve as valuable input for 6lowpan-specific requirements,
which can be one of the application areas for RSN/RL2N.

Our updated draft should soon be available at:
http://tools.ietf.org/wg/6lowpan/draft-dokaspar-6lowpan-routreq-02.txt

Cheers,
Dominik

On 7/10/07, JP Vasseur <[email-masked]> wrote:
> In the next revision, we'll cover the security (particularly important due
> to the MP2P traffic
>    (L2N) such as sensor networks comprised of highly constrained devices
>    of applications has grown dramatically in recent years and a routing
> http://www.ietf.org/internet-drafts/draft-culler-rl2n-routing-reqs-01.txt
>
> You can also visit
> https://www1.ietf.org/mailman/listinfo/I-D-announce

---

From: JP Vasseur <[email-masked]>
Date: Tue, 17 Jul 2007 12:48:35 -0400

Hi Dominik,

> routing". Hopefully, that will lead to a better separation.

Indeed, we need to clearly show the separation to avoid confusion.

> which can be one of the application areas for RSN/RL2N.

Absolutely.

> http://tools.ietf.org/wg/6lowpan/draft-dokaspar-6lowpan-routreq-02.txt

I'll be happy to send comments.

Cheers.

JP.