Subject: unknown object class

From: Axel Hoebeke <[email-masked]>
Date: Tue, 10 Apr 2001 09:50:32 +0200

Hi,

I read in RFC 2205 that they are 3 possible ways to  treat an object
with unknown class.  This choice is determined by the two high-order
bits  of the Class-Num octet.

My question  is related to the third case:
 - Class-Num = 11bbbbbb
           The node should ignore the object but forward it,
            unexamined and unmodified, in all messages resulting
            from this message.

What should the node do if it is not possible to forward it (eg: it is
the destination node). ??
SHOULD (MUST ?) the node reject the entire message and sent a error
message back ??

Thanks in Advance,
Axel

---

From: Bob Braden <[email-masked]>
Date: Tue, 10 Apr 2001 15:37:11 GMT

*> From [email-masked]  Tue Apr 10 00:53:27 2001
  *> Date: Tue, 10 Apr 2001 09:50:32 +0200
  *> From: Axel Hoebeke <[email-masked]>
  *> X-Accept-Language: en
  *> MIME-Version: 1.0
  *> To: [email-masked]
  *> Subject: unknown object class
  *> Content-Transfer-Encoding: 7bit
  *> 
  *> Hi,
  *> 
  *> I read in RFC 2205 that they are 3 possible ways to  treat an object
  *> with unknown class.  This choice is determined by the two high-order
  *> bits  of the Class-Num octet.
  *> 
  *> My question  is related to the third case:
  *>  - Class-Num = 11bbbbbb
  *>            The node should ignore the object but forward it,
  *>             unexamined and unmodified, in all messages resulting
  *>             from this message.
  *> 
  *> What should the node do if it is not possible to forward it (eg: it is
  *> the destination node). ??
  *> SHOULD (MUST ?) the node reject the entire message and sent a error
  *> message back ??
  *> 

That would certainly violate the Principle of Least Astonishment.
If the message has reached the receiver and the receiver does not
recognize the object, it should (of course!) just ignore it.

RFC 2205 did not use capital letters here.

Bob Braden

  *> Thanks in Advance,
  *> Axel
  *> 
  *>