Subject: probable bug!!

From: Khuzema Pithewan <[email-masked]>
Date: Thu, 19 Apr 2001 17:49:38 +0530

Hi,

While going through code I found following inconsistency..

while preparing resv refresh message it calculates the scope for wild card
style  by comparing the phop addresses of each PSB in list with the scope
addresses of already existing RSB. if it matches it turns on the InScope
flag in the PSB.

Here is the part of form_scope_union() function:-

for (rp = destp->d_RSB_list; rp != NULL; rp = rp->rs_next) {
	    for (sp = destp->d_PSB_list ; sp != NULL; sp = sp->ps_next) {
		if (IsHopAPI(&sp->ps_phop))
			continue;
		if (rp->rs_scope) {
			/*
			 *	Merge scope list into scope union, by
turning
			 *	on scope bit in each matching PSB that is
not 
			 *	local API. (Doing linear search of PSBs, but

			 *	could use hash table)
			 */
			if (hop_in_scope(&sp->ps_phop, rp->rs_scope))
				sp->ps_flags |= PSBF_InScope;

 and while actually sending the resv message it construct the scope by
concatenating all the sender templates' addresses of the PSBs whose In scope
flag was turned on earlier..Here is the part of code from resv_refresh_PSB()
which does this..

	case STYLE_WF:
			flwdp->rsvp_specp = max_specp;
			flwdp->rsvp_filtp = NULL;
			pkt->rsvp_nflwd = 1;
			/*
			 *    If this sender has scope bit on, add this
			 *    sender host to the outgoing SCOPE list.
			 */
			if (sp->ps_flags & PSBF_InScope)
				scope_catf(&mapp->rsvp_scope_list,
sp->ps_templ);
			break;

so as per my understanding this is inconsistency in turing ON the InScope
flag by comparing the PHOP Addresses in place of Sender Template address...

I think its bug!!
Can somebody clarify this, please respond back.

Thanks,
Khuzema.

------------------------------------------------
Net Brahma Technologies Private Limited
Internext Networking Software
A Microland Group Company
777, 3rd 'a' cross, 18th Main 
Koramangala VI th block
Bangalore-95
Phone no.s - (080) 5521451 / 5525011 / 5525012  Ext. 232
Fax no        - (080) 5537233 
email : [email-masked]
www.netbrahma.com

---

From: Shuji Ebisu <[email-masked]>
Date: Fri, 20 Apr 2001 11:04:04 +0900

Hi

On Thu, 19 Apr 2001 17:49:38 +0530

>			 *	local API. (Doing linear search of PSBs, but
Maybe...
---------
<			if (hop_in_scope(&sp->ps_phop, rp->rs_scope))
---------
>			if (!(filterspec_in_scope(sp->ps_templ, rp->rs_scope) <0))
---------
>Can somebody clarify this, please respond back.

-----------
Shuji Ebisu