Subject: rsvp rfc 2210

From: "Hong Liao" <[email-masked]>
Date: Wed, 2 May 2001 18:15:50 -0400

Hi,

I have question for the rfc 2210.

On page of rfc 2210, the format for the Guaranteed service:

"  Service - specific general parameter headers/value", it is means that
the list of general parameter headers/values, which is consist of a list of
parameter ID, parameter flag, and parameter length.  Can anyone give me the
confirmation for this one.

I am looking forward to receiving your opinion.

Thanks in an advance.

Julia

---

From: Bob Braden <[email-masked]>
Date: Wed, 2 May 2001 23:52:45 GMT

*> From [email-masked]  Wed May  2 16:50:00 2001
  *> Subject: rsvp rfc 2210
  *> To: [email-masked]
  *> Cc: "Hong Liao" <[email-masked]>
  *> From: "Hong Liao" <[email-masked]>
  *> Date: Wed, 2 May 2001 18:15:50 -0400
  *> X-MIMETrack: Serialize by Router on notes640/Telcordia(Release 5.0.6a |January 17, 2001) at
  *>  05/02/2001 06:15:50 PM
  *> MIME-Version: 1.0
  *> 
  *> Hi,
  *> 
  *> I have question for the rfc 2210.
  *> 
  *> On page of rfc 2210, the format for the Guaranteed service:
  *> 
  *> "  Service - specific general parameter headers/value", it is means that
  *> the list of general parameter headers/values, which is consist of a list of
  *> parameter ID, parameter flag, and parameter length.  Can anyone give me the
  *> confirmation for this one.
  *> 
  *> I am looking forward to receiving your opinion.
  *> 
  *> Thanks in an advance.
  *> 
  *> Julia
  *> 
  *> 
  *> 

The complete and careful examples in the document should eliminate
ambiguity.

Bob Braden

---

From: "Hong Liao" <[email-masked]>
Date: Wed, 2 May 2001 23:23:37 -0400

Bob,

The rfc2210 do give example, but the example do not include any "Service -
specific general parameter headers/values", so I still can not find the
answer from the example.

Can you tell me if my point is correct or not?
Thanks,

Julia

Bob Braden <[email-masked]> on 05/02/2001 07:52:45 PM

To:   [email-masked], [email-masked]
cc:    (bcc: Hong Liao/Telcordia)
Subject:  Re: rsvp rfc 2210

  *> From [email-masked]  Wed May  2 16:50:00 2001
  *> Subject: rsvp rfc 2210
  *> To: [email-masked]
  *> Cc: "Hong Liao" <[email-masked]>
  *> From: "Hong Liao" <[email-masked]>
  *> Date: Wed, 2 May 2001 18:15:50 -0400
  *> X-MIMETrack: Serialize by Router on notes640/Telcordia(Release 5.0.6a
|January 17, 2001) at
  *>  05/02/2001 06:15:50 PM
  *> MIME-Version: 1.0
  *>
  *> Hi,
  *>
  *> I have question for the rfc 2210.
  *>
  *> On page of rfc 2210, the format for the Guaranteed service:
  *>
  *> "  Service - specific general parameter headers/value", it is means
that
  *> the list of general parameter headers/values, which is consist of a
list of
  *> parameter ID, parameter flag, and parameter length.  Can anyone give
me the
  *> confirmation for this one.
  *>
  *> I am looking forward to receiving your opinion.
  *>
  *> Thanks in an advance.
  *>
  *> Julia
  *>
  *>
  *>

Bob Braden

---

From: "Hong Liao" <[email-masked]>
Date: Sun, 6 May 2001 16:53:27 -0400

Madhusudhan,

Thanks for your detail explanation.
I think you agree with my point here.   "  Service - specific general
parameter headers/value", it is means that
the list of general parameter headers/values, which is consist of a list of
parameter ID, parameter flag, and parameter length.

Julia

Madhusudhan M <[email-masked]> on 05/03/2001 12:56:40 AM

To:   "'Hong Liao'" <[email-masked]>
cc:    (bcc: Hong Liao/Telcordia)
Subject:  RE: rsvp rfc 2210

Hi
  In the Intserv architecture, all processing is done on the basis of
Parameter values.So when you are sending the Flowspec object to the Traffic
control, u have to give proper information about the parameter you are
sending.The Guarenteed Flowspec has two parametes, one is the Sender Tspec
which describes the Traffic specifications and the second one is the Rspec
which defines the QOS.So while filling up the Flowspec object, a Parameter
header is included specifying the type of parameter which follows.

Regards

Madhusudhan.M
Net Brahma Technologies
Internext Networking Software
A Microland Group Venture
[email-masked]
www.netbrahma.com
Tel : 91.80. 552 1451 Extn 216
Fax : 91.80. 553 7233

> ----------
> From:   Hong Liao[SMTP:[email-masked]]
> Sent:   Thursday, May 03, 2001 8:53 AM
> To:     Bob Braden
> Cc:     [email-masked]

---

From: "Hong Liao" <[email-masked]>
Date: Thu, 10 May 2001 00:02:52 -0400

I agree with your point.

Thanks,

Julia

Madhusudhan M <[email-masked]> on 05/09/2001 11:23:02 PM

Hi
  I feel it is headers and values becoz the Flowspec structure is different
for different type of services.
Madhusudhan.M
Net Brahma Technologies
Internext Networking Software
A Microland Group Venture
[email-masked]
www.netbrahma.com
Tel : 91.80. 552 1451 Extn 216
Fax : 91.80. 553 7233

> Sent:   Thursday, May 10, 2001 2:35 AM
> To:     Madhusudhan M
> Cc:     [email-masked]
> Thanks for your reply.
> It is quite confused that the "Service-specific general parameters
> headers/values" statements, it means the "headers and values", or just
> means header values, which only includes the ParameterID, parameter
flags,
> and Parameter length.
>
> I will appreciate it if you can give me reply soon.
>
> Thanks,
>
> Julia
>
>
>
>
> > The rfc2210 do give example, but the example do not include any
"Service
> -

---

From: Apratim Mukherjee <[email-masked]>
Date: Thu, 10 May 2001 09:53:50 +0530

Hi 

I totally agree with Senthil . If there are problems in the RFC's or
something is unclear , then it is but natural for people to make queries
about them . The implementation is indeed , a wonderful effort , and a good
baseline , but i think , everyone will agree , that code will always have
bugs and room for improvements. To err is human , after all ! Hence , i
strongly believe that a very good understanding of the RFCs is also required