Subject: Regarding BFD session Detection Multiplier change

From: Mukund Mani <[email-masked]>
Date: Thu, 2 Dec 2010 17:36:49 +0530

Hi Dave

Section 6.8.12 of the BFD base draft mentions that Poll Sequence is not
required for Detect Multiplier changes.

Since in Asyncronous mode Detection Time Interval is calculated based on
Remote Detect Multiplier, is it not required to initiate a poll as is done
for changes in
Desired Tx and Required rx interval.

Or is it expected to re-calculate the Detection time on every packet
receival..?

Any specific reason why we dont restore to a  Poll during Detect Mult change
which I may be missing here??

With Regards
Mukund

---

From: Dave Katz <[email-masked]>
Date: Thu, 2 Dec 2010 08:58:06 -0800

Changing the multiplier doesn't require a poll sequence because the sending system does not change its transmit interval.  This means that the remote system cannot accidentally time out the session during the transition.

For example, if the transmit interval was 1 sec and the multiplier was changing from 3 to 2, the fact that the remote end's detection time is switching from three seconds to two is irrelevant;  the local system will keep on sending packets at the same rate and doesn't really care *when* the detection time changes.

In contrast, if the sender did something that increased its transmit interval (decreased the rate), it would need to know that the far end had upped its detection time before slowing down transmissions, or the session would be at risk.

Hope this helps.

--Dave

On Dec 2, 2010, at 4:06 AM, Mukund Mani wrote:

> Hi Dave
>  
> Section 6.8.12 of the BFD base draft mentions that Poll Sequence is not required for Detect Multiplier changes.
>  
> Since in Asyncronous mode Detection Time Interval is calculated based on Remote Detect Multiplier, is it not required to initiate a poll as is done for changes in
> Or is it expected to re-calculate the Detection time on every packet receival..?
>  
> Any specific reason why we dont restore to a  Poll during Detect Mult change which I may be missing here??
>  
>  
> With Regards
> Mukund