Subject: Mail regarding draft-wang-yang-bfd-oam

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Mon, 27 Oct 2014 12:44:33 +0000

Authors,

I see that you have just published draft-wang-yang-bfd-oam-00.

The BFD WG has formed a design team to define the yang models for the BFD technologies.

http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgYangCoord

Ensuring that multiple vendors are collaborating from the initial design, although will require more time, will help significantly to come up with the definition that accommodates large set of existing implementations.

I'm sure the authors of draft-wang-yang-bfd-oam have spent time/effort to defining your version of the BFD yang models, and I do appreciate that. What will be helpful, instead of attempting to push draft-wang-yang-bfd-oam any further, is for you to provide your input and focus to helping the BFD yang design team.

The BFD yang design team:
- will be presenting at IETF91.
- will have -00 posted, hopefully shortly after IETF91.

Thanks!

-Nobo, as the BFD WG co-chair

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 27 Oct 2014 10:09:13 -0400

> I'm sure the authors of draft-wang-yang-bfd-oam have spent time/effort to defining your version of the BFD yang models, and I do appreciate that. What will be helpful, instead of attempting to push…

I will be taking an action item to get the design team mailing list 
setup.  They're still working using mail cc: chains.  This will also provide
more openness to the work.

We'd also invite the authors of this draft to review the current git
repository of materials to see what other vendors have contributed as
materials toward modeling BFD and would invite them to contribute the draft
contents as another input to that repository.

> - will have -00 posted, hopefully shortly after IETF91.

We'd like to encourage the design team to review Wang and Wu's proposal,
specifically the BFD modeling constructs.  One of the more interesting
aspects, not yet decided at a larger IETF level, is integration with the
generic OAM framework that is starting to get attention in the LIME working
group.  In particular, the idea of "management domains".  While we see that
in this model there isn't a strong resemblance to the IEEE MEP model used
for Ethernet, there had been some prior concern about this.  Operators in
the past have strongly indicated a beneficial aspect of BFD is is didn't
require configuration integration in such a model.

While the deadline for IETF is approaching, if it's possible to include some
analysis of the proposal, that'd be helpful.  However, the chairs are very
aware that the weeks just prior to a session are usually very busy.

-- Jeff & Nobo

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 27 Oct 2014 10:46:44 -0400

Jeff,

The design team will *try* to take a look at this new draft before the meeting. But as you note, the weeks before the meeting tend to be the busiest and not the best time to take on new work. So thank you for that understanding.

Mahesh Jethanandani
[email-masked]

> On Oct 27, 2014, at 10:09 AM, Jeffrey Haas <[email-masked]> wrote:
>

---

From: wangzitao <[email-masked]>
Date: Tue, 28 Oct 2014 01:26:29 +0000

Hi, Nobo:
Apologize for my quick posting.
I didn't realize there was design team targeting to do this job when I came up this idea and wrote this draft unless Qin reminded me at the last minute in the rtg-yang-discussion list.
I am happy to cooperate with BFD YANG design team and provide our input.
Let me know who will be the contact person and I can discuss with him.

Regards!
-Michael
-----邮件原件-----
发件人: Nobo Akiya (nobo) [mailto:[email-masked]] 
发送时间: 2014年10月27日 20:45
收件人: [email-masked]
抄送: [email-masked]
主题: Mail regarding draft-wang-yang-bfd-oam

Authors,

Thanks!

---

From: wangzitao <[email-masked]>
Date: Tue, 28 Oct 2014 03:59:15 +0000

-----邮件原件-----
发件人: Jeffrey Haas [mailto:[email-masked]] 
发送时间: 2014年10月27日 22:09
收件人: [email-masked]; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: Mail regarding draft-wang-yang-bfd-oam

> I'm sure the authors of draft-wang-yang-bfd-oam have spent time/effort to defining your version of the BFD yang models, and I do appreciate that. What will be helpful, instead of attempting to push…

I will be taking an action item to get the design team mailing list setup.  They're still working using mail cc: chains.  This will also provide more openness to the work.

We'd also invite the authors of this draft to review the current git repository of materials to see what other vendors have contributed as materials toward modeling BFD and would invite them to contribute the draft contents as another input to that repository.

[Michael]: Thanks for your pointing.
Yes, we will review the latest output material in the git repository and would be happy to contribute draft contents as input if you think it useful.