Subject: Advancing S-BFD

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 18 Mar 2016 13:25:19 +0000

BFD Group, chairs, Álvaro,

Since BFD will not be meeting in IETF95 [1], I’m sending this message to the list attempting to understand the state, potential dependencies, and timing for advancing the S-BFD documents.

Note that [1] says:
“- S-BFD is done, AD comments being addressed.”

Currently, draft-ietf-bfd-seamless-base-08, submitted on 2016-02-23, addressed all of the AD Evaluation comments. Bfd-seamless-base is a hard (Normative) dependency on 5 other documents [2], which are stuck waiting for -base to move (bfd-seamless-ip, isis-sbfd, ospf-sbfd, l2tpext-sbfd, and pals-seamless-vccv). Not progressing bfd-seamless-base is blocking 6 docs (including itself)

One of the changes made as part of the AD Evaluation of draft-ietf-bfd-seamless-base is to make the rational for S-BFD in the Introduction independent (i.e., not Normatively dependent) from the use cases in bfs-seamless-use-case. Basically, bfd-seamless-base includes self-defined self-contained rational for the protocol, and informatively points to use-cases.

The bfd-seamless-use-case document was last submitted in July 2015. I can appreciate the fact that publishing use-cases after the protocol is potentially of little value — there is a value in that those use-cases can guide extensions to the protocol. But it also concerns me that there seems to be very little value for the base document to wait on publishing the use-cases first, since the -base protocol is done and the base document was updated to be independent from use cases. The use case document is only referenced by the -base document, and that pointer is Informative [3].

What’s the plan on pushing forward bfd-seamless-base (and untangling the other 5)? Is there something for the WG or editors to do (I assume not since -base has no dependencies and all AD Evaluation comments have been addressed)?

Net-net: I’d recommend moving -base (and dependents) forward.

Thanks,

— Carlos.

[1] https://www.ietf.org/mail-archive/web/rtg-bfd/current/msg03108.html
[2] https://datatracker.ietf.org/doc/draft-ietf-bfd-seamless-base/referencedby/
[3] https://datatracker.ietf.org/doc/draft-ietf-bfd-seamless-use-case/referencedby/

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Fri, 18 Mar 2016 20:31:08 +0000

On 3/18/16, 9:25 AM, "Carlos Pignataro (cpignata)" <[email-masked]>
wrote:

Carlos:

Hi!

>BFD Group, chairs, Álvaro,

I'm replying because the WG already asked for publication of the base
S-BFD documents (including the use-cases).

...
>The bfd-seamless-use-case document was last submitted in July 2015. I can
>appreciate the fact that publishing use-cases after the protocol is
>potentially of little value ‹ there is a value in that those use-cases
>can guide extensions to the protocol. But it also concerns me that there
>seems to be very little value for the base document to wait on publishing
>the use-cases first, since the -base protocol is done and the base
>document was updated to be independent from use cases. The use case
>document is only referenced by the -base document, and that pointer is
>Informative [3].
>
>What¹s the plan on pushing forward bfd-seamless-base (and untangling the
>other 5)? Is there something for the WG or editors to do (I assume not
>since -base has no dependencies and all AD Evaluation comments have been
>addressed)?

I had asked the WG to consider not publishing
draft-ietf-bfd-seamless-use-case [A], but after a lengthy exchange with
the authors and a discussion at IETF 94, the WG decided to "give another
chance to the authors" [B].

Last week I met with one of the authors of
draft-ietf-bfd-seamless-use-case; he assured me that he will be working on
the document in short order.  As you mentioned above, there is little
value in publishing the use cases *after* the solution.

The way forward is simple: I'll wait for draft-ietf-bfd-seamless-use-case
before progressing all 3 base documents together.  If the WG changes its
mind (about publishing draft-ietf-bfd-seamless-use-case) then we will have
other options.  

>Net-net: I¹d recommend moving -base (and dependents) forward.

I want to point out that there are 5 authors *and* 5 contributors listed
in draft-ietf-bfd-seamless-use-case (including 4 of the 5 authors of
draft-ietf-bfd-seamless-base).  I would hope that we could find more than
one person willing and able to complete the work -- and not depend on just
one.

Thanks!

Alvaro.

[A] 
https://mailarchive.ietf.org/arch/msg/rtg-bfd/kin3Me4WrKbe9WljhkSfkKvsefA
[B] https://www.ietf.org/proceedings/94/minutes/minutes-94-bfd

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 18 Mar 2016 23:25:34 +0000

Álvaro,

Thanks for the response! — please see inline.

> On Mar 18, 2016, at 4:31 PM, Alvaro Retana (aretana) <[email-masked]> wrote:
> 

A video [Ψ] is worth a lot more than a thousand meeting minutes [B]. I must say that [Ψ] conveys the sentiment with much more richness!

[B] that you cite says:

"[Jeff]
S-BFD use case document publication status - what is the feeling of WG? Taking
sense of the room. Do you think we should publish this? Not to publish this?
Two people have opinion on this, one way or the other. Sense of WG is that this
is not critical work, will give another chance to the authors.”

Basically:
“Two people have opinion on this”
“this is not critical work”
"will give another chance to the authors”
That does not sounds terribly convincing. Don’t get me wrong — I personally have no strong opinion about what to do with use-case; in fact, I find it terribly disappointing and even demoralizing that folks invest their volunteer time to get to Finish_Line_minus_5_minutes and be told ‘the race got cancelled’. I believe those decisions are taken early and then we stick with the decision, and IETF WGs and chairs will be much better served with an actual IESG statement about this. However, I do have an opinion about not artificially slowing down protocol work, and I believe that protocol (i.e., the 5 S-BFD documents on base, ip, ospf, isis, l2tpext, and pals) work is the high-order bit in this set.

In any case, I have one quick question: WG, Jeff, Reshad, Alvaro, when does this 'another chance' expire? By Buenos Aires?

> value in publishing the use cases *after* the solution.

What’ the value for bfd-seamless-base for waiting? Does it get better with age?

> mind (about publishing draft-ietf-bfd-seamless-use-case) then we will have

See above — wait indefinitely?

> one person willing and able to complete the work -- and not depend on just

Thank you!

— Carlos.

[Ψ] https://youtu.be/ZCQ08Q-Nnn4?t=390

---

From: Marc Binderberger <[email-masked]>
Date: Fri, 18 Mar 2016 17:28:03 -0700

Hello Alvaro, Carlos and BFD work group,

I think "bfd-seamless-base" is ready to go - so we should move forward 
towards RFC. I do no see any value waiting. Waiting for what?

>> value in publishing the use cases *after* the solution.

I disagree with this. Neither the base draft nor the implementations will 
change anymore, whether the use-case is published before, after or at all.

> personally have no strong opinion about what to do with use-case; in fact, 
> I find it terribly disappointing and even demoralizing that folks invest 
> their volunteer time to get to Finish_Line_minus_5_minutes and be told ‘
> the race got cancelled’. I believe those decisions are taken early and 

agree. That's an IETF problem: you want a discussion about the use cases to 
clarify the problem, to clarify the direction to go. But once you had this 
discussion the focus should be on the main technical drafts. Use-cases are 
somewhat a disposable. We should honor the work but I don't think the usual 
mechanisms do fit.

Maybe we should treat use-case documents on a fast track to informal RFC? And 
work groups should have a focus on terminating the use-case discussions 
early? Accept these documents will have a "raw" appeal because that's what 
they are?

Anyway, I would propose to move on with the drafts that define the technical 
standards.

For the use-case document, Carlos wrote ...

"[...] there is a value in that those use-cases can guide extensions to the 
protocol."

... and we actually may have a good discussion in the work group about the 
future of S-BFD and use the use-case document to keep these avenues open. 
Again, I don't see there is any interlock which documents are first.

Regards, Marc

On Fri, 18 Mar 2016 23:25:34 +0000, Carlos Pignataro (cpignata) wrote:
> A video [Ψ] is worth a lot more than a thousand meeting minutes [B]. I 
> must say that [Ψ] conveys the sentiment with much more richness!
> 
> [B] that you cite says:
> 
> "[Jeff]
> 	•	“Two people have opinion on this”
> 	•	“this is not critical work”
> 	•	"will give another chance to the authors”
> That does not sounds terribly convincing. Don’t get me wrong — I 
> personally have no strong opinion about what to do with use-case; in fact, 
> I find it terribly disappointing and even demoralizing that folks invest 
> their volunteer time to get to Finish_Line_minus_5_minutes and be told ‘
> the race got cancelled’. I believe those decisions are taken early and 
> then we stick with the decision, and IETF WGs and chairs will be much 
> better served with an actual IESG statement about this. However, I do have 
> an opinion about not artificially slowing down protocol work, and I believe 
> that protocol (i.e., the 5 S-BFD documents on base, ip, ospf, isis, 
> l2tpext, and pals) work is the high-order bit in this set.
> 
> In any case, I have one quick question: WG, Jeff, Reshad, Alvaro, when does 
> this 'another chance' expire? By Buenos Aires?
> 
>

---

From: Sam Aldrin <[email-masked]>
Date: Fri, 18 Mar 2016 18:09:12 -0700

Hi Carlos,

I do owe a new version with comments addressed, irrespective of whether it
becomes RFC or not.
Few top level points though.
1. If you are making decisions based on how many are interested, BFD WG
will disappoint you, pretty much every draft. Mailing list is the
reflection of it.
2. Till there is a parking place for documents like use cases, problem
statements, Frameworks, it is moot point to say that, there is no use.

Fact of the matter, IETF takes too long that protocols becomes obsolete
before they become RFC and no one know what those protocols are trying to
solve (lack of use case?). :D

Having said that, will try to get a version soon and let WG deal with it
however it likes.
Unfortunately IETF is not fulltime job and co-authors and contributors have
gone incognito.

On Fri, Mar 18, 2016 at 4:25 PM, Carlos Pignataro (cpignata) <
[email-masked]> wrote:

> *"[Jeff]*
> *S-BFD use case document publication status - what is the feeling of WG?
> Taking*
> *sense of the room. Do you think we should publish this? Not to publish
> this?*
> *Two people have opinion on this, one way or the other. Sense of WG is
> that this*
> *is not critical work, will give another chance to the authors.”*
>
> *Basically:*
>
>    - “*Two* people have opinion on this”
>    - “this is *not critical work*”
>    - "will give *another chance* to the authors”
>
> their volunteer time to get to Finish_Line_minus_5_minutes and be told ‘the
> race got cancelled’. I believe those decisions are taken early and then we
> stick with the decision, and IETF WGs and chairs will be much better served
> with an actual IESG statement about this. However, I do have an opinion
> about not artificially slowing down protocol work, and I believe that
> protocol (i.e., the 5 S-BFD documents on base, ip, ospf, isis, l2tpext, and
> pals) work is the high-order bit in this set.
>
%sam - If 'S' in S-BFD meant SDN, it would have been different story :D.
IMO, if usecase or requirements do not have interest, why would protocols
are important and have interest? Alternately, question to be asked is, why
is WG not interested. Document or SBFD itself?

>
> In any case, I have one quick question: WG, Jeff, Reshad, Alvaro, when
> does this 'another chance' expire? By Buenos Aires?
>
>
%sam - I take the ownership for cause of this delay. Let me revert back
with updated version.

> See above — wait indefinitely?
%sam - Have you tried your hands at MIB documents? :D

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 19 Mar 2016 01:29:52 +0000

Hi Sam,
thank you for your dedication. Please let me know if I can be of any help.

                Regards,
                                Greg

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Sam Aldrin
Sent: Friday, March 18, 2016 6:09 PM
To: Carlos Pignataro (cpignata)
Cc: <[email-masked]>
Subject: Re: Advancing S-BFD

Hi Carlos,

I do owe a new version with comments addressed, irrespective of whether it becomes RFC or not.
Few top level points though.
1. If you are making decisions based on how many are interested, BFD WG will disappoint you, pretty much every draft. Mailing list is the reflection of it.
2. Till there is a parking place for documents like use cases, problem statements, Frameworks, it is moot point to say that, there is no use.

Fact of the matter, IETF takes too long that protocols becomes obsolete before they become RFC and no one know what those protocols are trying to solve (lack of use case?). :D

Having said that, will try to get a version soon and let WG deal with it however it likes.
Unfortunately IETF is not fulltime job and co-authors and contributors have gone incognito.

On Fri, Mar 18, 2016 at 4:25 PM, Carlos Pignataro (cpignata) <[email-masked]<mailto:[email-masked]>> wrote:
Álvaro,

On Mar 18, 2016, at 4:31 PM, Alvaro Retana (aretana) <[email-masked]<mailto:[email-masked]>> wrote:

On 3/18/16, 9:25 AM, "Carlos Pignataro (cpignata)" <[email-masked]<mailto:[email-masked]>>
wrote:

Carlos:

Hi!

...

[B] that you cite says:

"[Jeff]

Basically:

  *   “Two people have opinion on this”
  *   “this is not critical work”
  *   "will give another chance to the authors”
That does not sounds terribly convincing. Don’t get me wrong — I personally have no strong opinion about what to do with use-case; in fact, I find it terribly disappointing and even demoralizing that folks invest their volunteer time to get to Finish_Line_minus_5_minutes and be told ‘the race got cancelled’. I believe those decisions are taken early and then we stick with the decision, and IETF WGs and chairs will be much better served with an actual IESG statement about this. However, I do have an opinion about not artificially slowing down protocol work, and I believe that protocol (i.e., the 5 S-BFD documents on base, ip, ospf, isis, l2tpext, and pals) work is the high-order bit in this set.
%sam - If 'S' in S-BFD meant SDN, it would have been different story :D. IMO, if usecase or requirements do not have interest, why would protocols are important and have interest? Alternately, question to be asked is, why is WG not interested. Document or SBFD itself?

What’ the value for bfd-seamless-base for waiting? Does it get better with age?
%sam - I take the ownership for cause of this delay. Let me revert back with updated version.

Thanks!

Thank you!

Alvaro.

— Carlos.

[A]

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 21 Mar 2016 22:38:51 -0400

> mind (about publishing draft-ietf-bfd-seamless-use-case) then we will have

I have just reviewed the updated -04 for the use case document.

It's my belief that the issues you had raised are covered in this update.

There are a number of small grammatical and typo issues in the document, but
none that should impact clarity upon the editing process.  I would propose
that we leave the cleanup of these to the RFC Editor who will do a much
better job of it than the WG will in fewer passes. :-)

I believe this document is ready to advance with the bundle.

On Fri, Mar 18, 2016 at 11:25:34PM +0000, Carlos Pignataro (cpignata) wrote:
> their volunteer time to get to Finish_Line_minus_5_minutes and be told
> ‘the race got cancelled’. I believe those decisions are taken early and
> an opinion about not artificially slowing down protocol work, and I
> believe that protocol (i.e., the 5 S-BFD documents on base, ip, ospf,
> isis, l2tpext, and pals) work is the high-order bit in this set.

The fact that the sense of IETF has been shifting away from publishing use
case documents is something that caught the contributors to the draft in
mid-stream.  It's for that reason the chairs and the Alvaro have been
patient about advancing the bundle.

(It doesn't hurt that we also hit a common IETF pattern that the required
edits for the other documents didn't happen until near the cut-off. :-)

While I think we'll be using this effort as an example of how *not* to
motivate use case authors, let's push this to the finish line.

-- Jeff