Subject: I-D Action: draft-ietf-bfd-stability-09.txt

From: [email-masked]
Date: Sat, 10 Apr 2021 19:06:36 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Bidirectional Forwarding Detection WG of the IETF.

        Title           : BFD Stability
        Authors         : Ashesh Mishra
                          Mahesh Jethanandani
                          Ankur Saxena
                          Santosh Pallagatti
                          Mach Chen
                          Peng Fan
	Filename        : draft-ietf-bfd-stability-09.txt
	Pages           : 13
	Date            : 2021-04-10

Abstract:
   This document describes extensions to the Bidirectional Forwarding
   Detection (BFD) protocol to measure BFD stability.  Specifically, it
   describes a mechanism for detection of BFD packet loss.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-bfd-stability-09
https://datatracker.ietf.org/doc/html/draft-ietf-bfd-stability-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bfd-stability-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mahesh Jethanandani <[email-masked]>
Date: Sat, 10 Apr 2021 19:19:52 -0700

This version of the draft addresses YANG Doctors comments and also removes the augmentation of TE model, as it has been dropped from the BFD YANG model also.

Comments are welcome.

> On Apr 10, 2021, at 7:06 PM, [email-masked] wrote:
> 
> 

Mahesh Jethanandani
[email-masked]

---

From: Reshad Rahman <[email-masked]>
Date: Sun, 11 Apr 2021 14:19:57 -0400

Hi Mahesh,

Thanks for the update, looks good.

Nits:

Section 6.1:
Is lsp really needed in this paragraph? If lsp is kept, please capitalize to LSP (and add a reference).
   This YANG module augments the "ietf-bfd" module to add the loss count
   to the per-session or lsp for BFD packets that are lost.

Section 7.2: s/registers one YANG modules/registers one YANG module/

Also, a couple of minor comments from a previous version haven't been addressed  (see attached).

Regards,
Reshad.

On 2021-04-10, 10:20 PM, "Rtg-bfd on behalf of Mahesh Jethanandani" <[email-masked] on behalf of [email-masked]> wrote:

    Comments are welcome.

    Mahesh Jethanandani
    [email-masked]

Subject: Re: New Version Notification for draft-ietf-bfd-stability-07.txt
From: Reshad Rahman <reshad=[email-masked]>
To: Santosh P K <[email-masked]>, rtg-bfd WG <[email-masked]>
Date: Sat, 30 Jan 2021 18:26:32 -0500
List-Id: "RTG Area: Bidirectional Forwarding Detection DT" <rtg-bfd.ietf.org>

Hi Santosh,

Thanks for making the changes and addressing my comments.

Nits:
Null was changed to NULL except in the header of section 4
In section 4, it’d be good to have informative references for CFM and OWAMP.

Regards,

Reshad.

From: Rtg-bfd <[email-masked]> on behalf of Santosh P K <[email-masked]>
Date: Thursday, January 14, 2021 at 8:35 AM
To: rtg-bfd WG <[email-masked]>
Subject: Fwd: New Version Notification for draft-ietf-bfd-stability-07.txt

I have refreshed stability draft. Diff from the previous version is attached. 

---------- Forwarded message ---------
From: <[email-masked]>
Date: Thu, Jan 14, 2021 at 3:28 PM
Subject: New Version Notification for draft-ietf-bfd-stability-07.txt
To: Ankur Saxena <[email-masked]>, Ashesh Mishra <[email-masked]>, Mach Chen <[email-masked]>, Mahesh Jethanandani <[email-masked]>, Peng Fan <[email-masked]>, Santosh Pallagatti <[email-masked]>

A new version of I-D, draft-ietf-bfd-stability-07.txt
has been successfully submitted by Santosh Pallagatti and posted to the
IETF repository.

Name:           draft-ietf-bfd-stability
Revision:       07
Title:          BFD Stability
Document date:  2021-01-14
Group:          bfd
Pages:          6
URL:            https://www.ietf.org/archive/id/draft-ietf-bfd-stability-07.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-bfd-stability
Htmlized:       https://tools.ietf.org/html/draft-ietf-bfd-stability-07
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-bfd-stability-07

Abstract:

The IETF Secretariat

Subject: Re: New Version Notification for draft-ietf-bfd-stability-06.txt
From: Santosh P K <[email-masked]>
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: rtg-bfd WG <[email-masked]>, "reshad@yahoo. com" <[email-masked]>
Date: Sat, 28 Nov 2020 17:57:08 +0530
List-Id: "RTG Area: Bidirectional Forwarding Detection DT" <rtg-bfd.ietf.org>

Sure will do that.

On Tue, Nov 24, 2020, 5:54 AM Reshad Rahman (rrahman) <[email-masked]>
wrote:

> Hi Santosh, authors,
>
>
>
> The comments below are pretty minor. Please address them in next rev and
> we’ll be good to go to next step for this document.
>
>
>
> Regards,
>
> Reshad,
>
>
>
> *From: *Rtg-bfd <[email-masked]> on behalf of "Reshad Rahman
> (rrahman)" <rrahman=[email-masked]>
> *Date: *Thursday, July 23, 2020 at 10:43 PM
> *To: *Santosh P K <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: New Version Notification for
> draft-ietf-bfd-stability-06.txt
>
>
>
> Hi Santosh,
>
>
>
> Thanks for addressing the comments.
>
>
>
> General: NULL authentication TLV is still used, should be replaced with
> NULL authentication type or section as appropriate.
>
> Be consistent for Null v/s NULL (NULL Auth is used in
> bfd-optimizing-authentication)
>
>
>
> Introduction
>
> s/detect lost packet/detect lost packets/
>
>
>
> Section 3 Use Cases:
>
> s/any BFD packet loss if loss/any BFD packet loss if the loss/
>
> s/BFD implementation/BFD implementations/
>
> Where the text says “failure of a link”, might be better to say “failure
> of a datapath”?
>
> Informative references to CFM and TWAMP would be useful
>
>
>
> Section 4
>
> “by appending the Null-Authentication type “. Suggest “by appending an authentication section with the NULL Authentication type “
>
>
>
> Section 5
>
> “BFD uses authentication TLV”, suggest change to “BFD uses an
> authentication section”.
>
>
>
> “BFD packets MUST include NULL-Auth TLV”. Change to “BFD control packets
> MUST include an authentication section with the NULL Authentication type”
>
>
>
> Section 5.1
>
>
>
> “The first BFD NULL-Auth type processed by the receiver…”.  Change to  “The first BFD authentication section with the NULL Authentication type, in a valid BFD control packet, processed by the receiver” .
>
> Also, does it have to be NULL Auth, I believe it can be any auth with sequence number? If that’s the case change to  “The first BFD authentication section with a non-zero sequence number, in a valid BFD control packet, processed by the receiver is used for….”.
>
>
>
> Regards,
>
> Reshad.
>
>
>
> *From: *Rtg-bfd <[email-masked]> on behalf of Santosh P K <
> [email-masked]>
> *Date: *Sunday, July 19, 2020 at 4:06 PM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *Fwd: New Version Notification for
> draft-ietf-bfd-stability-06.txt
>
>
>
> Hello All,
>
>     A new version of draft for BFD-stablity is here for review. Changes
> include addressing shepherd comments as provided here.
> https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/shepherdwriteup/.
> Please also see attached diff.
>
>
>
> Thanks
>
> Santosh P K
>
> ---------- Forwarded message ---------
> From: <[email-masked]>
> Date: Mon, Jul 13, 2020 at 4:41 PM
> Subject: New Version Notification for draft-ietf-bfd-stability-06.txt
> To: Mach Chen <[email-masked]>, Ankur Saxena <[email-masked]>,
> Peng Fan <[email-masked]>, Mahesh Jethanandani <[email-masked]>,
> Ashesh Mishra <[email-masked]>, Santosh Pallagatti <
> [email-masked]>
>
>
>
>
> A new version of I-D, draft-ietf-bfd-stability-06.txt
> has been successfully submitted by Santosh Pallagatti and posted to the
> IETF repository.
>
> Name:           draft-ietf-bfd-stability
> Revision:       06
> Title:          BFD Stability
> Document date:  2020-07-13
> Group:          bfd
> Pages:          6
> URL:
> https://www.ietf.org/internet-drafts/draft-ietf-bfd-stability-06.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-bfd-stability-06
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-ietf-bfd-stability
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-bfd-stability-06
>
> Abstract:
> The IETF Secretariat