Subject: Draft liaison statement to BBF re: TR-146 and draft-ietf-bfd-unaffiliated-echo

From: Jeffrey Haas <[email-masked]>
Date: Wed, 24 Nov 2021 11:46:18 -0500

Working Group,

The chairs are considering the following text for a liaison statement to the 
Broadband Forum with regard to draft-ietf-bfd-unaffiliated-echo.

We'd like your feedback before we send it out.

-- Jeff

-------------

From group: bfd
From Contact: Jeffrey Haas
To Group: Broadband-forum
To Contacts: (bbf-contacts)
Cc: [email-masked], [email-masked], [email-masked]
Response Contact: Jeffrey Haas, Reshad Rahman

Body:
The IETF Bidirectional Forwarding Detection (BFD) Working Group has begun
work on "Unaffiliated BFD Echo Function".  This work is happening in the
Internet-Draft draft-ietf-bfd-unaffiliated-echo.[1]

The BFD protocol (IETF RFC 5880, etc.) is used as a service in routers and
other IP gateway devices for testing bi-directional connectivity.  Such
devices benefit from having BFD as a common interface for monitoring the
status of such connectivity.  

The purpose of this work is to permit an implementation of BFD that supports
Echo functionality to be used with a Internet Protocol host that does not
support the BFD protocol, but is capable of providing the packet loopback
behavior required by the BFD Echo mechanism.  

The BFD Working Group is aware of an overlapping use case addressed by 
BBF TR-146.

We welcome feedback and further dialog regarding this work.

[1] https://datatracker.ietf.org/doc/draft-ietf-bfd-unaffiliated-echo/

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 24 Nov 2021 17:04:20 -0500

This looks like a fine liaison to me.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: David Sinicrope <[email-masked]>
Date: Wed, 24 Nov 2021 18:07:28 -0500

Hi Jeff,

One suggestion on the
line requesting feedback:  We don't really want any SDO using
the liaison process as a substitute for participation in the
IETF process.  Some organizations consider a liaison to carry
the collective weight of the organization and expect technical
comments in the liaison to carry the same weight. (vs individual
comments).  Such is not the case in IETF.  That said, the
organization is of course free to provide feedback via liaison
response in whatever form they see fit.

It would be good to add
the following
to make it clear that we prefer comments through the IETF
process while still leaving the door open for the SDO (BBF) to
respond as they deem appropriate:

"Those interested in
providing detailed feedback and technical comment on the draft
are encouraged to participate in the development of the draft in
the IETF via the IETF process."

I hope this helps.  Please let me know if you have any questions.

Dave

On 11/24/21 11:46, Jeffrey Haas wrote:

Working Group,

-- Jeff

-------------

Body:

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 24 Nov 2021 19:03:31 -0500

David,

Thanks for the feedback.  I had considered adding such a line to the statement but was wary of the implication of "you must come here to participate".  If such is acceptable, I'll add it to the next iteration.

-- Jeff

> On Nov 24, 2021, at 6:07 PM, David Sinicrope <[email-masked]> wrote:
> 
> Hi Jeff, 
> 
> One suggestion on the line requesting feedback:  We don't really want any SDO using the liaison process as a substitute for participation in the IETF process.  Some organizations consider a liaison to carry the collective weight of the organization and expect technical comments in the liaison to carry the same weight. (vs individual comments).  Such is not the case in IETF.  That said, the organization is of course free to provide feedback via liaison response in whatever form they see fit.  
> 
> It would be good to add the following to make it clear that we prefer comments through the IETF process while still leaving the door open for the SDO (BBF) to respond as they deem appropriate:   
> 
> "Those interested in providing detailed feedback and technical comment on the draft are encouraged to participate in the development of the draft in the IETF via the IETF process."
> 
>> Cc: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
>> [1] https://datatracker.ietf.org/doc/draft-ietf-bfd-unaffiliated-echo/ <https://datatracker.ietf.org/doc/draft-ietf-bfd-unaffiliated-echo/>
>>