Subject: Re: [Rtg-yang-coord] NETMOD: A YANG module for NAT

From: Nadeau Thomas <[email-masked]>
Date: Mon, 21 Sep 2015 08:57:19 -0700

I’d also copy the routing coordination group who can help as this is “a routing thing”.

	—Tom

> On Sep 20, 2015:11:14 PM, at 11:14 PM, Juergen Schoenwaelder <[email-masked]> wrote:
> 
> On Mon, Sep 21, 2015 at 05:44:42AM +0000, [email-masked] wrote:
>> Hi Jurguen,
>> 
>> We prepared a draft to specify a YANG module that covers various NAT flavors (NAT44, NAT64): https://tools.ietf.org/html/draft-sivakumar-yang-nat-03
>> 
>> As there is no home for this work (behave wg closed), I wonder whether this effort can be hosted in netmod as I read the following in the charter:
>> 
>> "
>> The NETMOD WG may also develop any additional data models written in YANG that the WG considers core building blocks and that do not fall under the charters of other active IETF working groups. The NETMOD WG may simply add such milestones as it sees fit, with the advice and consent of the responsible AD.
>> "
>> 
> 
> You are welcome to send a pointer to the NETMOD WG list so that people
> are aware that this work out there. Whether NETMOD is the right place
> I can't tell at the moment. The other obvious choice would be TSVWG.
> The key is to get a sufficient number of people with NAT
> implementation experience to review this. I am CC'ing my response to
> the other NETMOD co-chairs (since I am leaving and hence they will
> have to take responsibility should this work be done in NETMOD).
> 
> /js
> 
> -- 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Nadeau Thomas <[email-masked]>
Date: Mon, 21 Sep 2015 11:02:56 -0700

—Tom