Subject: Fwd: RFC 5378 and Draft Submissions

From: "John G. Scudder" <[email-masked]>
Date: Fri, 16 Jan 2009 16:54:14 -0500

Folks submitting Internet Drafts which incorporate material from  
earlier IETF content should be aware of the below.  You may also want  
to take a look at http://www.ietf.org/mail-archive/web/ietf/current/msg54839.html 
  .

I would be interested in knowing if any rtgwg draft authors believe  
they will be affected by this issue.  Any discussion of this issue not  
specifically related to rtgwg drafts should be taken to the main IETF  
discussion list where you will find a lively discussion underway.

--John

Begin forwarded message:

> From: "Eric Rescorla" <[email-masked]>
> Date: January 15, 2009 12:03:42 AM GMT-05:00
> To: "Working Group Chairs" <[email-masked]>
> Subject: Fwd: RFC 5378 and Draft Submissions
>
> FYI
>
>
> ---------- Forwarded message ----------
> From: Eric Rescorla <[email-masked]>
> Date: Wed, Jan 14, 2009 at 9:03 PM
> Subject: RFC 5378 and Draft Submissions
> To: [email-masked]
>
>
> IETF Chair Russ Housley has asked WG chairs to apprise their WGs of
> the following information.
>
> If you've been following the IETF mailing list, you may be aware of
> the ongoing discussion about the impact of RFC 5378 on revised draft
> submissions. Briefly, RFC 5378 requires Contributors to grant a more
> expansive set of rights than were granted by RFC 3978, and 4748. If
> you are submitting a document which contains text contributed by
> others prior to the publication of RFC 5378 you may need to obtain
> additional rights from the
> copyright holders of that text in order to contribute under the 5378
> terms.
>
> The IESG and the IETF Trustees are working to resolve those issues
> (see
> http://trustee.ietf.org/docs/Background-to-Draft-Update-to-IETF-Trust-Legal-Provisions.txt) 
> .
> However,
> at present I would advise care prior to submitting any draft
> which contains material derived from an RFC, draft, or mailing
> list message published prior to November 10, 2008.
> Speaking personally, I have chosen not to submit new versions
> of most of my drafts until matters are resolved.
>
> Please take any general discussion of RFC 5378 to [email-masked]
>
> -Ekr
> [As WG Chair]

_______________________________________________
rtgwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 16 Jan 2009 16:23:50 -0800

Hi John,

Not for rtgwg but for idr wg I have been struggling with this for the 
last 10 days and it's just hopeless.

Can we ask Bill to post real xml2rfc translation 1.34 which does the job 
right and we all are done ?

The beta 1.34r2 currently available still fails the new IDNITS check.

Thx,
R.

> Folks submitting Internet Drafts which incorporate material from earlier 
> IETF content should be aware of the below.  You may also want to take a 
> look at http://www.ietf.org/mail-archive/web/ietf/current/msg54839.html .
> 
> I would be interested in knowing if any rtgwg draft authors believe they 
> will be affected by this issue.  Any discussion of this issue not 
>> http://trustee.ietf.org/docs/Background-to-Draft-Update-to-IETF-Trust-Legal-Provisions.txt). 
>>
>> However,

---

From: "John G. Scudder" <[email-masked]>
Date: Sat, 17 Jan 2009 19:19:10 -0500

For the benefit of others: The problem Robert was having turned out to  
be that to pass the new idnits, assuming you're using the XML template  
you have to not only use the beta xml2rfc but also put in  
'ipr="trust200811"' in the <rfc> element.

Note that having done so, your I-D will contain new IPR language.   
Whether that IPR language is acceptable to you is another matter and  
is what the initial message was about.

--John

On Jan 16, 2009, at 7:23 PM, Robert Raszuk wrote:

> Hi John,
>
> Not for rtgwg but for idr wg I have been struggling with this for  
> the last 10 days and it's just hopeless.
>
> Can we ask Bill to post real xml2rfc translation 1.34 which does the  
> job right and we all are done ?
>
>> earlier IETF content should be aware of the below.  You may also  
>> want to take a look at http://www.ietf.org/mail-archive/web/ietf/current/msg54839.html 
>>  .
>> they will be affected by this issue.  Any discussion of this issue  
>> not specifically related to rtgwg drafts should be taken to the  
>> main IETF discussion list where you will find a lively discussion  
>> underway.
>> --John
>> Begin forwarded message:

From: [email-masked]
To: [email-masked]
Subject: I-D Action:draft-ietf-rtgwg-ipfrr-framework-10.txt 
Date: Fri, 27 Feb 2009 06:30:02 -0800 (PST)
Cc: [email-masked]

--NextPart

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Routing Area Working Group Working Group of the IETF.

	Title           : IP Fast Reroute Framework
	Author(s)       : M. Shand, S. Bryant
	Filename        : draft-ietf-rtgwg-ipfrr-framework-10.txt
	Pages           : 15
	Date            : 2009-02-27

This document provides a framework for the development of IP fast-
reroute mechanisms which provide protection against link or router
failure by invoking locally determined repair paths.  Unlike MPLS
fast-reroute, the mechanisms are applicable to a network employing
conventional IP routing and forwarding.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-rtgwg-ipfrr-framework-10.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

--NextPart
Content-Type: Message/External-body;
	name="draft-ietf-rtgwg-ipfrr-framework-10.txt";
	site="ftp.ietf.org";
	access-type="anon-ftp";
	directory="internet-drafts"

Content-Type: text/plain
Content-ID: <[email-masked]>

--NextPart--