Subject: RTGWG LC for draft-ietf-rtgwg-bgp-routing-large-dc

From: Jeff Tantsura <[email-masked]>
Date: Mon, 3 Aug 2015 03:31:13 +0000

Hi RTGWG,

This email is to start 2 weeks RTGWG LC for
draft-ietf-rtgwg-bgp-routing-large-dc-05
Authors have addressed all the comments.

Please indicate support or no-support as well as your comments by August
18, 2015.

If you are listed as a document author or contributor please respond to
this email stating of whether or not you are aware of any relevant IPR.
The response needs to be sent to the RTGWG mailing list. The document will
not advance to the next stage until a response has been received from each
author and each individual that has contributed to the document.

Thanks,

Jeff & Chris

---

From: Petr Lapukhov <[email-masked]>
Date: Mon, 3 Aug 2015 04:47:05 +0000

Hi Jeff,

Thanks for moving this forward! 

I'm not aware of any IPR associated with the document.

Best regards,

Petr
________________________________________
From: rtgwg [[email-masked]] on behalf of Jeff Tantsura [[email-masked]]
Sent: Sunday, August 02, 2015 8:31 PM
To: [email-masked]
Cc: [email-masked]; rtgwg-chairs
Subject: RTGWG LC for draft-ietf-rtgwg-bgp-routing-large-dc

Hi RTGWG,

Thanks,

Jeff & Chris

_______________________________________________
rtgwg mailing list
[email-masked]
https://urldefense.proofpoint.com/v1/url?u=https://www.ietf.org/mailman/listinfo/rtgwg&k=ZVNjlDMF0FElm4dQtryO4A%3D%3D%0A&r=4Cgrr4FbaWmFJmFxSc8F6Q%3D%3D%0A&m=coWo%2B6SXtPCjDaHfR5BdtKqwtXre0mW25rq53qYFpbw%3D%0A&s=676ba198da7627d74cd95d9b732df8ecac99ca80ab35bf73f3565970262ef008

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 3 Aug 2015 10:40:00 +0200

Support !

Thx,
r.

On Mon, Aug 3, 2015 at 5:31 AM, Jeff Tantsura <[email-masked]>
wrote:

> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 3 Aug 2015 10:21:32 +0000

Support. 
Acee

---

From: Ebben Aries <[email-masked]>
Date: Mon, 3 Aug 2015 16:14:00 +0200

support

On 08/03/2015 05:31 AM, Jeff Tantsura wrote:
> https://urldefense.proofpoint.com/v1/url?u=https://www.ietf.org/mailman/listinfo/rtgwg&k=ZVNjlDMF0FElm4dQtryO4A%3D%3D%0A&r=GJQFPrZyyh453ywaGV%2FvoQ%3D%3D%0A&m=TtKTnZzFkNer45AgU5bOkA2NX2NiPtylLsJycE3kEpk%3D%0A&s=ae0b6e8c321ceaeef25471f4585c356345011bb0ffbbb48e92a670cfa9865ce0
>

---

From: Pushpasis Sarkar <[email-masked]>
Date: Mon, 3 Aug 2015 15:06:09 +0000

Support

Thanks
-Pushpasis

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Mon, 3 Aug 2015 17:18:06 +0000

support

---

From: Antoni Przygienda <[email-masked]>
Date: Mon, 3 Aug 2015 17:20:44 +0000

Support +1 

thanks 

--- tony
 
An idealist believes that the short run doesn't count. A cynic believes the long run doesn't matter. A realist believes that what is done or left undone in the short run determines the long run. ~~~ Sidney J. Harris 

> -----Original Message-----
> From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
> Please indicate support or no-support as well as your comments by August 18,
> 2015.
> 
> If you are listed as a document author or contributor please respond to this
> email stating of whether or not you are aware of any relevant IPR.
> The response needs to be sent to the RTGWG mailing list. The document will not
> advance to the next stage until a response has been received from each author
> and each individual that has contributed to the document.
> 
> Thanks,
> 
> Jeff & Chris
>

---

From: Jon Mitchell <[email-masked]>
Date: Mon, 3 Aug 2015 17:50:47 -0400

Not aware of IPR.

-Jon

> On Aug 2, 2015, at 11:31 PM, Jeff Tantsura <[email-masked]> wrote:
> 
> Hi RTGWG,
>

---

From: Ariff Premji <[email-masked]>
Date: Mon, 3 Aug 2015 20:28:41 -0700

Thank you Jeff et al.
No I am not aware of any IPR.
Appreciate the support guys.

-ariff

> On Aug 2, 2015, at 8:31 PM, Jeff Tantsura <[email-masked]> wrote:
> 
> Hi RTGWG,
>

---

From: "Russ White" <[email-masked]>
Date: Tue, 4 Aug 2015 10:57:34 -0400

Support.

:-)

Russ

---

From: Rick Casarez <[email-masked]>
Date: Tue, 4 Aug 2015 15:02:24 -0400

Support.

-------------------
Cheers, Rick

Experiences not things.

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 4 Aug 2015 23:35:25 +0000

Support.

--
Uma C.

-----Original Message-----
From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Sunday, August 02, 2015 8:31 PM
To: [email-masked]
Cc: [email-masked]; rtgwg-chairs
Subject: RTGWG LC for draft-ietf-rtgwg-bgp-routing-large-dc

Hi RTGWG,

Please indicate support or no-support as well as your comments by August 18, 2015.

If you are listed as a document author or contributor please respond to this email stating of whether or not you are aware of any relevant IPR.
The response needs to be sent to the RTGWG mailing list. The document will not advance to the next stage until a response has been received from each author and each individual that has contributed to the document.

Thanks,

Jeff & Chris

---

From: Mohan Nanduri <[email-masked]>
Date: Wed, 5 Aug 2015 13:55:19 -0400

Support.

Cheers,
-Mohan

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 5 Aug 2015 19:04:56 -0700

Support.  I have mostly minor comments included below.

Anoop

======

Section 2.3
I had trouble understanding this statement:

   Operating large-scale infrastructure could be expensive, provided
   that a larger amount of elements will statistically fail more often.

Is it just trying to say that with a larger number of elements, likelihood
of seeing failures goes up?  Or is it saying something else?

Section 3.2.4

   If a data center network size is small, it is possible to reduce the
   number of switches in Tier-1 or Tier-2 of Clos topology by a power of
   two.

Should this say factor of 2?

Section 4.1

   The major downside of this
   approach is the proprietary nature of such extensions.

The bigger issue is probably limited scalability because of the need for
synchronization between switches at a given tier level where the protocol
is implemented.  Also wastage of ports to implement the inter-chassis
link.  I say that because a standard for this now exists -- 802.1AX DRNI,
so technically, the proprietary nature is no longer a limiting factor.

Section 4.1, para 2

currently the maturity of the protocol

Did you mean lack of maturity?

Section 4.3

   Application providers and network operators continue

   to also develop new solutions to meet some of the requirements that
   previously have driven large Layer 2 domains.

Would be good to add a reference.

Section 5.2.1

 A unique ASN is allocated per each group of Tier-2 devices.

By group, do you mean all of the switches in a cluster (cluster being a
term previously defined)?  Or is group something else?

Typos and minor editorial
===================

Section 2.4, line 6
situation -> situations (or a situation)

Section 4.1, line 11
larger topologies many of the fundamentals ->
larger topologies, many of the fundamentals

Section 4.2, last bullet
Layer-2 -> Layer 2
Layer-3 -> Layer 3
(Only instance where hyphens are used :))

Section 5.1, bullet 6

It is worth mentioning that all widely deployed
      link-state IGPs also feature periodic refreshes of routing
      information, while BGP does not expire routing state, even if this
      rarely causes significant impact to modern router control planes.

would read better as

It is worth mentioning that all widely deployed
      link-state IGPs also feature periodic refreshes of routing
      information even if this
      rarely causes significant impact to modern router control planes,

      while BGP does not expire routing state.

Section 5.1, last bullet
NRLI -> NLRI

Section 5.2.3
The section Section 8.2 -> Section 8.2

Section 5.2.5
iBGP -> IBGP

Section 5.2.5, 2nd bullet

device with the other devices in the Clos

change to

device compared with the other devices in the Clos

Section 6.1, 3rd para, 2nd line
step (e) Section -> step (e) in Section

Section 6.4, line 1
used to ECMP -> used for ECMP

Section 6.4, line 2
minimizing -> minimize

Section 7.1, 3rd para, 1st line
Ethernet technologies -> Ethernet links (or platforms)

Section 7.1, 2nd line from bottom
it's -> its

Section 7.4, 1st para after bullets, line 2 from bottom
only store -> only stores

Section 7.5, line 4 from bottom
server IP address subnet -> server IP address subnets

Section 8.1, 1st para, last line
iBGP -> IBGP

Section 8.2, 2nd para, line 2 from bottom
Tiers -> tiers

Section 8.2.2, line 9
there is no failures -> there are no failures

---

From: Lizhenbin <[email-masked]>
Date: Thu, 6 Aug 2015 07:17:40 +0000

The solution proposed in the draft is truly a useful solution. And it has been adopted in the actual deployment.
Support for WG adoption.

Best Regards,
Zhenbin(Robin)

-----邮件原件-----
发件人: rtgwg [mailto:[email-masked]] 代表 Jeff Tantsura
发送时间: 2015年8月3日 11:31
收件人: [email-masked]
抄送: [email-masked]; rtgwg-chairs
主题: RTGWG LC for draft-ietf-rtgwg-bgp-routing-large-dc

Hi RTGWG,

Thanks,

Jeff & Chris

---

From: Lizhenbin <[email-masked]>
Date: Thu, 6 Aug 2015 11:29:21 +0000

Support for WG LC.

Best Regards,
Zhenbin(Robin)

-----邮件原件-----
发件人: Lizhenbin 
发送时间: 2015年8月6日 15:18
收件人: 'Jeff Tantsura'; [email-masked]
抄送: [email-masked]; rtgwg-chairs
主题: 答复: RTGWG LC for draft-ietf-rtgwg-bgp-routing-large-dc

Best Regards,
Zhenbin(Robin)

-----邮件原件-----
发件人: rtgwg [mailto:[email-masked]] 代表 Jeff Tantsura
发送时间: 2015年8月3日 11:31
收件人: [email-masked]
抄送: [email-masked]; rtgwg-chairs
主题: RTGWG LC for draft-ietf-rtgwg-bgp-routing-large-dc

Hi RTGWG,

Thanks,

Jeff & Chris

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 7 Aug 2015 01:54:47 +0000

Support.

Xiaohu

> Sent: Monday, August 03, 2015 11:31 AM
> To: [email-masked]

---

From: Richard Li <[email-masked]>
Date: Thu, 6 Aug 2015 17:15:18 +0000

Support.

/Richard

-----Original Message-----
From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Sunday, August 02, 2015 8:31 PM
To: [email-masked]
Cc: [email-masked]; rtgwg-chairs
Subject: RTGWG LC for draft-ietf-rtgwg-bgp-routing-large-dc

Hi RTGWG,

Thanks,

Jeff & Chris

---

From: Jon Mitchell <[email-masked]>
Date: Mon, 10 Aug 2015 09:38:16 -0500

Anoop -

Thanks, helpful comments, please see [JM] inline.  We will address these in a version that covers comments post-WGLC.

-Jon

> On Aug 5, 2015, at 9:04 PM, Anoop Ghanwani <[email-masked]> wrote:
> 
> Is it just trying to say that with a larger number of elements, likelihood of seeing failures goes up?  Or is it saying something else?

[JM]  That's it, will simplify the wording in next revision.

> Should this say factor of 2?

[JM]  Yes, good catch!  16->8, not 16->4.

> The bigger issue is probably limited scalability because of the need for synchronization between switches at a given tier level where the protocol is implemented.  Also wastage of ports to implement the inter-chassis link.  I say that because a standard for this now exists -- 802.1AX DRNI, so technically, the proprietary nature is no longer a limiting factor.
> 

[JM]  I believe 802.1ax-rev is not technically completed the standards process but I will discuss state and inability to scale such implementations past a 1+1 model in a sentence or two in next rev.

> Did you mean lack of maturity?

[JM]  Yes, will fix.

> Would be good to add a reference.

[JM]  Rather than add 5 or 6 I think we can clarify that we are referring to various overlay/tunneling techniques.

> By group, do you mean all of the switches in a cluster (cluster being a term previously defined)?  Or is group something else?

[JM]  Yes, we will clarify to mean cluster.

> Typos and minor editorial

[JM]  Will address all below in next rev.

>> On Sun, Aug 2, 2015 at 8:31 PM, Jeff Tantsura <[email-masked]> wrote:
>> Hi RTGWG,
>>

---

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 10 Aug 2015 09:26:26 -0700

Hi Jon,

Thanks for the follow up.

DRNI (distributed resilient network interconnect) is part of the revised
link aggregation spec (802.1AX-2014).  It is now complete and folks can get
a copy at:
http://standards.ieee.org/about/get/802/802.1.html

The spec actually allows for up to 3 nodes in a portal (optional
capability; 2 is required).

Anoop

On Mon, Aug 10, 2015 at 7:38 AM, Jon Mitchell <[email-masked]>
wrote:

>
> Anoop -
>
> Thanks, helpful comments, please see [JM] inline.  We will address these
> in a version that covers comments post-WGLC.
>
> -Jon
>
> [JM]  I believe 802.1ax-rev is not technically completed the standards
> process but I will discuss state and inability to scale such
> implementations past a 1+1 model in a sentence or two in next rev.
>
> Section 4.1, para 2
> >>
>

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 18 Aug 2015 10:09:10 -0400

Support.