Subject: Re: WGLC for draft-rtgwg-mrt-frr-architecture *and* draft-ietf-rtgwg-mrt-frr-algorithm

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Wed, 2 Dec 2015 20:56:48 +0000

Hi!

The WGLC period is over, but I haven't heard back from the following authors about IPR (see below): Andras, Russ.  We can't move on until we do.

Thanks!

Alvaro.

On 11/12/15, 9:27 AM, "rtgwg on behalf of Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Fat fingered the name of one of the drafts.. :-(

In case it's not obvious, this WGLC is for draft-ietf-rtgwg-mrt-frr-architecture *and* draft-ietf-rtgwg-mrt-frr-algorithm.

Alvaro.

On 11/12/15, 9:22 AM, "rtgwg on behalf of Alvaro Retana (aretana)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi!

Because both WG Chairs and the Responsible AD are directly involved (as authors) in the MRT work, they have recused themselves and asked me to make the WGLC and corresponding consensus call.  Janos Farkas has agreed to be the Shepherd for both documents.  I will continue to be the Responsible AD for both.  [Note that Jeff is not listed as author/contributor on draft-ietf-rtgwg-mrt-frr-algorithm, but it only makes sense to process the 2 documents together.]

This message starts a WGLC for draft-rtgwg-mrt-frr-architecture *and* draft-ietf-rtgwg-mrt-frr-algorithm.  This call will close by EOD (pick your favorite time zone) on November 30, 2015.  Please provide specific feedback as to why you support (or not) the advancement of these drafts.  Please avoid "+1"-type responses.

https://tools.ietf.org/html/draft-ietf-rtgwg-mrt-frr-architecture
https://tools.ietf.org/html/draft-ietf-rtgwg-mrt-frr-algorithm

I want to formally ask the authors (no additional contributors are listed in the latest version of either document) to please respond to this message indicating whether or not you are aware of any relevant IPR, beyond what has already been disclosed.  The drafts will not progress (pending the results of the WGLC) until an explicit response from each author has been received.  Please be specific as to which draft you are referring to.

Currently, only draft-ietf-rtgwg-mrt-frr-architecture has any disclosed IPR:

http://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-rtgwg-mrt-frr-architecture
http://datatracker.ietf.org/ipr/1594/
http://datatracker.ietf.org/ipr/1733/
http://datatracker.ietf.org/ipr/1801/

If you are on the WG email list or attend WG meetings but are not listed as an author or contributor, please keep in mind your obligations under the IETF IPR rules which encourage you to notify the IETF if you are aware of IPR of others on an IETF contribution, or to refrain from participating in any contribution or discussion related to your undisclosed IPR.

Thanks!

Alvaro.

---

From: "Russ White" <[email-masked]>
Date: Wed, 2 Dec 2015 20:26:45 -0500

> The WGLC period is over, but I haven't heard back from the following
> authors about IPR (see below): Andras, Russ.  We can't move on until we
do.

Sorry for taking so long to answer -- I don't know of any IPR on this.

I've moved my ietf email to [email-masked]. My work address (if anyone
wants it) is now [email-masked]. My other addresses haven't changed.

:-)

Russ

---

From: András Császár <[email-masked]>
Date: Thu, 3 Dec 2015 13:57:12 +0000

Hi Alvaro,

I support publication of both drafts as a co-author.  I am not aware of IPR , other than that already disclosed.

Terribly sorry for the slow response.

András

From: Alvaro Retana (aretana) [mailto:[email-masked]]
Sent: Thursday, November 12, 2015 3:28 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: WGLC for draft-rtgwg-mrt-frr-architecture *and* draft-ietf-rtgwg-mrt-frr-algorithm

Alvaro.

Hi!

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Tue, 15 Dec 2015 16:07:11 +0000

Hi!

We have concluded the WGLC.  There are some clarifying comments and nits that were brought up that need to be addressed before progressing to the next stage, including the author list in the architecture draft.

As a reminder, Janos is the Shepherd and will be assisting me in the process as both WG Chairs and the Responsible AD for rtgwg are authors.

Thanks!

Alvaro.

Alvaro.

Hi!

Thanks!

Alvaro.

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 17 Dec 2015 12:28:56 +0000

Hopefully the authors will respond to my last call comments.

Also I think that Rob's characterization of the operational
issues need a response.

- Stewart

On 15/12/2015 16:07, Alvaro Retana (aretana) wrote:
> Hi!
>
> We have concluded the WGLC.  There are some clarifying comments and 
> nits that were brought up that need to be addressed before progressing 
> to the next stage, including the author list in the architecture draft.
>
> As a reminder, Janos is the Shepherd and will be assisting me in the 
> process as both WG Chairs and the Responsible AD for rtgwg are authors.
>
> Thanks!
>
> Alvaro.
>
> On 11/12/15, 9:27 AM, "rtgwg on behalf of Alvaro Retana (aretana)" 
> <[email-masked] <mailto:[email-masked]> on behalf of 
> [email-masked] <mailto:[email-masked]>> wrote:
>
>     In case it's not obvious, this WGLC is
>     for draft-ietf-rtgwg-mrt-frr-architecture *and*
>     draft-ietf-rtgwg-mrt-frr-algorithm.
>
>     Alvaro.
>
>     On 11/12/15, 9:22 AM, "rtgwg on behalf of Alvaro Retana (aretana)"
>     <[email-masked] <mailto:[email-masked]> on behalf
>     of [email-masked] <mailto:[email-masked]>> wrote:
>
>         Hi!
>
>         Because both WG Chairs and the Responsible AD are directly
>         involved (as authors) in the MRT work, they have recused
>         themselves and asked me to make the WGLC and corresponding
>         consensus call.  Janos Farkas has agreed to be the Shepherd
>         for both documents.  I will continue to be the Responsible AD
>         for both.  [Note that Jeff is not listed as author/contributor
>         on draft-ietf-rtgwg-mrt-frr-algorithm, but it only makes sense
>         to process the 2 documents together.]
>
>         This message starts a WGLC for
>         draft-rtgwg-mrt-frr-architecture *and*
>         draft-ietf-rtgwg-mrt-frr-algorithm.  This call will close by
>         EOD (pick your favorite time zone) on November 30,
>         2015.  Please provide specific feedback as to why you support
>         (or not) the advancement of these drafts.  Please avoid
>         "+1"-type responses.
>
>         I want to formally ask the authors (no additional contributors
>         are listed in the latest version of either document) to please
>         respond to this message indicating whether or not you are
>         aware of any relevant IPR, beyond what has already been
>         disclosed.  The drafts will not progress (pending the results
>         of the WGLC) until an explicit response from each author has
>         been received.  Please be specific as to which draft you are
>         referring to.
>
>         If you are on the WG email list or attend WG meetings but are
>         not listed as an author or contributor, please keep in mind
>         your obligations under the IETF IPR rules which encourage you
>         to notify the IETF if you are aware of IPR of others on an
>         IETF contribution, or to refrain from participating in any
>         contribution or discussion related to your undisclosed IPR.
>
>         Thanks!
>
>         Alvaro.
>
>
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Chris Bowers <[email-masked]>
Date: Mon, 21 Dec 2015 14:46:38 +0000

Alvaro,

We have posted new revisions of the two drafts.  Diffs can be found at the links below:

https://www.ietf.org/rfcdiff?url2=draft-ietf-rtgwg-mrt-frr-architecture-08
https://www.ietf.org/rfcdiff?url2=draft-ietf-rtgwg-mrt-frr-algorithm-07

The changes are summarized below:

draft-rtgwg-mrt-frr-architecture:

Moved algorithm for determining loop-free island neighbor to draft-ietf-rtgwg-mrt-frr-algorithm, as suggested in Janos' comments.

Fixed the idnits issues pointed out by Janos.

Made changes to address many of the comments from Stewart Bryant and Rob Shakir.  See responses to those comments for details.

draft-ietf-rtgwg-mrt-frr-algorithm:

Moved algorithm for determining loop-free island neighbor from draft-rtgwg-mrt-frr-architecture as suggested in Janos' comments.

Fixed the idnits issues pointed out by Janos.

Made changes to address many of the comments from Stewart Bryant. See responses to those comments for details.

Cleaned up a place in the python code where some code that is no longer being used was left in the text, but commented out, and improved handling of failure of primary NH directly connected to D, or order proxy for D, where that link is MRT_INELIGIBLE.

Thanks,
Chris

From: Alvaro Retana (aretana) [mailto:[email-masked]]
Sent: Tuesday, December 15, 2015 10:07 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; Janos Farkas <[email-masked]>
Subject: Re: WGLC for draft-rtgwg-mrt-frr-architecture *and* draft-ietf-rtgwg-mrt-frr-algorithm

Hi!

Thanks!

Alvaro.

Alvaro.

Hi!

Thanks!

Alvaro.