Subject: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

From: Robert Wilton <[email-masked]>
Date: Fri, 2 Dec 2016 14:09:33 +0000

Hi,

I have read this draft, and support adoption of it.

I would also encourage that this draft moves quickly so that other YANG 
drafts can make use of the types that it defines.

Thanks,
Rob (Cisco)

On 30/11/2016 22:15, Jeff Tantsura wrote:
>
> Dear RTGWG,
>
> The authors have requested the RTGWG to adopt 
> draft-rtgyangdt-rtgwg-routing-types.
>
> The draft has been presented in Seoul, and found of interest for wg.
>
> Please indicate support or no-support by December 15, 2016.
>
> IPR:
>
> If you are listed as a document author or contributor, please respond 
> to this email.
>
> of whether or not you are aware of any relevant IPR. The response 
> needs to be sent to the RTGWG mailing list.
>
> The document will not advance to the next stage until a response has 
> been received from each author and each
>
> individual that has contributed to the document.
>
> Thanks,
>
> Jeff & Chris
>
>
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

---

From: <[email-masked]>
Date: Mon, 5 Dec 2016 08:43:28 +0000

Support

From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Wednesday, November 30, 2016 23:15
To: RTGWG
Cc: [email-masked]; 'rtgwg-chairs'
Subject: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Dear RTGWG,

The authors have requested the RTGWG to adopt draft-rtgyangdt-rtgwg-routing-types.
The draft has been presented in Seoul, and found of interest for wg.

IPR:
If you are listed as a document author or contributor, please respond to this email.
of whether or not you are aware of any relevant IPR. The response needs to be sent to the RTGWG mailing list.
The document will not advance to the next stage until a response has been received from each author and each
individual that has contributed to the document.

Thanks,
Jeff & Chris

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Loa Andersson <[email-masked]>
Date: Mon, 5 Dec 2016 17:35:27 +0800

Folks,

This is a very useful document, I support the adoption as working group
document.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: wangzitao <[email-masked]>
Date: Tue, 6 Dec 2016 09:54:52 +0000

Hi RTGWG,

I have read this document and I believe it useful and valuable.
And yes, I support to adopt it.

Otherwise, some types defined in this model can used by LIME WG’s  “draft-ietf-lime-yang-connectionless-oam<https://tools.ietf.org/wg/lime/draft-ietf-lime-yang-connectionless-oam/>” and  “ draft-ietf-lime-yang-connectionless-oam-methods<https://tools.ietf.org/wg/lime/draft-ietf-lime-yang-connectionless-oam-methods/>”.
As the lime model’s coauthor, I’d like to reuse your types, update lime model to keep it synchronized.

Best Regards!
-Michael

发件人: rtgwg [mailto:[email-masked]] 代表 Jeff Tantsura
发送时间: 2016年12月1日 6:15
收件人: RTGWG
抄送: [email-masked]; 'rtgwg-chairs'
主题: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 06 Dec 2016 10:59:40 -0800

Hi Michael,

Thanks for detailed feedback,

Would be grand, if you could send the authors a list of commonly used types that in your opinion should be included.

Thanks!

Cheers,

Jeff

From: wangzitao <[email-masked]>
Date: Tuesday, December 6, 2016 at 01:54
To: Jeff Tantsura <[email-masked]>, RTGWG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, 'rtgwg-chairs' <[email-masked]>
Subject: RE: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi RTGWG,

Otherwise, some types defined in this model can used by LIME WG’s  “draft-ietf-lime-yang-connectionless-oam” and  “ draft-ietf-lime-yang-connectionless-oam-methods”.

Best Regards!

-Michael

Dear RTGWG,

IPR:

 

Thanks,

Jeff & Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 6 Dec 2016 21:17:45 +0000

Hi Michael, Jeff,

Actually, I’ve found these definitions in https://www.ietf.org/id/draft-ietf-lime-yang-connectionless-oam-02.txt. One point, I see that some of the types in this draft are mixed case. Unless I heard a good reason not to, we will stick with lower-case identifiers consistent with RFC 6021 (existing YANG types RFC). Comments?
Thanks
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, December 6, 2016 at 1:59 PM
To: wangzitao <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, 'rtgwg-chairs' <[email-masked]<mailto:[email-masked]>>
Subject: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael,

Thanks!

Cheers,
Jeff

From: wangzitao <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, December 6, 2016 at 01:54
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, RTGWG <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, 'rtgwg-chairs' <[email-masked]<mailto:[email-masked]>>
Subject: RE: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi RTGWG,

Best Regards!
-Michael

发件人: rtgwg [mailto:[email-masked]] 代表 Jeff Tantsura
发送时间: 2016年12月1日 6:15
收件人: RTGWG
抄送: [email-masked]<mailto:[email-masked]>; 'rtgwg-chairs'
主题: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: wangzitao <[email-masked]>
Date: Fri, 9 Dec 2016 10:22:54 +0000

Hi Jeff,
Sorry for late response.
I review the document again, and the types we can reusing are:
route-distinguisher; multicast-source-ipv4-addr-type; multicast-source-ipv6-addr-type.
And potential type which we need to use in LIME are:
tunnel-id, ip-mulitcast-group-address, lsp-id, system-id.

Hi Acee,
You are right, the lower-case identifiers are good for us.

Best Regards!
-Michael
发件人: Acee Lindem (acee) [mailto:[email-masked]]
发送时间: 2016年12月7日 5:18
收件人: Jeff Tantsura; wangzitao; RTGWG
抄送: [email-masked]; 'rtgwg-chairs'
主题: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael, Jeff,

Hi Michael,

Thanks!

Cheers,
Jeff

Hi RTGWG,

Best Regards!
-Michael

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 9 Dec 2016 13:21:03 +0000

Hi Michael,

From: wangzitao <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 9, 2016 at 5:22 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, 'rtgwg-chairs' <[email-masked]<mailto:[email-masked]>>
Subject: RE: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Jeff,
Sorry for late response.

Note that for naming consistency with the existing ietf-ip-types types, I have proposed changing:

     multicast-source-ipv4-addr-type->ipv4-multicast-source-address
     multicast-source-ipv6-addr-type->ipv6-multicast-source-address

I see we could pick up the definitions from your models.

Thanks,
Acee

Hi Acee,

Best Regards!
-Michael

Hi Michael, Jeff,

Hi Michael,

Thanks!

Cheers,
Jeff

Hi RTGWG,

Best Regards!
-Michael

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 9 Dec 2016 16:56:52 -0500

Hi Michael,

From: rtgwg [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, December 9, 2016 8:21 AM
To: wangzitao <[email-masked]>; Jeff Tantsura <[email-masked]>; RTGWG <[email-masked]>
Cc: [email-masked]; 'rtgwg-chairs' <[email-masked]>
Subject: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael, 

From: wangzitao <[email-masked] <mailto:[email-masked]> >
Date: Friday, December 9, 2016 at 5:22 AM
To: Acee Lindem <[email-masked] <mailto:[email-masked]> >, Jeff Tantsura <[email-masked] <mailto:[email-masked]> >, Routing WG <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, 'rtgwg-chairs' <[email-masked] <mailto:[email-masked]> >
Subject: RE: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Jeff, 

Sorry for late response. 

 

I see we cold pick up the definitions from your models. 

[Xufeng] tunnel-id and lsp-id are currently also defined in ietf-te.yang. We need to discuss whether to keep it in te-types or in routing-types. Also, why do you define lsp-id as a string, where the current relevant RFCs specify it as uint16? 

Why do you specify system-id as URI? Is it used to identify the router? If so, why not use router-id?

Thanks,

Acee 

Hi Acee,

Best Regards!

-Michael

发件人: Acee Lindem (acee) [mailto:[email-masked]] 
发送时间: 2016年12月7日 5:18
收件人: Jeff Tantsura; wangzitao; RTGWG
抄送: [email-masked] <mailto:[email-masked]> ; 'rtgwg-chairs'
主题: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael, Jeff, 

Thanks

Acee 

From: rtgwg <[email-masked] <mailto:[email-masked]> > on behalf of Jeff Tantsura <[email-masked] <mailto:[email-masked]> >
Date: Tuesday, December 6, 2016 at 1:59 PM
To: wangzitao <[email-masked] <mailto:[email-masked]> >, Routing WG <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, 'rtgwg-chairs' <[email-masked] <mailto:[email-masked]> >
Subject: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael,

Thanks!

Cheers,

Jeff

From: wangzitao <[email-masked] <mailto:[email-masked]> >
Date: Tuesday, December 6, 2016 at 01:54
To: Jeff Tantsura <[email-masked] <mailto:[email-masked]> >, RTGWG <[email-masked] <mailto:[email-masked]> >
Cc: "[email-masked] <mailto:[email-masked]> " <[email-masked] <mailto:[email-masked]> >, 'rtgwg-chairs' <[email-masked] <mailto:[email-masked]> >
Subject: RE: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi RTGWG,

Otherwise, some types defined in this model can used by LIME WG’s  “ <https://tools.ietf.org/wg/lime/draft-ietf-lime-yang-connectionless-oam/> draft-ietf-lime-yang-connectionless-oam” and  “  <https://tools.ietf.org/wg/lime/draft-ietf-lime-yang-connectionless-oam-methods/> draft-ietf-lime-yang-connectionless-oam-methods”.

Best Regards!

-Michael

发件人: rtgwg [mailto:[email-masked]] 代表 Jeff Tantsura
发送时间: 2016年12月1日 6:15
收件人: RTGWG
抄送: [email-masked] <mailto:[email-masked]> ; 'rtgwg-chairs'
主题: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Dear RTGWG,

IPR:

 

Thanks,

Jeff & Chris

---

From: wangzitao <[email-masked]>
Date: Mon, 12 Dec 2016 03:05:04 +0000

Hi Acee,

发件人: Acee Lindem (acee) [mailto:[email-masked]]
发送时间: 2016年12月9日 21:21
收件人: wangzitao; Jeff Tantsura; RTGWG
抄送: [email-masked]; 'rtgwg-chairs'
主题: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael,

Hi Jeff,
Sorry for late response.

     multicast-source-ipv4-addr-type->ipv4-multicast-source-address
     multicast-source-ipv6-addr-type->ipv6-multicast-source-address
Agree! Consistency with existing format is reasonable.

Thanks,
Acee

Hi Acee,

Best Regards!
-Michael

Hi Michael, Jeff,

Hi Michael,

Thanks!

Cheers,
Jeff

Hi RTGWG,

Best Regards!
-Michael

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: wangzitao <[email-masked]>
Date: Mon, 12 Dec 2016 03:23:30 +0000

Hi Xufeng,

发件人: Xufeng Liu [mailto:[email-masked]]
发送时间: 2016年12月10日 5:57
收件人: 'Acee Lindem (acee)'; wangzitao; 'Jeff Tantsura'; 'RTGWG'
抄送: [email-masked]; 'rtgwg-chairs'
主题: RE: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael,

From: rtgwg [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, December 9, 2016 8:21 AM
To: wangzitao <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; RTGWG <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; 'rtgwg-chairs' <[email-masked]<mailto:[email-masked]>>
Subject: Re: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Hi Michael,

Hi Jeff,
Sorry for late response.

I see we cold pick up the definitions from your models.
[Xufeng] tunnel-id and lsp-id are currently also defined in ietf-te.yang. We need to discuss whether to keep it in te-types or in routing-types. Also, why do you define lsp-id as a string, where the current relevant RFCs specify it as uint16?
Why do you specify system-id as URI? Is it used to identify the router? If so, why not use router-id?
I encourage you to pick it up, since for model user importing one “type module” are more convenient than importing two or more.
And I agree with you, the “lsp-id” should with unit16,  and I’d like to reuse “router-id” to replace “system-id”.
Thanks,
Acee

Hi Acee,

Best Regards!
-Michael

Hi Michael, Jeff,

Hi Michael,

Thanks!

Cheers,
Jeff

Hi RTGWG,

Best Regards!
-Michael

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: Christian Hopps <[email-masked]>
Date: Tue, 13 Dec 2016 08:17:05 -0500

Hi,

I support this action as co-auther. I am not aware of any relevant IPR.

Thanks,
Chris.

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 15 Dec 2016 01:46:12 -0800

Dear RTGWG,

The draft has been adopted as the working group document.

Authors – please re-publish the draft accordingly.

Thanks!
Jeff and Chris

From: Jeff Tantsura <[email-masked]>
Date: Wednesday, November 30, 2016 at 14:15
To: RTGWG <[email-masked]>
Cc: 'rtgwg-chairs' <[email-masked]>, <[email-masked]>
Subject: RTGWG adoption of draft-rtgyangdt-rtgwg-routing-types

Dear RTGWG,

IPR:

 

Thanks,

Jeff & Chris