Subject: YANG in draft-ietf-rtgwg-yang-key-chain

From: Benoit Claise <[email-masked]>
Date: Thu, 19 Jan 2017 09:55:19 +0100

Dear authors,

Thanks for posting a new version of the draft.
However, there is a problem with the YANG module.
You have two extra greater-than signs after the module name, as you can 
see from the diff.

Therefore, we can't extract the YANG module:

    $ xym.py draft-ietf-rtgwg-yang-key-chain-12.txt

    Extracting [email-masked]'
        ERROR: 'draft-ietf-rtgwg-yang-key-chain-12.txt', Line 1344 -
    Missing <CODE ENDS>

    No models created.

And all the YANG module that imports [email-masked] 
obviously fail.
Please update this draft asap.

Finally, this error should have been caught by idnits.
Let me know if it's not the case.

Regards, Benoit

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 19 Jan 2017 10:48:17 +0000

Hi Benoit,
It should be fixed now - sorry the compilation error. I have validated the draft using: http://www.yangvalidator.com/

I remember looking at the idnits prior to submission but perhaps I didn't check the YANG validation link.

Thanks,
Acee

From: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 19, 2017 at 2:55 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: YANG in draft-ietf-rtgwg-yang-key-chain
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Jeffrey Zhang <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Helen Chen <[email-masked]<mailto:[email-masked]>>, Yingzhen Qu <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Thursday, January 19, 2017 at 2:55 AM

Dear authors,

Thanks for posting a new version of the draft.
However, there is a problem with the YANG module.
You have two extra greater-than signs after the module name, as you can see from the diff.

Extracting [email-masked]<mailto:[email-masked]>'
   ERROR: 'draft-ietf-rtgwg-yang-key-chain-12.txt', Line 1344 - Missing <CODE ENDS>

No models created.

And all the YANG module that imports [email-masked]<mailto:[email-masked]> obviously fail.
Please update this draft asap.

Regards, Benoit