Subject: Routing in DC RTGWG interim - updated

From: "Black, David" <[email-masked]>
Date: Mon, 16 Jan 2017 11:42:40 +0000

When: Jan 25, 2017 (all day)
--
_____________________________________________
From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Tuesday, January 10, 2017 4:19 PM
To: RTGWG
Cc: Isis-wg; 'rtgwg-chairs'; Idr; [email-masked]
Subject: Re: Routing in DC RTGWG interim - updated

Hi,

Please find updated agenda for 25th’s interim

Presenters:
Problem statements:
Petr Lapukhov - FB
Dmitry Afanasiev - YANDEX
Russ White/ Shawn Zandi - LinkedIn

Solutions proposed:
Keyur Patel, Arrcus  - Shortest Path Routing Extensions for BGP Protocol, draft-keyupate-idr-bgp-spf
Naiming Shen , Cisco  - IS-IS Routing for Spine-Leaf Topology, draft-shen-isis-spine-leaf-ext
Tony Przygienda, Juniper - RIFT: Routing in Fat Trees, draft-przygienda-rift  (draft to be published later this week)
Bhumip Khasnabish, ZTE - Generic Fault-avoidance Routing Protocol for Data Center Networks, draft-sl-rtgwg-far-dcn

Thanks!

Cheers,
Jeff & Chris

From: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Saturday, December 17, 2016 at 06:10
To: RTGWG <[email-masked]<mailto:[email-masked]>>
Cc: 'rtgwg-chairs' <[email-masked]<mailto:[email-masked]>>, Idr <[email-masked]<mailto:[email-masked]>>, Isis-wg <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Routing in DC RTGWG interim

Hi Routing Protocols wg’s,

There have been number of recently published drafts and discussions on the topic
As discussed in Seoul, we’d like to have a RTGWG interim to provide the platform for both, draft authors and implementers to talk about what and why.

The date we have set is January 25, 9:00AM PST.
We will be reaching out to you.

Based on our preliminary discussion in Seoul we are planning to have the following presenters:

drafts:
draft-keyupate-idr-bgp-spf – Keyur to present
draft-shen-isis-spine-leaf-ext – Naiming?
draft-sl-rtgwg-far-dcn -?
Tony P?

DC network designers:
LinkedIn – Shawn Z./Russ
Yandex - Dmitry Afanasiev

More to be announced

Thanks,
Jeff & Chris

---

From: "Van De Velde, Gunter (Nokia - BE)" <[email-masked]>
Date: Thu, 26 Jan 2017 08:14:04 +0000

Inline: GV>

We have thought about that. The beauty of BGP SPF is that you can use it solely for the underlay and maintain the services (e.g., RFC 4364) in the overlay.

Additionally, it is very easy to migrate only a portion of your data center to BGP SPF. Routers operating in both domains (BGP SPF and RFC 7938) can perform the interworking by advertising AF IPv4 unicast routes into the BGP-SPF domain as BGP-LS Prefix NLRI and reachable BGP-SPF prefixes into the normal BGP IPv4 or IPv6 unicast domain as reachable NLRI.

​That's not what I am talking about ... I am talking of running both in parallel not interworking at the boundary. Think outside of the box pls.

Just to translate to your world is like running ISIS and OSPF together if for nothing else then for routing with OSPF and using ISIS only to compute your LFAs (if really needed and OSPF does not support it yet on your boxes) :) ​.

Yes – the could be done and the next-hops could be resolved recursively anywhere in the BGP-SPF domain. However, what advantage would this bring over advertising attached prefixes as BGP-LS Prefix NLRI?

GV> The promise is to make things easier, not more complex… so what would be a realistic use-case for such a setup? Sounds as a special corner use-case, particular in the DC. DCs fabrics tend to be decommissioned and completely rebuild in a new architecture for faster/better/larger?

G/