Subject: Re: draft-nitish-vrrp-bfd

From: Greg Mirsky <[email-masked]>
Date: Tue, 29 Aug 2017 11:01:04 -0700

Hi Thibault,
thank you for your interest in the draft, much appreciated. Please don't be
discouraged that it lapsed, we can fix it easily. I think that authors had
similar to your idea when we've started thinking about BFD supporting VRRP.
And like you we haven't found any reference in existing documents, hence
this draft draft-nitish-vrrp-bfd. Would be much obliged if you review and
share your comments, suggestion regarding solutions proposed in the draft.

Regards,
Greg

On Tue, Aug 29, 2017 at 9:20 AM, TABANI Thibault <[email-masked]
> wrote:

> Hello,
>
>
>
> I am working at improving VRRP convergence time. (target a few 100’s of
> milliseconds)
>
>
>
> It appears that VRRP supports BFD health monitoring which might be a
> better option than tuning VRRP aggressive timers.
>
>
>
> Unfortunately I cannot find any active RFC where VRRP supports BFD. The
> only document I found is your draft document:
>
>
>
> Fast failure detection in VRRP with BFD
> draft-nitish-vrrp-bfd-04
>
>
>
> Unfortunately date expires of this document.  As BFD support for VRRP is
> implemented on most routers, I suppose that an active RFC might exist on
> that specific BFD implementation within VRRP. (new backup advertisement
> messages….peer table….)
>
> br
>
>
>
>
>
> *Thibault TABANI *
> architect Altran Connected Solutions
> Altran France
>
>
> **
>
>
>
> 1, Impasse Charles Trenet
>
> 44800 Saint-Herblain
> France
>
> Tel. : +33 2 40 67 62 62 <+33%202%2040%2067%2062%2062>
> Mob. : +33 6 79 06 33 63 <+33%206%2079%2006%2033%2063>
> [email-masked] <[email-masked]>*
> *www.altran.fr <http://www.altran.fr/>*
>
>
>
> <http://facebook.com/AltranFrance>[image: Description : Description :
> cid:[email-masked]] <http://twitter.com/AltranFrance>[image:
> Description : Description : LinkedIn_signatureMail]
> <http://linkedin.com/company/altran-france>[image: Description :
> Description : pictog_viadeo] <http://www.viadeo.com/fr/company/altran>
>
>
>

---

From: "Nitish Gupta (nitisgup)" <[email-masked]>
Date: Thu, 31 Aug 2017 05:51:17 +0000

Hi Thibault,

Thanks for the interest in the Draft, appreciate it. Please review the draft and let us know if you have any comments, suggestions.

Hi RTGWG/RTGBFD,

There were two solutions proposed in the draft.
One pertains to making a peer table in VRRP and uses p2p BFD.
The second solution pertains to p2mp BFD.

While we were working on the draft there was an IPR associated to the DRAFT and the WG felt that we need to wait until we can see the IPR and what its associated to.
We can see that the IPR is available for us to view and we can see that the IPR is associated to p2mp BFD.

https://www.google.com/patents/US20170005915

We are going to submit a draft with the p2p BFD so that we can continue working on the Draft.
There was lot of interest last time as well, just because of the IPR claim we had stopped the work.

Thanks,
Nitish

From: Greg Mirsky <[email-masked]>
Date: Tuesday, August 29, 2017 at 11:01 AM
To: TABANI Thibault <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Nitish Gupta (nitisgup)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: draft-nitish-vrrp-bfd
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Tuesday, August 29, 2017 at 11:01 AM

Hi Thibault,
thank you for your interest in the draft, much appreciated. Please don't be discouraged that it lapsed, we can fix it easily. I think that authors had similar to your idea when we've started thinking about BFD supporting VRRP. And like you we haven't found any reference in existing documents, hence this draft draft-nitish-vrrp-bfd. Would be much obliged if you review and share your comments, suggestion regarding solutions proposed in the draft.

Regards,
Greg

On Tue, Aug 29, 2017 at 9:20 AM, TABANI Thibault <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

I am working at improving VRRP convergence time. (target a few 100’s of milliseconds)

It appears that VRRP supports BFD health monitoring which might be a better option than tuning VRRP aggressive timers.

Unfortunately I cannot find any active RFC where VRRP supports BFD. The only document I found is your draft document:

Unfortunately date expires of this document.  As BFD support for VRRP is implemented on most routers, I suppose that an active RFC might exist on that specific BFD implementation within VRRP. (new backup advertisement messages….peer table….)
br

Thibault TABANI

[id:[email-masked]]

1, Impasse Charles Trenet
44800 Saint-Herblain
France
Tel. : +33 2 40 67 62 62<tel:+33%202%2040%2067%2062%2062>
Mob. : +33 6 79 06 33 63<tel:+33%206%2079%2006%2033%2063>
[email-masked]<mailto:[email-masked]>
www.altran.fr<http://www.altran.fr/>

[escription : Description : cid:[email-masked]]<http://facebook.com/AltranFrance>[escription : Description : cid:[email-masked]]<http://twitter.com/AltranFrance>[escription : Description : LinkedIn_signatureMail]<http://linkedin.com/company/altran-france>[escription : Description : pictog_viadeo]<http://www.viadeo.com/fr/company/altran>

---

From: "Nitish Gupta (nitisgup)" <[email-masked]>
Date: Thu, 31 Aug 2017 06:39:13 +0000

Hi All,

We have submitted the draft for VRRP with p2p BFD.
Please review and let us know your comments and suggestions.
https://www.ietf.org/internet-drafts/draft-nitish-vrrp-bfd-p2p-00.txt

Thanks,
Nitish
From: "Nitish Gupta (nitisgup)" <[email-masked]>
Date: Wednesday, August 30, 2017 at 10:51 PM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "Aditya Dogra (addogra)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: draft-nitish-vrrp-bfd

Hi Thibault,

Hi RTGWG/RTGBFD,

Thanks,
Nitish

Hi Thibault,

Regards,
Greg

Thibault TABANI

[scription : Description : cid:[email-masked]]<http://facebook.com/AltranFrance>[scription : Description : cid:[email-masked]]<http://twitter.com/AltranFrance>[scription : Description : LinkedIn_signatureMail]<http://linkedin.com/company/altran-france>[scription : Description : pictog_viadeo]<http://www.viadeo.com/fr/company/altran>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 31 Aug 2017 09:55:50 +0000

Hi Nitish,

Irrespective of any IPR discussions, BFD is inherently a P2P protocol and, consequently, I would vote for P2P peer table.

Thanks,
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of "Nitish Gupta (nitisgup)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 31, 2017 at 1:51 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Aditya Dogra (addogra)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: draft-nitish-vrrp-bfd

Hi Thibault,

Hi RTGWG/RTGBFD,

Thanks,
Nitish

From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, August 29, 2017 at 11:01 AM
To: TABANI Thibault <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Nitish Gupta (nitisgup)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: draft-nitish-vrrp-bfd
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Tuesday, August 29, 2017 at 11:01 AM

Hi Thibault,

Regards,
Greg

Thibault TABANI

---

From: Colin Docherty <[email-masked]>
Date: Thu, 31 Aug 2017 13:10:02 +0000

Totally agree.

Colin.

On Thu, 31 Aug 2017 at 10:56 Acee Lindem (acee) <[email-masked]> wrote:

> Hi Nitish,
>
> Irrespective of any IPR discussions, BFD is inherently a P2P protocol and,
> consequently, I would vote for P2P peer table.
>
> Thanks,
> Acee
>
> From: rtgwg <[email-masked]> on behalf of "Nitish Gupta
> (nitisgup)" <[email-masked]>
> To: "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, Routing WG <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "Aditya
> Dogra (addogra)" <[email-masked]>
> Thanks for the interest in the Draft, appreciate it. Please review the
> draft and let us know if you have any comments, suggestions.
>
>
>
> Hi RTGWG/RTGBFD,
>
>
>
> While we were working on the draft there was an IPR associated to the
> DRAFT and the WG felt that we need to wait until we can see the IPR and
> what its associated to.
>
> *From: *Greg Mirsky <[email-masked]>
> *Date: *Tuesday, August 29, 2017 at 11:01 AM
> *To: *TABANI Thibault <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>,
> "Nitish Gupta (nitisgup)" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *Re: draft-nitish-vrrp-bfd
> *Resent-From: *<[email-masked]>
> *Resent-To: *<[email-masked]>, <[email-masked]>, <[email-masked]>,
> <[email-masked]>, <[email-masked]>
> *Resent-Date: *Tuesday, August 29, 2017 at 11:01 AM
>
>
>
> Hi Thibault,
>
> thank you for your interest in the draft, much appreciated. Please don't
> be discouraged that it lapsed, we can fix it easily. I think that authors
> had similar to your idea when we've started thinking about BFD supporting
> VRRP. And like you we haven't found any reference in existing documents,
> hence this draft draft-nitish-vrrp-bfd. Would be much obliged if you review
> and share your comments, suggestion regarding solutions proposed in the
> draft.
>
>
>
> Regards,
>
> Greg
>
>
>
> On Tue, Aug 29, 2017 at 9:20 AM, TABANI Thibault <
> [email-masked]> wrote:
>
> Hello,
>
>
>
> <http://facebook.com/AltranFrance>[image: escription : Description :
> escription : Description : LinkedIn_signatureMail]
> <http://linkedin.com/company/altran-france>[image: escription :

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 31 Aug 2017 10:20:11 -0700

Hi Acee,
I'd refer to BFD for Multipoint Networks
<https://datatracker.ietf.org/doc/draft-ietf-bfd-multipoint/?include_text=1>
that being prepared for publication. I believe that this very nicely
matches VRRP scenario when Backup need to monitor the Master and Master
doesn't have to know about the Backup at all.
Appreciate your consideration and comments.

Regards,
Greg

On Thu, Aug 31, 2017 at 2:55 AM, Acee Lindem (acee) <[email-masked]> wrote:

> Cc: "[email-masked]" <[email-masked]>, "draft-nitish-vrrp-bfd@ietf.
> org" <[email-masked]>, "Aditya Dogra (addogra)" <
> [email-masked]>