Subject: Re. Re: I-D Action: draft-hu-rtgwg-cu-separation-yang-model-01.txt

From: <[email-masked]>
Date: Tue, 27 Feb 2018 15:04:25 +0800 (CST)

Hi, Petch

A new version draft has been submitted to the IETF website to fix your comments. We add the descriptions of security consideration section.

More comments are appreciatedly welcomed. Thanks.

A new version of I-D, draft-hu-rtgwg-cu-separation-yang-model-02.txt

has been successfully submitted by Fangwei Hu and posted to the

IETF repository.

Name:        draft-hu-rtgwg-cu-separation-yang-model

Revision:    02

Title:        YANG Data Model for Configuration Interface of Control-Plane and User- Plane separation BNG

Document date:    2018-02-26

Group:        Individual Submission

Pages:        32

URL:            https://www.ietf.org/internet-drafts/draft-hu-rtgwg-cu-separation-yang-model-02.txt

Status:         https://datatracker.ietf.org/doc/draft-hu-rtgwg-cu-separation-yang-model/

Htmlized:       https://tools.ietf.org/html/draft-hu-rtgwg-cu-separation-yang-model-02

Htmlized:       https://datatracker.ietf.org/doc/html/draft-hu-rtgwg-cu-separation-yang-model-02

Diff:           https://www.ietf.org/rfcdiff?url2=draft-hu-rtgwg-cu-separation-yang-model-02

Abstract:

   This document defines the YANG data model for operation management of

   Control-Plane and User-Plane separation BNG.

Regards.

Fangwei.

发件人： <[email-masked]>;
收件人：胡方伟10075772;
抄送人： <[email-masked]>;
日 期 ：2018年01月30日 21:27
主 题 ：Re: Re: I-D Action: draft-hu-rtgwg-cu-separation-yang-model-01.txt

Fangwei

I don't know if you are familiar with
   Guidelines for Authors and Reviewers of YANG Data Model Documents
                    draft-ietf-netmod-rfc6087bis-16
but that is where I look for the latest on red tape for YANG modules.

It is in Last Call and so is reasonably stable.

It is rather big but can be dipped into to find e.g. what is needed for
the section on Security Considerations.

Tom Petch

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, January 29, 2018 1:21 AM

> Hi, Petch
>
>
> Thanks for your comments, I will update the draft to fix the
questions.
>
>
> Regards
>
>
> Fangwei.
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> 原始邮件
>
>
>
> 发件人： <[email-masked]>;
> 收件人： <[email-masked]>;
> 抄送人：胡方伟10075772;
> 日 期 ：2018年01月27日 01:45
> 主 题 ：Re: I-D Action: draft-hu-rtgwg-cu-separation-yang-model-01.txt
>
>
> This I-D is still lacking some basics e.g. you cannot have a YANG
module
> without IANA Considerations or without Security Considerations nor are
> most of the necessary Normative References listed..
>
> Tom Petch
>
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, January 25, 2018 7:56 AM
>
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> >
> >
> >         Title           : YANG Data Model for Configuration
Interface
> of Control-Plane and User- Plane separation BNG
> >         Authors         : Fangwei Hu
> >                           RongRong Hua
> >                           Shujun Hu
> > Filename        : draft-hu-rtgwg-cu-separation-yang-model-01.txt
> > Pages           : 30
> > Date            : 2018-01-24
> >
> > Abstract:
> >    This document defines the YANG data model for operation
management
> of
> >    Control-Plane and User-Plane separation BNG.
> >
> >
> > The IETF datatracker status page for this draft is:
> >
>
https://datatracker.ietf.org/doc/draft-hu-rtgwg-cu-separation-yang-model
> /
> >
> > There are also htmlized versions available at:
> >
https://tools.ietf.org/html/draft-hu-rtgwg-cu-separation-yang-model-01
https://datatracker.ietf.org/doc/html/draft-hu-rtgwg-cu-separation-yang-
> model-01
> >
> > A diff from the previous version is available at:
> >
>
https://www.ietf.org/rfcdiff?url2=draft-hu-rtgwg-cu-separation-yang-mode
> l-01
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > _______________________________________________
> > I-D-Announce mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/i-d-announce
> > Internet-Draft directories: http://www.ietf.org/shadow.html
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "t.petch" <[email-masked]>
Date: Tue, 27 Feb 2018 17:25:39 -0000

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Tuesday, February 27, 2018 7:04 AM

> Hi, Petch
>
> A new version draft has been submitted to the IETF website to fix your
comments. We add the descriptions of security consideration section.
> More comments are appreciatedly welcomed. Thanks.

Since you are asking:-)

Imports into the yang modules must have a reference in the Reference
section of the I-D to the RFC/I-D from which they are being imported

The RFC/I-D must then have a I-D style reference to them lest they be
listed as unused references but this reference cannot appear in the YANG
module since that must be standalone plain text .

So the text of the I-D must contain the references.

draft-ietf-netmod-syslog-model shows you one way of doing this.

You must have an IANA Considerations to register the namespace and the
XML - again
draft-ietf-netmod-syslog-model
shows how this might be done.

The Abstract contains the abbreviation BNG which I do not think well
enough known yet for it not to be spelled out.

Tom Petch

> Title:        YANG Data Model for Configuration Interface of
Control-Plane and User- Plane separation BNG
> URL:
https://www.ietf.org/internet-drafts/draft-hu-rtgwg-cu-separation-yang-m
odel-02.txt
> Status:
> Htmlized:
https://tools.ietf.org/html/draft-hu-rtgwg-cu-separation-yang-model-02
> Htmlized:
model-02
> Diff:
l-02
> 主 题 ：Re: Re: I-D Action:
draft-hu-rtgwg-cu-separation-yang-model-01.txt