Subject: Re: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

From: Jeff Tantsura <[email-masked]>
Date: Fri, 6 Jul 2018 13:19:50 -0700

Robert/Linda,

RTGWG chairs have been thinking of starting SD-WAN discussion in RTGWG.
Service data modeling(data modeling in general)is an obvious candidate (at ONUG we started, there’s some early effort, but IETF help is needed).
Control plane interworking is another interesting topic.
Please bring your ideas, I’m still working on agenda

Regards,
Jeff

> On Jul 6, 2018, at 13:12, Robert Raszuk <[email-masked]> wrote:
> 
> Hi Linda,
> 
> What you are expressing is very clear and in fact happens today on any good SD-WAN controller. 
> 
> But in the context of this discussion are you bringing it here to suggest that draft-rosen-bess-secure-l3vpn should have such functionality build in ? 
> 
> Personally I don't think it really belongs in this draft as perfect sweet spot for it still IMHO resides on a SD-WAN controller. Pushing all that logic into BGP may be a bit excessive ...
> 
> Many thx,
> R.
> 
> 
>> On Fri, Jul 6, 2018 at 9:32 PM, Linda Dunbar <[email-masked]> wrote:
>> Ron,
>> 
>>  
>> 
>> This is referring to a Managed Overlay WAN services with many CPEs (large scale SD-WAN) and where
>> 
>> -        there are many CPEs at each location and multiple WAN ports on each CPE
>> 
>> -        SD-WAN Controller needs to detour a path between Site -A-&  Site-B via another site (e.g. Site-C) for reasons like Performance, Regulatory,  or others. Instead of designating to specific CPE of the site-C.
>> 
>>  
>> 
>> It is preferable to partition CPEs to clusters, as shown in the figure below:
>> 
>>  
>> 
>> 
>> 
>>  
>> 
>> Do I explain well? If not, can we talk face to face in Montreal?
>> 
>>  
>> 
>> Thanks, Linda Dunbar
>> 
>>  
>> 
>> From: Ron Bonica [mailto:[email-masked]] 
>> Sent: Friday, July 06, 2018 1:25 PM
>> To: Linda Dunbar <[email-masked]>; Eric Rosen <[email-masked]>; [email-masked]
>> Subject: RE: comments and suggestions to draft-rosen-bess-secure-l3vpn-01
>> 
>>  
>> 
>> Hi Linda,
>> 
>>  
>> 
>> I’m not sure that I understand what you mean when you say, “aggregate CPE-based VPN routes with internet routes that interconnect the CPEs”. Could you elaborate?
>> 
>>  
>> 
>>                                                             Ron
>> 
>>  
>> 
>>  
>> 
>> From: Linda Dunbar <[email-masked]> 
>> Sent: Thursday, July 5, 2018 11:53 AM
>> To: Eric Rosen <[email-masked]>; Ron Bonica <[email-masked]>; [email-masked]
>> Subject: comments and suggestions to draft-rosen-bess-secure-l3vpn-01
>> 
>>  
>> 
>> Eric and Ron,
>> 
>>  
>> 
>> We think that the method described in your draft is useful for CPE based EVPN, especially for SD-WAN between CPEs.
>> 
>> But, it misses some aspects to aggregate CPE-based VPN routes with internet routes that interconnect the CPEs.
>> 
>>  
>> 
>> Question to you: Would you like to expand your draft to cover the scenario of aggregating CPE-based VPN routes with internet routes that interconnect the CPEs?
>> 
>>  
>> 
>> If yes, we think the following areas are needed:
>> 
>>  
>> 
>> •        For RR communication with CPE, this draft only mentioned IPSEC. Are there any reasons that TLS/DTLS are not added? 
>> 
>> •        The draft assumes that C-PE “register” with the RR. But it doesn’t say how. Should “NHRP” (modified version) be considered?
>> 
>> •        It assumes that C-PE and RR are connected by IPsec tunnel. With zero touch provisioning, we need an automatic way to synchronize the IPSec SA between C-PE and RR. The draft assumes:
>> 
>> p  A C-PE must also be provisioned with whatever additional information is needed in order to set up an IPsec SA with each of the red RRs
>> 
>> •        IPsec requires periodic refreshment of the keys. How to synchronize the refreshment among multiple nodes?
>> 
>> •        IPsec usually only send configuration parameters to two end points and let the two end points to negotiate the KEY. Now we assume that RR is responsible for creating the KEY for all end points. When one end point is confiscated, all other connections are impacted.
>> 
>>  
>> 
>> If you are open to expand your draft to cover SD-WAN, we can help providing the sections to address the bullets mentioned above.
>> 
>>  
>> 
>> We have a draft analyzing the technological gaps when using SD-WAN to interconnect workloads & apps hosted in various locations: https://datatracker.ietf.org/doc/draft-dm-net2cloud-gap-analysis/
>> 
>> Appreciate your comments and suggestions to our gap analysis.
>> 
>>  
>> 
>>  
>> 
>> Thanks, Linda Dunbar
>> 
>>  
>> 
>> 
>> _______________________________________________
>> BESS mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/bess
>> 
> 
> _______________________________________________
> BESS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bess

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 6 Jul 2018 20:33:29 +0000

Jess,

Great Action! There are much more than the Data modeling.
A lot to be done in Control Plane. Many SD-WAN deployment (ours included) use NHRP/DMVPN/DSPVN to manage routes via internet. But NHRP being developed decades ago (for ATM) just doesn’t scale to support Managed Overlay network of 100s or 1000s CPEs.

Linda

From: BESS [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Friday, July 06, 2018 3:20 PM
To: Robert Raszuk <[email-masked]>
Cc: Ron Bonica <[email-masked]>; RTGWG <[email-masked]>; Eric Rosen <[email-masked]>; [email-masked]; Linda Dunbar <[email-masked]>
Subject: Re: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Robert/Linda,

Regards,
Jeff

On Jul 6, 2018, at 13:12, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:
Hi Linda,

Many thx,
R.

On Fri, Jul 6, 2018 at 9:32 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Ron,

Thanks, Linda Dunbar

From: Ron Bonica [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, July 06, 2018 1:25 PM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Eric Rosen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Hi Linda,

                                                            Ron

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, July 5, 2018 11:53 AM
To: Eric Rosen <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Eric and Ron,

•  A C-PE must also be provisioned with whatever additional information is needed in order to set up an IPsec SA with each of the red RRs

We have a draft analyzing the technological gaps when using SD-WAN to interconnect workloads & apps hosted in various locations: https://datatracker.ietf.org/doc/draft-dm-net2cloud-gap-analysis/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Ddm-2Dnet2cloud-2Dgap-2Danalysis_&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-AWF2EfpHcAwrDThKP8&m=zU9RrstHx08_qwVE-_wbaPcJUwA0Cx7W9wg4K6cDAOs&s=1SH5CDBkEFKTyKPWRpPpy-dfxkl19-hrgXiR7nRkq50&e=>
Appreciate your comments and suggestions to our gap analysis.

Thanks, Linda Dunbar

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess

---

From: Ron Bonica <[email-masked]>
Date: Fri, 6 Jul 2018 21:23:29 +0000

+1

Let’s follow up on this discussion in Montreal.

From: Linda Dunbar <[email-masked]>
Sent: Friday, July 6, 2018 4:33 PM
To: Jeff Tantsura <[email-masked]>; Robert Raszuk <[email-masked]>
Cc: Ron Bonica <[email-masked]>; RTGWG <[email-masked]>; Eric Rosen <[email-masked]>; [email-masked]
Subject: RE: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Jess,

Linda

From: BESS [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Friday, July 06, 2018 3:20 PM
To: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Cc: Ron Bonica <[email-masked]<mailto:[email-masked]>>; RTGWG <[email-masked]<mailto:[email-masked]>>; Eric Rosen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Robert/Linda,

Regards,
Jeff

Many thx,
R.

Thanks, Linda Dunbar

Hi Linda,

                                                            Ron

Eric and Ron,

Thanks, Linda Dunbar

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bess&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-AWF2EfpHcAwrDThKP8&m=-YF-QCTv5uEfMyt2Wc0PmtR67-K6YA_3N6rtLgrOn8s&s=SriB9BByrX7UeyUS1mlwSgHjqLf0roIqfTnM8SdQA7E&e=>

_______________________________________________
BESS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bess<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bess&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-AWF2EfpHcAwrDThKP8&m=-YF-QCTv5uEfMyt2Wc0PmtR67-K6YA_3N6rtLgrOn8s&s=SriB9BByrX7UeyUS1mlwSgHjqLf0roIqfTnM8SdQA7E&e=>

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 6 Jul 2018 17:15:36 -0700

There are also many companies using EVPN as the control plane.
It is important to find a “golden middle” where on one side we achieve interoperability but on another don’t hinder the innovation in that, fast growing space.
Data planes are a jungle and would not be standardized any time soon.
However - an abstraction on top would be very useful.

Regards,
Jeff

> On Jul 6, 2018, at 14:23, Ron Bonica <[email-masked]> wrote:
> 
> +1
>

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 10 Jul 2018 12:22:00 +0000

Jeff,

                Comments In-Line..

Thanks,
                Jim Uttaro

From: BESS [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Friday, July 06, 2018 8:16 PM
To: Ron Bonica <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; Eric Rosen <[email-masked]>; Robert Raszuk <[email-masked]>; Linda Dunbar <[email-masked]>
Subject: Re: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

[Jim U>] Is this specific to inter-operability with secure-l3vpn-01 or intended as a general statement in re interoperability with the 2547 ?

Regards,
Jeff

On Jul 6, 2018, at 14:23, Ron Bonica <[email-masked]<mailto:[email-masked]>> wrote:
+1

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Sent: Friday, July 6, 2018 4:33 PM
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Cc: Ron Bonica <[email-masked]<mailto:[email-masked]>>; RTGWG <[email-masked]<mailto:[email-masked]>>; Eric Rosen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Jess,

Linda

Robert/Linda,

Regards,
Jeff

Many thx,
R.

On Fri, Jul 6, 2018 at 9:32 PM, Linda Dunbar <linda.dunbar@huawei..com<mailto:[email-masked]>> wrote:
Ron,

Thanks, Linda Dunbar

Hi Linda,

                                                            Ron

From: Linda Dunbar <[email-masked]<mailto:linda..dunbar@huawei..com>>
Sent: Thursday, July 5, 2018 11:53 AM
To: Eric Rosen <[email-masked]<mailto:[email-masked]>>; Ron Bonica <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Eric and Ron,

Thanks, Linda Dunbar

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 10 Jul 2018 07:11:02 -0700

Hi Jim,

This is a general statement applicable to overall SD-WAN effort.

Cheers,

Jeff

From: "UTTARO, JAMES" <[email-masked]>
Date: Tuesday, July 10, 2018 at 05:22
To: Jeff Tantsura <[email-masked]>, Ron Bonica <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, RTGWG <[email-masked]>, Eric Rosen <[email-masked]>, Robert Raszuk <[email-masked]>, Linda Dunbar <[email-masked]>
Subject: RE: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Jeff,

                Comments In-Line..

Thanks,

                Jim Uttaro

Regards,

Jeff

+1

Jess, 

Linda

Robert/Linda,

Regards,

Jeff

Hi Linda,

Many thx,

R.

On Fri, Jul 6, 2018 at 9:32 PM, Linda Dunbar <linda.dunbar@huawei..com> wrote:

Ron, 

 

Thanks, Linda Dunbar

Hi Linda,

                                                            Ron

Eric and Ron, 

 

Thanks, Linda Dunbar

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 10 Jul 2018 14:32:26 +0000

Jeff,

                IMO, there is going to be a need for that the various flavors of SD-WAN to inter-operate with the current suite of network services with an emphasis on 2547.  May be best to approach this as we did with EVPN and create a requirements draft detailing what the need is.

Thanks,
                Jim Uttaro

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Tuesday, July 10, 2018 10:11 AM
To: UTTARO, JAMES <[email-masked]>; Ron Bonica <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; Eric Rosen <[email-masked]>; Robert Raszuk <[email-masked]>; Linda Dunbar <[email-masked]>
Subject: Re: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Hi Jim,

Cheers,
Jeff

From: "UTTARO, JAMES" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 10, 2018 at 05:22
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Ron Bonica <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, RTGWG <[email-masked]<mailto:[email-masked]>>, Eric Rosen <[email-masked]<mailto:[email-masked]>>, Robert Raszuk <[email-masked]<mailto:[email-masked]>>, Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Subject: RE: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Jeff,

                Comments In-Line..

Thanks,
                Jim Uttaro

From: BESS [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Friday, July 06, 2018 8:16 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; RTGWG <[email-masked]<mailto:[email-masked]>>; Eric Rosen <[email-masked]<mailto:[email-masked]>>; Robert Raszuk <[email-masked]<mailto:[email-masked]>>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bess] comments and suggestions to draft-rosen-bess-secure-l3vpn-01

Regards,
Jeff

Jess,

Linda

Robert/Linda,

Regards,
Jeff

Many thx,
R.

Thanks, Linda Dunbar

Hi Linda,

                                                            Ron

Eric and Ron,

Thanks, Linda Dunbar