Subject: Expired draft-ietf-rtgwg-ipfrr-ip-mib

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 25 Nov 2018 11:46:19 +0000

Dear colleagues,
I have noticed that  IP FRR MIB draft (that appears as one of the WG milestones with November-2015 as the target date) has expired more than 2 years ago.  At the same time I have not seen any YANG draft that could be considered as its replacement.

I wonder if there are any plans to resuscitate this draft or to replace it by a YANG one.

Your timely feedback would be highly appreciated.

Regards, and lots of thanks in advance,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

___________________________________________________________________________

This e-mail message is intended for the recipient only and contains information which is 
CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this 
transmission in error, please inform us by e-mail, phone or fax, and then delete the original 
and all copies thereof.
___________________________________________________________________________

---

From: <[email-masked]>
Date: Mon, 26 Nov 2018 10:19:40 +0000

Hi Sasha,

It was decided to stop the work on this document and focus on YANG. The IPFRR MIB counters are part of the OSPF and ISIS yang models.

Brgds,

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Sunday, November 25, 2018 12:46
To: [email-masked]; [email-masked]; LITKOWSKI Stephane OBS/OINIS
Cc: Michael Gorokhovsky; [email-masked]
Subject: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Dear colleagues,

Office: +972-39266302
Cell:      +972-549266302

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 28 Nov 2018 12:41:43 +0000

Stephane,
Lots of thanks for a prompt response.

I have guessed that the reason for dropping the MIB draft for IP FRR was transition to YANG data models.
And it seems that the current versions of the OSPF and IS-IS Yang data model drafts cover not just FRR-related counters but also FRR-related configuration and state attributes.

However, this looks as duplicated definitions (with some protocol-specific variations). Doesn't it make more sense to place all these definitions into a single document?

Office: +972-39266302
Cell:      +972-549266302

From: [email-masked] <[email-masked]>
Sent: Monday, November 26, 2018 12:20 PM
To: Alexander Vainshtein <[email-masked]>; [email-masked]; [email-masked]
Cc: Michael Gorokhovsky <[email-masked]>; [email-masked]
Subject: RE: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Hi Sasha,

Brgds,

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Sunday, November 25, 2018 12:46
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; LITKOWSKI Stephane OBS/OINIS
Cc: Michael Gorokhovsky; [email-masked]<mailto:[email-masked]>
Subject: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Dear colleagues,

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]<mailto:[email-masked]>

Thank you.

---

From: <[email-masked]>
Date: Thu, 29 Nov 2018 12:21:31 +0000

That's a possibility. However for now, we have taken the approach to add FRR into the IGP models.
You could propose your view to the LSR list. ISIS and OSPF yang are in Shepherd's review state.

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Wednesday, November 28, 2018 13:42
To: LITKOWSKI Stephane OBS/OINIS
Cc: Michael Gorokhovsky; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Stephane,

Office: +972-39266302
Cell:      +972-549266302

Hi Sasha,

Brgds,

Dear colleagues,

Office: +972-39266302
Cell:      +972-549266302

Thank you.

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 29 Nov 2018 12:42:17 +0000

Stephane,

I think that a proposal to extract FRR-related things from the IGP YANG data models and to move them to a new document in a different WG would be rejected at this stage - and justly so.

On the other hand, I wonder what is supposed to happen with YANG for TI-LFA:

-          I would expect substantial overlap with YANG definitions for LFA-based FRR in IS-IS and OSPF

-          Since these  definitions are in two different documents handled by the LSR WG, and TI-LFA is handled by the RTGWG, this would probably mean yet another draft, with its own lifecycle etc.
Keeping all these documents consistent (at least in their overlapping parts) can be quite non-trivial IMHO.

One practical (and easy to implement) step should be removal of the milestone "Submit MIB for IP Fast-Reroute for publication as Proposed Standard" (with the target date two years behind us already) from the RTGWG charter<https://datatracker.ietf.org/group/rtgwg/about/>. Chris/Jeff?

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: [email-masked] <[email-masked]>
Sent: Thursday, November 29, 2018 2:22 PM
To: Alexander Vainshtein <[email-masked]>
Cc: Michael Gorokhovsky <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Cc: Michael Gorokhovsky; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Stephane,

Office: +972-39266302
Cell:      +972-549266302

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Monday, November 26, 2018 12:20 PM
To: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Hi Sasha,

Brgds,

Dear colleagues,

Office: +972-39266302
Cell:      +972-549266302

Thank you.

Thank you.

---

From: <[email-masked]>
Date: Thu, 29 Nov 2018 13:15:48 +0000

Hi Sasha,

Currently TILFA is part of the SR IGP Yang models and there is an augmentation of the existing fast-reroute container.

Consistency between YANG models is a valid concern ! for IS-IS and OSPF (including SR extensions) we are working very closely together to ensure consistency. However there is still a chance that we've missed something.

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Thursday, November 29, 2018 13:42
To: LITKOWSKI Stephane OBS/OINIS
Cc: Michael Gorokhovsky; [email-masked]; [email-masked]; [email-masked]; Jeff Tantsura
Subject: RE: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Stephane,

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

Stephane,

Office: +972-39266302
Cell:      +972-549266302

Hi Sasha,

Brgds,

Dear colleagues,

Office: +972-39266302
Cell:      +972-549266302

Thank you.

Thank you.

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 29 Nov 2018 13:25:56 +0000

Stephane,
Again, lots of thanks for a prompt response.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: [email-masked] <[email-masked]>
Sent: Thursday, November 29, 2018 3:16 PM
To: Alexander Vainshtein <[email-masked]>
Cc: Michael Gorokhovsky <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Jeff Tantsura <[email-masked]>
Subject: RE: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Hi Sasha,

Cc: Michael Gorokhovsky; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Jeff Tantsura

Stephane,

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, November 29, 2018 2:22 PM
To: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
Cc: Michael Gorokhovsky <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: Expired draft-ietf-rtgwg-ipfrr-ip-mib

Stephane,

Office: +972-39266302
Cell:      +972-549266302

Hi Sasha,

Brgds,

Dear colleagues,

Office: +972-39266302
Cell:      +972-549266302

Thank you.

Thank you.

Thank you.