Subject: comments on draft-aguado-opsawg-l3sm-l3nm

From: li zhenqiang <[email-masked]>
Date: Wed, 14 Aug 2019 09:59:02 +0000

Hi authors and all,

I think this work is valuable.
Please consider to add process id and import route for ospf used as the protocol between CE and PE.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Wed, 14 Aug 2019 10:43:43 +0000

Hi Li,

Appreciate your comments.

We have already included the import/export profiles for the CE-PE Routing connections:

                 +--rw routing-protocols

                 |  +--rw routing-protocol* [type]

                 |     +--rw type                identityref

                 |     +--rw routing-profiles* [id]

                 |     |  +--rw id      -> /l3vpn-ntw/vpn-profiles/valid-provider-identifiers/routing-profile-identifier/id

                 |     |  +--rw type?   ie-type

We'll include the process-id as an upgrade for the next version.

Regards,

Samier Barguil
Transport & IP Networks | GCTIO - Technology | CIT Centro Integrado de Transporte |

Móvil +57 311 2402952

Móvil +34 665416074

E-mail [email-masked]

E-mail [email-masked]

________________________________
De: OPSAWG <[email-masked]> en nombre de li zhenqiang <[email-masked]>
Enviado: miércoles, 14 de agosto de 2019 4:59
Para: draft-aguado-opsawg-l3sm-l3nm <[email-masked]>; [email-masked] <[email-masked]>; rtgwg <[email-masked]>
Asunto: [OPSAWG] comments on draft-aguado-opsawg-l3sm-l3nm

Hi authors and all,

Best Regards,
Zhenqiang Li

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: li zhenqiang <[email-masked]>
Date: Fri, 16 Aug 2019 09:28:00 +0000

Hello Samier Barguil,

Thank you very much for your consideration. But I am still a little bit confused about the routing-protocols defined in this model.
What we need to define for the PE-CE connection includes:
1) the VPN it belongs
2) the routing protocol running between them
3) the routes needed to be redistributed from PE-CE connetion to VPN and vice versa, for example we need to redistribute ospf routes running between PE-CE to iBGP running between PEs.

I am not sure whether or not this model satisfies the requirement 3.

Best Regards,
Zhenqiang Li

From: SAMIER BARGUIL GIRALDO<mailto:[email-masked]>
Date: 2019-08-14 18:43
To: li zhenqiang<mailto:[email-masked]>; draft-aguado-opsawg-l3sm-l3nm<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; rtgwg<mailto:[email-masked]>
Subject: RE: comments on draft-aguado-opsawg-l3sm-l3nm
Hi Li,

                 +--rw routing-protocols

                 |     +--rw type                identityref

                 |     |  +--rw type?   ie-type

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hi authors and all,

Best Regards,
Zhenqiang Li

---

From: SAMIER BARGUIL GIRALDO <[email-masked]>
Date: Mon, 19 Aug 2019 09:05:49 +0000

HI Zhenqiang,

I really appreciate your questions, I'll try to explain each one, if you consider something is not clear do not hesitate rise an issue in the list but also if you can add it to the git repository would be really helpful https://github.com/oscargdd/l3nm/issues:

The PE-CE Connections is defined in each site-network-access.
The Site Network Access has the Node-ID, Service-ID leaf-ref. So you can relate to which VRF,VPN a SNA belongs respectively.
For each site network access exists a List of the Routing protocol used in this connection.

The routing protocols defined for each site network access are the following:
OSPF
BGP
VRRP
STATIC
RIP

You can Import/export Routes using the Routing Profiles. It allows you to create a Routing Policy and add it to the CE-PE Routing protocol.
As for example, Inside the VPRN there is a BGP connection using import/export policies:

bgp

remove-private

import "non-default-route"

export "To_CE_Datos_BGP"

local-as 1234

peer-as 4321

neighbor 10.4.101.186

exit.

 In our model is can be translated as:

Regards,
--

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

________________________________
De: li zhenqiang <[email-masked]>
Enviado: viernes, 16 de agosto de 2019 4:28
Para: SAMIER BARGUIL GIRALDO <[email-masked]>; draft-aguado-opsawg-l3sm-l3nm <[email-masked]>; [email-masked] <[email-masked]>; rtgwg <[email-masked]>
Asunto: Re: RE: comments on draft-aguado-opsawg-l3sm-l3nm

Hello Samier Barguil,

Best Regards,
Zhenqiang Li

                 +--rw routing-protocols

                 |     +--rw type                identityref

                 |     |  +--rw type?   ie-type

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hi authors and all,

Best Regards,
Zhenqiang Li

---

From: li zhenqiang <[email-masked]>
Date: Wed, 21 Aug 2019 01:15:38 +0000

Hi Samier,

Thank you for your explaination. I will try to review this model to align with the requirement of China Mobile and post my comments in both the list and the git.

Best Regards,
Zhenqiang Li

From: SAMIER BARGUIL GIRALDO<mailto:[email-masked]>
Date: 2019-08-19 17:05
To: li zhenqiang<mailto:[email-masked]>; draft-aguado-opsawg-l3sm-l3nm<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; rtgwg<mailto:[email-masked]>
Subject: RE: RE: comments on draft-aguado-opsawg-l3sm-l3nm
HI Zhenqiang,

bgp

remove-private

export "To_CE_Datos_BGP"

local-as 1234

peer-as 4321

neighbor 10.4.101.186

exit.

Regards,
--

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hello Samier Barguil,

Best Regards,
Zhenqiang Li

                 +--rw routing-protocols

                 |     +--rw type                identityref

                 |     |  +--rw type?   ie-type

Regards,

Samier Barguil

Móvil +57 311 2402952

Móvil +34 665416074

Hi authors and all,

Best Regards,
Zhenqiang Li