Subject: APN (Application-aware Networking) Mailing List

From: Lizhenbin <[email-masked]>
Date: Thu, 13 Aug 2020 04:25:14 +0000

Hi Folks,

The APN mailing list has been created. If you have interest in the work, please subscribe.

List address: [email-masked]
Archive: https://mailarchive.ietf.org/arch/browse/apn
To subscribe: https://www.ietf.org/mailman/listinfo/apn

Purpose:
This email list is the discussion list for the Application-aware Networking (APN). Application-aware Networking is a mechanism whereby traffic flows can be steered and routed within the network to ensure that the specific service levels needed by applications can be delivered.  

This list belongs to IETF area: RTG

Look forward to going on to have more discussion in the mailing list.

Best regards, 
Zhenbin (Robin)

________________________________________
发件人: Architecture-discuss [[email-masked]] 代表 Lizhenbin [[email-masked]]
发送时间: 2020年7月29日 0:17
收件人: [email-masked]; [email-masked]
抄送: [email-masked]
主题: [arch-d] APN (Application-aware Networking) Side Meeting

Hi All,
We will have the APN side meeting at 12:30 - 14:00 UTC on July 30 (Thursday). The agenda and the WebEx information is provided in the following link.
https://github.com/APN-Community/IETF108-Side-Meeting-APN

There has been several similar work like APN such as SPUD and PLUS. Recently Network Token work was also proposed. The side meeting is to try to clarify the scope of APN comparing with other work. The possible usecases are also proposed for the APN work. Another goal of the side meeting is to clarify the security and privacy issues which are always proposed against such application-ware networking work. In RTGWG session held yesterday, the presentation of APN work discussed the possible scenarios related with the security and privacy issues. The following slides is for your reference:
https://www.ietf.org/proceedings/108/slides/slides-108-rtgwg-8-rtgwg-apn6-01

Since it is a complex cross-area work and there is much background information, wish you could join the side meeting if you have interest in the work and your comments and suggestions are appreciated.

Best Regards,
Daniel & Zhenbin (Robin)
_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: Joe Touch <[email-masked]>
Date: Fri, 14 Aug 2020 17:37:19 -0700

This WG appears to be revisiting the issues of the expired trigtran wg. It might be useful to understand why that did not succeed and whether you are asking the same question twice and expecting a different answer. 

Joe

> On Aug 12, 2020, at 9:25 PM, Lizhenbin <[email-masked]> wrote:
> 
> Hi Folks,
>

---

From: John Day <[email-masked]>
Date: Fri, 14 Aug 2020 23:11:52 -0400

No, these are the ones who think that your browser should be able to tell Windows what order to do the disk queue.

John

> On Aug 14, 2020, at 20:37, Joe Touch <[email-masked]> wrote:
>

---

From: Joseph Touch <[email-masked]>
Date: Sat, 15 Aug 2020 09:35:38 -0700

TRIGTRAN did look at signals both up and down the network stack.

(Browser to OS to disk doesn’t involve that stack)

Joe

> On Aug 14, 2020, at 8:11 PM, John Day <[email-masked]> wrote:
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 17 Aug 2020 13:52:06 -0500

Adding the PANRG chairs, in case I get something wrong about PANRG ...

On Fri, Aug 14, 2020 at 7:37 PM Joe Touch <[email-masked]> wrote:

> This WG appears to be revisiting the issues of the expired trigtran wg. It
> might be useful to understand why that did not succeed and whether you are
> asking the same question twice and expecting a different answer.
>

Joe. thank you for nudging me on this thread.

PANRG (https://datatracker.ietf.org/rg/panrg/about/) has a draft about the
history of Path-Aware Networking (
https://datatracker.ietf.org/doc/draft-irtf-panrg-what-not-to-do/), and why
most path-aware networking technologies haven't been deployed, although it
seems they should have been deployed (especially to the people who proposed
them).

TRIGTRAN specifically is covered in
https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-12#section-5.5,
but TRIGTRAN was one of eight technologies considered, and we found enough
commonality to justify summarizing what we learned in 12 lessons (
https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-12#section-2),
and then considering whether what we've learned is still relevant (
https://tools.ietf.org/html/draft-irtf-panrg-what-not-to-do-12#section-3).
Some are, some aren't.

This document doesn't have any standing in the IETF, other than providing
information, but I hope it's helpful for you (full disclosure, I'm the
editor).

Best,

Spencer

> > This email list is the discussion list for the Application-aware
> Networking (APN). Application-aware Networking is a mechanism whereby
> traffic flows can be steered and routed within the network to ensure that
> the specific service levels needed by applications can be delivered.
> >
> > We will have the APN side meeting at 12:30 - 14:00 UTC on July 30
> (Thursday). The agenda and the WebEx information is provided in the
> following link.
> > There has been several similar work like APN such as SPUD and PLUS.
> Recently Network Token work was also proposed. The side meeting is to try
> to clarify the scope of APN comparing with other work. The possible
> usecases are also proposed for the APN work. Another goal of the side
> meeting is to clarify the security and privacy issues which are always
> proposed against such application-ware networking work. In RTGWG session
> held yesterday, the presentation of APN work discussed the possible
> scenarios related with the security and privacy issues. The following
> slides is for your reference:
> >
> > Since it is a complex cross-area work and there is much background
> information, wish you could join the side meeting if you have interest in
> the work and your comments and suggestions are appreciated.
> >
> >
> > Best Regards,
> > Daniel & Zhenbin (Robin)