Subject: RE: KRP ID Discussion.

From: Khaled Omar <[email-masked]>
Date: Wed, 5 Aug 2020 23:20:26 +0000

Dear RTGWG members,

As you saw, I wasn’t able to present the KRP ID during the IETF 108 online meeting due to personal reasons, but you still have the chance to read and add your comments to make the draft take the best form to make progress, all participants are encouraged to modify the recent version and if something is unclear don’t hesitate to ask.

Regards,

Khaled Omar

From: Yingzhen Qu <[email-masked]>
Sent: Wednesday, August 5, 2020 11:36 PM
To: Khaled Omar <[email-masked]>; rtgwg-chairs <[email-masked]>
Subject: Re: KRP ID Discussion.

Hi Khaled Omar,

Instead of only asking me to review the draft, a better way is to send an email to [email-masked]<mailto:[email-masked]> and ask people to review it. You can include a pointer to your slides as well, and people interested in this topic will send their comments.

Thanks,
Yingzhen

On Mon, Aug 3, 2020 at 12:18 PM Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Hi Yingzhen,

As my online participation to discuss KRP was not successful, it will be great if you read the draft and tell me your opinions, comments and suggestions so we can work on it and move it to the next better form.

Thanks,

Khaled Omar

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 6 Aug 2020 11:15:23 +0200

Khaled,

Physical network topologies do not follow geo nor political boundaries. Any
solution based on the above is simply not practical.

Best,
R.

On Thu, Aug 6, 2020 at 7:00 AM Khaled Omar <[email-masked]>
wrote:

> Dear RTGWG members,
>
>
>
> As you saw, I wasn’t able to present the KRP ID during the IETF 108 online
> meeting due to personal reasons, but you still have the chance to read and
> add your comments to make the draft take the best form to make progress,
> all participants are encouraged to modify the recent version and if
> something is unclear don’t hesitate to ask.
>
>
>
> Regards,
>
>
>
> Khaled Omar
>
>
>
> *From:* Yingzhen Qu <[email-masked]>
> *Sent:* Wednesday, August 5, 2020 11:36 PM
> *To:* Khaled Omar <[email-masked]>; rtgwg-chairs <
> [email-masked]>
> *Subject:* Re: KRP ID Discussion.
>
>
>
> Hi Khaled Omar,
>
>
>
> Instead of only asking me to review the draft, a better way is to send an
> email to [email-masked] and ask people to review it. You can include a
> pointer to your slides as well, and people interested in this topic will
> send their comments.
>
>
>
> Thanks,
>
> Yingzhen
>
>
>
> On Mon, Aug 3, 2020 at 12:18 PM Khaled Omar <[email-masked]>
> wrote:
>
> Hi Yingzhen,
>
>
>
> As my online participation to discuss KRP was not successful, it will be
> great if you read the draft and tell me your opinions, comments and
> suggestions so we can work on it and move it to the next better form.
>
>
>
> Thanks,
>
>
>
> Khaled Omar
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 6 Aug 2020 11:02:38 +0100

Robert

I make no comment on the draft, but whilst what you say is currently true, the state of world politics seem to make the current decoupling of the various topologies that we enjoy at the moment less likely to continue than was the case a few years back.

The political actions of governments trumps (if you excuse the unfortunate pun) the preferences of the engineers and accountants.

ITU-T SG2 (numbering) has a list of Middle East cases of traffic routing issues based on politics, the EU GDPR rules, the developing countries' concern over traffic patterns, the actions of the current US administration, all take us in the direction of the application of geo and political considerations to traffic routing.

Regrettably, the writing is on the wall for restrictions to become normalised and built into the traffic planning rules, and that will push them into the routing system.

Stewart

> On 6 Aug 2020, at 10:15, Robert Raszuk <[email-masked]> wrote:
> 
> Khaled,
> 
> Physical network topologies do not follow geo nor political boundaries. Any solution based on the above is simply not practical. 
> 
> Best,
> R.

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 6 Aug 2020 12:16:57 +0200

Hi Stewart,

I hear what you are saying and politically speaking I understand your
comment. Not that I would agree - but this does not matter.

But just thinking on the technical level I do not understand it. Are you
saying that maybe in 2030 it would not be legally possible to create a link
of some form (physical or virtual) and run single IGP between US and Europe
? Or between EMEA and Japan ? Or EMEA to Africa ?

Are you saying that global operators would have to artificially divide
their networks into chunks ? And who would control what goes between such
chunks ? ITU-T ?

What about new zoo of satellites just launched to precisely offer Internet
without any geo boundaries ? Would we need to now map earth continents to
orbit and create "fences" in the space as well ?

Sorry but not only that would be end of the Internet but possibly end of
Google, MS, FB and other global operators and enterprises too. Or maybe the
idea is to kill open Internet and still allow enterprises to be global and
take most of the transit ?

Best,
R.

On Thu, Aug 6, 2020 at 12:02 PM Stewart Bryant <[email-masked]>
wrote:

> Robert
>
> I make no comment on the draft, but whilst what you say is currently true,
> the state of world politics seem to make the current decoupling of the
> various topologies that we enjoy at the moment less likely to continue than
> was the case a few years back.
>
> The political actions of governments trumps (if you excuse the unfortunate
> pun) the preferences of the engineers and accountants.
>
> ITU-T SG2 (numbering) has a list of Middle East cases of traffic routing
> issues based on politics, the EU GDPR rules, the developing countries'
> concern over traffic patterns, the actions of the current US
> administration, all take us in the direction of the application of geo and
> political considerations to traffic routing.
>
> Regrettably, the writing is on the wall for restrictions to become
> normalised and built into the traffic planning rules, and that will push
> them into the routing system.
>
> Stewart
>
> > Physical network topologies do not follow geo nor political boundaries.
> Any solution based on the above is simply not practical.
> >
> > Best,
> > R.
>
>

---

From: Khaled Omar <[email-masked]>
Date: Thu, 6 Aug 2020 12:47:31 +0000

Hi Robert,

I think we should work as a prerequisite on drawing the boundaries between the regions to separate one from another but the issue is which area belongs to which region, some may need to join a specific area that is difficult for them to do.

But regarding the added values, attacking BGP could be dangerous and the migration to KRP should be smooth.

Best Regards,

Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Robert Raszuk <[email-masked]>
Sent: Thursday, August 6, 2020 12:16:57 PM
To: Stewart Bryant <[email-masked]>
Cc: Khaled Omar <[email-masked]>; rtgwg <[email-masked]>
Subject: Re: KRP ID Discussion.

Hi Stewart,

I hear what you are saying and politically speaking I understand your comment. Not that I would agree - but this does not matter.

But just thinking on the technical level I do not understand it. Are you saying that maybe in 2030 it would not be legally possible to create a link of some form (physical or virtual) and run single IGP between US and Europe ? Or between EMEA and Japan ? Or EMEA to Africa ?

Are you saying that global operators would have to artificially divide their networks into chunks ? And who would control what goes between such chunks ? ITU-T ?

What about new zoo of satellites just launched to precisely offer Internet without any geo boundaries ? Would we need to now map earth continents to orbit and create "fences" in the space as well ?

Sorry but not only that would be end of the Internet but possibly end of Google, MS, FB and other global operators and enterprises too. Or maybe the idea is to kill open Internet and still allow enterprises to be global and take most of the transit ?

Best,
R.

On Thu, Aug 6, 2020 at 12:02 PM Stewart Bryant <[email-masked]<mailto:[email-masked]>> wrote:
Robert

Stewart

> On 6 Aug 2020, at 10:15, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:
>
> Khaled,
>

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 6 Aug 2020 14:00:44 +0100

Hi Robert,

> On 6 Aug 2020, at 11:16, Robert Raszuk <[email-masked]> wrote:
> 
> Hi Stewart,
> 

Firstly, I should make it clear that I am not advocating this, and since you mention 2030 in the next line the 2030 project is definitely not proposing this.

My remarks are based on what I see in the world about me and what I hear from talking to people in the industry.

> But just thinking on the technical level I do not understand it. Are you saying that maybe in 2030 it would not be legally possible to create a link of some form (physical or virtual) and run singl…

Well who knows. You can see as I do what the US administration is saying about “clean” networks, whatever that means. You will have also seen what the EC is saying about where personally identifying data can flow. You will have also heard in SPRING/6man about the US restrictions on how its traffic can travel around Africa. My crystal ball is no better than anyone else’s but the signs are not good that the best engineering solution will win against what the politicians require of the operators.

> Are you saying that global operators would have to artificially divide their networks into chunks ? And who would control what goes between such chunks ? ITU-T ?

Look at what the politicians seem to be saying. All I know is that the operators have to obey their rules, that  the engineers have to design systems that meet the operators needs, and the politicians are apparently retrenching from globalisation to nationalism. That does not mean that I support such changes, I am just trying to understand the engineering implications of what seems to be happening.

> What about new zoo of satellites just launched to precisely offer Internet without any geo boundaries ? Would we need to now map earth continents to orbit and create "fences" in the space as well ? 

Setting aside the weaponisation of space that is being reported, this is an interesting issue and one that started me on this thought train.

About a year ago Mark Handley presented a paper looking at how the zoo would work without free-space optics, since that seemed to have been omitted from the first bloc of Starlink satellites. His conclusion was that the operator would need to use the earth terminals as relays and he speculated that since Starlink owned both the satellites and the earth terminals every earth terminal could be a relay. It was an interesting talk and worth looking up on Youtube. I was explaining this to a senior member of SG2 at a T-SAG meeting and it was at that point that I was told of the huge problems that exist in telephone numbering (which includes call routing) as a result of political considerations about which countries traffic can transit their network. It was suggested that this would apply to ground terminal transit traffic. Now, I have no idea how this will pan out, but it is not inconceivable that the ground terminal radio licences (which most governments strictly control) could specifically prohibited transit destinations.

> Sorry but not only that would be end of the Internet but possibly end of Google, MS, FB and other global operators and enterprises too. Or maybe the idea is to kill open Internet and still allow en…

Do not shoot the messenger.

I do not advocate this.

I am simply thinking about the engineering consequences of what I see.

Something that I learned at business school was to always understand where the power is. Despite the huge size of the global operators, at the moment the power  is still with nation states, and many of them are getting concerned about the power of the big operators.

I have no interest in killing the open Internet. I have worked to support it for long enough. However that does not invalidate my concern about the trajectory of global politics and the engineering implications for the network.

Stewart

> 
> Best,
> R.
> 
> On Thu, Aug 6, 2020 at 12:02 PM Stewart Bryant <[email-masked] <mailto:[email-masked]>> wrote:
> Robert
> 
> > On 6 Aug 2020, at 10:15, Robert Raszuk <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Khaled,
> >

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 6 Aug 2020 13:16:49 +0000

The intro section has the following line:

“The internet will be subdivided into logical regions or by the physical location of continents”

How will this routing protocol adapt when geo-political change occurs as it always does resulting in a different connectivity model ?

How will a governance in a given continent opt out or in to said constraints imposed by it’s location or logical region?

Thanks,
              Jim Uttaro

From: rtgwg <[email-masked]> On Behalf Of Stewart Bryant
Sent: Thursday, August 06, 2020 9:01 AM
To: Robert Raszuk <[email-masked]>
Cc: rtgwg <[email-masked]>
Subject: Re: KRP ID Discussion.

Hi Robert,

On 6 Aug 2020, at 11:16, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:

Hi Stewart,

I do not advocate this.

Stewart

Best,
R.

Stewart

---

From: Zhuangshunwan <[email-masked]>
Date: Thu, 6 Aug 2020 13:18:12 +0000

Hi Khaled,

Does this solution require hierarchical IPv4/IPv6 address re-allocation?

Regards,
Shunwan

From: rtgwg [mailto:[email-masked]] On Behalf Of Khaled Omar
Sent: Thursday, August 6, 2020 7:20 AM
To: rtgwg <[email-masked]>
Subject: RE: KRP ID Discussion.

Dear RTGWG members,

Regards,

Khaled Omar

From: Yingzhen Qu <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, August 5, 2020 11:36 PM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>; rtgwg-chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: KRP ID Discussion.

Hi Khaled Omar,

Thanks,
Yingzhen

Thanks,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Thu, 6 Aug 2020 13:20:24 +0000

Yes, it does.

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Zhuangshunwan <[email-masked]>
Sent: Thursday, August 6, 2020 3:18:12 PM
To: Khaled Omar <[email-masked]>; rtgwg <[email-masked]>
Subject: RE: KRP ID Discussion.

Hi Khaled,

Regards,

Shunwan

Dear RTGWG members,

Regards,

Khaled Omar

Hi Khaled Omar,

Thanks,

Yingzhen

Hi Yingzhen,

Thanks,

Khaled Omar

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 6 Aug 2020 18:38:19 +0000

Khaled and all,
I think that any proposal that involves massive (world-wide if I understand you correctly) re-allocation of already allocated stable public IPv4/IPv6 addresses can be safely rejected as impractical without going into any additional technical details.

My 2c.

Get Outlook for Android<https://aka.ms/ghei36>

________________________________
From: rtgwg <[email-masked]> on behalf of Khaled Omar <[email-masked]>
Sent: Thursday, August 6, 2020, 16:20
To: Zhuangshunwan; rtgwg
Subject: Re: KRP ID Discussion.

Yes, it does.

Get Outlook for iOS<https://clicktime.symantec.com/38dTJPJvRNhZrmapq1p1v3L6H2?u=https%3A%2F%2Faka.ms%2Fo0ukef>

Hi Khaled,

Regards,

Shunwan

Dear RTGWG members,

Regards,

Khaled Omar

Hi Khaled Omar,

Thanks,

Yingzhen

Hi Yingzhen,

Thanks,

Khaled Omar

-----------------------------------------------------------------------------------------------------------------------
Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. that
is confidential and/or proprietary for the sole use of the intended recipient.  Any review, disclosure, reliance or
distribution by others or forwarding without express permission is strictly prohibited.  If you are not the intended
recipient, please notify the sender immediately and then delete all copies, including any attachments.
-----------------------------------------------------------------------------------------------------------------------

---

From: Khaled Omar <[email-masked]>
Date: Thu, 6 Aug 2020 18:53:54 +0000

As you know, IPv4 lifetime is short (if IPv10 will be used), if the allocation of IPv6 follows the requirements of KRP, then we can move correctly to KRP, if more than one thing will be missing, then we all will face the consequences, read the draft carefully and the problem really is that it depends on the practical human intervention which I don’t like at all, things defined must be done independent of any other thing, this is IMHO, I must gain a profit from the non-stoppable efforts to this draft.

Khaled Omar

From: Alexander Vainshtein <[email-masked]>
Sent: Thursday, August 6, 2020 8:38 PM
To: Khaled Omar <[email-masked]>; Zhuangshunwan <[email-masked]>; rtgwg <[email-masked]>
Subject: Re: KRP ID Discussion.

Khaled and all,

My 2c.

________________________________
From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Khaled Omar <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, August 6, 2020, 16:20
To: Zhuangshunwan; rtgwg
Subject: Re: KRP ID Discussion.

Yes, it does.

Get Outlook for iOS<https://clicktime.symantec.com/38dTJPJvRNhZrmapq1p1v3L6H2?u=https%3A%2F%2Faka.ms%2Fo0ukef>
________________________________
From: Zhuangshunwan <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, August 6, 2020 3:18:12 PM
To: Khaled Omar <[email-masked]<mailto:[email-masked]>>; rtgwg <[email-masked]<mailto:[email-masked]>>
Subject: RE: KRP ID Discussion.

Hi Khaled,

Regards,

Shunwan

From: rtgwg [mailto:[email-masked]] On Behalf Of Khaled Omar
Sent: Thursday, August 6, 2020 7:20 AM
To: rtgwg <[email-masked]<mailto:[email-masked]>>
Subject: RE: KRP ID Discussion.

Dear RTGWG members,

Regards,

Khaled Omar

Hi Khaled Omar,

Thanks,

Yingzhen

Hi Yingzhen,

Thanks,

Khaled Omar

________________________________
Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.
________________________________