Subject: [sacm] should draft-ietf-sacm-use-cases be published as an RFC?

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 6 Jan 2015 12:22:32 +0000

Hi,

During the virtual interim meeting yesterday Kathleen Moriarty (speaking as AD) informed us that the current thinking of the IESG is that use case documents produced by the WG need not be published as RFCs - it's enough if they are maintained for the duration that is considered useful by the WG. This guidance catches SACM with  draft-ietf-sacm-use-cases-07 already submitted to the IESG for consideration as an Informational RFC. Other I-Ds (like draft-ietf-sacm-requirements and draft-ietf-sacm-architecture) also have references to draft-ietf-sacm-use-cases.

What is the opinion of the WG participants? Should we request from the IESG to discuss, approve and publish draft-ietf-sacm-use-cases, or is it enough if we maintain it alive as an I-D as long as we need, and then let it die?

Thanks and Regards,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 22 Jan 2015 15:50:41 +0000

Hi,

I did not see any answer to this query.

Should we draw the conclusion that there is no special interest for the publication of this document as an RFC?

Thanks and Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, January 06, 2015 2:23 PM
To: [email-masked]
Subject: [sacm] should draft-ietf-sacm-use-cases be published as an RFC?

Hi,

Thanks and Regards,

Dan

---

From: David Harrington <[email-masked]>
Date: Thu, 22 Jan 2015 11:34:12 -0500

I think the use cases draft helps to frame the problem(s) being addressed by sacm proposals and is important for guiding future development and recording the history of consensus about the scope of sacm work. 

David Harrington
[email-masked]
603-828-1401

> On Jan 22, 2015, at 10:50 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
> 
> Hi,
>  
> During the virtual interim meeting yesterday Kathleen Moriarty (speaking as AD) informed us that the current thinking of the IESG is that use case documents produced by the WG need not be published as RFCs – it’s enough if they are maintained for the duration that is considered useful by the WG. This guidance catches SACM with  draft-ietf-sacm-use-cases-07 already submitted to the IESG for consideration as an Informational RFC. Other I-Ds (like draft-ietf-sacm-requirements and draft-ietf-sacm-architecture) also have references to draft-ietf-sacm-use-cases.
>  
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm

---

From: David Harrington <[email-masked]>
Date: Thu, 22 Jan 2015 11:39:49 -0500

Oh. To be explicit i think use cases should be published as an rfc. 

David Harrington
[email-masked]
603-828-1401

> On Jan 22, 2015, at 11:34 AM, David Harrington <[email-masked]> wrote:
>

---

From: "Waltermire, David A." <[email-masked]>
Date: Thu, 22 Jan 2015 18:50:33 +0000

+1

From: sacm [mailto:[email-masked]] On Behalf Of David Harrington
Sent: Thursday, January 22, 2015 11:40 AM
To: Romascanu, Dan (Dan)
Cc: [email-masked]
Subject: Re: [sacm] should draft-ietf-sacm-use-cases be published as an RFC?

David Harrington
[email-masked]<mailto:[email-masked]>
603-828-1401

On Jan 22, 2015, at 11:34 AM, David Harrington <[email-masked]<mailto:[email-masked]>> wrote:
I think the use cases draft helps to frame the problem(s) being addressed by sacm proposals and is important for guiding future development and recording the history of consensus about the scope of sacm work.

David Harrington
[email-masked]<mailto:[email-masked]>
603-828-1401

On Jan 22, 2015, at 10:50 AM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks and Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, January 06, 2015 2:23 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [sacm] should draft-ietf-sacm-use-cases be published as an RFC?

Hi,

Thanks and Regards,

Dan

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 22 Jan 2015 16:55:26 -0500

Hi David,

Sent from my iPhone

> I think the use cases draft helps to frame the problem(s) being addressed by sacm proposals and is important for guiding future development and recording the history of consensus about the scope of…

Do you have done more specific arguments?  This will help when I discuss this with the IESG.  In terms of guiding the WG, why wouldn't a draft or wiki be able to do the same thing?  For historical value, why wouldn't a wiki or an expired draft accomplish the same thing?  The one problem I have seen is that folks not involved would have no idea that they should look for an expired draft.

Basically, I need help with good arguments if the WG members would like to see the use case draft published.

Thanks in advance,
Kathleen

---

From: "Adam W. Montville" <[email-masked]>
Date: Thu, 22 Jan 2015 16:09:18 -0600

As a contributor…  From my perspective, effectively canonizing the context from which the work in this group is derived makes sense.  A wiki is too dynamic, so how can anyone later trust that the wiki hasn’t somehow changed?  Some may not, as you’ve mentioned, know to look for an expired draft.  We may have difficulty referencing the expired draft from the others we create.  Even if we don’t have process/logistical issues with such references, referencing something that is expired (i.e. no longer in effect; invalid) seems out of place, if not flat out wrong.

Adam

> On Jan 22, 2015, at 3:55 PM, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hi David,
> 
> Sent from my iPhone
> 
> On Jan 22, 2015, at 11:34 AM, David Harrington <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> [email-masked] <mailto:[email-masked]>
>> 603-828-1401
>> 
>> 
>> On Jan 22, 2015, at 10:50 AM, Romascanu, Dan (Dan) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> Hi, 
>>>  
>>> From: sacm [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Romascanu, Dan (Dan)
>>> To: [email-masked] <mailto:[email-masked]>
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>

---

From: Sean Turner <[email-masked]>
Date: Thu, 29 Jan 2015 15:06:20 -0500

It also allows us to get cross-area review and IESG input earlier in the process on the whole SACM concept.  I guess we can get that with an IETF LC and then not asking that it be published - but that seems like a bit of a waste of time and probably wouldn’t be taken seriously by the reviewers without a “threat” of publication.

For this draft there is *NO* 2119-language so it ought to scoot right through what with the lower bar for informational drafts as compared to standards track drafts.  If the IESG is applying some higher bar to informational drafts then that’s their problem not ours.  I think it’d be fine to remind the IESG in the Shepherd write-up that the 2119-language was purposely removed in an earlier version and it’s informational precisely for the reasons David noted below and ask them to remember to apply this lower bar to an information draft that doesn’t include a protocol; note I interpret the word “guide” below to not mean we must follow everything it says.

As a non-author, I think we should publish the draft.

spt

---

From: Michael Hammer <[email-masked]>
Date: Thu, 29 Jan 2015 20:40:32 +0000

You could also put a note in the boilerplate section that explains 
the 2119 language definitions that there is no such usage in the document.

________________________________
Michael Hammer
Principal Engineer
[email-masked]
Mobile: +1 408 202 9291
542 Gibraltar Drive
Milpitas, CA 95035 USA
www.yaanatech.com

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: Thursday, January 29, 2015 3:06 PM
To: [email-masked]
Subject: Re: [sacm] should draft-ietf-sacm-use-cases be published as an RFC?

It also allows us to get cross-area review and IESG input earlier in the
process on the whole SACM concept.  I guess we can get that with an IETF LC
and then not asking that it be published - but that seems like a bit of a
waste of time and probably wouldn't be taken seriously by the reviewers
without a "threat" of publication.

For this draft there is *NO* 2119-language so it ought to scoot right
through what with the lower bar for informational drafts as compared to
standards track drafts.  If the IESG is applying some higher bar to
informational drafts then that's their problem not ours.  I think it'd be
fine to remind the IESG in the Shepherd write-up that the 2119-language was
purposely removed in an earlier version and it's informational precisely for
the reasons David noted below and ask them to remember to apply this lower
bar to an information draft that doesn't include a protocol; note I
interpret the word "guide" below to not mean we must follow everything it
says.

spt

On Jan 22, 2015, at 11:34, David Harrington <[email-masked]>
wrote:

> I think the use cases draft helps to frame the problem(s) being addressed
by sacm proposals and is important for guiding future development and
recording the history of consensus about the scope of sacm work. 
>> During the virtual interim meeting yesterday Kathleen Moriarty (speaking
as AD) informed us that the current thinking of the IESG is that use case
documents produced by the WG need not be published as RFCs - it's enough if
they are maintained for the duration that is considered useful by the WG.
This guidance catches SACM with  draft-ietf-sacm-use-cases-07 already
submitted to the IESG for consideration as an Informational RFC. Other I-Ds
(like draft-ietf-sacm-requirements and draft-ietf-sacm-architecture) also
have references to draft-ietf-sacm-use-cases.
>>  
>> What is the opinion of the WG participants? Should we request from the
IESG to discuss, approve and publish draft-ietf-sacm-use-cases, or is it
enough if we maintain it alive as an I-D as long as we need, and then let it
die?

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 29 Jan 2015 20:48:59 -0500

I'd prefer just a mention in the shepherd write up as Sean suggested.  Mention in the draft may lead to unnecessary discussions.

Thanks for your input, it helps to see if there is consensus.  Anyone else?

Best regards,
Kathleen

Sent from my iPhone

> On Jan 29, 2015, at 3:40 PM, Michael Hammer <[email-masked]> wrote:
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 30 Jan 2015 04:53:45 +0000

I support going for an RFC. 

Regards,

Dan

> From: sacm [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
> Sent: Friday, January 30, 2015 3:49 AM
> To: Michael Hammer
> Cc: [email-masked]; [email-masked]
> I'd prefer just a mention in the shepherd write up as Sean suggested.
> Mention in the draft may lead to unnecessary discussions.
> 
> > You could also put a note in the boilerplate section that explains the
> > 2119 language definitions that there is no such usage in the document.
> >
> > It also allows us to get cross-area review and IESG input earlier in
> > the process on the whole SACM concept.  I guess we can get that with
> > an IETF LC and then not asking that it be published - but that seems
> > like a bit of a waste of time and probably wouldn't be taken seriously
> > by the reviewers without a "threat" of publication.
> >
> > through what with the lower bar for informational drafts as compared
> > to standards track drafts.  If the IESG is applying some higher bar to
> > informational drafts then that's their problem not ours.  I think it'd
> > be fine to remind the IESG in the Shepherd write-up that the
> > 2119-language was purposely removed in an earlier version and it's
> > informational precisely for the reasons David noted below and ask them
> > to remember to apply this lower bar to an information draft that
> > doesn't include a protocol; note I interpret the word "guide" below to
> > not mean we must follow everything it says.
> >
> >>> On Jan 22, 2015, at 10:50 AM, Romascanu, Dan (Dan)
> >>> <[email-masked]>
> >> wrote:
> >>
> >>> Hi,
> >>>
> >>> Should we draw the conclusion that there is no special interest for
> >>> the
> > publication of this document as an RFC?
> >>>
> >>> Thanks and Regards,
> >>>
> >>> Dan
> >>>
> >>>
> >>> From: sacm [mailto:[email-masked]] On Behalf Of Romascanu,
> >>> Dan
> > (Dan)
> > as AD) informed us that the current thinking of the IESG is that use
> > case documents produced by the WG need not be published as RFCs - it's
> > enough if they are maintained for the duration that is considered useful by
> the WG.
> > submitted to the IESG for consideration as an Informational RFC. Other
> > I-Ds (like draft-ietf-sacm-requirements and
> > draft-ietf-sacm-architecture) also have references to draft-ietf-sacm-use-
> cases.
> >>>
> > IESG to discuss, approve and publish draft-ietf-sacm-use-cases, or is
> > it enough if we maintain it alive as an I-D as long as we need, and
> > then let it die?
> >>>
> >>> Thanks and Regards,
> >>>
> >>> Dan
> >>>
> >>>
> >>>
> >>> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_ma
> >>>
> ilman_listinfo_sacm&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR3
> 1OcN
> >>> XCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=Y6gXr7DBThdXy-doQef69dE-
> fqmEs9FWRa
> >>> gD5rnbohA&s=EY-
> hP0P8LhDLnb9T0FW0bsasy5K95Ao4VpmueRxzpZ8&e=
> >> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mai
> >>
> lman_listinfo_sacm&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR3
> 1OcNXC
> >> JfQzvlsiLQfucBXRucPvdrphpBsFA&m=Y6gXr7DBThdXy-doQef69dE-
> fqmEs9FWRagD5
> >> rnbohA&s=EY-hP0P8LhDLnb9T0FW0bsasy5K95Ao4VpmueRxzpZ8&e=
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> >
> man_listinfo_sacm&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31
> OcNXCJf
> > QzvlsiLQfucBXRucPvdrphpBsFA&m=Y6gXr7DBThdXy-doQef69dE-
> fqmEs9FWRagD5rnb
> > ohA&s=EY-hP0P8LhDLnb9T0FW0bsasy5K95Ao4VpmueRxzpZ8&e=
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> >
> man_listinfo_sacm&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31
> OcNXCJf
> > QzvlsiLQfucBXRucPvdrphpBsFA&m=Y6gXr7DBThdXy-doQef69dE-
> fqmEs9FWRagD5rnb
> > ohA&s=EY-hP0P8LhDLnb9T0FW0bsasy5K95Ao4VpmueRxzpZ8&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_sacm&d=AwICAg&c=BFpWQw8bsuKpl
> 1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=Y6gXr7
> DBThdXy-doQef69dE-fqmEs9FWRagD5rnbohA&s=EY-
> hP0P8LhDLnb9T0FW0bsasy5K95Ao4VpmueRxzpZ8&e=