Subject: [sacm] poll: Trac or GitHub or None?

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 6 Jan 2015 12:12:52 +0000

Hi,

Thanks to Lisa and to Aziz we have now a good amount of information concerning the functionality and the advantages and disadvantages of the two tools considered for tracking comments and open issues related to the WG I-Ds - Trac and GitHub.

As discussed at the virtual interim meeting we are initiating a poll to determine the WG participants opinions on the following two questions:

1.       Are you in favor of using a tool to record and follow-up comments and open issues related to the WG work items?

2.       If your answer to question 1 was 'yes' - do you prefer Trac or GitHub?

Thanks and Regards,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 22 Jan 2015 15:45:57 +0000

Hi,

I did not see any answer to this query?

Should we reach the conclusion that the issue of using a tool for tracking comments is not urgent in the opinion of the WG participants and especially of the active contributors?

Thanks and Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, January 06, 2015 2:13 PM
To: [email-masked]
Subject: [sacm] poll: Trac or GitHub or None?

Hi,

Thanks and Regards,

Dan

---

From: Alberto Bastos <[email-masked]>
Date: Thu, 22 Jan 2015 15:05:04 -0200

Yes. In favor to concentrate in GitHub.

*From:* sacm [mailto:[email-masked]] *On Behalf Of *Romascanu, Dan
(Dan)
*Sent:* quinta-feira, 22 de janeiro de 2015 13:46
*To:* [email-masked]
*Subject:* Re: [sacm] poll: Trac or GitHub or None?

Hi,

Should we reach the conclusion that the issue of using a tool for tracking
comments is not urgent in the opinion of the WG participants and especially
of the active contributors?

Thanks and Regards,

Dan

*From:* sacm [mailto:[email-masked] <[email-masked]>] *On
Behalf Of *Romascanu, Dan (Dan)
*Sent:* Tuesday, January 06, 2015 2:13 PM
*To:* [email-masked]
*Subject:* [sacm] poll: Trac or GitHub or None?

Hi,

Thanks to Lisa and to Aziz we have now a good amount of information
concerning the functionality and the advantages and disadvantages of the
two tools considered for tracking comments and open issues related to the
WG I-Ds – Trac and GitHub.

As discussed at the virtual interim meeting we are initiating a poll to
determine the WG participants opinions on the following two questions:

1.       Are you in favor of using a tool to record and follow-up comments
and open issues related to the WG work items?

2.       If your answer to question 1 was ‘yes’ – do you prefer Trac or
GitHub?

Thanks and Regards,

Dan

---

From: "Lorenzin, Lisa" <[email-masked]>
Date: Sat, 24 Jan 2015 01:29:40 +0000

I think it would be helpful to have an issue tracker.

I think that Github may be a better tool overall, but looks (to me) like it has a steeper learning curve.

If it was just me, I'd use Trac because it seems simpler to me. But if the rest of the group prefers Github, I will endeavor to wrap my head around it. :)

Regards,
Lisa

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, January 22, 2015 10:46 AM
To: [email-masked]
Subject: Re: [sacm] poll: Trac or GitHub or None?

Hi,

Thanks and Regards,

Dan

Hi,

Thanks and Regards,

Dan

---

From: "Haynes, Dan" <[email-masked]>
Date: Wed, 28 Jan 2015 18:00:35 +0000

1.      I am in favor of using a tool to record and follow-up with comments and open issues related to WG work items.

2.      I would prefer GitHub.

Thanks,

Danny

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, January 06, 2015 7:13 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [sacm] poll: Trac or GitHub or None?

Hi,

Thanks and Regards,

Dan

---

From: "Landfield, Kent" <[email-masked]>
Date: Wed, 28 Jan 2015 18:07:45 +0000

1.  Yes, I am in favor of a tool to track comments and open issues
  2.  I don't think it really matters. What will be the easiest to use and maintain for the IETF and the working group members should drive the decision.  I can work with either.

Kent Landfield
Director, Standards and Technology Policy
McAfee. Part of Intel Security
+1.817.637.8026

From: <Haynes>, Dan Haynes <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 28, 2015 at 12:00 PM
To: "Romascanu, Dan (Dan)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sacm] poll: Trac or GitHub or None?

Thanks,

Danny

Hi,

Thanks and Regards,

Dan

---

From: Sean Turner <[email-masked]>
Date: Thu, 29 Jan 2015 14:25:06 -0500

> If it was just me, I'd use Trac because it seems simpler to me. But if the rest of the group prefers Github, I will endeavor to wrap my head around it. :)

I’ve got some links to some pointers for GitHub that Martin Thompson provided when I had to get my head around GitHub too.

For ID authors there’s:
https://github.com/martinthomson/i-d-template

If the chairs make a WG repo (and make you a contributor) then it’ll look slightly more official - and they can add note well and the like.

Personally, I like github because there’s a whole lotta open source folks using it.

spt

---

From: Shawn Wells <[email-masked]>
Date: Fri, 30 Jan 2015 15:17:15 -0500

On 1/22/15 10:45 AM, Romascanu, Dan (Dan) wrote:
> Should we reach the conclusion that the issue of using a tool for 
> tracking comments is not urgent in the opinion of the WG participants 
> and especially of the active contributors?
>

Tracking working group activity through sporadic monitoring of a mailing 
list is untenable, yet alone attempting to participate in a meaningful 
way. I can't see where the current documents are, who has changed 
sections, why they changed them, what comments there are on previously 
issued documents, how to open tickets, etc.

GitHub or bust.