Subject: [sacm] Using Github

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 5 Jan 2015 12:29:22 -0500

Thank you to Aziz for the overview on using GitHub today!

I just checked and both the HTTPbis and TLS working groups are using
Github to edit revisions of drafts in between publishing IETF draft
revisions.  The tools used do put the draft into the IETF format.

You'll see the Notewell on their home page to make it clear that
contributions via this mechanism are covered and if SACM uses this
approach, you should also include the Notewell.

https://github.com/http2/http2-spec

Thanks.

-- 

Best regards,
Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 5 Jan 2015 13:47:13 -0500

Some additional info from Richard Barnes that will be helpful:

Most of the important stuff is ... (wait for it) ... in a GitHub repo :)

https://github.com/martinthomson/i-d-template

Sent from my iPhone

> On Jan 5, 2015, at 12:29 PM, Kathleen Moriarty <[email-masked]> wrote:
>

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 5 Jan 2015 21:37:42 +0000

Thanks Kathleen!

I can try to take a look at this though it’ll be in a couple of weeks when I can spend more dedicated time after biz travel….
Are the AD’s finding this a good medium to get comments resolved with proposed text before it gets committed to draft submission?

Thanks, Nancy
From: Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>
Date: Monday, January 5, 2015 at 10:47 AM
To: Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sacm] Using Github

Sent from my iPhone

On Jan 5, 2015, at 12:29 PM, Kathleen Moriarty <[email-masked]<mailto:[email-masked]>> wrote:

Thanks.

--

Best regards,
Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 5 Jan 2015 16:49:44 -0500

Hi Nancy,

On Mon, Jan 5, 2015 at 4:37 PM, Nancy Cam-Winget (ncamwing)
<[email-masked]> wrote:
> Thanks Kathleen!
>
> I can try to take a look at this though it’ll be in a couple of weeks when I
> can spend more dedicated time after biz travel….
> Are the AD’s finding this a good medium to get comments resolved with
> proposed text before it gets committed to draft submission?

This is more for WGs to decide if it helps to maintain drafts between
revisions.  ADs will work off of published drafts typically and we may
look at a revision before it gets posted to see if an issue is
resolved.  This or another method works.  We do like the ability to
see what exactly was changed, which in other cases (not using
something like this) would rely on submitting a revision so we can use
the diff tool.

It's up to the WG if you think this will be helpful or not.  It's good
that you are aware of options.

Thanks,
Kathleen
>
> Thanks, Nancy
> From: Kathleen Moriarty <[email-masked]>
> To: Kathleen Moriarty <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> On Jan 5, 2015, at 12:29 PM, Kathleen Moriarty
> <[email-masked]> wrote:
>

-- 

Best regards,
Kathleen

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 6 Jan 2015 07:58:42 +0000

It seems that NETCONF and NETMOD find GitHub useful because their I-Ds contain a large amount of code (YANG modules) which is edited and discussed in-between I-D versions. Currently SACM does not need that capability that much, but with information and data models in our list of future deliverables this may change. 

Regards,

Dan

> -----Original Message-----
> From: sacm [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
> Sent: Monday, January 05, 2015 11:50 PM
> To: Nancy Cam-Winget (ncamwing)
> Cc: [email-masked]
> > I can try to take a look at this though it’ll be in a couple of weeks
> > when I can spend more dedicated time after biz travel….
> revisions.  ADs will work off of published drafts typically and we may look at a
> revision before it gets posted to see if an issue is resolved.  This or another
> method works.  We do like the ability to see what exactly was changed,
> which in other cases (not using something like this) would rely on submitting
> a revision so we can use the diff tool.
> 
> It's up to the WG if you think this will be helpful or not.  It's good that you are
> aware of options.
> 
> Thanks,
> Kathleen
> >
> > Thanks, Nancy
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__github.com_martin
> > thomson_i-2Dd-
> 2Dtemplate&d=AwIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31
> >
> OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=Zh4na9JUeZ3GbJFYVTuzmfI5YQ
> vvBuvhq
> > FaEhv_u4k4&s=v8FXAJRdwtYjUP6BAtnnEIqjVRO-wqcuq-Nk4shN990&e=
> >
> > Sent from my iPhone
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__github.com_http2_
> > http2-
> 2Dspec&d=AwIGaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQz
> vls
> >
> iLQfucBXRucPvdrphpBsFA&m=Zh4na9JUeZ3GbJFYVTuzmfI5YQvvBuvhqFaEhv
> _u4k4&s
> > =a63_D-WqFjCBaOXr01ZULfbbapvdOV_A5-6n5wvHB-8&e=
> >
> > Thanks.
> >
> > --
> >
> > Best regards,
> > Kathleen
> 
> 
> 
> --
> 
> Best regards,
> Kathleen
> 
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_sacm&d=AwIGaQ&c=BFpWQw8bsuKpl
> 1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=Zh4na9
> JUeZ3GbJFYVTuzmfI5YQvvBuvhqFaEhv_u4k4&s=bGl7upZ8wMiTulWDloQf2w
> B0TG-JM3YkPRlEd28bn3o&e=