Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Need to clarify "attribute" vs. "posture attributes" (#67)

From: adammontville <[email-masked]>
Date: Sun, 10 Dec 2017 07:15:48 -0800

attribute: "Is a data element, as defined in RFC5209, that is atomic."

posture attributes: "Defined in RFC5209 as 'attributes describing the configuration or status (posture) of a feature of the endpoint.  A Posture Attribute represents a single property of an observed state.  For example, a Posture Attribute might describe the version of the operating system installed on the system.'"

Perhaps we simply make "posture attributes" singular, then define attribute as "see posture attribute"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/67

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 15:04:51 +0000 (UTC)

Another way to resolve this, is to get rid of posture attribute. I am starting to slightly favor that approach

Wrt Adam's proposal, attributes would be a synonym for posture attributes and we would have to merge the complete information element semantics into that definition (which would limit the definition of information elements to "security posture", I suppose, and that would be incorrect).

Actually, I start to think that posture attribute is an artifact from the very beginning that we did not dare to throw out yet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/67#issuecomment-351736433

---

From: adammontville <[email-masked]>
Date: Mon, 18 Dec 2017 19:43:10 +0000 (UTC)

I am left wondering whether you agree or disagree with the proposal :-)  And what your alternate proposal is. If I had to guess, I would say that you roughly agree with the issue, but would propose to remove posture attributes from the terminology altogether. Is that correct?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/67#issuecomment-352536793