Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Proposed update to Security Automation (#82)

From: adammontville <[email-masked]>
Date: Sun, 10 Dec 2017 16:06:44 +0000 (UTC)

The present definition is:

> The process of which security alerts can be automated through the use of different components to monitor, analyze and assess endpoints and network traffic for the purposes of detecting misconfigurations, misbehaviors or threats.

I propose (changes emphasized):

> The process *by* which security *programs* can be automated through the use of different components to monitor, analyze and assess endpoints and network traffic for the purposes of detecting misconfigurations, misbehaviors or threats.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/82

---

From: David Somers-Harris <[email-masked]>
Date: Tue, 12 Dec 2017 17:59:48 -0800

What does "security program" mean?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/82#issuecomment-351257376

---

From: adammontville <[email-masked]>
Date: Wed, 13 Dec 2017 12:58:42 +0000 (UTC)

That's a fair question. In trying to find a standard definition for "security program", I realized that I should probably have said "information security program" which seems to have some fairly well-understood boundaries (see [these Google search results](https://www.google.com/search?ei=iiMxWriaGOWT_Qbf4ZWgBA&q=define%3A%22information+security+program%22&oq=define%3A%22information+security+program%22&gs_l=psy-ab.3...6158.8721.0.9011.18.14.2.0.0.0.130.1151.10j4.14.0....0...1c.1.64.psy-ab..7.0.0....0.qWAP7z_gH-E)). 

If you, or someone else, has a better way to describe this, please let me know.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/82#issuecomment-351383905

---

From: David Somers-Harris <[email-masked]>
Date: Thu, 14 Dec 2017 03:43:27 +0000 (UTC)

Ah OK I think I was confused by the definition of program. I thought you meant

> a series of coded software instructions to control the operation of a computer or other machine.

But apparently you meant

> a set of related measures or activities with a particular long-term aim.

But yes, Information Security is more specific than security.

In any case, I think usage of such a term would require a new entry in the terminology section.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/82#issuecomment-351600085

---

From: adammontville <[email-masked]>
Date: Thu, 14 Dec 2017 11:48:23 +0000 (UTC)

We could add another term. How about this definition for _information security program_:

> A documented approach for organizing and directing all activities undertaken to ensure the confidentiality, integrity, and availability of the information held by the organization.

That's taken from ISO 704:2009.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/82#issuecomment-351689150

---

From: David Somers-Harris <[email-masked]>
Date: Fri, 15 Dec 2017 00:24:52 +0000 (UTC)

That would do it :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/82#issuecomment-351877024

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 15 Dec 2017 07:45:38 -0800

:+1: for adding the term "Information Security Program" defined in ISO 704:2009 in order to be used in the definition of Security Automation proposed by Adam. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/82#issuecomment-352038018