Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Propose to remove Interaction Model from terminology (#65)

From: adammontville <[email-masked]>
Date: Sun, 10 Dec 2017 15:11:03 +0000 (UTC)

As presently defined: 

> "The definition of specific sequences regarding the exchange of messages (data in motion), including, for example,  conditional branching, thresholds and timers. An interaction model, for example, can be used to define operations, such as registration or discovery, on the control plane. A composition of data models for data in motion and a corresponding interaction model is a protocol."

This definition feels very similar to process or workflow (the latter is defined in our terminology as "A workflow is a modular composition of tasks that can contain loops, conditionals, multiple starting points and multiple endpoints").

I move to strike this term from the terminology unless there is some compelling reason to keep it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/65

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 06:13:33 -0800

The requirements on control plane functions imply certain interaction models (e.g. component registration, capability authentication, or content authorization). The same is true with the way how SACM content is conveyed: Request/Response schemes (e.g. REST), Repository Subscriptions (e.g. YANG Push), Brokered Pub/Sub Topics (e.g. xmpp-grid), or Deployment (e.g. dynamic Call-Home) make use of certain interaction models. As the SACM architecture intends not to prescribe certain solutions, it has to elaborate about the required functions on a more abstract level. The term Interaction Model supports the definition of appropriate non-prescriptive sets of functions in the architecture, I think.

Maybe this is a flawed assumption? If so, we can remove the term.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/65#issuecomment-351721829

---

From: strazzie123 <[email-masked]>
Date: Thu, 14 Dec 2017 11:42:18 -0800

In UML, interaction diagrams are a subset of behavior diagrams. Interaction
diagrams describe the flow of data and control among the entities being
modeled. For example, a sequence diagram shows how different entities
communicate with each other using a sequence of messages. Things like BPMN
expand the (limited) concepts in a UML sequence diagram to include a rich
set of control constructs.

Hence, I think we need this term. More importantly, we need user stories
that use interaction and behavior diagrams to illustrate how SACM (can)
work.

regards,
John

On Thu, Dec 14, 2017 at 6:13 AM, Henk Birkholz <[email-masked]>
wrote:

> The requirements on control plane functions imply certain interaction
> models (e.g. component registration, capability authentication, or content
> authorization). The same is true with the way how SACM content is conveyed:
> Request/Response schemes (e.g. REST), Repository Subscriptions (e.g. YANG
> Push), Brokered Pub/Sub Topics (e.g. xmpp-grid), or Deployment (e.g.
> dynamic Call-Home) make use of certain interaction models. As the SACM
> architecture intends not to prescribe certain solutions, it has to
> elaborate about the required functions on a more abstract level. The term
> Interaction Model supports the definition of appropriate non-prescriptive
> sets of functions in the architecture, I think.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/65#issuecomment-351721829>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AJgkSWdr8Lrd0Z4E5zhfVIMDG0som6Zgks5tAS0MgaJpZM4Q8hl2>
> .
>

-- 
regards,
John

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/65#issuecomment-351815219

---

From: adammontville <[email-masked]>
Date: Mon, 18 Dec 2017 12:23:04 -0800

If we're keeping it, do we mind segregating the definition from the exposition? 

> The definition of specific sequences regarding the exchange of messages (data in motion), including, for example, conditional branching, thresholds and timers. 

>An interaction model, for example, can be used to define operations, such as registration or discovery, on the control plane. A composition of data models for data in motion and a corresponding interaction model is a protocol.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/65#issuecomment-352547018