Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Improve the definition of SACM Component Discovery (#69)

From: adammontville <[email-masked]>
Date: Sun, 10 Dec 2017 07:46:02 -0800

SACM Component Discovery: "The task of brokering appropriate SACM components according to their capabilities or roles on request."

The definition doesn't seem to match the term. I would expect, instead, to see something like: "the action or process of discovering SACM Components within a SACM Domain."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/69

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 07:34:50 -0800

Agreed. While the definition is not "wrong" it is totally confusing.

Interestingly, you wrote action instead of task (which is on my list and off-topic). I will go with task for now, but at some point we should revisit task.

Maybe somthing like this? "the task of discovering the capabilities provided by SACM components within a SACM domain via an appropriate set of control plane functions." This reverses the order of Component and Capability - but maybe that is for the better? Capabilities are the starting point, I think. If 10 components can provide the capability, maybe they provide also other characteristics that help me to choose.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/69#issuecomment-351745397