Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Do we really need to define timestamps? (#80)

From: adammontville <[email-masked]>
Date: Sun, 10 Dec 2017 15:58:37 +0000 (UTC)

Do we need this term? Or should we talk about "data object timestamp" and "event timestamp" (and thus "network event timestamp")?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/80

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 16:32:12 +0000 (UTC)

Unfortunately, the current understanding is yes *sigh* because they are highly relevant in the scope of a SACM domain.

Having said that, I am have a hard time understanding the question, as the definition basically references rfc4949 and the reference is about a "data object timestamp". I.e. we are already talking about data object timestamps. We came to the conclusion that while sometimes clumsy terms, such as, "Target Endpoint Characterization Record" cannot be avoided, here we could just refer to the term timestamp and illustrate the use in the context of a SACM domain.

Is that a bad approach? We can name it "Data Object Timestamps", but I am not sure that this would solve a problem.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/80#issuecomment-351763141

---

From: adammontville <[email-masked]>
Date: Mon, 18 Dec 2017 20:17:48 +0000 (UTC)

If we need to define these and point to 4949 there's nothing wrong with that. I only observed that the 4949 definition of timestamp actually provides the definition for two specializations. If we're ok with "timestamps", that's probably fine. It just seems that in some cases we're trying very hard to be semantically precise, and in others not so much - I'm trying to understand how we choose.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/80#issuecomment-352545731