Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] We need to revisit Software Component and possibly Software Instance (#71)

From: adammontville <[email-masked]>
Date: Sun, 10 Dec 2017 15:50:47 +0000 (UTC)

I'm not really happy with our definition for *Software Component*. To me, a software component may be part of a specific package, not an installed package. For example, the Atom text editor may have a "file viewer" component. This definition is more like the intent behind SACM Component. Does this really mean to say "software application"? That may solve a lot. 

If we update this to say software application, then we'll need to additionally update *Software Instance* to be defined as "a running instance of a software application."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/71

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 07:45:19 -0800

There is a reason why "Software Component" is "installed software" (it is not always installed package, firstly because it can be only a subset of the package and 2ndly because we are not sure if package includes every common source today John had some insight on this, if I remember correctly.):

Software Component and Hardware Component are currently on the same semantic level. Both are "installed but not necessarily in use". This creates the object property relationship that every endpoint "is-a" composite of zero or more Hardware Components & and zero or more Software Components. As Endpoint is the taxonomic parent of Target Endpoint and SACM Component this is of course also true for those.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/71#issuecomment-351748528