Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Should SACM scope statements belong in the terminology draft? (#64)

From: adammontville <[email-masked]>
Date: Sun, 10 Dec 2017 15:08:32 +0000 (UTC)

For Data In Motion we say, "The SACM architecture and corresponding models focus on data in motion."

For Data At Rest we say, "In the context of SACM, data models for data at rest are out of scope."

Do we really need either of these statements in the terminology draft? They seem out of place.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 14:00:50 +0000 (UTC)

It is true that scope is not defined in this document. Also, explanatory (con)text should help and not confuse.

In consequence, I would raise the question: Is it useful to reiterate the association with scope as explanatory (con)text, or is it confusing? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-351718453

---

From: David Waltermire <[email-masked]>
Date: Thu, 14 Dec 2017 06:35:49 -0800

The charter defines what is in scope for an IETF WG. Any mention of scope should be left to the SACM charter.

Regards,
Dave

From: Henk Birkholz [mailto:[email-masked]]
Sent: Thursday, December 14, 2017 9:01 AM
To: sacmwg/draft-ietf-sacm-terminology <[email-masked]>
Cc: Subscribed <[email-masked]>
Subject: Re: [sacmwg/draft-ietf-sacm-terminology] Should SACM scope statements belong in the terminology draft? (#64)

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fsacmwg%2Fdraft-ietf-sacm-terminology%2Fissues%2F64%23issuecomment-351718453&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cc454bf0a45fb43b292af08d542fb15a1%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636488568520605164&sdata=Qq8g%2FaHb8Ip9E6Kg1mBTE%2BOUNnCk4okjUmH8FxxMvEE%3D&reserved=0>, or mute the thread<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fnotifications%2Funsubscribe-auth%2FAJaiaGfGSf08cvs-vqzeW1IL3FikEOQBks5tASoRgaJpZM4Q8hiP&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cc454bf0a45fb43b292af08d542fb15a1%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636488568520605164&sdata=ID14tcWGlUO8rtt1Up8A0owhbbgjm3lRDWmBgARM7uc%3D&reserved=0>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-351727868

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 14:54:07 +0000 (UTC)

The charter text does neither include date in motion nor data at rest. How would you resolve the disconnect between definition and scope, Dave?

Also, when the WG is closed, a definition, what the scope the created set of RFC (i.e. the scope of the contributions, not the scope of the WG) will have, should remain in at least one document. Where would you retain that information, Dave?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-351733285

---

From: David Waltermire <[email-masked]>
Date: Thu, 14 Dec 2017 15:02:41 +0000 (UTC)

If the charter does not state something as out of scope, it is typical that the thing is considered within scope. From a process perspective, it’s up to the WG chairs to sort out scope issues if needed.

I don’t think it’s necessary to retain information about the scope of the WG. Each published RFC should articulate the scope of what it is defining. If cross RFC or architectural concerns need to be defined, then an architecture draft should speak to such concerns.

From: Henk Birkholz [mailto:[email-masked]]
Sent: Thursday, December 14, 2017 9:54 AM
To: sacmwg/draft-ietf-sacm-terminology <[email-masked]>
Cc: Waltermire, David A. (Fed) <[email-masked]>; Comment <[email-masked]>
Subject: Re: [sacmwg/draft-ietf-sacm-terminology] Should SACM scope statements belong in the terminology draft? (#64)

—
You are receiving this because you commented.
Reply to this email directly, view it on GitHub<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fsacmwg%2Fdraft-ietf-sacm-terminology%2Fissues%2F64%23issuecomment-351733285&data=02%7C01%7Cdavid.waltermire%40nist.gov%7C605e82d262c0412759b008d5430287bf%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636488600502407702&sdata=ofei7mkloh8EqW7IuC0V%2BCNVmwqH%2FrEUj5ha1qdJt9k%3D&reserved=0>, or mute the thread<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fnotifications%2Funsubscribe-auth%2FAJaiaHlE-MYKy8aoFM5ff_v477swXvdtks5tATaOgaJpZM4Q8hiP&data=02%7C01%7Cdavid.waltermire%40nist.gov%7C605e82d262c0412759b008d5430287bf%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636488600502407702&sdata=nF%2F4XVhI1qiqhHLxkEV1dhJGyPbVJtqMcdPC7pHFbmI%3D&reserved=0>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-351735771

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 14 Dec 2017 15:15:09 +0000 (UTC)

I agree that we do not need to retain WG charter scope.

That is why I tried to highlight "scope of resulting solutions".

In the end, there will be a set of proposed standards, a few of them informational. Imagine, the reader for example being an engineer of a vendor, I would like to know the intend and applicability of these proposed standards to my products and business strategy. Effectively, I would like to know if I can just use any data at rest representation I want, or if there are some imposed prescribed restrictions wrt the characteristics of how I store processed content in a repository - and there are none.

This is the only reason why the text is in the definition. If this violates an exclusiveness that is tied to the context of the charter, we just have to rephrase it and/or put that information in another document. If not, maybe just keep it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-351739403