Subject: Re: SACRED IPR - draft mail for Friday

From: "RL 'Bob' Morgan" <[email-masked]>
Date: Thu, 6 Oct 2005 10:27:54 -0700 (PDT)

Well, so as to provide at least one additional data point:  it is my 
opinion, which I guess is consistent with that of the WG chairs, that a 
standard in this technical space would only be valuable -- ie, only worth 
developing -- if implementations could be written and distributed without 
having to pay license fees.  So given the stated terms neither of these 
technologies is worth building into a standard.  This is very unfortunate, 
since it seems to mean that SACRED won't be able to produce a standard, 
since no appropriate unencumbered technologies appear to exist.

  - RL "Bob" Morgan
    University of Washington and Internet2

---

On Fri, 23 Sep 2005, Stephen Farrell wrote:

> Hi All,
>
> At the Paris meeting [1,2] Lucent and Phoenix agreed to
> actions to specify their IPR positions wrt PAK and SPEKE
> respectively.
>
> Unfortunately the results so far do not, in our opinion,
> represent significant progress.
>
> Essentially, Lucent have re-iterated their license terms for
> PAK (part of Planet9's open source license), but any other
> implementation would be RAND. To quote their response:
>
>        1) PAK has been implemented as part of the open-source
>           PLAN 9 Operating System, whose OSI-certified Lucent
>           Public License Version 1.02 is available at
>              http://www.cs.bell-labs.com/plan9dist/license.html.
> 	2) Any other use of IPR associated with PAK will be licenced
>           by Lucent under RAND, if it becomes an IETF standard.
>
> Phoenix have indicated that they can offer RF terms, but
> only for clients on "standard personal computers" - they
> maintain their RAND terms for servers.
>
> We think the above captures the position, but of course
> Lucent or Phoenix folks can clarify if we've gotten
> something wrong.
>
> Magnus and I have communicated our opinions of these
> terms to the relevant folks. Basically, this amounts to
> an opinion that neither scheme seems attractive on
> these terms. They have both said they'd get back to
> us with further information, but since the Vancouver
> meeting is so close, we want to get this information
> to the list now, to help us all make (or not make)
> travel plans.
>
> We'd ask you to comment on these terms, in particular
> whether you'd find them attractive enough to warrant
> this WG doing new work. (Please don't get into invective
> though - the only question of interest is whether or
> not you find these terms ok for sacred, we don't want
> your more general IPR opinions please!).
>
> Regards,
> Stephen & Magnus.
>
> [1] http://www.imc.org/ietf-sacred/mail-archive/msg00665.html
> [2]
> https://datatracker.ietf.org/public/proceeding_interim.cgi?meeting_num=63
>
>
>
>
>
>
>

---

From: "RL 'Bob' Morgan" <[email-masked]>
Date: Thu, 6 Oct 2005 10:42:50 -0700 (PDT)

> This is very unfortunate, since it seems to mean that SACRED won't be 
> able to produce a standard, since no appropriate unencumbered 
> technologies appear to exist.

A standard using EKE-style technology, that is, as an alternative to 3767.

  - RL "Bob"