Subject: Re: draft-burdis-cat-srp-sasl-07.txt

From: "Trevor Perrin" <[email-masked]>
Date: Sat, 14 Sep 2002 18:32:42 -0800

>From: "Raif S. Naffah" <[email-masked]>
>
>nevertheless, since this wording in the draft is now clearly ambiguous,
>i therefore suggest we remove it from the next iteration; i.e. the
>paragraph in question in "1. Introduction" would then becomes:
>
>"The mechanism described herein is based on the SRP protocol described
>at the end of section 3 in [RFC-2945]..."
>

Hi Raif,

I still think that's wrong.  The protocol described at the end of section 3 
in RFC 2945 is clearly "optimized" in the sense I decribed, which 
corresponds with Tom's use of the term "optimized" in the SRP paper (see 
Table 5 vs. Table 6):
http://www-cs-students.stanford.edu/~tjw/srp/ndss.html

The protocol in your draft is not optimized in this sense.  So the text in 
question should not refer to "the end of section 3".

Trevor

_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com

---

From: "Raif S. Naffah" <[email-masked]>
Date: Sun, 15 Sep 2002 15:20:26 +1000

hello Trevor,

> question should not refer to "the end of section 3".

the end of section 3 in RFC-2945 states:
QUOTE
        Client                             Host
       --------                           ------
        U, A                        -->
                                    <--    s, B
        H(H(N) XOR H(g) | H(U) | s | A | B | K)
                                    -->
                                    <--    H(A | M | K)

   The values of N and g used in this protocol must be agreed upon by
   the two parties in question.  They can be set in advance, or the host
   can supply them to the client.  In the latter case, the host should
   send the parameters in the first message along with the salt...
UNQUOTE

if N and g are negotiated, as it is the case in our draft, then the exchange
becomes:

   Client     Host
   ------     ------
   U     -->
         <--  N,g,s
   A     -->
         <--  B
   M1    -->
         <--  M2

given the above, does anybody else think that the new wording: "The mechanism
described herein is based on the SRP protocol described at the end of section
3 in [RFC-2945]..." is unclear, misleading or untrue?

cheers;
rsn

---

From: "Raif S. Naffah" <[email-masked]>
Date: Sun, 15 Sep 2002 15:20:26 +1000

hello Trevor,

   Client     Host
   ------     ------
   U     -->
         <--  N,g,s
   A     -->
         <--  B
   M1    -->
         <--  M2

cheers;
rsn