Subject: Re: I-D ACTION:draft-hansen-sasl-pki-00.txt

From: Sam Hartman <[email-masked]>
Date: Sat, 08 Mar 2003 15:16:51 -0500

It seems that we really already have enough mechanisms for doing
PKI-like things with SASL:

* SPKM 
* LIPKI
* TLS + plain

What's wrong with using something like LIPKI and negotiating no
integrity protection?

If your complaint is simply the lack of implementations of LIPKI, then
I think that the advantages of having fewer standards outweigh the
implementation complexity of LIPKI.

If your complaint is that you don't want the complexity of a GSS
library, then you should realize that you can implement the LIPKI
protocol without actually using a GSSAPI library.

---

From: Sam Hartman <[email-masked]>
Date: Sat, 08 Mar 2003 15:49:03 -0500

* SPKM 
* LIPKI
* TLS + plain

---

From: Sam Hartman <[email-masked]>
Date: Sat, 08 Mar 2003 15:16:51 -0500

* SPKM 
* LIPKI
* TLS + plain

---

From: Sam Hartman <[email-masked]>
Date: Sat, 08 Mar 2003 15:49:03 -0500

* SPKM 
* LIPKI
* TLS + plain