Subject: [corrected] Re: draft-ietf-sasl-crammd5-02 / additional mechanisms ?

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 09 Apr 2004 12:41:41 -0700

My previous note had a few unfortunate typos in it.  This should be
more clear.  Sorry for any confusion. -- Kurt

Tino,

The SASL WG's CRAM-MD5 work item is limited to revising the SASL
CRAM-MD5 authentication mechanism.  Engineering of other CRAM-based
mechanisms is simply beyond the scope of this working group.  I
suggest you pursue the specification of other mechanisms on an
individual basis.

I do note that this list is an acceptable forum for review of
SASL-related submissions produced by individuals (as long as
such review does not impede progress on WG deliverables).

Regards, Kurt (as co-chair of the SASL-WG)

At 03:26 AM 4/8/2004, Tino Reichardt wrote:

>Hello ietf-sasl list.
>
>First of all: my english isn't the best and I am new to this list.
>
>I think the draft 'The CRAM-MD5 SASL Mechanism' should not only
>specify the CRAM-MD5 mechanism.
>Maybe it can be renamed to 'The CRAM SASL Mechanism family' or similar
>and then specify also some other standard hash routines as SASL CRAM
>mechanisms:
>
>: CRAM-MD5
>160bit: CRAM-SHA1
>160bit: CRAM-RIPEMD-160
>320bit: CRAM-RIPEMD-320
>
>
>ps: The CRAM-SHA1 mechanism is already used by serveral servers and
>    clients.
>
>
>references:
>
>[SHA1]   http://www.itl.nist.gov/fipspubs/fip180-1.htm
>[RIPEMD] http://www.esat.kuleuven.ac.be/~bosselae/ripemd160.html
>
>
>-- 
>regards, TR

---

From: Tino Reichardt <[email-masked]>
Date: Fri, 9 Apr 2004 22:29:54 +0200

> more clear.  Sorry for any confusion. -- Kurt
No problem :)

> suggest you pursue the specification of other mechanisms on an
Okay, I will do so.

> such review does not impede progress on WG deliverables).
Sorry, if I was to pertly :)

-- 
regards, TR

---

From: Tino Reichardt <[email-masked]>
Date: Fri, 9 Apr 2004 22:29:54 +0200

No problem :)

Okay, I will do so.

-- 
regards, TR