Subject: Re: [savi] DAD as a binding distribution protocol: why not

From: "Guang Yao" <[email-masked]>
Date: Mon, 1 Jun 2009 22:51:18 +0800

Because currently CPS only set up bindings for directly connected hosts, the
possibility of DAD packet loss is low. However, it will be argued this would
happen anyway. 
I have to say, it is partly cause by the defect of DAD. 
I wonder whether there would always be
argument that DAD should never be used because unreliable DAD would lead to
a wrong configuration in the network, unless in the future, DAD is design to
be a reliable model (a model I can't image now).
However, after all, DAD is widely used.

Packet loss can never be eliminated. I just want to argue:
1 DAD packet loss wouldn't happen that frequently. And things will be better
in the future.

	(1) In wired network, zero-frame loss is not a new concept, which
means no frame will be dropped within the throughput. 
	  I think more devices will have zero-frame loss feature, because of
the requirement of real-time multimedia, online game, etc.
	
	(2) The number of DAD NS is configurable. Though currently it is 1,
I think 3 is a good number, as the collision detection number of IPv4 

	(3) Wireless network has higher loss possibility. 
	  But the things are some different from wired network.
	  Some research has been performed on spoofing in wireless network,
including MANET.
	  I'm not quite familiar with this area. I will check related
papers.

2 Even it happens, the damage is not that great.

	Stop a session before it is initialized maybe is better than shut it
when it is alive.
	In a typical scene, a host finds it cannot send packets, thus it
will configure another address or re-initialize interface, then everything
is OK, nothing get lost.
	Actually I always have to re-configure my address because the
address in our lab is manually configured. If someone has used my address
ahead, I have to change
	my address.

Regards, Guang

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Christian Vogt
> Sent: Thursday, May 21, 2009 4:52 AM
> To: Guang Yao
> Cc: SAVI Mailing List
> Subject: Re: [savi] DAD as a binding distribution protocol: why not
> 
> On Apr 28, 2009, Guang Yao wrote:
> 
> > Thus, without DAD, the SAVI device cannot get known whether this
> > address
> > has been used by other nodes. Only after a successful DAD, the SAVI
> > device has confident to set up a binding for that address; or else, it
> > may cause fallacious binding.
> 
> 
> Guang -
> 
> As with the first data packet, also the DAD packets are not guaranteed
> to
> reach the SAVI device.  There are two reasons for this:  First, DAD
> packets may get lost, as Marcelo has mentioned.  This is in particular
> so
> if the DAD packets have to make an extra hop via a legacy switch.
> Second,
> because the DAD packets may deliberately not be forwarded to the SAVI
> device.  DAD packets are not broadcast; they are either unicast or
> limited
> to a certain multicast group, so they may not reach the SAVI device.
> 
> Since DAD packets are not guaranteed to reach the SAVI device just as
> data packets, CPS may run into problems that are very similar to the
> FCFS-
> specific problems you have identified.
> 
> - Christian
> 
> 
> _______________________________________________
> savi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/savi

---

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 02 Jun 2009 10:01:44 +0200

> possibility of DAD packet loss is low. However, it will be argued this would
exactly, it will happen

> I have to say, it is partly cause by the defect of DAD. 
i wouldn't call it a defect, it is simply an unreliable protocol, cause 
it was not designed to be reliable

In any case, it is not relevant to use whehter we can change DAD to make 
it reliable, since no hosts changes are acceptable.

So, the bottom line is it is not accpetable to design a SAVI solution 
that relies on DAD to grant access to the network.

Regards, marcelo

---

From: "Greg Daley" <[email-masked]>
Date: Wed, 3 Jun 2009 09:05:20 +1000

Hi Marcelo,

> Guang Yao escribió:
> > Because currently CPS only set up bindings for directly connected 
> > hosts, the possibility of DAD packet loss is low. However, it will be 
> > argued this would happen anyway.
> >   
> exactly, it will happen

> i wouldn't call it a defect, it is simply an unreliable protocol, cause it was not designed to be reliable
>
> In any case, it is not relevant to use whehter we can change DAD to make it reliable, since no hosts changes are acceptable.
>
> So, the bottom line is it is not accpetable to design a SAVI solution that relies on DAD to grant access to the network.
>
> Regards, marcelo

I agree that DAD is insufficient as a binding discovery protocol since it is an instantaneous action with
no inherent reliability.  Once an address is known, NS is a valid (perhaps reliable) way of testing the address's
continued presence, but loss of the initial packet inhibits subsequent testing.

An existing protocol which reliably reports addresses is MLDv2.  This protocol periodically reports only multicast
addresses, including the Solicited Nodes' multicast addresses which are required to be bound for successful
multicast Neighbour Discovery Message reception.

Presence of a reported Solicited Nodes' address indicates that a unicast address may continue to be present on the link.
(It shows at least that the port is interested in receiving the Multicast packets to this solicited nodes' address).
Solicited nodes addresses do not uniquely identify addresses, though, so presence of a solicited nodes' address without
seeing a commensurate DAD message cannot identify which of the 2^24 (per prefix) mapped to the group is in use.

No other mandatory link-local IPv6 protocol has a continual reporting mechanism which identifies all participants.

The closest to this is DHCPv6 on a managed network (RFC4862 M=1), but this doesn't manage link-local addressing issues, as
link-locals are required before DHCPv6 can be attempted.

Greg