Subject: [scim] Schema Extension Question

From: Rolf Brugger <[email-masked]>
Date: Tue, 27 Feb 2018 13:54:01 +0100

Hi all,

We plan to use SCIM in one of our services. We will need a schema 
extension, and I was wondering if we can choose our own schema extension 
URI, or if it has to be hierarchically below in the namespace 
"urn:ietf:params:scim:schemas:extension"?

Does our extension have to be registered somewhere?

If we can define our own URI, we would probably use something like 
"urn:mace:switch.ch:SWITCHeduid" (according to 
https://www.switch.ch/aai/mace/ )

Cheers
Rolf

-- 
SWITCH
Rolf Brugger, Trust & Identity
Werdstrasse 2, P.O. Box, 8021 Zurich, Switzerland
direct +41 44 268 15 89
[email-masked], https://www.switch.ch

---

From: Phil Hunt <[email-masked]>
Date: Wed, 28 Feb 2018 07:24:05 -0800

There is a registration process described in the IANA section. 

In practice people don’t usually register schemas for local or specific deployment use and often do use shorter urns. This can become a migration issue if you have a need to register in IANA SCIM registry down the road.  

Phil

> On Feb 27, 2018, at 4:54 AM, Rolf Brugger <[email-masked]> wrote:
> 
> Hi all,
> 
> We plan to use SCIM in one of our services. We will need a schema extension, and I was wondering if we can choose our own schema extension URI, or if it has to be hierarchically below in the namespace "urn:ietf:params:scim:schemas:extension"?
> 
> If we can define our own URI, we would probably use something like "urn:mace:switch.ch:SWITCHeduid" (according to https://urldefense.proofpoint.com/v2/url?u=https-3A__www.switch.ch_aai_mace_&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=KN5wrUhJxy4TFaMiUQf1CBiiMb-8XYyOkA48eBy0aOQ&s=1d1TRPe015MDsqAKfOBvNgx0Sig5JWdWY0RjXgPMgbc&e= )
> 
> Cheers
> Rolf
> 
> -- 
> SWITCH
> [email-masked], https://urldefense.proofpoint.com/v2/url?u=https-3A__www.switch.ch&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=KN5wrUhJxy4TFaMiUQf1CBiiMb-8XYyOkA48eBy0aOQ&s=HIHzAVwT2UgaGrfLDDtvZcMGBYAS39E2WLrNuYkvuEg&e=
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_scim&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=KN5wrUhJxy4TFaMiUQf1CBiiMb-8XYyOkA48eBy0aOQ&s=76joCnl202Nd9yuHIK6zFCzH6AwnMFLokMtLtyGVFoQ&e=