Subject: [SCITT] GitHub DIDs & VCs for Supply Chain Traceability

From: Orie Steele <[email-masked]>
Date: Mon, 7 Mar 2022 12:41:11 -0600

Hello,

I'm Orie, I work on identifier and credentialing standards at W3C and IETF.

My company Transmute
<https://streaklinks.com/A9ifQyqiYqEgkF4xWgxA5Ast/https%3A%2F%2Ftransmute.industries%2F>
applies these standards to supply traceability (both physical and software).

Some of our work is funded by DHS SVIP
<https://streaklinks.com/A9ifQyqNTelooObAhwFx98Nw/https%3A%2F%2Fwww.dhs.gov%2Fscience-and-technology%2Fsvip>,
including our work on applying DIDs and VCs to physical supply chain issues
associated with global trade and imports and exports.

If you are interested in that work it can be found here:
https://w3id.org/traceability
<https://streaklinks.com/A9ifQy2fH6UWEI23iw-vWGEG/https%3A%2F%2Fw3id.org%2Ftraceability>
.

I wanted to share some very recent (experimental and unstable) work we've
done to enable Decentralized Identifiers
<https://streaklinks.com/A9ifQyqX11lXlzLvQgPI070Q/https%3A%2F%2Fwww.w3.org%2FTR%2Fdid-core%2F>
and Verifiable Credentials
<https://streaklinks.com/A9ifQymDA7VYHe95RgZjMZKI/https%3A%2F%2Fwww.w3.org%2FTR%2Fvc-data-model%2F>
to assist with the software supply chain.

Here are the links:

- https://github.com/transmute-industries/verifiable-actions
<https://streaklinks.com/A9ifQyqXl4mGukfBcw_Wj_Q8/https%3A%2F%2Fgithub.com%2Ftransmute-industries%2Fverifiable-actions>
-
https://github.com/transmute-industries/public-credential-registry-template
<https://streaklinks.com/A9ifQyuHh9DtUHodDwKXtBBB/https%3A%2F%2Fgithub.com%2Ftransmute-industries%2Fpublic-credential-registry-template>

The key idea is to enable github actions to sign and verify credentials
that conform to the W3C Verifiable Credentials standard (which in turn
supports various envelope formats including JOSE, COSE and PGP).

The issuers are identified with W3C Decentralized Identifiers, which
provide a layer of interoperability for public key identifier registries.
The key value of this standard is the ability to support both traditional
public key based identifiers, web resource based identifiers and
blockchain based identifiers in the same data model.

The examples in the repository links above demonstrate support for these
standards using did:key
<https://streaklinks.com/A9ifQyuGxqSDtSpdZABx8eMt/https%3A%2F%2Fw3c-ccg.github.io%2Fdid-method-key%2F>
and
did:web
<https://streaklinks.com/A9ifQyqsLGN-htS74QXmSanv/https%3A%2F%2Fgithub.com%2Fw3c-ccg%2Fdid-method-web>,

however I am one of the editors of the Sidetree Protocol
<https://streaklinks.com/A9ifQyuu7nlpbor7UAurwtjs/https%3A%2F%2Fgithub.com%2Fdecentralized-identity%2Fsidetree>
which
is what powers did:ion
<https://streaklinks.com/A9ifQyuxcXKIp3hEOgkQqHLh/https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fidentity-standards-blog%2Fion-we-have-liftoff%2Fba-p%2F1441555>
which
is being developed by Microsoft and other DIF members...
The GitHub examples I provided will also work with did:ion.

Feel free to raise issues on any of the repositories linked, or ask me
questions directly by email if you are not comfortable commenting on a
public repo.

Regards,

OS

-- 
*ORIE STEELE*
Chief Technical Officer
www.transmute.industries

<https://streaklinks.com/A9ifQyqJyZSff0skfwnnG7JR/https%3A%2F%2Fwww.transmute.industries>
ᐧ

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 9 Mar 2022 22:49:34 +0100

Hello global supply chain enthusiasts,

as a quick recap, the purpose of this list is stated in its initial 
message here:

> https://mailarchive.ietf.org/arch/msg/scitt/a7K7zIKLe-pZnsE1lyz85iEiVSI/

Kay already announced that weekly recurring discussions on all topics 
about Supply Chain Integrity, Transparency, and Trust happen Mondays 4pm 
UTC, currently. Details on how to join these are in her message can be 
found here:

> https://mailarchive.ietf.org/arch/msg/scitt/NgkcZAMgEWQUNNpigx2KXYTGPTk/

Now - there has been some initial work on how suitable IETF buildings
blocks could be used in the SCITT context. As a result, there are 
currently two I-Ds in the SCITT space":

> https://datatracker.ietf.org/doc/draft-birkholz-scitt-architecture/

and

> https://datatracker.ietf.org/doc/draft-birkholz-scitt-receipts/

Both of them reflect work that happens live on github in an
IETF-minded github organization:

> https://github.com/ietf-scitt

Next, we'll request secdispatch agenda time for the two I-Ds mentioned 
above and will see how that goes. Please expect cross-posts between 
[email-masked] and [email-masked].

Independently, well... this is the place. If you'd like to chime in, 
have an opinion of what is feasible or not for SCITT, how that clashes 
with the highlighted proposals or not, and how to build resilient and 
useful solutions for SCITT in the IETF space, please voice your point of 
view here.

Viele Grüße,

Henk

p.s. if you feel that this message or one of the I-Ds highlighted is 
interesting to your IETF WG, please feel free to relay or cross-post.

---

From: Kay Williams <[email-masked]>
Date: Fri, 11 Mar 2022 22:59:06 +0000

Hi Orie (and Sapan),

Apologies for my late response to your email.  It landed in my spam folder, and I am just now seeing it.  (As a side note, I have now unblocked all email from ietf.org.)

Thank you for sharing this work.  Would you be interested in taking a few minutes on the agenda at our Monday 3/14 4 PM UTC meeting, or a future meeting, to provide an overview an entertain discussion?

Kay

From: SCITT <[email-masked]> On Behalf Of Orie Steele
Sent: Monday, March 7, 2022 10:41 AM
To: [email-masked]
Cc: Sapan Narang <[email-masked]>
Subject: [SCITT] GitHub DIDs & VCs for Supply Chain Traceability

Hello,

My company Transmute<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqiYqEgkF4xWgxA5Ast%2Fhttps%253A%252F%252Ftransmute.industries%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956101386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=9R5j2qoK1Pwv2blibs6LsjcrxOH6r4wGLA%2Bej0QTowE%3D&reserved=0> applies these standards to supply traceability (both physical and software).

Some of our work is funded by DHS SVIP<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqNTelooObAhwFx98Nw%2Fhttps%253A%252F%252Fwww.dhs.gov%252Fscience-and-technology%252Fsvip&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=aIJmd5v43klp8sTVCwfzXaj%2FYaTDlZzcbfUTiEsIULQ%3D&reserved=0>, including our work on applying DIDs and VCs to physical supply chain issues associated with global trade and imports and exports.

If you are interested in that work it can be found here: https://w3id.org/traceability<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQy2fH6UWEI23iw-vWGEG%2Fhttps%253A%252F%252Fw3id.org%252Ftraceability&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=yFaOJyKbjDNmQcAiqsQavv3CSSDpb8xJ1IIP1Iax7jk%3D&reserved=0>.

I wanted to share some very recent (experimental and unstable) work we've done to enable Decentralized Identifiers<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqX11lXlzLvQgPI070Q%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fdid-core%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=nRWgY1i%2BR1f7bPsZqjbBsnCzWE99473A7KfBFnq31C8%3D&reserved=0> and Verifiable Credentials<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQymDA7VYHe95RgZjMZKI%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fvc-data-model%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=yow6DrPjnCMJ8nNo4bdnC2aQqnK2VEaoz%2FNMaAEhjPk%3D&reserved=0> to assist with the software supply chain.

Here are the links:

- https://github.com/transmute-industries/verifiable-actions<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqXl4mGukfBcw_Wj_Q8%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fverifiable-actions&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=8NnTSuiG7EuvwPW8HSFqdgwsEHNGOvVGjGSMsbQ5iWo%3D&reserved=0>
- https://github.com/transmute-industries/public-credential-registry-template<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuHh9DtUHodDwKXtBBB%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fpublic-credential-registry-template&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=zNRyp1Amaglk7M5KtAAAre0g0p4COR2B4MnNw3HyXdA%3D&reserved=0>

The key idea is to enable github actions to sign and verify credentials that conform to the W3C Verifiable Credentials standard (which in turn supports various envelope formats including JOSE, COSE and PGP).

The issuers are identified with W3C Decentralized Identifiers, which provide a layer of interoperability for public key identifier registries.
The key value of this standard is the ability to support both traditional public key based identifiers, web resource based identifiers and blockchain based identifiers in the same data model.

The examples in the repository links above demonstrate support for these standards using did:key<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuGxqSDtSpdZABx8eMt%2Fhttps%253A%252F%252Fw3c-ccg.github.io%252Fdid-method-key%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=Z8q%2B%2B%2B5un6kXFtoJco8Zq%2FFQ0SkbAbEA6rIln4Icoik%3D&reserved=0> and did:web<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqsLGN-htS74QXmSanv%2Fhttps%253A%252F%252Fgithub.com%252Fw3c-ccg%252Fdid-method-web&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=uk%2FI2jVLWPstJ8BPNC48FwX%2BSIkL7JpkLQSoGZp5R10%3D&reserved=0>,
however I am one of the editors of the Sidetree Protocol<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuu7nlpbor7UAurwtjs%2Fhttps%253A%252F%252Fgithub.com%252Fdecentralized-identity%252Fsidetree&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=x46LrtTjutTQOlGxvgOfSssV0lt%2FGw3tT2WMOmOOEEQ%3D&reserved=0> which is what powers did:ion<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuxcXKIp3hEOgkQqHLh%2Fhttps%253A%252F%252Ftechcommunity.microsoft.com%252Ft5%252Fidentity-standards-blog%252Fion-we-have-liftoff%252Fba-p%252F1441555&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956201387%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=O%2FYemSxT96Ju3GxGpQphQCkUixMRci3cvSflSRufHdk%3D&reserved=0> which is being developed by Microsoft and other DIF members...
The GitHub examples I provided will also work with did:ion.

Feel free to raise issues on any of the repositories linked, or ask me questions directly by email if you are not comfortable commenting on a public repo.

Regards,

OS

--
ORIE STEELE
Chief Technical Officer
www.transmute.industries<http://www.transmute.industries>

[https://drive.google.com/a/transmute.industries/uc?id=1hbftCJoB5KdeV_kzj4eeyS28V3zS9d9c&export=download]<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqJyZSff0skfwnnG7JR%2Fhttps%253A%252F%252Fwww.transmute.industries&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956201387%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=78P89eUSJMqceWK1Pfkl1xZ%2F9MfwbkRUhu12F0EqlFE%3D&reserved=0>
ᐧ

---

From: Orie Steele <[email-masked]>
Date: Mon, 14 Mar 2022 10:21:56 -0500

Sorry I got to this late.

I can prepare something for the next meeting.

Regards,

OS

On Fri, Mar 11, 2022 at 4:59 PM Kay Williams <[email-masked]> wrote:

> Hi Orie (and Sapan),
>
>
>
> Apologies for my late response to your email.  It landed in my spam
> folder, and I am just now seeing it.  (As a side note, I have now unblocked
> all email from ietf.org.)
>
>
>
> Thank you for sharing this work.  Would you be interested in taking a few
> minutes on the agenda at our Monday 3/14 4 PM UTC meeting, or a future
> meeting, to provide an overview an entertain discussion?
>
>
>
> Kay
>
>
>
> *From:* SCITT <[email-masked]> *On Behalf Of * Orie Steele
> *Sent:* Monday, March 7, 2022 10:41 AM
> *To:* [email-masked]
> *Cc:* Sapan Narang <[email-masked]>
> *Subject:* [SCITT] GitHub DIDs & VCs for Supply Chain Traceability
>
>
>
> Hello,
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqiYqEgkF4xWgxA5Ast%2Fhttps%253A%252F%252Ftransmute.industries%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956101386%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=9R5j2qoK1Pwv2blibs6LsjcrxOH6r4wGLA%2Bej0QTowE%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqNTelooObAhwFx98Nw%2Fhttps%253A%252F%252Fwww.dhs.gov%252Fscience-and-technology%252Fsvip&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=aIJmd5v43klp8sTVCwfzXaj%2FYaTDlZzcbfUTiEsIULQ%3D&reserved=0>,
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQy2fH6UWEI23iw-vWGEG%2Fhttps%253A%252F%252Fw3id.org%252Ftraceability&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=yFaOJyKbjDNmQcAiqsQavv3CSSDpb8xJ1IIP1Iax7jk%3D&reserved=0>
> .
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqX11lXlzLvQgPI070Q%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fdid-core%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=nRWgY1i%2BR1f7bPsZqjbBsnCzWE99473A7KfBFnq31C8%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQymDA7VYHe95RgZjMZKI%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fvc-data-model%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=yow6DrPjnCMJ8nNo4bdnC2aQqnK2VEaoz%2FNMaAEhjPk%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqXl4mGukfBcw_Wj_Q8%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fverifiable-actions&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=8NnTSuiG7EuvwPW8HSFqdgwsEHNGOvVGjGSMsbQ5iWo%3D&reserved=0>
> -
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuHh9DtUHodDwKXtBBB%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fpublic-credential-registry-template&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=zNRyp1Amaglk7M5KtAAAre0g0p4COR2B4MnNw3HyXdA%3D&reserved=0>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuGxqSDtSpdZABx8eMt%2Fhttps%253A%252F%252Fw3c-ccg.github.io%252Fdid-method-key%252F&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=Z8q%2B%2B%2B5un6kXFtoJco8Zq%2FFQ0SkbAbEA6rIln4Icoik%3D&reserved=0> and
> did:web
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqsLGN-htS74QXmSanv%2Fhttps%253A%252F%252Fgithub.com%252Fw3c-ccg%252Fdid-method-web&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=uk%2FI2jVLWPstJ8BPNC48FwX%2BSIkL7JpkLQSoGZp5R10%3D&reserved=0>,
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuu7nlpbor7UAurwtjs%2Fhttps%253A%252F%252Fgithub.com%252Fdecentralized-identity%252Fsidetree&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956151382%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=x46LrtTjutTQOlGxvgOfSssV0lt%2FGw3tT2WMOmOOEEQ%3D&reserved=0> which
> is what powers did:ion
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuxcXKIp3hEOgkQqHLh%2Fhttps%253A%252F%252Ftechcommunity.microsoft.com%252Ft5%252Fidentity-standards-blog%252Fion-we-have-liftoff%252Fba-p%252F1441555&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956201387%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=O%2FYemSxT96Ju3GxGpQphQCkUixMRci3cvSflSRufHdk%3D&reserved=0> which
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqJyZSff0skfwnnG7JR%2Fhttps%253A%252F%252Fwww.transmute.industries&data=04%7C01%7Ckayw%40microsoft.com%7C4fa261ad2e11431b18be08da006aaec3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637822756956201387%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=78P89eUSJMqceWK1Pfkl1xZ%2F9MfwbkRUhu12F0EqlFE%3D&reserved=0>
>
> ᐧ
>

-- 
*ORIE STEELE*
Chief Technical Officer
www.transmute.industries

<https://www.transmute.industries>

---

From: Orie Steele <[email-masked]>
Date: Fri, 18 Mar 2022 09:19:38 -0500

I am prepared to present, can you confirm a time.

Regards,

OS

-- 
*ORIE STEELE*
Chief Technical Officer
www.transmute.industries

---

From: Antoine Delignat-Lavaud <[email-masked]>
Date: Fri, 18 Mar 2022 16:54:14 +0000

Hi Orie,

Is there any follow up to the W3C Traceability Vocabulary document? It has some good context and terminology on supply chain security but doesn’t seem to offer any concrete solution or improvement. 

Antoine

From: SCITT <[email-masked]> On Behalf Of Orie Steele
Sent: 18 March 2022 14:20
To: Kay Williams <[email-masked]>
Cc: Sapan Narang <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [SCITT] GitHub DIDs & VCs for Supply Chain Traceability

Some people who received this message don't often get email from [email-masked] <mailto:[email-masked]> . Learn why this is important <http://aka.ms/LearnAboutSenderIdentification> 

Regards,

OS

On Mon, Mar 14, 2022 at 10:21 AM Orie Steele <[email-masked] <mailto:[email-masked]> > wrote:

Regards,

OS

On Fri, Mar 11, 2022 at 4:59 PM Kay Williams <[email-masked] <mailto:[email-masked]> > wrote:

Hi Orie (and Sapan),

Apologies for my late response to your email.  It landed in my spam folder, and I am just now seeing it.  (As a side note, I have now unblocked all email from ietf.org <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fietf.org%2F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843394128%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=ZYSZJV0zxzL3rq%2FSEi7Zvc8KyOPbN3p0hHhizvaAMBo%3D&reserved=0> .)

Kay

From: SCITT <[email-masked] <mailto:[email-masked]> > On Behalf Of Orie Steele
Sent: Monday, March 7, 2022 10:41 AM
To: [email-masked] <mailto:[email-masked]> 
Cc: Sapan Narang <[email-masked] <mailto:[email-masked]> >
Subject: [SCITT] GitHub DIDs & VCs for Supply Chain Traceability

Hello,

My company Transmute <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqiYqEgkF4xWgxA5Ast%2Fhttps%253A%252F%252Ftransmute.industries%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843394128%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=6thfhO%2FamDDW8VGe3vWFAMtCgRberjlJSnsK3U7nS%2BI%3D&reserved=0>  applies these standards to supply traceability (both physical and software).

Some of our work is funded by DHS SVIP <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqNTelooObAhwFx98Nw%2Fhttps%253A%252F%252Fwww.dhs.gov%252Fscience-and-technology%252Fsvip&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843394128%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=PNClBX7s6LJwTCK58IWoeCknvUmXb%2BuU5bprqb%2BXHDY%3D&reserved=0> , including our work on applying DIDs and VCs to physical supply chain issues associated with global trade and imports and exports.

If you are interested in that work it can be found here: https://w3id.org/traceability <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQy2fH6UWEI23iw-vWGEG%2Fhttps%253A%252F%252Fw3id.org%252Ftraceability&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843594123%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=jgUMxbIp3iypuGXzrGuBiuxsGd76ky1o%2FhQ0iCt5%2Fco%3D&reserved=0> .

I wanted to share some very recent (experimental and unstable) work we've done to enable Decentralized Identifiers <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqX11lXlzLvQgPI070Q%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fdid-core%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843594123%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=hUDex2umg%2BhGKce2k%2FwMryNpSPu7v2VRlUVGiZd%2F6%2F0%3D&reserved=0>  and Verifiable Credentials <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQymDA7VYHe95RgZjMZKI%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fvc-data-model%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843594123%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Hho%2BgX2VaeoztUkVXkLF67fxrmgDKFw6FrlNnEM0d60%3D&reserved=0>  to assist with the software supply chain.

Here are the links:

- https://github.com/transmute-industries/verifiable-actions <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqXl4mGukfBcw_Wj_Q8%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fverifiable-actions&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=0BNa54C%2BKPAm5nma%2BUSqMZAGyabQwEzkjc3Z0itYA1A%3D&reserved=0> 
- https://github.com/transmute-industries/public-credential-registry-template

The examples in the repository links above demonstrate support for these standards using did:key <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuGxqSDtSpdZABx8eMt%2Fhttps%253A%252F%252Fw3c-ccg.github.io%252Fdid-method-key%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=%2BAomrNyRCdpgcDwtBVsOpofiATZOz7ff%2Fvj%2Bs7bk%2B%2F4%3D&reserved=0>  and did:web <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqsLGN-htS74QXmSanv%2Fhttps%253A%252F%252Fgithub.com%252Fw3c-ccg%252Fdid-method-web&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=VzdlDZTCiJBVFv1mokeAoxf14VKj9Jd13jrM%2FYCgW3w%3D&reserved=0> , 
however I am one of the editors of the Sidetree Protocol <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuu7nlpbor7UAurwtjs%2Fhttps%253A%252F%252Fgithub.com%252Fdecentralized-identity%252Fsidetree&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=pKAHmQOymeq1gquTJPcxijcBxuAc%2FkRrWi6UpUxIWhs%3D&reserved=0>  which is what powers did:ion which is being developed by Microsoft and other DIF members... 
The GitHub examples I provided will also work with did:ion.

Regards,

OS

-- 

ORIE STEELE

Chief Technical Officer

www.transmute.industries <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=pv3xaPyy8Uw4RynudDGggy7dlHtWZgjLUIQx5rWK%2F8I%3D&reserved=0> 

 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqJyZSff0skfwnnG7JR%2Fhttps%253A%252F%252Fwww.transmute.industries&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=C3QvbpZsKWPV8FA2TfnHHF5O%2FNZfJv8SxCoSSuVA3wk%3D&reserved=0> 

  <https://mailfoogae.appspot.com/t?sender=ab3JpZUB0cmFuc211dGUuaW5kdXN0cmllcw%3D%3D&type=zerocontent&guid=76629253-3770-41de-9267-75822572b3a6> ᐧ

-- 

ORIE STEELE 

Chief Technical Officer

www.transmute.industries <http://www.transmute.industries> 

 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=3M8AJs5OxbUjF13cqJx9TLayJ2wdxuNAx1QG6dXk6vc%3D&reserved=0> 

-- 

ORIE STEELE 

Chief Technical Officer

www.transmute.industries <http://www.transmute.industries> 

 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843694104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=wl7DU8CV3SPJb5xgqdl3MRYzwK4bBeux16YPNbmcPus%3D&reserved=0>

---

From: Orie Steele <[email-masked]>
Date: Fri, 18 Mar 2022 12:01:59 -0500

Antoine,

I'm not sure which "W3C" document you are referring to.

I linked 2 W3C TRs (both contributed to by Microsoft and approved by
Microsoft AC Rep), and a few community group drafts at DIF (contributed to
by Microsoft) and at the W3C CCG (not contributed to by Microsoft).

Which document are you referring to?

OS

On Fri, Mar 18, 2022 at 11:54 AM Antoine Delignat-Lavaud <
[email-masked]> wrote:

> Hi Orie,
>
>
>
> Is there any follow up to the W3C Traceability Vocabulary document? It has
> some good context and terminology on supply chain security but doesn’t seem
> to offer any concrete solution or improvement.
>
>
>
> Antoine
>
>
>
> *From:* SCITT <[email-masked]> *On Behalf Of *Orie Steele
> *Sent:* 18 March 2022 14:20
> *To:* Kay Williams <[email-masked]>
> *Cc:* Sapan Narang <[email-masked]>; [email-masked]
> *Subject:* [EXTERNAL] Re: [SCITT] GitHub DIDs & VCs for Supply Chain
> Traceability
>
>
>
> Some people who received this message don't often get email from
> [email-masked]. Learn why this is important
> <http://aka.ms/LearnAboutSenderIdentification>
>
> all email from ietf.org
> <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fietf.org%2F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843394128%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=ZYSZJV0zxzL3rq%2FSEi7Zvc8KyOPbN3p0hHhizvaAMBo%3D&reserved=0>
> .)
>
>
>
> *From:* SCITT <[email-masked]> *On Behalf Of *Orie Steele
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqiYqEgkF4xWgxA5Ast%2Fhttps%253A%252F%252Ftransmute.industries%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843394128%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=6thfhO%2FamDDW8VGe3vWFAMtCgRberjlJSnsK3U7nS%2BI%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqNTelooObAhwFx98Nw%2Fhttps%253A%252F%252Fwww.dhs.gov%252Fscience-and-technology%252Fsvip&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843394128%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=PNClBX7s6LJwTCK58IWoeCknvUmXb%2BuU5bprqb%2BXHDY%3D&reserved=0>,
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQy2fH6UWEI23iw-vWGEG%2Fhttps%253A%252F%252Fw3id.org%252Ftraceability&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843594123%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=jgUMxbIp3iypuGXzrGuBiuxsGd76ky1o%2FhQ0iCt5%2Fco%3D&reserved=0>
> .
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqX11lXlzLvQgPI070Q%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fdid-core%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843594123%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=hUDex2umg%2BhGKce2k%2FwMryNpSPu7v2VRlUVGiZd%2F6%2F0%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQymDA7VYHe95RgZjMZKI%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fvc-data-model%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843594123%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Hho%2BgX2VaeoztUkVXkLF67fxrmgDKFw6FrlNnEM0d60%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqXl4mGukfBcw_Wj_Q8%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fverifiable-actions&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=0BNa54C%2BKPAm5nma%2BUSqMZAGyabQwEzkjc3Z0itYA1A%3D&reserved=0>
> -
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuHh9DtUHodDwKXtBBB%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fpublic-credential-registry-template&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=a0cKcxHbR2qHrxkG0Qa6qqKCl6X6VE162iisrQY5MoM%3D&reserved=0>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuGxqSDtSpdZABx8eMt%2Fhttps%253A%252F%252Fw3c-ccg.github.io%252Fdid-method-key%252F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=%2BAomrNyRCdpgcDwtBVsOpofiATZOz7ff%2Fvj%2Bs7bk%2B%2F4%3D&reserved=0> and
> did:web
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqsLGN-htS74QXmSanv%2Fhttps%253A%252F%252Fgithub.com%252Fw3c-ccg%252Fdid-method-web&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=VzdlDZTCiJBVFv1mokeAoxf14VKj9Jd13jrM%2FYCgW3w%3D&reserved=0>,
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuu7nlpbor7UAurwtjs%2Fhttps%253A%252F%252Fgithub.com%252Fdecentralized-identity%252Fsidetree&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=pKAHmQOymeq1gquTJPcxijcBxuAc%2FkRrWi6UpUxIWhs%3D&reserved=0> which
> is what powers did:ion
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuxcXKIp3hEOgkQqHLh%2Fhttps%253A%252F%252Ftechcommunity.microsoft.com%252Ft5%252Fidentity-standards-blog%252Fion-we-have-liftoff%252Fba-p%252F1441555&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=WBCQ9HHha9X5XgmQi3vApvOj9oWFaukHcZo1RHIzNb8%3D&reserved=0> which
> <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7C93f0efd4fc634008538808da08ea64eb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832101843644104%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=pv3xaPyy8Uw4RynudDGggy7dlHtWZgjLUIQx5rWK%2F8I%3D&reserved=0>
>
>
>
>

-- 
*ORIE STEELE*
Chief Technical Officer
www.transmute.industries

---

From: Antoine Delignat-Lavaud <[email-masked]>
Date: Fri, 18 Mar 2022 17:09:46 +0000

I am referring to this draft - Traceability Vocabulary v0.0 (w3c-ccg.github.io) <https://w3c-ccg.github.io/traceability-vocab/> 

Do you have any follow up draft that goes beyond vocabulary? 

Antoine

From: SCITT <[email-masked]> On Behalf Of Orie Steele
Sent: 18 March 2022 17:02
To: Antoine Delignat-Lavaud <[email-masked]>
Cc: [email-masked]; Sapan Narang <[email-masked]>; Kay Williams <[email-masked]>
Subject: Re: [SCITT] [EXTERNAL] Re: GitHub DIDs & VCs for Supply Chain Traceability

You don't often get email from [email-masked] <mailto:[email-masked]> . Learn why this is important <http://aka.ms/LearnAboutSenderIdentification> 

Antoine,

I linked 2 W3C TRs (both contributed to by Microsoft and approved by Microsoft AC Rep), and a few community group drafts at DIF (contributed to by Microsoft) and at the W3C CCG (not contributed to by Microsoft).

OS

On Fri, Mar 18, 2022 at 11:54 AM Antoine Delignat-Lavaud <[email-masked] <mailto:[email-masked]> > wrote:

Hi Orie,

Antoine

From: SCITT <[email-masked] <mailto:[email-masked]> > On Behalf Of Orie Steele
Sent: 18 March 2022 14:20
To: Kay Williams <[email-masked] <mailto:[email-masked]> >
Cc: Sapan Narang <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: [EXTERNAL] Re: [SCITT] GitHub DIDs & VCs for Supply Chain Traceability

Regards,

OS

Regards,

OS

Hi Orie (and Sapan),

Apologies for my late response to your email.  It landed in my spam folder, and I am just now seeing it.  (As a side note, I have now unblocked all email from ietf.org <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fietf.org%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406809551%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=4jYvz%2BbE4EX0fO%2FhkFtA97ZmJci54AMPkdrbn6psZyw%3D&reserved=0> .)

Kay

Hello,

My company Transmute <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqiYqEgkF4xWgxA5Ast%2Fhttps%253A%252F%252Ftransmute.industries%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Ix4VGApu5xPqBdsE%2BlnU0rBRUWUA%2Bw8HYCchDpSzDsg%3D&reserved=0>  applies these standards to supply traceability (both physical and software).

Some of our work is funded by DHS SVIP <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqNTelooObAhwFx98Nw%2Fhttps%253A%252F%252Fwww.dhs.gov%252Fscience-and-technology%252Fsvip&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=FjLr2DPDP%2FmqyEMSCCL2lKkLPGFzinrHlZ0YNu7Yj%2B0%3D&reserved=0> , including our work on applying DIDs and VCs to physical supply chain issues associated with global trade and imports and exports.

If you are interested in that work it can be found here: https://w3id.org/traceability <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQy2fH6UWEI23iw-vWGEG%2Fhttps%253A%252F%252Fw3id.org%252Ftraceability&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=BzeAH4EO3qhT%2BiOvFIgY0iP0JxD9w8aIjBZltzoNA0s%3D&reserved=0> .

I wanted to share some very recent (experimental and unstable) work we've done to enable Decentralized Identifiers <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqX11lXlzLvQgPI070Q%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fdid-core%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=mipIQWqDcsK13zKrbXd0Ux2KlC11KUFV5MV3d%2BOrP04%3D&reserved=0>  and Verifiable Credentials <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQymDA7VYHe95RgZjMZKI%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fvc-data-model%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=l1f8CCIU71FCXXamkWDcTrZlxAOIqCVTZOfoOeDEzjE%3D&reserved=0>  to assist with the software supply chain.

Here are the links:

- https://github.com/transmute-industries/verifiable-actions <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqXl4mGukfBcw_Wj_Q8%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fverifiable-actions&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=LYTZNASkLQaZSTgTNMEVfLZhWGoN%2BAyIsKYm%2Bv9LQUo%3D&reserved=0> 
- https://github.com/transmute-industries/public-credential-registry-template

The examples in the repository links above demonstrate support for these standards using did:key <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuGxqSDtSpdZABx8eMt%2Fhttps%253A%252F%252Fw3c-ccg.github.io%252Fdid-method-key%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=d9RkjLXNP%2B8gJ%2BQmUvSjLCkOrp6P1NNicOK5vubVoCk%3D&reserved=0>  and did:web <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqsLGN-htS74QXmSanv%2Fhttps%253A%252F%252Fgithub.com%252Fw3c-ccg%252Fdid-method-web&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=h4FixwKFTWBYIsyqFLwBuPSTzC59JgVmV6CiFMUAqYA%3D&reserved=0> , 
however I am one of the editors of the Sidetree Protocol <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuu7nlpbor7UAurwtjs%2Fhttps%253A%252F%252Fgithub.com%252Fdecentralized-identity%252Fsidetree&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=GSKjzf%2FwQjN%2Bti8QnGr9Ngs%2FAogG5BvnGwdflhm3R7M%3D&reserved=0>  which is what powers did:ion which is being developed by Microsoft and other DIF members... 
The GitHub examples I provided will also work with did:ion.

Regards,

OS

-- 

ORIE STEELE

Chief Technical Officer

www.transmute.industries <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=8rexUHYxTWo%2BdscrZQn%2FfNepT89zLhzkqj%2FOlBSKtmM%3D&reserved=0> 

 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqJyZSff0skfwnnG7JR%2Fhttps%253A%252F%252Fwww.transmute.industries&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=s68xBb9HX6UQisVtRWMdNUvLwYCEpW%2Bhxp6wNMyNVY4%3D&reserved=0> 

 

-- 

ORIE STEELE 

Chief Technical Officer

www.transmute.industries <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=8rexUHYxTWo%2BdscrZQn%2FfNepT89zLhzkqj%2FOlBSKtmM%3D&reserved=0> 

 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=1YUAFfSlm9oMsIvZz2nExEwdbumZLfSfi9w8hDyl7Ak%3D&reserved=0> 

-- 

ORIE STEELE 

Chief Technical Officer

www.transmute.industries <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=8rexUHYxTWo%2BdscrZQn%2FfNepT89zLhzkqj%2FOlBSKtmM%3D&reserved=0> 

 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=1YUAFfSlm9oMsIvZz2nExEwdbumZLfSfi9w8hDyl7Ak%3D&reserved=0> 

-- 

ORIE STEELE 

Chief Technical Officer

 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=1YUAFfSlm9oMsIvZz2nExEwdbumZLfSfi9w8hDyl7Ak%3D&reserved=0>

---

From: Orie Steele <[email-masked]>
Date: Fri, 18 Mar 2022 14:18:55 -0500

Antoine,

There is a paired work item for using DIDs and VCs with HTTP -
https://w3id.org/traceability/interoperability

But long story short is that we and others are currently incubating that
work in the W3C CCG (a community group of the W3C)... We also work on
related projects at both DIF and IETF.

That profile defines one way that businesses have historically exchanged
data, and explains how to use HTTPS, REST, OAuth2 to exchange JSON based
Verifiable Credentials and Presentations.

There is a lot of prior art in the supply chain standards space, and we do
our best to address it or directly support it, for example:

- https://schema.org/
- https://www.gs1.org/voc/
- https://www.gs1.org/standards/epcis
- https://www.gs1.org/standards/gs1-digital-link

But also:

- https://developers.google.com/knowledge-graph (powered by JSON-LD /
schema.org)
- https://docs.microsoft.com/en-us/azure/digital-twins/concepts-models
(essentially
a reinvention of RDF / JSON-LD).

One of the things that most excites me about this WG at IETF (SCITT) is the
interest in COSE / CBOR and compact binary representations and transports.

While many of these technologies are younger than JSON / HTTP, they offer
some tremendous advantages, specifically

- https://developers.google.com/protocol-buffers (gRPC)
- https://en.wikipedia.org/wiki/LEB128 (WASM)

There are many use cases in industrial IoT or smart cities, or distributed
mobile computing that are gated by our inability to efficiently and safely
exchange compact binary messages over multiple protocols, including QR
Codes, NFC, Bluetooth, etc.

Many of these use cases have nothing to do with "Blockchain" or
"Decentralized Identifiers" or "Crypto Currencies", but sometimes there is
overlap or a desire to support interoperability, or good lessons we have
learned that impact the business framing of the standards.

I look forward to sharing a taste of some of this work on the next call if
time allows.

Regards,

OS

On Fri, Mar 18, 2022 at 12:09 PM Antoine Delignat-Lavaud <
[email-masked]> wrote:

> I am referring to this draft - Traceability Vocabulary v0.0
> (w3c-ccg.github.io) <https://w3c-ccg.github.io/traceability-vocab/>
>
> *Sent:* 18 March 2022 17:02
> *To:* Antoine Delignat-Lavaud <[email-masked]>
> *Cc:* [email-masked]; Sapan Narang <[email-masked]>; Kay
> Williams <[email-masked]>
> *Subject:* Re: [SCITT] [EXTERNAL] Re: GitHub DIDs & VCs for Supply Chain
> Traceability
>
>
>
> You don't often get email from [email-masked]. Learn why this
> is important <http://aka.ms/LearnAboutSenderIdentification>
>
> Antoine,
>
> <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fietf.org%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406809551%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=4jYvz%2BbE4EX0fO%2FhkFtA97ZmJci54AMPkdrbn6psZyw%3D&reserved=0>
> .)
>
>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqiYqEgkF4xWgxA5Ast%2Fhttps%253A%252F%252Ftransmute.industries%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Ix4VGApu5xPqBdsE%2BlnU0rBRUWUA%2Bw8HYCchDpSzDsg%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqNTelooObAhwFx98Nw%2Fhttps%253A%252F%252Fwww.dhs.gov%252Fscience-and-technology%252Fsvip&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=FjLr2DPDP%2FmqyEMSCCL2lKkLPGFzinrHlZ0YNu7Yj%2B0%3D&reserved=0>,
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQy2fH6UWEI23iw-vWGEG%2Fhttps%253A%252F%252Fw3id.org%252Ftraceability&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=BzeAH4EO3qhT%2BiOvFIgY0iP0JxD9w8aIjBZltzoNA0s%3D&reserved=0>
> .
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqX11lXlzLvQgPI070Q%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fdid-core%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=mipIQWqDcsK13zKrbXd0Ux2KlC11KUFV5MV3d%2BOrP04%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQymDA7VYHe95RgZjMZKI%2Fhttps%253A%252F%252Fwww.w3.org%252FTR%252Fvc-data-model%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=l1f8CCIU71FCXXamkWDcTrZlxAOIqCVTZOfoOeDEzjE%3D&reserved=0>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqXl4mGukfBcw_Wj_Q8%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fverifiable-actions&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=LYTZNASkLQaZSTgTNMEVfLZhWGoN%2BAyIsKYm%2Bv9LQUo%3D&reserved=0>
> -
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuHh9DtUHodDwKXtBBB%2Fhttps%253A%252F%252Fgithub.com%252Ftransmute-industries%252Fpublic-credential-registry-template&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=P2GLeIO9erpNGOGKmnLyNMbsRGsHe%2FOez6r%2B%2FzlJzRI%3D&reserved=0>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuGxqSDtSpdZABx8eMt%2Fhttps%253A%252F%252Fw3c-ccg.github.io%252Fdid-method-key%252F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=d9RkjLXNP%2B8gJ%2BQmUvSjLCkOrp6P1NNicOK5vubVoCk%3D&reserved=0> and
> did:web
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyqsLGN-htS74QXmSanv%2Fhttps%253A%252F%252Fgithub.com%252Fw3c-ccg%252Fdid-method-web&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406859548%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=h4FixwKFTWBYIsyqFLwBuPSTzC59JgVmV6CiFMUAqYA%3D&reserved=0>,
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuu7nlpbor7UAurwtjs%2Fhttps%253A%252F%252Fgithub.com%252Fdecentralized-identity%252Fsidetree&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=GSKjzf%2FwQjN%2Bti8QnGr9Ngs%2FAogG5BvnGwdflhm3R7M%3D&reserved=0> which
> is what powers did:ion
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fstreaklinks.com%2FA9ifQyuxcXKIp3hEOgkQqHLh%2Fhttps%253A%252F%252Ftechcommunity.microsoft.com%252Ft5%252Fidentity-standards-blog%252Fion-we-have-liftoff%252Fba-p%252F1441555&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=YCr2pamOUmq4Yq39LDLlpeotuj2bNGZIutxts1Sum68%3D&reserved=0> which
> <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=8rexUHYxTWo%2BdscrZQn%2FfNepT89zLhzkqj%2FOlBSKtmM%3D&reserved=0>
>
>
>
>
> <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=8rexUHYxTWo%2BdscrZQn%2FfNepT89zLhzkqj%2FOlBSKtmM%3D&reserved=0>
>
>
>
>
> <https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.transmute.industries%2F&data=04%7C01%7Cantdl%40microsoft.com%7Cff4a183e93be4a9d938408da09011473%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637832198406909546%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=8rexUHYxTWo%2BdscrZQn%2FfNepT89zLhzkqj%2FOlBSKtmM%3D&reserved=0>
>
>
>
>

-- 
*ORIE STEELE*
Chief Technical Officer
www.transmute.industries