Subject: [Sdn] Security in SDN controllers presentation

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Wed, 22 Jul 2015 07:42:34 +0000

Hi Sandra, list

When you speak about app resilience, a question pops up to my mind: so you have an app that crashes and you want a new instance of this app to take control... this can lead to situations where the new instance sends commands to the controller that are in conflict with the ones previously installed. Doesn't this call for some sort of 'conflict resolution' mechanism, construct, ... in the SDN controller?

Best,
/PA

---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ Zurbarán,12
28010 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Songhaibin (A)" <[email-masked]>
Date: Wed, 22 Jul 2015 09:05:01 +0000

I guess this problem should be solved by state synchronization between the controller and the new instance, instead of conflict resolution that aimed to solve conflict from different configurations from the applications. Maybe I am wrong.

BR,
-Haibin

From: sdn [mailto:[email-masked]] On Behalf Of PEDRO ANDRES ARANDA GUTIERREZ
Sent: Wednesday, July 22, 2015 3:43 PM
To: [email-masked]
Subject: [Sdn] Security in SDN controllers presentation

Hi Sandra, list

Best,
/PA

---

Technology Exploration -