Subject: [Sdn] Poll for RG Adoption - draft-contreras-sdnrg-layered-sdn

From: "King, Daniel" <[email-masked]>
Date: Mon, 15 Feb 2016 13:26:29 +0000

Greetings SDN Researchers, 

At IETF 94 we had a request from the authors of "Cooperating Layered Architecture for SDN" to poll the Research Group for adoption of their document: 

o If you missed their presentation at IETF 94 - https://www.ietf.org/proceedings/94/slides/slides-94-sdnrg-2.pdf
o The current version of the document - https://tools.ietf.org/html/draft-contreras-sdnrg-layered-sdn-04

We would like to open a two-week adoption call the document, but specifically ask that a "support" or "no support" response be substantiated with accompanying comments discussing why the document should be adopted, or indeed not.

Kind Regards, 
Dan & Kohei

---

From: Gabriel Lopez <[email-masked]>
Date: Fri, 19 Feb 2016 12:43:36 +0100

Hi,

> El 15 feb 2016, a las 14:26, King, Daniel <[email-masked]> escribió:
> 

The draft describes a SDN layered architecture based on different strata for both service and data transport layers.
Service controllers and Transport controllers need to coexist and collaborate among them. This draft defines the framework for
this collaboration. It is also aligned with the ONF framework.

So I support the adoption of this draft.

Some additional comments:

Section 1.

- "which functionality is supposed to perform traffic forwarding (only)". The "(only)" statement may confuse the
readers. If authors try to make emphasis in a special behaviour here it should be mentioned more clearly, or to add some reference.

Section 3.

- the concept of "external service" has not been introduced

- Paragraphs 5 and 6 are difficult to read due to the (mix)-use of the terms "layers", "blocks", "stratum" and "planes".

- Figure 1:
    - communication API/channel between Transport Stratum and Service Stratum should be labelled.
    - s/Resource Pl./Resource Plane/resource plane (according to the text). Idem for Control Pl. and Mngmt Pl.

- In line with the previous paragraphs, would this sentence "There is a hierarchy in which the Service SDN controller
   requests transport capabilities to the Transport SDN controller." be expressed in a best way as "There is a hierarchy in
   which Service SDN controller(s) request(s) transport capabilities to the Transport SDN controller(s)." ?? (idem about the next sentence)

- "The Service SDN controller acts as a client of the Transport SDN
   controller." From the previous paragraphs it seems more like a peer-to-peer relationship rather than a client-to-server one.

- the concept of "external application" has not been introduced.

-  "This document does assume that SDN techniques can be enabled jointly
   with other distributed means (e.g., IGP)". Please, could you elaborate this statement.

Section 5.

-  "The communication between controllers should be also secure,
   preventing denial of service." It should prevent any kind of secure threat, not only denial of service.

> Kind Regards,
> Dan & Kohei
> <winmail.dat>_______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn

-----------------------------------------------------------
Gabriel López Millán
Departamento de Ingeniería de la Información y las Comunicaciones
University of Murcia
Spain
Tel: +34 868888504
Fax: +34 868884151
email: [email-masked] <mailto:[email-masked]>

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Fri, 19 Feb 2016 12:17:26 +0000

As a coauthor, I support the adoption.

And let me add that some of the ideas that were originally proposed in this document were incorporated to the discussions between ONF and ETSI NFV on the relationship between SDN and NFV.

Be goode,

On 15 Feb 2016, at 13:26 , King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:

Kind Regards,
Dan & Kohei
_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Leeyoung <[email-masked]>
Date: Fri, 19 Feb 2016 16:14:51 +0000

Support,

Young

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: Monday, February 15, 2016 7:26 AM
To: [email-masked]'
Cc: [email-masked]
Subject: [Sdn] Poll for RG Adoption - draft-contreras-sdnrg-layered-sdn

Kind Regards, 
Dan & Kohei

---

From: Alex Galis <[email-masked]>
Date: Sat, 20 Feb 2016 14:48:59 +0000

Support
Alex Galis ( University College London)

> On 15 Feb 2016, at 13:26, King, Daniel <[email-masked]> wrote:
>

---

From: Ricard Vilalta <[email-masked]>
Date: Mon, 22 Feb 2016 08:02:15 +0100

Support.

Ricard Vilalta (CTTC)

On Mon, Feb 15, 2016 at 2:26 PM, King, Daniel <[email-masked]>
wrote:

> At IETF 94 we had a request from the authors of "Cooperating Layered
> Architecture for SDN" to poll the Research Group for adoption of their
> document:
>
> o If you missed their presentation at IETF 94 -
> https://www.ietf.org/proceedings/94/slides/slides-94-sdnrg-2.pdf
> o The current version of the document -
> https://tools.ietf.org/html/draft-contreras-sdnrg-layered-sdn-04
>
> We would like to open a two-week adoption call the document, but
> specifically ask that a "support" or "no support" response be substantiated
> with accompanying comments discussing why the document should be adopted,
> or indeed not.
>
> Kind Regards,
> Dan & Kohei
>

---

From: <[email-masked]>
Date: Mon, 22 Feb 2016 07:51:50 +0000

Dear chairs, all,

I support the adoption of the document. 

Cheers,
Med

> -----Message d'origine-----
> De : sdn [mailto:[email-masked]] De la part de King, Daniel
> Envoyé : lundi 15 février 2016 14:26
> À : [email-masked]'
> Cc : [email-masked]
> Objet : [Sdn] Poll for RG Adoption - draft-contreras-sdnrg-layered-sdn
> 
> specifically ask that a "support" or "no support" response be
> substantiated with accompanying comments discussing why the document
> should be adopted, or indeed not.
> 
> Kind Regards,
> Dan & Kohei

---

From: <[email-masked]>
Date: Mon, 22 Feb 2016 08:49:43 +0000

Hello WG,

I too support the adoption of draft-contreras-sdnrg-layered-sdn as a sdnrg WG document.

Cheers,

Christian.
On Mon, Feb 15, 2016 at 2:26 PM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
Greetings SDN Researchers,

Kind Regards,
Dan & Kohei

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Gino Carrozzo <[email-masked]>
Date: Mon, 22 Feb 2016 20:11:47 +0100

Hi SDNRG-ers

I also support the adoption of this document.

IMHO, it'd be a great addition to the I-D to have it addressing
- specific challenges for implementing different control actions/scope
between Transport & Service layer.
- relationships with other WG/RG, in particular ACTN for Transport stratum
- options for  using the same architecture pattern recursively across the
various layers

br
Gino

-- 
==============================================================
  Dr. Gino Carrozzo
  Deputy Head of R&D

  mobile    : +39 348 7610 081
  landline  : +39 050 3871 679
  fax         : +39 050 3871 601
  e-mail    : [email-masked]
  web       : www.nextworks.it
  address   : Nextworks s.r.l.
                  via Livornese, 1027
                  56122 S.Piero a Grado, Pisa, ITALY
==============================================================

---

From: Ramon Casellas <[email-masked]>
Date: Tue, 23 Feb 2016 09:02:59 +0100

> I also support the adoption of this document.

Dear all, Dan, Kohei,

Likewise, I support the adoption of the document as a starting point; I 
find the separation of service / transport stratum very appropriate and 
much needed.

Aspects IMHO worth developing are the multi-domain aspects, with 
multiple 1:1, 1:N, N:1 and N:M relationships between service stratum and 
transport stratum (i.e., use cases involving federation etc. will 
require a common framework w.r.t to the service stratum above)

As Gino mentioned, alignment with similar initiatives (ONF arch, ACTN 
within TEAS, etc.) is also an important point

Thanks
Ramon

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Tue, 23 Feb 2016 09:36:01 -0300

Support.

Section on Recursiveness -> should point (relate/compare) to related
work at NFVRG: https://tools.ietf.org/html/draft-unify-nfvrg-recursive-programming-02

The Use Case section should be completed in the next revision.

-ch

On Tue, Feb 23, 2016 at 5:02 AM, Ramon Casellas <[email-masked]> wrote:
> Likewise, I support the adoption of the document as a starting point; I find
> the separation of service / transport stratum very appropriate and much
> needed.
>
> Aspects IMHO worth developing are the multi-domain aspects, with multiple
> 1:1, 1:N, N:1 and N:M relationships between service stratum and transport
> stratum (i.e., use cases involving federation etc. will require a common
> framework w.r.t to the service stratum above)
>
> As Gino mentioned, alignment with similar initiatives (ONF arch, ACTN within
> TEAS, etc.) is also an important point
>
> Thanks
> Ramon
>
>

---

From: Ali Haider <[email-masked]>
Date: Wed, 24 Feb 2016 01:06:31 +0500

Support.

I would like to suggest that the document is updated to include clearly
spelled out motivation for this separation. Right now, the motivation is
not very clear and the document quickly jumps to providing a solution when
the problem has not been properly documented yet.

On Tue, Feb 23, 2016 at 5:36 PM, Christian Esteve Rothenberg <
[email-masked]> wrote:

> work at NFVRG:
> https://tools.ietf.org/html/draft-unify-nfvrg-recursive-programming-02
>
> find

-- 
*​Syed Ali Haider*, Ph.D
​Assistant Professor
School of Electrical Engineering and Computer Science
National University of Sciences ​and​ Technology
Sector H-12, Islamabad, Pakistan
​t: +92 51 90852109
​e: [email-masked]​
- - - - - - - - - - - - - - - - - - - - -

---

From: "Bartosz Belter" <[email-masked]>
Date: Wed, 24 Feb 2016 10:07:46 +0100

Hello all,

I support the adoption of this document as a very good starting point.
As some of you already mentioned, the document lacks some strong motivation
statements. Use cases definitely should be provided in the next version +
strong links towards other WG/RGs.

Best regards
Bartosz Belter, PSNC

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: Monday, February 15, 2016 2:26 PM
To: [email-masked]' <[email-masked]>
Cc: [email-masked]
Subject: [Sdn] Poll for RG Adoption - draft-contreras-sdnrg-layered-sdn

We would like to open a two-week adoption call the document, but
specifically ask that a "support" or "no support" response be substantiated
with accompanying comments discussing why the document should be adopted, or
indeed not.

Kind Regards,
Dan & Kohei

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 24 Feb 2016 09:24:21 +0000

Hi,

I also support the adoption of the document, and share with the others the need of provide a motivation, and some potential use cases which show the need of a modular architecture.

Best Regards,
Maria Rita

------------------------------------------------
Dr. Maria Rita Palattella
Research Associate
SnT, University of Luxembourg
[email-masked]
+352 4666445841

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of Bartosz Belter
Sent: Wednesday, February 24, 2016 10:08 AM
To: 'King, Daniel' <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [Sdn] Poll for RG Adoption - draft-contreras-sdnrg-layered-sdn

Hello all,

I support the adoption of this document as a very good starting point.
As some of you already mentioned, the document lacks some strong motivation statements. Use cases definitely should be provided in the next version + strong links towards other WG/RGs.

Best regards
Bartosz Belter, PSNC

-----Original Message-----
From: sdn [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: Monday, February 15, 2016 2:26 PM
To: [email-masked]' <[email-masked]>
Cc: [email-masked]
Subject: [Sdn] Poll for RG Adoption - draft-contreras-sdnrg-layered-sdn

At IETF 94 we had a request from the authors of "Cooperating Layered Architecture for SDN" to poll the Research Group for adoption of their
document:

Kind Regards,
Dan & Kohei

---

From: Zhenghaomian <[email-masked]>
Date: Wed, 24 Feb 2016 20:21:42 +0000

Yes/Support. 

This draft provide idea/requirement of how the cooperated layers interact with each other, which is an important topic in SDN deployment. It is necessary to have the research group together to move this work forward. RG adoption will enable experts in SDNRG to discuss the content in more detail, the current version (04) is a great draft as foundation. Further information and details need to be included in section 6 and 7, for deployment and use case respectively. Thanks. 

Best wishes,
Haomian

-----邮件原件-----
发件人: sdn [mailto:[email-masked]] 代表 King, Daniel
发送时间: 2016年2月15日 21:26
收件人: [email-masked]'
抄送: [email-masked]
主题: [Sdn] Poll for RG Adoption - draft-contreras-sdnrg-layered-sdn

At IETF 94 we had a request from the authors of “Cooperating Layered Architecture for SDN” to poll the Research Group for adoption of their document: 

Kind Regards, 
Dan & Kohei