Subject: [Sdn] gRPC

From: Hesham ElBakoury <[email-masked]>
Date: Mon, 14 Nov 2016 08:09:24 +0000

Hi Eric,

Do you think we can use gRPC as southbound protocol for SDN controllers.

Thanks

Hesham

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Mon, 14 Nov 2016 17:31:53 +0900

> Do you think we can use gRPC as southbound protocol for SDN controllers.

Hi,

Sorry to interfere but being a general RPC I think there should be no
problem to use it there. It would be interesting to map OpenFlow and
even NETCONF/YANG to protobuf/gRPC but, however, I do not see a clear
benefit as it means more complexity in devices. What is your idea?

> Hesham

Regards,
Pedro

-- 
Pedro Martinez-Julia
Network Science and Convergence Device Technology Laboratory
Network System Research Institute
National Institute of Information and Communications Technology (NICT)
4-2-1, Nukui-Kitamachi, Koganei, Tokyo 184-8795, Japan
Email: [email-masked]
---------------------------------------------------------
*** Entia non sunt multiplicanda praeter necessitatem ***

---

From: Hariharan Ananthakrishnan <[email-masked]>
Date: Mon, 14 Nov 2016 08:36:29 +0000

Some router vendors claim to support gRPC in their network devices. So yes, gRPC between SDN Controller to network devices is coming.

- Hari

On 14/11/2016, 17:31, "sdn on behalf of Pedro Martinez-Julia" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    
    Regards,
    Pedro

    _______________________________________________
    sdn mailing list
    [email-masked]
    https://www.irtf.org/mailman/listinfo/sdn

---

From: Pedro Martinez-Julia <[email-masked]>
Date: Mon, 14 Nov 2016 17:52:32 +0900

> Some router vendors claim to support gRPC in their network devices. So yes, gRPC between SDN Controller to network devices is coming.

So I guess there would be some interfaces already defined in protobuf
for such control operations. If you know about any of them, please share
some link. Thank you.

Regards,
Pedro

---

From: Ozgur Karatas <[email-masked]>
Date: Mon, 14 Nov 2016 11:02:43 +0200

Hello all,

Last time Engineer's say to "gRPC supported" and we buy to Extreme network products but we don't use gRPC.
Maybe, installed as gRPC on the outside (github).

I didn't get to experience the YANG.

Regards,

--
Ozgur Karatas

[email-masked]
https://mueddib.github.io