Subject: RE: [seamoby] MANET Critique ( was Yet Another BOF?

From: Nitin H Vaidya <[email-masked]>
Date: Wed, 7 Mar 2001 06:27:58 -0600 (CST)

>> From: Kulwinder Atwal <[email-masked]>
  ...
  >> I thought about the TORA draft some more.  It is trying to solve the problem
  >> of which way is upstream and which way is downstream by using "heights".  In
  >> a Master-Slave Network a device knows that upstream is toward its Master,
  >> and downstream is toward its Slave.  
  >> 
  >> In a technology neutral Ad Hoc routing solution the upstream/downstream
  >> problem does not exist.

I am afraid you may have misinterpreted TORA (which is, incidentally,
derived from a very nice paper by Gafni and Bertsekas on
"link reversal" algorithms).
Or, perhaps what you mean by ad hoc is different from what TORA
assumes.

Your statement may be accurate if all you have is one Master, and its
slaves talking to each other. But if the network of interest contains
multiple piconets (hence multiple masters), one would need a protocol
to route packets between the piconets -- "downstream" is just
TORAs way of saying "this way to destination D", nothing
more than that. So, it makes sense to assign downstream
directions in case of BlueTooth as well. Heights in TORA are just
a means to decide which way a link points, not an end unto
themselves.

Since piconets have a Master-Slave organization, one can use
hierarchical routing, where packets are routed to the destination's
"cluster head" (i.e., Master), and then to the slave. Many such
hierarchical protocols have been proposed for MANETs, needless
to say, and one could easily adapt TORA (or AODV, etc.) to optimize
for such a hierarchy.

For a brief overview of MANET research, you may want to take a look
at the tutorial available at www.cs.tamu.edu/facylty/vaidya (click
on Seminars). Hopefully, the tutorial is easier to read than some of
the papers. The tutorial is not comprehensive, particularly, it lacks
coverage of many cluster-based schemes.

Just to elaborate briefly on the "link reversal" algorithms
by Gafni/Bertsekas (also used in TORA): for each plausible
destination, a given node maintains 0 or more "downstream"
pointers -- following any of the pointers will eventually get
the packet to that destination. The trick is to maintain these
downstream pointers correctly, which is what Gafni/Bertsekas do
well . TORAs contribution is to detect when network is "partitioned"
and avoid doing fruitless work trying to find routes between the
partitions. This is important since in MANETs, partitions may occur.

Cheerio.

- nitin

  >> - Kulwinder.
  >> > 	    Mike

---

From: Theo Pagtzis <[email-masked]>
Date: Wed, 07 Mar 2001 07:26:15 -0800

Nitin,

   I have some reservations to what has been said over Bluetooth.
In particular

> to say, and one could easily adapt TORA (or AODV, etc.) to optimize

Master-slave organization (or better point to point to multipoint) is also over
802.11 at infrastructure mode
This is the case over PCF (no contention) and DCF (with contention). Does that
render a constitute a reason for using MANET protocols
over 802.11 at that mode?

What I am trying to say is that there will be two distinct cases for piconets.

1) the case where the Blue(tooth) AP that forwards traffic to the Bluetooth node
(for instance a stereo forwards traffic to some headphone, a laptop forwards traffic
to some cellphone/palm pilot. In that case we would expect the AP to be fixed,
wouldn't we? This is more faithfull to the intent also of a cable interconnect,
which I think people would like to market FIRST if they want their money BACK.

2) the case where the Blue AP moves independently of the Bluetooth node. In that
case we have two cases
       a) you have ad-hoc mode where both Blue AP and node work over ad-hoc mode
clusterhead scheme and hope for the best if the population of the Blue nodes is
sparse (indoor/inhouse outdoors)
       b) continue on infrastructure mode by making use of fixed-point Blue
relay-APs (for instance the Blue node is near the fridge in the kitchen
and so the Blue node reassociates with the fridge Blue AP so that the traffic does
not go through the PREVIOUS Blue AP.

As far as I can see MANET protocols kick in during the havoc of movement of BOTH the
Blue AP and the Blue node. Why are we jumping into the MANET boat on this list at a
time where the MANET guys are already solving the problem????

Theo

UCL/Mobile systems

---

From: Michael Thomas <[email-masked]>
Date: Thu, 8 Mar 2001 10:10:36 -0800 (PST)

> over 802.11 at that mode?

   I think Nitin described the situation well. I'll 
   point out that routing protocols would be useful
   if you want to keep your IP address across multiple
   different AP/AR's. 802.11 with its IAPP, I believe, is
   an L2 scheme for doing that. TORA and other L3 routing
   protocols could provide a means of doing the
   same thing across different L2's.

   This is completely independent of how a
   particular L2 manages its spectrum while you
   are attached to it.

		Mike