Subject: RE: [seamoby] RE: [rohc] RE: Restarting Compressor on Mobile IPv6 Handover

From: "Lars-Erik Jonsson (EPL)" <[email-masked]>
Date: Fri, 30 Mar 2001 09:59:11 +0200

Michael,

> My understanding about cellular traffic channels
> -- and I would be happy to find out differently --
> is that they do not deal well with variable rate
> traffic well. This is unsurprising since they are
> heavily optimized for voice traffic which has very
> regular periodicity and payload sizes. 

This basically means that these links are not that capable of handling IP traffic. I think it is better to say that these links are not that good at utilizing the advantages of header compression, than to say that there are problems with header compression since not all compressed headers have a small, fixed size. The default headers are the uncompressed headers and with header compression most of them are almost completely removed, but not all of them because of natural causes. You must be prepared to pay the price, nothing is for free.

> Now, it may be that the cellular MAC's and PHY's
> need some retooling in the long run in which case
> ROHC will work better,

I agree with you that future cellular link technologies must be better at handling real general data traffic (including speech traffic as one kind of data). 

/L-E

---

From: "Dr. Carsten Bormann" <[email-masked]>
Date: Fri, 30 Mar 2001 15:40:01 +0200

> This basically means that these links are not that capable of
> handling IP traffic.

Actually, they are.  They are just not good at handling traffic whose
payload already maxes out the link.

If the objective is to use only exactly as much capacity as is needed for
the payload, my humble advice would be not to run IP over the link.

(Oh, and one aspect often forgotten about wireless links is that you can
often play with the channel coding.  This gives you *some* form of VBR --
combined with variable BER, unfortunately.)

Gruesse, Carsten

---

From: Michael Thomas <[email-masked]>
Date: Fri, 30 Mar 2001 07:36:40 -0800 (PST)

> This basically means that these links are not that capable of

  Ah, I can see how you drew that inference :-) What
  I meant is that they have problems with real time,
  periodic fixed sized flows like VoIP. Obviously,
  queuing solves the problem with bursty, best effort
  traffic.

>  I think it is better to say that these links are not that good at
utilizing the advantages of header compression, than to say that there
are problems with header compression since not all compressed headers
have a small, fixed size. The default headers are the uncompressed
headers and with header compression most of them are almost completely
removed, but not all of them because of natural causes. You must be
prepared to pay the price, nothing is for free.

  It's hard to assign blame here: the two things were
  optimized for two entirely different purposes. What
  we are left with is not an entirely great fit.

 > I agree with you that future cellular link technologies must be better at handling real general data traffic (including speech traffic as one kind of data). 

   I'd love to see a centralized schedular that handles
   variable rate data better but doesn't chew up lots
   of bandwidth. Fundamentally, these two design criteria
   are at odds with each other though.

       Mike