Subject: RE: [seamoby] MANET Critique ( was Yet Another BOF?

From: Nitin H Vaidya <[email-masked]>
Date: Thu, 8 Mar 2001 05:57:53 -0600 (CST)

hi Kulwinder

My reply below. As I read what I wrote below, I see that I
am starting to repeat myself. So I plan to drop off this
thread here.

  >> From [email-masked] Wed Mar  7 23:35:32 2001
  >> 
  >> Consider this:
  >> 
  >> 1. All the Masters are arranged in a tree structure such that each Master
  >> itself is a Slave in the piconet of its Master.  
  >> 
  >> 2. The root of the tree contains a 'Super-Master'.
  >> 
  >> 3. The 'Super-Master' may be an Isolated Mobile Node (no link to an Access
  >> Point).
  >> 
  >> 4. Only the 'Super-Master' may be an a Access Point.
  >> 
  >> 5. Only the 'Super-Master' can attach the entire tree to an Access Point. 
  >> 
  >> 6. Any Mobile Node may leave to join another Access Point, or become an
  >> Isolated Mobile Node, taking any and all of its Slave Nodes that are
  >> attached to it. (its subnet)
  >> 
  >> 7. An Isolated Mobile Node when linking to an Access Point will surrender
  >> its 'Super-Master' Role.
  >> 
  >> Do we still need TORA?

You would never *need* TORA as such.
TORA is just *a* routing protocol. If you think you *need*
*a* routing protocol, then TORA, AODV, DSR, Link State,
Distance Vector, manual configuration, are all plausible
options. The correct question to ask would be is TORA
the best choice in the above situation.

Sounds like the tree structure you describe above is
not static, which will call for some sort of routing protocol.
Which protocol is best? Hard to say. But with low mobility,
the choice is not terribly critical, pick something simple
but reasonable (say, one of Link State/AODV/DSR depending
on bandwidth/latency constraints).

Cheerio.

- nitin

  >> - Kulwinder.

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 08 Mar 2001 11:16:42 -0800

Hello,

Your proposed structure places severe restrictions.  With no loss
of functionality, or increase in complexity, it would be quite possible
to let any ad hoc node be an Internet Access Point.

I also would like to suggest that manet protocols (and AODV in
particular) have been portrayed as necessarily heavyweight because
they assure loop freedom even over multiple hops.  This isn't right,
and AODV in particular was intended to be a lightweight protocol.

I think that a distance-vector approach is quite suitable for
Bluetooth's master-slave architecture.  AODV only has to say
where the next hop is.  Enforcing the master-slave connectivity
is going to happen below IP anyway.

I'm pretty sure this discussion doesn't belong here, though...

Regards,
Charlie P.