Subject: RE: Registration (was RE: [seamoby] L2/L3 Paging)

From: "Casati, Alessio (Alessio)" <[email-masked]>
Date: Mon, 26 Mar 2001 21:21:01 +0100

> But MIP registration implies there is an active L3 connectivity end to
end,
 > or L2 paging is in place to wake up a dormant node and then deliver
 > IP packets...

   I guess that depends on your definition of "active".
   Active in the MIP sense means that the state is
   still resident on the thing that keeps the binding.
   It doesn't imply that you move packets around.

Exactly. But when there is no link we may have 2 cases:
the link can be re-established via L2 paging, or the packets (when they do 
need to be delivered) get dropped
for a while, and then timers will do the rest.

   Also: L3 "connectivity" can be transient with respect
   to L2 connectivity. I can, for example, unplug my
   ethernet cable from my laptop and plug it back in
   only when I want service.
   The upper layer IP stack
   doesn't care much about this: the only time it cares
   is when it needs to send/receive a packet. 

Which is a case we should quite care about :).

---

From: Michael Thomas <[email-masked]>
Date: Mon, 26 Mar 2001 12:33:31 -0800 (PST)

> for a while, and then timers will do the rest.
 
   I believe that there is a third possibility:
   The paging interface allows delivery of IP 
   datagrams. None of these exist, as far as I 
   know, but that doesn't preclude some clever
   radio-heads from doing so :-)

		   Mike