Subject: RE: [seamoby] Yet Another BOF?

From: Pat Calhoun <[email-masked]>
Date: Wed, 28 Feb 2001 10:24:36 -0800 (PST)

>   I think you miss Phil's point. It's all simply a matter of
> software, and no doubt, with enough extensions, modifications, 
> and bit twiddling, we could turn ARP into some version of a 
> mobility protocol (or any other protocol, heck, there are still
> people working on mobile wireless ATM).
> 
>    The frustration comes because with each attempt at a
> problem statement, MIP proponents come forth and state:
> "oh, well sure, we can make MIP do that". No problem statement
> for MM will ever be sufficient if this is the nature of the game.

Those people are as entitled to their opinions as you and Phil are. The point
is that their opinion may not reflect rough concensus or the WG.

I believe that the problem statement does have some things that Mobile IP will
have a REALLY hard time handling. However, as I have stated numerous times,
statements like "MIP is too slow" just doesn't cut it. Let's get to the meat
of the requirements, and then we can identify whether MIP can do the job.

PatC

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Wed, 28 Feb 2001 15:48:21 -0800

>  However, as I have stated 
> numerous times,
> statements like "MIP is too slow" just doesn't cut it.  

Lets try it this way then - please shoot me down.

We clearly believe that micro-mobility means not invoking
the MIP HAs each time we handoff? So all the action must be local.
That excludes vanilla MIP as a solution and under those
conditions its slow and lossy, etc. 

So what is this local protocol? I would claim that trees,
levels of FAs and tunneling (the base MIP class) are 
costly (tunnel/detunel overhead/complexity)
and not robust (the tree of FAs, single gateways). 
I'm not digging here; just some unsubstantiated 
thoughts off the top of my head. 

The point that a number of people are making (and 
developing solutions for, e.g., CIP, Hawaii, etc.) 
is that if I'm forced to use FAs (trees and levels of them),
tunneling and MIP signaling to solve every new
wireless problem (e.g., QOS, fast handoff, etc.) 
that surfaces in IETF, then, how do we innovate 
and deliver new wireless IP technologies?  

Is this because people think that the investment in MIP
is so great that must reap dividend at no end? sister of
MIP, cousin of MIP, etc.

Coupling each development to the base MIP mechanisms
(FAs, tunneling, MIP signaling) as a perquisite to
the development of new wireless IP protocols is a
little like driving a car with a straight-jacket on.

Building fast/seamless handoff, paging, context, 
QOS, etc. etc., on MIP is where we are heading today;
consensus or not; it looks to me its all engineered
that way? 

The goals should to let MIP be the macro-mobilty 
protocol to interwork with and allow 
new and innovative technologies with 
(for fast handoff, seamless, fast security, 
QOS, context, etc. etc.) to be created.

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 28 Feb 2001 12:49:43 -0800 (PST)

> Lets try it this way then - please shoot me down.

ok

> and deliver new wireless IP technologies?  

Ahhh..... technical arguments. Good. This is all good. This is what we need.
They are alot harder to defend than the "MIP is too slow" argument.

> is so great that must reap dividend at no end? sister of

Sure, and I do understand where they stand, but our charter is not to save
engineering work. It is to build what we need.

> consensus or not; it looks to me its all engineered

well, I haven't seen paging, context nor QoS being built on top of MIP, but
perhaps I've missed something. Of course, I've seen individual contributions
that propose this, but this is hardly a WG's work item.

> QOS, context, etc. etc.) to be created.

Sounds reasonable to me.

PatC

---

From: "Gary Kenward" <[email-masked]>
Date: Wed, 28 Feb 2001 13:18:48 -0500

James:

With all due respect,
Gary

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Tuesday, February 27, 2001 7:01 PM
> To: [email-masked]; [email-masked]
> Subject: Re: [seamoby] Yet Another BOF?
> 
> 
> Phil,
> 
> I think you are being much too pessimistic. Dana and Mike 
> Thomas have raised
> some significant issues regarding the interaction between MIP 
> and routing. 
> Thought
> the rhetoric and accusations have been flying, there is the 
> kernel of some 
> serious questions that need to be addressed. In particular, 
> the interaction 
> of RSVP and MIP that Mike has identified in his draft are 
> serious, since 
> RSVP was designed with standard routing protocols in mind, 
> not with MIP. 
> Perhaps they can be fixed by aggregated RSVP, perhaps not 
> (after reading 
> the aggregated RSVP draft, I
> have my doubts).
> 
> In any event, working out the details and pinning down 
> exactly what can and 
> can't be
> done using MIP will be what tips the balance of whether a 
> routing based 
> micromobility protocol gets done or not. If you look in the 
> paging draft, 
> ultimately, we determined that it would be possible to do 
> most everything 
> using MIP, but practical considerations and the complexity of 
> doing it 
> argued for a modest IP paging protocol. Something similar may 
> happen for 
> micromobility as well.
> 
> So...hang in there!
> 
>                  jak
> 
> PS: regarding fiber in Nebraska and New York, the point is, New York 
> probably has
> the fiber, and the ROI of laying it in Nebraska probably 
> isn't big enough 
> (especially
> considering the telco financial condition these days) to do 
> justify it. 
> Just as with paging, you need to give the people doing the network 
> engineering some flexibility
> without overwhelming them with options.
> 
> At 05:50 PM 2/27/01 -0600, [email-masked] wrote:
> 
> 
> 
> >After a brief history with mobility BOFs,  I am convinced 
> that they are of
> >limited use.  Perhaps an
> >informational RFC is a better approach (not my idea).  I am 
> convinced that 
> >many
> >of us (perhaps
> >Gary, (Andrew, James, John, Peter, and the other OBAST 
> disciples:-))) that
> >wanted to build true
> >all IP based, edge oriented, routers with wireless cards, 
> with a standardized
> >backhaul, some
> >how got muscled out of the IETF by the powerful forces of 
> the MIP and MANET
> >groups.  We
> >played nice, let them hack up the charter into what is now a 
> tenuous set of
> >problem statements
> >dangling on the edge of existence.
> >
> >I for one find it difficult to contribute or create in this type of 
> >forum.  Its
> >completely stifling.  We need
> >to throw out all the assumptions and start from a clean 
> slate.  We need to
> >consider the implications of
> >ultra-wideband, widespread deployment of MMDS/LMDS, OFDM, 
> hybrid fiber 
> >wireless
> >schemes and
> >how they interact with mobility, and the failure of 3G.  I 
> am tired of arguing
> >about the minutia of where
> >an FA lives or whether its macro or micro mobility.  They 
> will all likely be
> >irrelevant in the forth coming
> >world of glass pipes everywhere (its easier to lay glass in 
> Nebraska than 
> >in NYC
> >James :-)).
> >
> >Some folks have approached me about another BOF.  I am 
> convinced it would 
> >NOT be
> >a good thing.
> >An informational RFC COULD provide a way to articulate some 
> ideas in a way 
> >that
> >at least gets them
> >documented and shared.  Some other folks have approached me 
> about this 
> >concept.
> >I am in favor
> >of this.  How about a seamoby4g mail list?  Anybody 
> interested in a 4g seamoby
> >list?  This would
> >get all the off charter dreamware chatter off the seamoby list.
> >
> >As for the SeaMoby WG, at this point I don't know.  We have 
> to see what 
> >happens.
> >It looks to me
> >like SeaMoby is becoming MIP's newborn cousin at this point. 
>  Hopefully, late
> >term abortions aren't
> >allowed.
> >
> >Thanks,
> >
> >Phil Neumiller
> 
>

---

From: Pat Calhoun <[email-masked]>
Date: Sun, 4 Mar 2001 16:22:29 -0800 (PST)

All,

This is an old e-mail that was resent by someone at m018.com. Somehow, this
site is resending old e-mail from both seamoby and mobileip lists. I have had
to shutdown my list (as has mobileip), as we are being attacked quite
viciously by this site. I do not know of a way to re-enable the site and not
be attacked.

This morning I had over 1800 e-mails resent from this site to my box. I am
getting quite annoyed.

In short, disregard these e-mails.

PatC