Subject: Re: [seamoby] L2/L3 Paging

From: James Kempf <[email-masked]>
Date: Mon, 26 Mar 2001 09:14:29 -0800 (PST)

Dave/Mike/All,

>Martin, David P writes:
> > At the meeting in Minnesota, there was a question that basically asked
> > "Should seamoby paging *require* L2 Paging be present".  Consensus was no
> > ...  I think a better question to ask would be "Should seamoby *assume* that
> > layer 2 has knowledge of the location of the MN".  I think (perhaps I'm
> > wrong), that the answer to the latter question would be yes.
>
>   I don't see why we should assume that. If a mobile
>   is dormant, we probably know its last attachment 
>   point, but that doesn't mean that the L2 must 
>   track its movement accurately. In fact, I'd say
>   that that should be an explicit *non-goal* as it
>   would allow the MN to sleep for longer periods.
>
> > I'm not sure how you can have a link without knowing where you are sending
> > stuff.  I am a little concerned that the paging team may be attempting to
> > solve a very difficult problem that will never exist.
>
>   This doesn't seem to hard: suppose you have a
>   beacon which all dormant nodes listen too. To
>   find a node, the last attachment point performs
>   a search in the local paging area. When the mobile
>   wakes up, it establishes a link to its current AP,
>   and a tunnel to the old AP to scoop up the
>   packet(s).
>

My interpretation of the working group discussion and concensus is that an IP 
paging protocol should not require L2 paging. However, I don't think there
is any reason why it should not be designed to allow use of L2 paging
if there. To not do so would be putting unwise constraints on
implementors.

I'd like to suggest that the requirement read something like:

	The IP paging protocol shall utilize L2 paging support if available,
	but shall not require L2 paging. 

		jak

---

From: Michael Thomas <[email-masked]>
Date: Mon, 26 Mar 2001 11:41:19 -0800 (PST)

> 	but shall not require L2 paging. 

   I'm hair splitting here, but we MUST use it? It 
   seems to me that what we really want is that 
   IP paging not inhibit the use of L2 paging 
   mechanisms as appropriate for that L2. Otherwise,
   we might be inhibiting the ability to develop
   native IP paging mechanisms in the future, which
   I'll guess is not your intent.

	      Mike