Subject: RE: [seamoby] RE: [ROHC] Compression startup behaviour

From: "Gary Kenward" <[email-masked]>
Date: Thu, 29 Mar 2001 13:13:10 -0500

Having only skimmed the evolution of this thread, I have apparently
lost the train of thought . . . 

What does context transfer have to do with packet losses over the
air? No one is proposing context transfer to or from the mobile. All
context transfer being discussed in this wg is within the wireline
network.

Gary

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, March 29, 2001 12:35 PM
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [seamoby] RE: [rohc] Compression startup behavior
> 
> 
> > No, the best case would be 1, 
> 
> ... if there are no transmission errors and the compressor knows
> this.
> 
> > while 3 probably would be a 
> > good candidate for realistic conditions and VERY FEASIBLE IN 
> > PRACTICE. If the systems are providing acceptable service 
> > quality, higher numbers should not be needed. 
> 
> 3 may or may not work. It depends. In cellular, "acceptable 
> service quality" means different thing at different time and 
> location (of the mobile node). When you are driving in your car 
> in a traffic jam at 5pm, a higher packet loss rate is acceptable 
> (to the operator, not you). The very reason that a handover
> occurs is due to poor radio conditions at the edge of a cell,
> which means you are also at the edge of the new cell after
> handover, which means the condition of the new channel probably
> will not be very good either. Those factors have to be 
> considered.
> 
> > We could probably argue about this for months (see ROHC 
> > mailing list from April 2000), so I will try not to continue 
> > this discussion. 
> 
> Oops, I just did. 
> 
> > I guess that context transfer is a mechanism 
> > that will be developed (snip)
> 
> Good, at least we agree on one thing.
> 
> Br,
> Zhigang
>  
>  
> > Rgds,
> > /L-E
> > ---
> > Mailing list for Robust Header Compression WG
> > Archive: http://www.cdt.luth.se/rohc/
> > 
>

---

From: [email-masked]
Date: Thu, 29 Mar 2001 13:23:16 -0600

Hi Gary,

You're right. The discussion is indeed confusing for anyone 
who hasn't followed the ROHC list. In short, the argument on the 
packet losses (more accurately, the consecutive losses)
is about how much is the benefit of HC context relocation,
and thus whether it is needed.

The logic is: without context relocation, an estimate of consecutive
packet losses determines how many IR packets are needed to establish 
the context over the air after handover. With context relocation,
those IR packets can be avoided.

To me, the benefit outweighs the cost (if any).

Br,
Zhigang

-----Original Message-----
From: ext Gary Kenward [mailto:[email-masked]]
Sent: Thursday, March 29, 2001 12:13 PM
To: 'seamoby'
Cc: [email-masked]'; [email-masked]';
[email-masked]'
Subject: RE: [seamoby] RE: [ROHC] Compression startup behaviour

---

From: [email-masked]
Date: Thu, 29 Mar 2001 13:21:00 -0600

Hello Gary,

Having only skimmed the evolution of this thread, I have apparently 
lost the train of thought . . . 
[Rajeev]  Happens sometimes :-)

What does context transfer have to do with packet losses over the 
air? 
[Rajeev]  Header compression context initialization is done over the air
interface. The packet losses over the air need to be considered here since a
compressor has to obtain sufficient confidence that the decompressor has the
required state to conduct operation in a spectrally efficient manner. Packet
losses, higher link latencies could exacerbate context initialization,
leading to wasted bandwidth over air interface. 

When we do context transfer, we can provide a useful alternative to context
re-initialization (where packets losses over air could occur) during
handovers. 

In summary, since context transfer alleviates the need for context
re-initialization, it also helps avoid packets losses  during compression
context re-initialization!

 No one is proposing context transfer to or from the mobile. All 
context transfer being discussed in this wg is within the wireline 
network. 
[Rajeev]  Right. 

Regards,

-Rajeev

Gary 

> From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> > Archive: http://www.cdt.luth.se/rohc/ <http://www.cdt.luth.se/rohc/>  
> > 
>

---

From: "Gary Kenward" <[email-masked]>
Date: Thu, 29 Mar 2001 15:48:15 -0500

Zhigang:

  Thanks for the clarification. If I understand you, I agree that the
benefits of CT outweigh the costs. The primary application of header
compression as far as I know is VoIP. I find it hard to believe that
3 packets can be sent over the air in time to prevent noticeable artifacts
from being introduced at the decoder.

Gary

> Sent: Thursday, March 29, 2001 2:23 PM
> To: Kenward, Gary [WDLN2:AN10:EXCH]; [email-masked]
> Cc: [email-masked]; [email-masked]