Subject: [seamoby] RE: comments on the micro-mobility problem statement draft

From: [email-masked]
Date: Sat, 17 Mar 2001 07:57:52 +0200

Hi Sharif,

> 1.	After the second paragraph in section 1 "introduction", 
> I would like the following paragraph to be added.

I hesitate to add your paragraph - as it I am not sure what
it adds - if you feel that it is important - please give me
supporting reasons.

> 2.	In section 1.1 "scope": I want to add:
> 	Possiblities include:
> 
> 	Mobility where the user's rouable IP address does change.

I'd call this macromobility.  

> 	I also request to add the following:
> 
> 	Where mobility may be:
> 
> 		Within a sub-net.
> 		Across muliple sub-nets.

Agreed.
 
> 3.	In section 1.2 "problem statement add the bullet to the list of
> considerations:
> 
> 		*	Buffering to minimize packet delay/loss during
> handoff.

Buffering I consider part of Context transfer.

> 4.	Section 1.3
> 
> 	In the definition of Local Mobility, it is stated that the "IP
> address must not change".
> 
> 	This has been stated several times throughout the document.
> 
> 	With the permission of the WG, I would like to re-phrase this
> definition. I request that the mandate "IP address must not change" 
> be dropped, so people can persure solutions where the IP address may 
> change, but not frequently. 

This would be the point where MM crosses with macromobility.  

> 	Section 2.1
> 
>       In the "Mandatory" section there is a bulleted item :
> 
> 		*	Use Mobile IP WG protocols for mobility between
> local mobility domains.

These are all updated according to v1 of the draft.

>       Section 3
> 
>       Minor changes requested here:
>       Local Mobility will interwork with Context Transfer and Paging.
> 
>       And also add the bullet:
> 
> 		*	paging

Agreed.

John

---

From: "Shahrier, Sharif M." <[email-masked]>
Date: Sat, 17 Mar 2001 14:17:55 -0500

JOHN,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, March 17, 2001 12:58 AM
To: [email-masked]
Cc: [email-masked]
Subject: RE: comments on the micro-mobility problem statement draft

Hi Sharif,

ON SECOND READING, IT IS NOT NECCESSARY TO ADD THE PARAGRAPH.

NO, THIS IS JUST AN IMPLEMENTATION ISSUE. I HAVE DEVELOPED A MICRO-MOBILITY
PROTOCOL, WHICH USES A TWO LEVEL ADDRESSING. (1) TO GET TO THE NEW "AR"
WITHIN THE SAME DOMAIN, (2) LOCAL ADDRESS OF THE "MN". ALTHOUGH, THE LOCAL
ADDRESS OF "MN" STAYS THE SAME, THE "AR" ADDRESS WILL CHANGE DURING HANDOFF,
TO A TOTALLY NEW "AR". NOTE, THAT WE'RE TALKING ABOUT "AR"'S WITHIN THE SAME
ADMINISTRATIVE DOMAIN, AND THAT IS MICRO-MOBILITY.

THIS PROTOCOL INTEGRATES BOTH MICRO-MOBILITY AND ROAMING INTO A SINGLE
PROTOCOL.

I WILL BE PUTTING THIS DRAFT OUT SHORTLY, AND IT WILL BE CLEARER THEN. BUT I
CAN'T SAY ANY MORE TILL THEN.

IT WILL REQUIRE "...user's routable IP address does change" TO BE PUT IN THE
DRAFT, TO ALLOW FOR MY DESIGN, AND POSSIBLY SOME OTHER PEOPLE'S AS WELL.

THAT IS MY REASON FOR THE INCLUSION OF THIS IMPORTANT TEXT.

Agreed.

OK.

PLEASE SEE MY REASONS FOR (2) ABOVE.

Agreed.

John