Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

From: "Gary Kenward" <[email-masked]>
Date: Thu, 1 Mar 2001 14:13:42 -0500

Sorry, but Glenn's observations made sense to me. He was not defining
the HA as a NAT, he was identifying that it performed Network Address
Translation, which it does. It then forwards the packets, which is what
most NAT gateways do.

Gary

> -----Original Message-----
> From: Hesham Soliman (ERA) [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2001 5:04 PM
> To: Morrow, Glenn [RICH2:C330:EXCH]
> Cc: 'Michael Thomas'; [email-masked]
> Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt
> 
> 
> Hello Glenn, 
> 
> A router is a device that forwards packets from one interface to
> another. That makes a NAT a router and so is a HA. 
> A router CAN definitely tunnel, I hope you agree with that.
> 
> A NAT is a device that hides addresses on one side of the 
> network from the other side and the end nodes. Typically 
> because they are not routable. 
> A HA _does_not_hide addresses from anyone. The end nodes 
> and the entire Internet can route a MN's Home address. 
> NATs typically break end to end security and many peer to
> peer protocols. A HA doesn't.
> 
> I'm a bit surprised by your analogy and definitions but 
> I dont really think we should spend our lives looking 
> for a definition that makes a HA look like a NAT. 
> Surely there are better reasons for justifying
> the mm problem and better things to do.
> 
> Regards,
> Hesham
> 
> > -----Original Message-----
> > From:	Glenn Morrow [SMTP:[email-masked]]
> > Sent:	Thursday, 1 March 2001 7:16
> > To:	'Hesham Soliman (ERA)'; 'Michael Thomas'
> > Cc:	[email-masked]
> > Subject:	RE: [seamoby] I-D 
> ACTION:draft-ietf-seamoby-mm-problem-00.txt
> > 
> > I don't mean to jump but IMHO here are some things to 
> realize about MIP in relation to these NAT statements: 
> > 
> > Route Optimized MIP is essentially per-host routing with 
> some signaling (BU) and a double NAT function built into the 
> end-nodes (hosts if you prefer).
> > 
> > Functionally you could decompose a MIP MN or a CN into the 
> NAT, per-host routing (binding cache) functions and the 
> "pure" host (applications) which uses the home addresses.
> > 
> > You could also think of the HA as a part of this double NAT 
> as well; albeit, it is using a tunnel to statelessly signal 
> the address translation.
> > 
> > The reason I am trying to bring this up to people is to 
> make them realize the following: 
> > 
> > - It is per-host routing. 
> > - It is double NAT (address translation at both ends) 
> > 
> > Because it is per-host routing the route tables of the 
> hosts may indeed grow large. For example, one of the hosts 
> may be a website which millions of mobile hosts communicate 
> simultaneously. Imagine a media or even just an HTTP server 
> with a million per-host route entries. 
> > 
> > Are there server companies and chip manufacturers working 
> on hardware assisted look-up engines and code to do these 
> lookups to meet the delay requirements?
> > 
> > Another approach we might take it to move the double NAT 
> and fast (per-host routing) lookup functions to the (purpose 
> built) subnet routers where they might have a chance of scaling. 
> > 
> > This might also serve to provide simultaneous route 
> optimization with location privacy and allow the existing 
> SA's between routers to be leveraged in order to avoid the 
> necessity of setting up SA's every time a mobile node wishes 
> to communicate with another node on the network.
> > 
> > I am also fairly convinced that there are solutions which 
> do not compromise the connectionless (redundant) nature of 
> IP, especially in the IPv6 case.
> > 
> > Indeed this would not be creating a new protocol to solve 
> the node mobility problem - it would be changing IP, itself, 
> to solve the node mobility problem - essentially making a new 
> "pure" IP.
> > 
> > O.K. fire away  - at least we might get off the "what is a 
> router" debate. 
> > 
> > Glenn 
> > 
> > 
> > 
> > 
> > -----Original Message----- 
> > From:   Hesham Soliman (ERA) [SMTP:[email-masked]] 
> > Sent:   Tuesday, February 27, 2001 11:25 AM 
> > To:     [email-masked] 
> > Subject:        RE: [seamoby] I-D 
> ACTION:draft-ietf-seamoby-mm-problem-00.txt 
> > 
> > 
> > > >     means choosing the shortest path between two nodes 
> > > >     on the Internet. 
> > > 
> > > Can you define node ? 
> > > 
> >         => Host ? Terminal ? 
> > 
> > > >     I hope you don't mean that having a router in the 
> > > >     middle that encapsulates a packet and forwards it 
> > > >     to the right address is breaking the Internet 
> > > >     model. That _is_routing.>  
> > > 
> > > But that is not what a Home Agent does.  No user application like 
> > > email or web browsing on the internet addresses a router. 
>  The cNode 
> > > and MN in Mobile IP actually address the Home Agent which has no 
> > > user application executing on it. 
> > > 
> >         => No it doesn't address the HA, this not true at 
> all. The application 
> >         addresses the Home address of the MN. The HA receives the 
> >         packet because of its ND/ARP advertisements. I'm sure you 
> >         know that already. So I don't know why you say that. 
> > 
> > 
> > > tunnels the packet.  The inner portion of an IP tunnel is 
> the application 
> > > layer of the outer header.  So the Home Agent is in 
> effect an application 
> > > layer switch in the middle of the network which is not 
> too different than a NAT. 
> > > 
> >         => That is a gross misinterpretation of a HA. How 
> could it possibly be a NAT ? 
> >         Do I need to list all the protocols that do not 
> work through a NAT ? 
> >         A HA does not operate above L3. This is the whole 
> point behind MIP. 
> > 
> > > > 
> > > >> An 
> > > >> anchor point anywhere in the network is neither client nor 
> > > >> server nor peer and therefore 
> > > >> 
> > > >     => It's a router ! They are usually in the middle 
> > > >     and they're not clients or servers. 
> > > 
> > > See my point above.  The Home Agent is not a router.  
> > > 
> >         => Of course it's a router, define a router ? 
> >         your claims above abou it being a NAT are wrong. 
> >         The first few pages in the MIP spec tell you 
> >         that it's a router don't they ? 
> > 
> > > Non-mobile 
> > > clients, servers, and peers do not address routers.  IOW, the IP 
> > > destination address of a packet originiating from a fixed 
> client, server, or 
> > > peer on the internet is not the address of a router.  
> > > 
> >         => I think you need to reread MIP. The CN does not 
> >         address the HA. 
> > 
> > > >     => I agree, but there are ways of making it redundant 
> > > >     like any other router. 
> > > 
> > > The only way is stateful transfer which requires some state other 
> > > than IP routing to be transfered.  It's expensive an wasteful. 
> > > What about networks that want to be multihomed ? 
> > > 
> >         => I was talking about a transfer of the binding cache. 
> >         Multihoming is not an issues here is it ? 
> > 
> >         Regards, 
> >         Hesham 
> > 
>

---

From: Michael Thomas <[email-masked]>
Date: Thu, 1 Mar 2001 11:32:46 -0800 (PST)

This is *really* out in the weeds, but getting
called "NAT-like" is something of a Scarlet Letter
(well, at least should be) and I think I come down
on Heshem's side on that account. Tunneling is not
the moral equivalent of NAT'ing because it:

1) Can just be thought of as an ordinary interface
   between the two routers which terminate the
   tunnel
2) Does not alter either the interior L3 headers
   and more importantly doesn't do stateful 
   inspection on the > L3 contents.

		 Mike