Subject: RE: [seamoby] Micro-mobility Issues for IESG to Consider

From: Kulwinder Atwal <[email-masked]>
Date: Thu, 15 Mar 2001 00:13:30 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, March 14, 2001 12:42 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [seamoby] Micro-mobility Issues for IESG to Consider
> 
> 
> Phil,
> 
> One comment:
> 
> >                 B).  The justification for micro-mobility is 
> > 				precisely the same
> >                       as that used for fast handoff (i.e. at 
> > 				this point stricly
> >                       an emotional appeal since no hard data 
> > 				currently exists).
> 
> MIP has been deployed, at least in lab situations, by many 
> companies.  Fast Handoff is an enhancement to an existing
> protocol based upon experience.  MM isn't really in the 
> same league (yet).  

Is MIP willing to wait for a MM with lab experience?
Do you have preformance numbers for MIP across the Internet, or only on
private 3GPP2 IP networks?

> I don't see any parallels between the
> two (useful parallels, at least).

Useful parallels:

Access	Core
LAN		WAN
Seamoby	MIP
Private	Service Provider
Low Cost	Fault Tolerant Redundancy
Small		Big

We can continue to discuss details like which is faster, but the real issue
is structural.  
Do we really want to write another Core mobility protocol to work with other
wireless access technologies?  
Or, promote protocol re-use by requiring that all IP mobility solutions
adhere to the Access/Core model? 

The real problem with MIP, as stated by many others, is deployment
flexibility across various wireless access technologies.

What I would like to see MIP proponents focus on discussing is:  

What are the merits of IP mobility protocol re-use across various core
network and mobile access network technologies?

Can MIP work effectively on and with:

Mobile Access Network Gateways?
Mobile Routers?
Mobile Nodes?
Mobile Hosts?
Mobile unaware nodes?
Ad Hoc mobile networks?

What is the clear division of labour between the core mobility protocol MIP
and access mobility protocols?

These questions are no longer esoteric, but will require real answers from
MIP proponents next week.

3G Cellular is no longer alone in seeking IP mobility solutions from the
IETF.

- Kulwinder.

>  If we want MM, then
> we need to justify it on its own merits.
> 
> John
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 15 Mar 2001 08:27:23 -0800

Hello,

I guess I count as a Mobile IP proponent, insofar as I want
to be sure that the "micromobility" (still dislike that term)
proposal should work well with Mobile IP.

> > two (useful parallels, at least).
definition?  > Access          Core
disagree     > LAN             WAN
definition   > Seamoby         MIP
disagree     > Private         Service Provider
disagree     > Low Cost        Fault Tolerant Redundancy
definition?  > Small           Big

I put some spaces in there so it would look O.K. on my screen.
I disagree with your classifications.   For instance, Mobile IP
can work in a private deployment as well as with a service
provider.  And, the intention was to make Mobile IP a small
protocol.  There are a few bells and whistles, but they could
be removed as the protocol progresses from Proposed Standard
to Draft Standard, depending on working group consensus and
experience.  I'd like to find out if you have any analysis to
support these assertions.  Of course, we'd all like protocols
to be smaller, lower cost, and all that.  Unfortunately, one
person's bell is another person's crucial part of the protocol
sometimes.  I don't believe that the evidence presented so far
proves that [seamoby] will be immune to that phenomenon.

> adhere to the Access/Core model?

Maybe an explicit statement of the Access/Core model would be useful
to be able to understand your point.  IP itself does not require nor
even suggest such a model.  [seamoby-mm] might, by the pure device of
stating that it serves a domain of applicability called an "access
network".  Or maybe you mean the Access Network to be the same thing
that is called a "Local Mobility Domain" in the draft.
 
> flexibility across various wireless access technologies.

Here is where I am really surprised.  Mobile IP is suitable for various
wireless access technologies.  I almost said all, but then I remembered
that I haven't done them all myself -- only quite a few.

> network and mobile access network technologies?

The merits are those of Mobile IP, which are supposed to include:
- seamless mobility, except that now that term is becoming
  more closely associated with the [seamoby] working group
- "always-on" operation for a node
- global reachability for mobile nodes with global IP addresses

If you don't care about "always on", or global IP addressability,
then you can do with less, but I always wonder about why.

> Mobile Access Network Gateways?

Why not?  I would say yes.  Do they offer care-of addresses?

> Mobile Routers?

Here the answer is "yes", depending on how you would like to
inject routes into rest of the Internet for the mobile portion
which is to be served by the mobile router.

> Mobile Nodes?

Yes -- but why is this different than the last question?

> Mobile Hosts?

Yes -- but maybe you weren't seriously asking this question...

> Mobile unaware nodes?

No.

> Ad Hoc mobile networks?

No.

> and access mobility protocols?

Mobile IP wants to deal with changing IP addresses, and wants the home
agent to find out about changed care-of addresses.  Keep the IP address
the same, and Mobile IP doesn't have to know.  If it's viewed as too
expensive to update the home agent, then one might find ways to keep
the care-of address known by the home agent to be the same.  Thus, we
have [seamoby], apparently for the case when the care-of address just
doesn't change at all, and various other proposals for localizing the
reporting requirements for changed care-of addresses.

That seems clear to me.  Is it unclear?

> MIP proponents next week.

How about now?

Also, if I may ask, were they actually questions or part of an ultimatum?

Charlie P.