Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

From: "Glenn Morrow" <[email-masked]>
Date: Thu, 1 Mar 2001 10:25:41 -0600

Hesham,

See below:

> Hello Glenn, 
> 
> A router is a device that forwards packets from one interface to
> another. That makes a NAT a router and so is a HA. 
> A router CAN definitely tunnel, I hope you agree with that.
[[gm]]  Sounds like a reasonable definition to me; however, I do suspect
that some routers can't tunnel and can't do NAT. I think we should say "some
routers can" and be done with this banter which has occured since the
original MIPv6 handoff discussion. 

> A NAT is a device that hides addresses on one side of the 
> network from the other side and the end nodes. Typically 
> because they are not routable. 
[[gm]]  You have limited your definition of NAT. A NAT is a device or
process that translates a source and or desination address to another. It
matters not whether the addresses are globally routable or not. One could
say that one application of network address translation is to hide internal
addresses from the external network.

> A HA _does_not_hide addresses from anyone. 
[[gm]]  Really - does a correspondent node know the MN's COA unless route
optmization is used?

> The end nodes 
> and the entire Internet can route a MN's Home address.
[[gm]]  I am extremely please by this. I am also pleased that the entire
Internet does not know the MN's COA. I am not please with the fact that in
order to provide route optimization, the entire Internet must know the COA.
I would suggest a solution that exposes the COA information to only routers
and not hosts.
>  
> NATs typically break end to end security and many peer to
> peer protocols. A HA doesn't.
[[gm]]  
If you apply network address translation at both sides (as route optmized
MIP does) then you have no problem with peer to peer protocols. One way of
avoiding the necessity of changing of supposedly un-mutable fields is to use
encapsulation. Do you see that in optimized MIP, the MN could use a tunnel
to the CN to deliver a packet instead of address translation. The packet is
delivered either way (i.e. same functionality - different mechanism).

> I'm a bit surprised by your analogy and definitions but 
> I dont really think we should spend our lives looking 
> for a definition that makes a HA look like a NAT. 
> Surely there are better reasons for justifying
> the mm problem and better things to do.
[[gm]]  begin
Surely the following:

- a list of true requirements for node mobility (macro, micro)
- an analysis of data-hiding ramifications of these requirments
- an analysis of the scaling ramifications of these requirments

are essential to any problem and solution set.

You are quite correct that I was not focusing merely on the micro-solution.
I was also addressing end to end security associations, scaling, etc.. that
are some of the "excuses" for micromobility solutions - not that I am
opposed to some solutions. I believe we need both solutions that can support
real-time handover. 

If you note, the HA correlation with NAT is only one aspect about what is
discussed below. Making an HA equivalent to a limited definition of a NAT
was not my goal. I am a bit perplexed as to why your response focuses so
much on such a minor analogy and adapt an attitude that I somehow do not
understand the difference. 

If you look, I believe you might find some more pertinent suggestions in
terms of requirements, ramifications and possible ways forward. I and I hope
others would see much more value for you to focus on these.

Regards,

Glenn

[[gm]]  end

> Regards,
> Hesham
> 
> > -----Original Message-----
> > From:	Glenn Morrow [SMTP:[email-masked]]
> > Sent:	Thursday, 1 March 2001 7:16
> > To:	'Hesham Soliman (ERA)'; 'Michael Thomas'
> > Cc:	[email-masked]
> > Subject:	RE: [seamoby] I-D
> ACTION:draft-ietf-seamoby-mm-problem-00.txt
> > 
> > I don't mean to jump but IMHO here are some things to realize about MIP
> in relation to these NAT statements: 
> > 
> > Route Optimized MIP is essentially per-host routing with some signaling
> (BU) and a double NAT function built into the end-nodes (hosts if you
> prefer).
> > 
> > Functionally you could decompose a MIP MN or a CN into the NAT, per-host
> routing (binding cache) functions and the "pure" host (applications) which
> uses the home addresses.
> > 
> > You could also think of the HA as a part of this double NAT as well;
> albeit, it is using a tunnel to statelessly signal the address
> translation.
> > 
> > The reason I am trying to bring this up to people is to make them
> realize the following: 
> > 
> > - It is per-host routing. 
> > - It is double NAT (address translation at both ends) 
> > 
> > Because it is per-host routing the route tables of the hosts may indeed
> grow large. For example, one of the hosts may be a website which millions
> of mobile hosts communicate simultaneously. Imagine a media or even just
> an HTTP server with a million per-host route entries. 
> > 
> > Are there server companies and chip manufacturers working on hardware
> assisted look-up engines and code to do these lookups to meet the delay
> requirements?
> > 
> > Another approach we might take it to move the double NAT and fast
> (per-host routing) lookup functions to the (purpose built) subnet routers
> where they might have a chance of scaling. 
> > 
> > This might also serve to provide simultaneous route optimization with
> location privacy and allow the existing SA's between routers to be
> leveraged in order to avoid the necessity of setting up SA's every time a
> mobile node wishes to communicate with another node on the network.
> > 
> > I am also fairly convinced that there are solutions which do not
> compromise the connectionless (redundant) nature of IP, especially in the
> IPv6 case.
> > 
> > Indeed this would not be creating a new protocol to solve the node
> mobility problem - it would be changing IP, itself, to solve the node
> mobility problem - essentially making a new "pure" IP.
> > 
> > O.K. fire away  - at least we might get off the "what is a router"
> debate. 
> > 
> > Glenn 
> > 
> > 
> > 
> >

---

From: "Glenn Morrow" <[email-masked]>
Date: Wed, 28 Feb 2001 14:15:35 -0600

I don't mean to jump but IMHO here are some things to realize about MIP in
relation to these NAT statements:

Route Optimized MIP is essentially per-host routing with some signaling (BU)
and a double NAT function built into the end-nodes (hosts if you prefer).

You could also think of the HA as a part of this double NAT as well; albeit,
it is using a tunnel to statelessly signal the address translation.

The reason I am trying to bring this up to people is to make them realize
the following:

Because it is per-host routing the route tables of the hosts may indeed grow
large. For example, one of the hosts may be a website which millions of
mobile hosts communicate simultaneously. Imagine a media or even just an
HTTP server with a million per-host route entries. 

Another approach we might take it to move the double NAT and fast (per-host
routing) lookup functions to the (purpose built) subnet routers where they
might have a chance of scaling. 

This might also serve to provide simultaneous route optimization with
location privacy and allow the existing SA's between routers to be leveraged
in order to avoid the necessity of setting up SA's every time a mobile node
wishes to communicate with another node on the network.

I am also fairly convinced that there are solutions which do not compromise
the connectionless (redundant) nature of IP, especially in the IPv6 case.

Indeed this would not be creating a new protocol to solve the node mobility
problem - it would be changing IP, itself, to solve the node mobility
problem - essentially making a new "pure" IP.

O.K. fire away  - at least we might get off the "what is a router" debate.

Glenn

> From:	Hesham Soliman (ERA) [SMTP:[email-masked]]
> Sent:	Tuesday, February 27, 2001 11:25 AM
> To:	[email-masked]
> > >	means choosing the shortest path between two nodes
> > >	on the Internet. 
> > 
> > Can you define node ?
> > 
> 	=> Host ? Terminal ? 
> 
> > >	I hope you don't mean that having a router in the 
> > >	middle that encapsulates a packet and forwards it
> > >	to the right address is breaking the Internet 
> > >	model. That _is_routing.
> > 
> > But that is not what a Home Agent does.  No user application like
> > email or web browsing on the internet addresses a router.  The cNode
> > and MN in Mobile IP actually address the Home Agent which has no
> > user application executing on it.
> > 
> 	=> No it doesn't address the HA, this not true at all. The
> application
> 	addresses the Home address of the MN. The HA receives the 
> 	packet because of its ND/ARP advertisements. I'm sure you 
> 	know that already. So I don't know why you say that.
> 
> 
> > tunnels the packet.  The inner portion of an IP tunnel is the
> application
> > layer of the outer header.  So the Home Agent is in effect an
> application
> > layer switch in the middle of the network which is not too different
> than a NAT.
> > 
> 	=> That is a gross misinterpretation of a HA. How could it possibly
> be a NAT ?
> 	Do I need to list all the protocols that do not work through a NAT ?
> 	A HA does not operate above L3. This is the whole point behind MIP.
> 
> > >
> > >> An
> > >> anchor point anywhere in the network is neither client nor
> > >> server nor peer and therefore 
> > >> 
> > >	=> It's a router ! They are usually in the middle
> > >	and they're not clients or servers.
> > 
> > See my point above.  The Home Agent is not a router.  
> > 
> 	=> Of course it's a router, define a router ? 
> 	your claims above abou it being a NAT are wrong.
> 	The first few pages in the MIP spec tell you 
> 	that it's a router don't they ?
> 
> > Non-mobile
> > clients, servers, and peers do not address routers.  IOW, the IP
> > destination address of a packet originiating from a fixed client,
> server, or
> > peer on the internet is not the address of a router.  
> > 
> 	=> I think you need to reread MIP. The CN does not 
> 	address the HA.
> 
> > >	=> I agree, but there are ways of making it redundant
> > >	like any other router.
> > 
> > The only way is stateful transfer which requires some state other
> > than IP routing to be transfered.  It's expensive an wasteful.
> > What about networks that want to be multihomed ?
> > 
> 	=> I was talking about a transfer of the binding cache.
> 	Multihoming is not an issues here is it ?
> 
> 	Regards,
> 	Hesham

---

From: "Glenn Morrow" <[email-masked]>
Date: Thu, 1 Mar 2001 10:25:41 -0600

Hesham,

[[gm]]  

[[gm]]  begin
Surely the following:

Regards,

Glenn

[[gm]]  end

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 23:03:36 +0100

Hello Glenn, 

A HA _does_not_hide addresses from anyone. The end nodes 

Regards,
Hesham

> Subject:	RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt
> 
> I don't mean to jump but IMHO here are some things to realize about MIP in relation to these NAT statements: 
> 
> Route Optimized MIP is essentially per-host routing with some signaling (BU) and a double NAT function built into the end-nodes (hosts if you prefer).
> 
> Functionally you could decompose a MIP MN or a CN into the NAT, per-host routing (binding cache) functions and the "pure" host (applications) which uses the home addresses.
> 
> You could also think of the HA as a part of this double NAT as well; albeit, it is using a tunnel to statelessly signal the address translation.
> 
> The reason I am trying to bring this up to people is to make them realize the following: 
> 
> Because it is per-host routing the route tables of the hosts may indeed grow large. For example, one of the hosts may be a website which millions of mobile hosts communicate simultaneously. Imagine a media or even just an HTTP server with a million per-host route entries. 
> 
> Are there server companies and chip manufacturers working on hardware assisted look-up engines and code to do these lookups to meet the delay requirements?
> 
> Another approach we might take it to move the double NAT and fast (per-host routing) lookup functions to the (purpose built) subnet routers where they might have a chance of scaling. 
> 
> This might also serve to provide simultaneous route optimization with location privacy and allow the existing SA's between routers to be leveraged in order to avoid the necessity of setting up SA's every time a mobile node wishes to communicate with another node on the network.
> 
> I am also fairly convinced that there are solutions which do not compromise the connectionless (redundant) nature of IP, especially in the IPv6 case.
> 
> Indeed this would not be creating a new protocol to solve the node mobility problem - it would be changing IP, itself, to solve the node mobility problem - essentially making a new "pure" IP.
> 
> Subject:        RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt 
> 
> 
> > >     model. That _is_routing.>  
> > 
>         => No it doesn't address the HA, this not true at all. The application 
> > tunnels the packet.  The inner portion of an IP tunnel is the application 
> > layer of the outer header.  So the Home Agent is in effect an application 
> > layer switch in the middle of the network which is not too different than a NAT. 
> > 
>         => That is a gross misinterpretation of a HA. How could it possibly be a NAT ? 
> > destination address of a packet originiating from a fixed client, server, or