Subject: RE: [mobile-ip] RE: [seamoby] RE: [rohc] RE: Restarting Compresso r on Mobile IPv6 Handover

From: "Gary Kenward" <[email-masked]>
Date: Tue, 10 Apr 2001 14:10:42 -0400

Michael:

   You were the one who stated that FMIP would not support context
tranfer for header compression. 

    Jumping over all the usual diabtribe, my point was that we need to 
find a solution, wherever the changes may be required, not just find
fault with the approach.

    End of thread as far as I am concerned.

Gary

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Tuesday, April 10, 2001 11:37 AM
> To: Kenward, Gary [WDLN2:AN10:EXCH]
> Cc: 'seamoby'; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: [mobile-ip] RE: [seamoby] RE: [rohc] RE: Restarting
> Compresso r on Mobile IPv6 Handover
> 
> 
> Gary Kenward writes:
>  > Michael:
>  > 
>  >    It *may* be the case here that FMIP is deficient in 
> supporting context
>  > transfer for header compression state. FMIP does not 
> define the problem 
>  > space. Kheim has done a fairly eloquent job of describing 
> a real world issue
>  > with wireless handover. To say that FMIP won't support it 
> is to say that
>  > FMIP
>  > is broken, not that the problem should not be solved.
> 
>    I find it hard to fault FMIP here; it's just setting up
>    a tunnel between the old AR and the MN. There's nothing
>    "broken" about that. The alternative is not
>    exactly very pretty either and could lead to
>    some bizarre and unforseen side effects (though MIPv4
>    may have a handle on them). There's a lot to be 
>    said about preserving transparency when ARnew
>    and ARold have no relationship with one another.
> 
>  >   So let's get on with solving the problem. If there is a 
> requirement to
>  > change
>  > FMIP, I'm sure the MIP group would be interested in our 
> input. After all,
>  > that is one of the reasons Seamoby was chartered.
> 
>    The requirement belongs on CT, not FMIP. It may
>    also be a bogus thing to do given the way that
>    ROHC/CRTP works.
> 
> 		Mike
>

---

From: Michael Thomas <[email-masked]>
Date: Tue, 10 Apr 2001 11:22:50 -0700 (PDT)

> tranfer for header compression. 

   That's *one* way to spin it. The way I wrote it is
   that header compression CT will have trouble with
   FMIP. I'm not interested in assigning blame to FMIP
   here because I don't think FMIP is the root of the
   problem.

		Mike