Subject: RE: [seamoby] RE: [rohc] RE: Restarting Compressor on Mobile IPv6 Handover

From: [email-masked]
Date: Tue, 3 Apr 2001 16:26:11 -0500

Hi,

How does this avoid the core problem of context _re-initialization_ ? You
would still need to send IR packets (to new access router over the air
interface) subsequent to handover in order to start a new context..
Anchoring it at the previous router may buy you some time, but not the bits.
I reckon anchoring will bring its own set of problems. 

Regards,

-Rajeev

> -----Original Message-----
> From: ext Pete McCann [mailto:[email-masked]]
> Sent: Tuesday, April 03, 2001 11:32 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [seamoby] RE: [rohc] RE: Restarting Compressor on Mobile
> IPv6 Handover
> 
> 
> 
> Hi,
> 
> I think there is a simpler solution to this problem that most people
> are overlooking.
> 
> It should be possible to keep the compressor/decompressor state at the
> old access router and to tunnel the already-compressed packets to and
> from the new access router.  Then the MN and new access router can
> renegotiate header compression state from scratch and take as long as
> they want to do so, because the MN is still getting service in the
> meantime.
> 
> Someone earlier asked about support for ROHC on IP tunnels and I think
> this would be a good application for that.
> 
> We are trying to move the mountain to Mohammed and I don't see why we
> can't do the reverse instead.
> 
> -Pete
> 
> 
> ---
> Mailing list for Robust Header Compression WG
> Archive: http://www.cdt.luth.se/rohc/
>

---

From: Pete McCann <[email-masked]>
Date: Tue, 3 Apr 2001 19:29:37 -0500 (CDT)

Yes, you would need to re-initialize the context over the air, but I
don't think the bandwidth usage is high enough to matter.  In a
wide-area cellular environment IP handoffs will be relatively
infrequent.  The important consideration is the "glitch" experienced
in voice traffic at handoff time, and this can be minimized by
temporarily anchoring the compressor.

-Pete

[email-masked] (rk) writes:

rk> Hi,

rk> How does this avoid the core problem of context
rk> _re-initialization_ ? You would still need to send IR packets (to
rk> new access router over the air interface) subsequent to handover
rk> in order to start a new context..  Anchoring it at the previous
rk> router may buy you some time, but not the bits.  I reckon
rk> anchoring will bring its own set of problems.

rk> Regards,

rk> -Rajeev

>> Archive: http://www.cdt.luth.se/rohc/
rk> ---
rk> Mailing list for Robust Header Compression WG
rk> Archive: http://www.cdt.luth.se/rohc/