Subject: RE: [seamoby] L2/L3 Paging

From: Kulwinder Atwal <[email-masked]>
Date: Mon, 2 Apr 2001 13:46:49 -0400

> -----Original Message-----
> From: Martin, David P [mailto:[email-masked]]
> Sent: Monday, April 02, 2001 10:06 AM
> To: 'Kulwinder Atwal'; 'Michael Thomas'; Martin, David P
> Cc: 'David R. Oran'; [email-masked]
> Subject: RE: [seamoby] L2/L3 Paging
> 
> 
> > 
> > Mobile left town, battery died, ... all fall under the 
> catagory: link
> > failure.
> > 
> > It can be resolved with an implementation specific Link 
> > Timeout Timer, where
> > if no packets are transferred for Link Timeout seconds link 
> failure is
> > assumed.  Link reliability is an L2 issue.
> > 
> > - Kulwinder.
> 
> Yes that is one solution, but how should the timer be set?  
> Different link
> protocols, different applications, different RF conditions, 
> etc would affect
> what the optimum timeout should be ... 

What I am suggesting is for us to simply consider an abstract L2 Trigger,
and let different L2s deal with how they wish for the L2 timer to be set.
Otherwise, we may find ourselves creating timers that compete with Link
Layer timers.  In some instances the L2 Trigger will be a timer, but in
other instances it will be a low Radio Signal Strength that will trigger a
change in the network.

L2 Trigger Case 1: The mobile user's battery dies unexpectedly ( L2 Timer )
L2 Trigger Case 2: The mobile moves away while sending ( low Radio Signal
Strength)

- Kulwinder.

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 2 Apr 2001 14:59:10 -0500

Hi Kulwinder,

Well hush my mouth and echo from the past...  Nice thinking here Kulwinder.
I want to re-emphasize that I think Kulwinder is really on to something here
and this is precisely the kind of thing that the new fangled sub-IP WG should
do if/when it gets created, the again Kulwinder since you are the co-Chair
of the Bluetooth WG you could start making sure that the bottom half of
Bluetooth is already doing this. ;-)

----- Original Message -----
From: "Kulwinder Atwal" <[email-masked]>

> and let different L2s deal with how they wish for the L2 timer to be set.

<stuff ripped>

> - Kulwinder.

This is very CRAPS-esque I might add.  I like this a whole lot and I have
bored many an IETFr with this rant, of course mine was always longer
for some reason. :-)

-pdn