Subject: RE: [mobile-ip] RE: [seamoby] RE: [rohc] RE: Restarting Compresso r on Mobile IPv6 Handover

From: Kulwinder Atwal <[email-masked]>
Date: Tue, 10 Apr 2001 20:16:53 -0400

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Tuesday, April 10, 2001 4:32 PM
> To: Gary Kenward
> Cc: 'Michael Thomas'; 'seamoby'; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: [mobile-ip] RE: [seamoby] RE: [rohc] RE: Restarting
> Compresso r on Mobile IPv6 Handover
> 
> 
> Gary Kenward writes:
>  > Sheesh. It's not about blame. 
>  > 
>  > It is *all* about determining where the most appropriate 
> place to fix a
>  > problem.
>  > That's what distinguishes engineering from hacking.
> 
>    Fine. You said that it looked like a problem with
>    FMIP and it should be fixed there. What leads you
>    to that conclusion and what would you have them do?

What lead some of us to that conclusion are two things:

1. Your statement below in a previous emial:

> All I'm asking here is how CT would interact with
> FMIP. I believe that FMIP is very likely to be a
> very important part of handoffs and as such, I
> would like to know whether CT for header
> compression state will help, hinder or be of no
> benefit at all. From what I can tell, there is
> indeed a problem and it is not clear whether there
> is a solution, or whether the solution would be
> worse than the original problem given the high
> likelihood of race conditions, etc.

2. The Bluetooth Special Interest Group, Personal Area Networking Working
Group, plans to use the output of CT in a mobility protocol other than FMIP,
HMIP, MIPv4, MIPv6 or anything else with MIP in the title.

Therefore, tying CT to your favorite flavor of MIP is NOT a requirement.
More importantly, requesting CT to change to accommodate FMIP is NOT a
requirement.  If there are problems with FMIP there is an IETF working group
established to deal with them.  It is called the: MIP WG

Here is a link.  Check it out:

http://www.ietf.org/html.charters/mobileip-charter.html

- Kulwinder.

> 
> 	   Mike
>    
>  > 
>  > > -----Original Message-----
>  > > From: Michael Thomas [mailto:[email-masked]]
>  > > Sent: Tuesday, April 10, 2001 2:23 PM
>  > > To: Kenward, Gary [WDLN2:AN10:EXCH]
>  > > Cc: 'Michael Thomas'; 'seamoby'; [email-masked];
>  > > [email-masked]; [email-masked]
>  > > Subject: RE: [mobile-ip] RE: [seamoby] RE: [rohc] RE: Restarting
>  > > Compresso r on Mobile IPv6 Handover
>  > > 
>  > > 
>  > > Gary Kenward writes:
>  > >  > Michael:
>  > >  > 
>  > >  >    You were the one who stated that FMIP would not 
> support context
>  > >  > tranfer for header compression. 
>  > > 
>  > >    That's *one* way to spin it. The way I wrote it is
>  > >    that header compression CT will have trouble with
>  > >    FMIP. I'm not interested in assigning blame to FMIP
>  > >    here because I don't think FMIP is the root of the
>  > >    problem.
>  > > 
>  > > 		Mike
>  > > 
>  > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
>  > <HTML>
>  > <HEAD>
>  > <META HTTP-EQUIV="Content-Type" CONTENT="text/html; 
> charset=iso-8859-1">
>  > <META NAME="Generator" CONTENT="MS Exchange Server version 
> 5.5.2654.19">
>  > <TITLE>RE: [mobile-ip] RE: [seamoby] RE: [rohc] RE: 
> Restarting Compresso r on  Mobile IPv6 Handover</TITLE>
>  > </HEAD>
>  > <BODY>
>  > 
>  > <P><FONT SIZE=2>Sheesh. It's not about blame. </FONT>
>  > </P>
>  > 
>  > <P><FONT SIZE=2>It is *all* about determining where the 
> most appropriate place to fix a problem.</FONT>
>  > <BR><FONT SIZE=2>That's what distinguishes engineering 
> from hacking.</FONT>
>  > </P>
>  > 
>  > <P><FONT SIZE=2>&gt; -----Original Message-----</FONT>
>  > <BR><FONT SIZE=2>&gt; From: Michael Thomas [<A 
> HREF="mailto:[email-masked]">mailto:[email-masked]</A>]</FONT>
>  > <BR><FONT SIZE=2>&gt; Sent: Tuesday, April 10, 2001 2:23 PM</FONT>
>  > <BR><FONT SIZE=2>&gt; To: Kenward, Gary [WDLN2:AN10:EXCH]</FONT>
>  > <BR><FONT SIZE=2>&gt; Cc: 'Michael Thomas'; 'seamoby'; 
> [email-masked];</FONT>
>  > <BR><FONT SIZE=2>&gt; [email-masked]; 
> [email-masked]</FONT>
>  > <BR><FONT SIZE=2>&gt; Subject: RE: [mobile-ip] RE: 
> [seamoby] RE: [rohc] RE: Restarting</FONT>
>  > <BR><FONT SIZE=2>&gt; Compresso r on Mobile IPv6 Handover</FONT>
>  > <BR><FONT SIZE=2>&gt; </FONT>
>  > <BR><FONT SIZE=2>&gt; </FONT>
>  > <BR><FONT SIZE=2>&gt; Gary Kenward writes:</FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp; &gt; Michael:</FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp; &gt; </FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp; &gt;&nbsp;&nbsp;&nbsp; You 
> were the one who stated that FMIP would not support context</FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp; &gt; tranfer for header 
> compression. </FONT>
>  > <BR><FONT SIZE=2>&gt; </FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp;&nbsp;&nbsp; That's *one* way 
> to spin it. The way I wrote it is</FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp;&nbsp;&nbsp; that header 
> compression CT will have trouble with</FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp;&nbsp;&nbsp; FMIP. I'm not 
> interested in assigning blame to FMIP</FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp;&nbsp;&nbsp; here because I 
> don't think FMIP is the root of the</FONT>
>  > <BR><FONT SIZE=2>&gt;&nbsp;&nbsp;&nbsp; problem.</FONT>
>  > <BR><FONT SIZE=2>&gt; </FONT>
>  > <BR><FONT SIZE=2>&gt; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 
> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Mike</FONT>
>  > <BR><FONT SIZE=2>&gt; </FONT>
>  > </P>
>  > 
>  > </BODY>
>  > </HTML>
>

---

From: Michael Thomas <[email-masked]>
Date: Tue, 10 Apr 2001 17:34:48 -0700 (PDT)

> > likelihood of race conditions, etc.

   I fail to see how this supports your argument.
   You can't run ROHC end to end either. That 
   doesn't imply that IP is broken.

 > HMIP, MIPv4, MIPv6 or anything else with MIP in the title.

   And this has what, exactly. to do with the
   interaction of FMIP and header compression CT?
 
 > Therefore, tying CT to your favorite flavor of MIP is NOT a

   Nobody said it was. CT does have a requirement to
   support MIP though.

 > established to deal with them.  It is called the: MIP WG

   Considering that there is a FMIP protocol defined
   and no CT protocol whatsoever, I don't know what
   it is that you think we should be telling the 
   mobile IP working group. Is mind reading in
   their charter too?

		 Mike