Subject: [seamoby] [Issue] Support for Multi-Phase CT

From: Pat Calhoun <[email-masked]>
Date: Thu, 21 Jun 2001 15:36:58 -0700

Issue 5: Support for multi-phase CT 

     Submitter name: Pat Calhoun 
     Submitter email address: [email-masked] 
     Date first submitted: June 21,2001 
     Reference: 
     Comment type: T 
     Priority: 1 
     Section: 4.9 

     Rationale/Explanation of issue: 
     The current requirement in section 4.9 states that a CT can only 
     occur once all of the state has been gathered. The CT protocol 
     must allow for state to be transferred in phases, where the high 
     priority state (e.g. Header Compression, session keys) is sent 
     first, and low priority items are sent at a later time (e.g. 
     accounting information). 

     This would reduce the size of the high priority CT packets, 
     lower the computational cost of processing the packet, and decrease 
     the handoff latency. 

     Requested change: 
     Change 4.9 to state something like: 

     "4.9 Context information MAY be transferred in phases, allowing for 
     higher priority state to be sent first, and lower priority 
     state to be sent at a later time. 

     The total cost of processing a smaller packet with high priority 
     state is smaller, and would decrease any latency introduced by CT. Each 
     CT profile would need to specify whether it is to be considered 
     as a high or low priority state." 

     Proposal: 
     Adopt the text above in the -01 version of the requirements spec.

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Mon, 25 Jun 2001 13:59:11 -0500

Pat,

I like your idea. I think it should be added. 
I just have one question and that is on the emphasi

-----Original Message-----
From: Pat Calhoun [mailto:[email-masked]]
Sent: Thursday, June 21, 2001 5:37 PM
To: [email-masked]
Subject: [seamoby] [Issue] Support for Multi-Phase CT

     Requested change: 

     Proposal:

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Thu, 28 Jun 2001 11:02:54 -0500

Pat,

I see. Maybe then you want to make your point of packet
size and "fast" context, a recommendation (May? rather
than a requirement), I am not sure whether recommendations
(without using May, should,...) can be included in a 
requirement document?

Madjid

-----Original Message-----
From: Pat Calhoun [mailto:[email-masked]]
Sent: Monday, June 25, 2001 5:05 PM
To: Nakhjiri Madjid-MNAKHJI1
Cc: 'Pat Calhoun'; [email-masked]
Subject: Re: [seamoby] [Issue] Support for Multi-Phase CT

On Mon, Jun 25, 2001 at 02:02:33PM -0500, Nakhjiri Madjid-MNAKHJI1 wrote:
> Pat,
> 
> I think this is a good idea.
> I just have one question, since your text emphasizes on
> the size of low priority packets. I can see that accounting
> could include a lot of data, but why the emphasis that every
> high priority context has small packet size and every low priority
> context has large packet size? Isn't that a bit of generalization?

yes it is. Perhaps packet size is the wrong thing to point out here,
but my point is that packet construction, transmission, reception and
parsing is much faster for small packets than larger packets (well,
transmission and reception is in the noise, but you get my drift). So,
things like L2 security info needs to be there REAL fast!

PatC
> Madjid