Subject: RE: FW: [seamoby] CT trigger or CT completion? was: proactive an d re active CT definitions

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Thu, 28 Jun 2001 10:58:21 -0500

I don't like this one, I seem to be chasing a moving target (definition of 
reactive, proactive). Last week we were talking about whether to use
link establishment or not, this week it is about default router.

I started to like Charlie's definition based on link establishment,
(however, we accepted that by link we are talking about L2)
since L2 establishment is more crisp than completed handover.
and we explored different cases, so we don't miss all the cases.
The draft versus Charlie's definition of reactive/ proactive 
definitions in the two turned out to cover different
set of scenarios without changing the outcome too much. 

 I don't see how this new definition that pop up everyday are 
making the CT better.

I am the newAR, How long do I have to wait until I make sure 
I am the default router, say in a FMIPv6 case: until I get
the NA and make sure MN has a valid newCoA?
What if the MN still has to use its oldCoA and a tunnel between
newAR and oldAR, how long do I have to wait to start CT, this 
introduces unnecessary delay for CT.

Another confusing thing is folks on the list keep using their
own favorite words and definitions in the continuing conversations
without paying attention what the other ends understanding
of that word is,

Lets finish off the link establishment discussion and if it
is not good enough, see what is better, the way it is going
I am not sure we are making a lot of progress in wrapping
things up.

Madjid

-----Original Message-----
From: Pat Calhoun [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 8:36 AM
To: Rajeev Koodli
Cc: Kulwinder Atwal; 'Pat Calhoun'; 'Nakhjiri Madjid-MNAKHJI1'; 'Charles
E. Perkins'; [email-masked]'
Subject: Re: FW: [seamoby] CT trigger or CT completion? was: proactive
and re active CT definitions

> > How is this:
> >
> > Pre-Handoff Context Transfer: The Context Transfer is initiated prior to
the
> > newAR becomes the MN's default router.
> >
> > Post-Handoff Context Transfer:  The Context Transfer is initiated after
the
> > newAR becomes the MN's default router.
> >
> > -Kulwinder.
> >
> >
> 
> Rajeev: This would work for me.  May be we should ask PatC on how to
proceed
> next?

what do folks think about using this terminology? Is this preferred over the
existing terminology in the draft?

PatC

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 28 Jun 2001 10:43:11 -0700

Hello madjid,

> set of scenarios without changing the outcome too much.

Rajeev: I have a question here. Is it possible that you can establish a new L2
and still not change your AR ? If yes, if you don't change AR, is there is
still any CT ? Is this too naive ?
It seems to me that the AR is the key entity (for our defintion) since that
holds the feature contexts.

> introduces unnecessary delay for CT.

Rajeev: There is IP router discovery that indicates to a node when some AR has
become the default AR.

Any CT that happens prior to this phase is "Pre"-something. This includes using
L2 triggers etc. When none of this is possible, the MN realizes that it has
changed its AR through router advertisements and does CT, which is
"Post"-something. Sure there is delay here. It is a matter of classification,
not debating performance.
Anyway, let's see if we can resolve the previous question.

Regards,

-Rajeev