Subject: RE: [seamoby] Reactive context transfer

From: "Gary Kenward" <[email-masked]>
Date: Fri, 15 Jun 2001 16:20:42 -0400

Actually, it turns out that consensus cannot be determined at the dt
level, only at the wg level - which requires Pat. 
 
Based upon this, every "decision" made during the last six months can
be re-opened. I hope Pat has lot's of energy.
 
Gary

-----Original Message-----
From: Kulwinder Atwal [mailto:[email-masked]]
Sent: Friday, June 15, 2001 2:26 PM
To: Kenward, Gary [WDLN2:AN10:EXCH]; 'Charles E. Perkins'
Cc: 'seamoby'
Subject: RE: [seamoby] Reactive context transfer

-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Friday, June 15, 2001 1:58 PM
To: 'Charles E. Perkins'
Cc: 'seamoby'
Subject: RE: [seamoby] Reactive context transfer

Charlie: 

 For us, it is unacceptable that CT should be dependent upon 
some layer 3 messaging from the MN. Over the air transit latencies 
are just too great, and we don' see the value. I think here we 
simply must agree that we have different views of the world.  

This is implementation specific. 

 This whole issue was discussed at great length, and it was 
clear then that there was no "right" approach. We decided then 
that we would abstract out the initiating event - some called 
it a trigger - and that would allow for different networks and 
different vendors to define the approach they like the best.  

Since I was the one who proposed triggers.  My recollection is quite
different.

The intent was that we would not know where the trigger packet came from,
but at no time did I ever suggest it was out of scope.

In fact, I explicitly stated that it could be MN or Network initiated as did
Vijay. 

 Who triggers context transfer is not relevant, unless we believe 
we are going to build the trigger into CTP as a signalling message. 
There was a long debate, and it was decided very early on that 
it was not necessary to build this into CTP. That does not 
mean that this approach is excluded from the mobility solution, nor 
does it mean that an MN message could not trigger CT indirectly. It 
simply means that CTP will not include an MN to AR message. 

 You can refer to the archives if you question this, in particular, 
the conference call meeting minutes.  

IETF rules do not allow concensus from meetings.  ONLY mailing lists
concenus is valid. 

 At the moment, I would suggest strongly that we retain that decision. 
It allows both camps to work on their preferred solution. More importantly, 
it would allow us to move forward. 

We cannot move forward until this is resolved.

- Kulwinder.  

 What you are proposing is to return to the discussions of six months ago. 
This would be unacceptable to me, for sure, and I suspect others engaged 
with this process would also be very frustrated. 

Gary 

> -----Original Message----- 
> From: Charles E. Perkins [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Friday, June 15, 2001 1:01 PM 
> To: Kenward, Gary [WDLN2:AN10:EXCH] 
> Cc: 'seamoby' 
> Subject: [seamoby] Reactive context transfer 
> 
> 
> 
> Hello Gary, 
> 
> > Gary Kenward wrote: 
> 
> >        .......                   We did discuss how CT was to be 
> > initiated, and agreed that there would be no explicit 
> signalling from 
> > the MN (not at least as far as CT was concerned). 
> 
> I would consider this as wholly unacceptable, except that in your 
> next paragraph you state: 
> 
> >   The definition of reactive CT (read the problem 
> statement)has to do with 
> > the order/timing of events, not with where the initiating 
> event comes from. 
> 
> So then I started to wonder about how one might define "reactive" to 
> make the previous sentence come true.  But, the word "reactive" does 
> not occur in draft-ietf-seamoby-context-transfer-problem-stat-01.txt. 
> No help there.  I did find some redefinition of "reactive" in 
> draft-hamid-seamoby-ct-fwk-00.txt, but that document was, I believe, 
> not the result of design team discussions.  In fact, I have some 
> other comments on the latter document, but for now I would just like 
> to suggest that it should not be taken as relevant to the current 
> discussion about reactive context transfers. 
> 
> That puts me back to square one.  From that standpoint, I would like 
> to suggest that the context transfer problem statement needs to 
> very clearly define the following concepts: 
> 
> - Network-initiated context transfer, for which the access network 
>   tells the mobile where to go 
> 
> - Mobile-initiated context transfer, for which the mobile tells the 
>   network where it wants to go 
> 
> - Predictive context transfer, for which either the mobile or the 
>   network initiates context transfer BEFORE leaving the previous 
>   access router 
> 
> - Reactive context transfer, for which either the mobile or 
> the network 
>   initiates context transfer AFTER the mobile arrives (establishes 
>   a link) at the new access router. 
> 
> 
> I like the word "predictive" for several reasons: 
> 
> - It has exactly the right meaning, and even connotes that caution 
>   is necessary because not all predictions come true 
> 
> - In contrast to some other alternatives one often hears, it is 
>   a word that one can find in the dictionary. 
> 
> Regards, 
> Charlie P. 
>

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 15 Jun 2001 14:09:31 -0700

Hello folks,

I don't want to fan the flames, but I have to pipe up and
speak here.

Gary Kenward wrote:

>  Actually, it turns out that consensus cannot be determined at the
> dtlevel, only at the wg level - which requires Pat.
>  Based upon this, every "decision" made during the last six months
> canbe re-opened. I hope Pat has lot's of energy.Gary

In the first place, according to my understanding, Pat should
play an equal role in the consensus as other working group
members.  The working group chair can make determinations
about what the consensus of the group is, and  try to
see whether or not the milestones are likely to be met by
following the processes of the moment.  However, it is possible
for the working group consensus to take shape in a way that
may be different than the desires of the working-group chair(s)

Of course, the foregoing is only my opinion and someone else
who knows the rules better might be able to make some
clarifications.  But I'll bet it's not too far wrong..

As for the problem of re-opening previous decisions, that
should only happen if the previous decisions cannot stand up
to working-group scrutiny.  I don't see that happening, and
it seems to me that the current discussion (about reactive
signaling) has only taken up a few days.  Of course there
were lots of discussions preceding the current one -- but I
reckon you weren't counting those.

Regards,
Charlie P.