Subject: RE: [seamoby] Issue 1: Change access network terminology

From: Kulwinder Atwal <[email-masked]>
Date: Wed, 20 Jun 2001 15:32:09 -0400

To expand on Mark's comment:

If we think of an AR or MN as a software thread/task/process with its own AR
context/MN context, instead of physical devices, then we should be able to
keep the terms AR and MN seperate.

1. A physical device may have just the AR task running, in which case it is
only an AR.

2. A physical device may have just the MN task running, in which case it is
only an MN.

3. A physical device may have a MN task and an AR task running in which case
it is both, but the functionality is modularized.

With the AR discovery protocol is possible to learn in a mobile environment
which mobile device nearby has an AR task running before attempting CT.

- Kulwinder.

> -----Original Message-----
> From: Rajeev Koodli [mailto:[email-masked]]
> Sent: Wednesday, June 20, 2001 3:06 PM
> To: Mark Smith
> Cc: [email-masked]
> Subject: Re: [seamoby] Issue 1: Change access network terminology
> 
> 
> 
> Perhaps I am missing something.. Aren't we concerned about 
> the "entity" which offers
> different features (QoS, HC,..) ?  I guess we went with AR 
> because that's the entity
> that typically offers the features.
> 
> Regards,
> 
> -Rajeev
> 
> 
> Mark Smith wrote:
> 
> > I guess my question is, does it matter if a Forwarding Node 
> (as Gary has
> > defined them) is also a Mobile Node?  What effect does it 
> have on our
> > design/requirement/problem statement?
> >
> > I think the idea is that, for the sake of a particular CTP 
> session, a
> > node is either an MN or an FN.  If it's an FN for this CTP 
> session, it
> > may be an MN for another session, but those two sessions 
> are independant
> > of each other and should be viewed as such.
> >
> > -Mark
> >
> > Pat Calhoun wrote:
> >
> > > On Tue, Jun 19, 2001 at 05:13:57PM -0700, Mark Smith wrote:
> > >
> > >>If we do this (which would be find for me, regardless of 
> what my last
> > >>post said :), make sure we define it to address Phil's 
> requests.  I
> > >>think if we were to specify that an AR, in our case, is 
> not neccessarily
> > >>a fixed, wired device, that it can, infact, be an MN 
> itself, that should
> > >>do the trick.
> > >>
> > >>Whatever we call it, it should be defined.
> > >>
> > >
> > > yes, you posts crossed each other :)
> > >
> > > Well, if a CT peer can be an MN, then the use of AR is 
> clearly innapropriate.
> > > AR is an access router, and this is typically where I see 
> CT being used, but
> > > I understand that there are others, such as Phil, that 
> see CT as having many
> > > other uses.
> > >
> > > Perhaps we should first have someone open an issue on 
> whether an MN can in fact
> > > be a CT peer, and the result of that issue would dictate 
> the future of this one.
> > >
> > > PatC
> > >
>

---

From: Mark Smith <[email-masked]>
Date: Wed, 20 Jun 2001 13:57:19 -0700

Thank you, yes, that summarizes quite nicely what I was trying to say.

I'm not trying to say that this isn't a problem, I'm asking if anyone 
can see why it would be.  I can't, but I don't claim to be all knowing.  :)

-Mark