Subject: RE: [seamoby] proactive and reactive CT definitions

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Wed, 20 Jun 2001 18:09:09 -0500

Hello Rajeev:
I think CT is required to support real time 
traffic. Can't I renegotiate the 
context in default case ? What is the saving in 
doing context transfer after completion of layer 3
handover? May be I am missing something.
regards,
ajoy 

-----Original Message-----
From: Rajeev Koodli [mailto:[email-masked]]
Sent: Wednesday, June 20, 2001 5:13 PM
To: Singh Ajoy-ASINGH1
Cc: Nakhjiri Madjid-MNAKHJI1; [email-masked]
Subject: Re: [seamoby] proactive and reactive CT definitions

Hello Ajoy,

Singh Ajoy-ASINGH1 wrote:

> Hello Madjid:
> I also like your definition of reactive handover. I do not think
> doing context transfer after completion of layer 3 handover will
> much sense.
>

Can you say why it does not make sense ?

-Rajeev

> regards,
> ajoy
>
> -----Original Message-----
> From: Nakhjiri Madjid-MNAKHJI1
> [mailto:[email-masked]]
> Sent: Wednesday, June 20, 2001 4:30 PM
> To: 'Rajeev Koodli'; [email-masked]
> Subject: RE: [seamoby] proactive and reactive CT definitions
>
> I still don't know whether I should respond to these issues or not,
> but it seems that is the going trend.
>
> For Proactive, your definition works, and actually it is the same
> as in the draft.
>
> I think this definition of reactive is going backward a bit.
> We did discuss this issue at length and I think you were in agreement that
>  reactive CT, does not always mean that CT cannot start until after the MN's
> packets have arrived.
>
> For reactive, CT can happens simultaneous as Handover signaling
> but it might not finish when handover signaling is complete.
>
> What you are suggesting, means that you don't need CT to deliver
> packets the mobile and are totally moving CT out of the critical
> path for timing. I guess say for header compression
> it means that the newAR does not have HC states for a while,
> assuming it can receive uncompressed packets,
> But would this work for security and authentication, I don't think so.
>
> I like the current definition for reactive:
>  "doing CT when handover is imminent" and that means that oldAR or
> newAR are already engaged in handover signaling, now this could be
> a L2 trigger that newAR has received or a HI or something else, but
> it does not mean completion of handover signaling and packet routing
> change.
>
> Madjid
>
> -----Original Message-----
> From: Rajeev Koodli [mailto:[email-masked]]
> Sent: Wednesday, June 20, 2001 1:49 PM
> To: [email-masked]
> Subject: [seamoby] proactive and reactive CT definitions
>
> Description of issue :Clear, unambiguous definitions are missing.
>
> Submitter name: Rajeev Koodli
>
> Submitter email address: [email-masked]
>
> Date first submitted: June 20, 2001
>
> Comment type: 'T'echnical
>
> Priority:  ''S'/MUST fix
>
> Section:  4.5
>
> Rationale/Explanation of issue:
>
> The section provides the description of proactive and reactive
> CT without properly defining what they are. We need the definitions.
>
> Requested Change:
>
> Reactive CT: The context transfer process which takes place subsequent
> to arrival of a MN's packet at the target AR
>
> Proactive (I prfer Charlie's Predictive better) CT: The context transfer
> process in which the required contexts are in place at the target AR
> prior to the arrival of MN's packet at target AR.

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 20 Jun 2001 16:45:10 -0700

Hello Ajoy,

Singh Ajoy-ASINGH1 wrote:

> context in default case ?

Rajeev: If you mean that the MN can re-establish the contexts, yes.

> What is the saving in

Rajeev: Perhaps.. after L3 handover (i.e., the MN has IP connectivity), if the
context is missing, doing re-establishment over a potentially narrow-band link is
expensive. Doing CT over a higher-speed link between the ARs is a better option.
Also, some could claim that it is not "seamless".

Regards,

-Rajeev