Subject: RE: [seamoby] proactive and reactive CT definitions

From: "Gary Kenward" <[email-masked]>
Date: Thu, 21 Jun 2001 12:23:53 -0400

Charlie:

  The issue isn't whether such a ct is useful or not, the issue
is whether the use of the even of the first packet "arrival" 
should be embedded in the requirements. As I tried to explain
in my response to Ranjeev, the fpa is useful in some situations,
but it's not exclusive - some networks will want to use different
triggers. 

And so, perhaps we are back to the debate over what constitutes
a trigger for a ct - in this case a reactive ct. The definition must
be open to accommodate different networking technologies, different 
topologies and different operational styles.

BTW, from Merriam-Webster:

Main Entry: pro·ac·tive 
Pronunciation: (")prO-'ak-tiv
Function: adjective
Date: 1933

1 [1pro-] : relating to, caused by, or being interference between previous
learning and the recall or performance of later learning <proactive
inhibition of memory>

2 [2pro- + reactive] : acting in anticipation of future problems, needs, or
changes 

(I would quote OED, if I had access).

Cheers,
Gary

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Thursday, June 21, 2001 11:58 AM
> To: Kenward, Gary [WDLN2:AN10:EXCH]
> Cc: Seamless Mobility Working Group
> Subject: Re: [seamoby] proactive and reactive CT definitions
> 
> 
> 
> Hello Gary,
> 
> I think that, even if context transfer begins AFTER a node
> finds a new point attachement, it is by no means necessarily
> too late.  This can be made obvious by a simple example:
> - What if a node does context transfer after a link establishment
>   which finalizes .0001 second after the previous link is dropped?
> If you agree with this, but have concerns about the .1ms latency,
> then we are just haggling over numbers.  It shouldn't be the
> place of the context framework document (for arbitrary media!)
> to arbitrate this, as long as there are media for which the
> context transfer can occur within meaningful time constraints.
> I think it's clear that such media will exist.
> 
> So, I claim that the proposed definition for reactive is very
> beneficial.  A reactive transfer is initiated after the new
> link is established.  A predictive transfer is initiated
> before the new link is established.  These definitions are
> easy, clear, and useful.
> 
> Since even the definition of handover seems to be too muddy,
> perhaps the definition for reactive/predictive (or, if we must
> use it, the non-English word "proactive") should depend only
> on link establishment.
> 
> Regards,
> Charlie P.
> 
> 
> 
> 
> 
> > Gary Kenward wrote:
> > 
> > Rajeev:
> > 
> > > -----Original Message-----
> > > From: Rajeev Koodli [mailto:[email-masked]]
> > > Sent: Wednesday, June 20, 2001 5:40 PM
> > > To: Kenward, Gary [WDLN2:AN10:EXCH]
> > > Cc: [email-masked]
> > > Subject: Re: [seamoby] proactive and reactive CT definitions
> > >
> > >
> > > Gary Kenward wrote:
> > >
> > > >
> > > >
> > > > This is essentially the same definitions I proposed during
> > > > the discussion over proactive and reactive a few months back.
> > > > And, as someone pointed out, it was mistaken.
> > > >
> > > > The first question that was asked then, and is still apropos:
> > > > what benefit is derived from focussing on the specific arrival
> > > > event as the delineator?
> > > >
> > >
> > > Rajeev: The benefit is a clear starting point for the CT
> > > process. (i.e.,
> > > when to initiate CT)
> > 
> > True enough, but the problem is that it is an event that 
> happens too late.
> > Certainly, for some networks, this may be the only handover 
> event that
> > is visible at L3. But, for many networks, there are L2 
> triggers, and mobility
> > events that can be forwarded to CT.
> > 
> > In this sense, the definition you have provided is too 
> limited. Perhaps
> > the answer is to define another phase. I have no real ideas 
> on this at the
> > moment: how about proactive, reactive and panic ;^}
> > 
> > >
> > > >
> > > > To explain further, let me illustrate with a scenario: 
> suppose that
> > > > it takes 10ms to complete a context transfer; now suppose
> > > > that the ct trigger event happens  in less then 10ms from the
> > > > actual first packet arrival, say 9 ms - is this a proactive or
> > > > reactive ct? The ct that occurs fulfills neither of the offered
> > > > definitions.
> > >
> > > Rajeev: The offered definition does not say anything 
> about how long
> > > context transfer takes place. The _start_ of CT request is
> > > the issue. A
> > > packet arrives at the new AR (e.g., a MN request for CT), 
> there is no
> > > context there, then you fetch it.
> > 
> > Ok. How CT starts is important. But as important is when it 
> finishes.
> > Indeed, it is more important to me, as I see too little 
> value in ct that
> > finishes after 3 or 4 packets have been forwarded. I want 
> ct to make real-time
> > 
> > handovers opaque to the end-user.
> > 
> > >
> > >
> > > >
> > > >
> > > > If the context is not in place for the first packet 
> forwarding, then
> > > > the transfer is reactive; meaning that at this point, 
> the goal is to
> > > > complete the transfer as fast as possible to minimize 
> the delay in
> > > > forwarding that first packet.
> > > >
> > >
> > > Rajeev: Exactly. This is what I am proposing to be added.
> > 
> > But this is in the current requirements. It just doesn't 
> say that reactive
> > starts with the first packet forwarding, accounting for the 
> fact that in some
> > networks, reactive mode can occur before that event.
> > 
> > >
> > > >
> > > > Reactive CT is when I either choose not to perform 
> proactive CT, or
> > > > I fail to meet the goal of being proactive.
> > >
> > > Rajeev: Agreed.  Can we add the text then ? What do others think ?
> > 
> > It seems to me that the only part that we disagree on is 
> what indicates that
> > "reactive mode" is occurring.
> > 
> > >
> > > Regards,
> > 
> > Onwards and upwards,
> > Gary
> > 
> > >
> > > -Rajeev
> > >
> > >
> > >
> > > >
> > > > > -----Original Message-----
> > > > > From: Rajeev Koodli [mailto:[email-masked]]
> > > > > Sent: Wednesday, June 20, 2001 2:49 PM
> > > > > To: [email-masked]
> > > > > Subject: [seamoby] proactive and reactive CT definitions
> > > > >
> > > > >
> > > > >
> > > > > Description of issue :Clear, unambiguous definitions 
> are missing.
> > > > >
> > > > > Submitter name: Rajeev Koodli
> > > > >
> > > > > Submitter email address: [email-masked]
> > > > >
> > > > > Date first submitted: June 20, 2001
> > > > >
> > > > > Comment type: 'T'echnical
> > > > >
> > > > > Priority:  ''S'/MUST fix
> > > > >
> > > > > Section:  4.5
> > > > >
> > > > > Rationale/Explanation of issue:
> > > > >
> > > > > The section provides the description of proactive and reactive
> > > > > CT without properly defining what they are. We need the
> > > definitions.
> > > >
> > > > >
> > > > > Requested Change:
> > > > >
> > > > > Reactive CT: The context transfer process which takes place
> > > > subsequent
> > > > > to arrival of a MN's packet at the target AR
> > > > >
> > > > > Proactive (I prfer Charlie's Predictive better) CT: The
> > > > > context transfer
> > > > > process in which the required contexts are in place at
> > > the target AR
> > > >
> > > > > prior to the arrival of MN's packet at target AR.
> > > > >
> > > > >
> > > > >
> > > > >
> > >
> > >
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 21 Jun 2001 12:31:54 -0700

Hello Gary,

You wrote:

> in my response to Rajeev, the fpa is useful in some situations,

Yes, we agree on this.  (I fixed Rajeev's name)

> topologies and different operational styles.

No, I don't think that this is the central issue.  I think the
central issue for the trigger is the link establishment, and
that the central issue for the definition of reactive vs. predictive
is whether the context transfer is initiated after vs. before the
new link is established.  I'm going to be careful not to use the
word "handover" for a while, because it seems to have too much
baggage.

> BTW, from Merriam-Webster:

        .....

> 2 [2pro- + reactive] : acting in anticipation of future problems, needs, or

Thanks for the lookup -- it's not there in my desk reference, which
probably just means that the word isn't as common as, say, predictive.
However, given that some dictionaries have it, I'll be happy to soften
my objection to its use.

Regards,
Charlie P.