Subject: RE: [seamoby] Issue 2: Make IP messages uniform

From: Kulwinder Atwal <[email-masked]>
Date: Wed, 27 Jun 2001 15:16:49 -0400

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Wednesday, June 27, 2001 2:50 PM
> To: Kulwinder Atwal
> Cc: 'Singh Ajoy-ASINGH1'; 'Rajeev Koodli'; 'Pat Calhoun';
> [email-masked]
> Subject: Re: [seamoby] Issue 2: Make IP messages uniform
> 
> 
> On Wed, Jun 27, 2001 at 02:58:01PM -0400, Kulwinder Atwal wrote:
> > > How does the newAR learn the IP address of the old AR?   
> > > 
> > > Ajoy: This can be sent in some layer 2 handoff request message 
> > > from oldAR to newAR. There are other ways too. Please 
> > > note that in cellular old BSC and new BSC exchange some 
> > > information before MN is tuned to different frequency at the 
> > > new BSC. 
> > > 
> > 
> > Yes, but in Bluetooth there is no L2 protocol message for 
> passing the oldAR
> > IP address.  I need an IP message.
> 
> It seems you have a chicken and egg problem. If you cannot figure out
> the IP address of the peer, how is a L3 message, being sent to an IP
> address that you don't know, going to help?

The MN does know the address of the oldAR, because it was just there.  The
MN tells the newAR the oldAR's IP address.

Remember this is Post-Connection.  The newAR may not know which AR the MN
came from.  The fastest way for it to find out is to ask the MN.  The MN
makes the introduction after L2 setup.

- Kulwinder.

> PatC

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 27 Jun 2001 12:08:32 -0700

> makes the introduction after L2 setup.

check. re-reading the requested change, I see that this is really a
request for MN initiated CT. I got confused there for a moment.

Thanks for your patience,

PatC