Subject: Re: [seamoby] Re: Wireless Terminology Draft

From: Jukka Manner <[email-masked]>
Date: Wed, 6 Jun 2001 13:14:02 +0300 (EEST)

Hi all,

	it seems to me that our initial attempt at defining "wireless and
mobile" terminology is getting support, or? Could I ask of you and others
interested to provide feedback on the latest terminology draft. So far, I have
received two questions about some terms, but nothing more. We intend to
edit a new version for the London meeting. Perhaps we could also discuss the
issue there too, and see if we should continue the work on the latest
terminology draft or take it as the basis and start a totally new one, with or
without the MANET terminology. I would see that this kind of draft would be
"cross-WG" work (seamoby, mip, manet), so maybe it should be kept as an
individual document/submission and aim as an Informational RFC later.

	BR,

	Jukka

On Thu, 31 May 2001, James Kempf wrote:

> Charlie,
>
> I think this is an excellent idea. IETF needs to get a common set of terminology
> for wireless. Leaving it up to the individual working groups means
> that someone from a different working group must translate terminology
> from one to another. Imagine the chaos if half the IETF RFCs referred
> to routers as routers and the other half as something else.
>
> This may actually be an IAB kind of item, perhaps we could get their
> sponsorship. It seems like the kind of thing they would do. In any
> event, I will take a look at your draft and submit comments. Thanks
> for taking the initative on this.
>
> 		jak
>
> >MBOX-Line: From [email-masked] Sat May 19 18:05:29 2001
> >X-mProtect: Fri, 18 May 2001 10:50:08 -0700 Nokia Silicon Valley Messaging
> Protection
> >Date: Fri, 18 May 2001 10:50:08 -0700
> >From: "Charles E. Perkins" <[email-masked]>
> >To: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
> >CC: "'Jukka Manner'" <[email-masked]>, Hamid Syed
> <[email-masked]>, "'James Kempf'" <[email-masked]>,
> [email-masked], Mobile Ad Hoc IETF working group <[email-masked]>
> >Subject: Re: Wireless Terminology Draft( was: Re: [seamoby] Seamoby  Charter
>       Last Call)
> >
> >
> >Hello folks,
> >
> >I made an attempt a few years ago to develop such a terminology
> >draft, within the context of the [manet] working group.  Here
> >is a URL for the draft if you are interested:
> >	http://people.nokia.net/~charliep/txt/manet/term.txt
> >
> >If you would like to use some of the definitions in that draft,
> >and/or if you are looking for help in creating the new draft,
> >I'd be happy to work on it.
> >
> >The draft was rejected within the [manet] working group for
> >a reason that I thought was very curious.  Essentially, the
> >objection was made that every working group Internet Draft should
> >contain its own terminology definitions, and that no common
> >terminology draft was desirable.  I disagreed with that reason
> >then, and I still disagree with it, but I haven't felt a very
> >strong need to take up the matter within the [manet] group
> >since I didn't need yet another battle on my hands.
> >
> >I do think it would be a good idea to keep the terminology
> >draft separated out from a more wide-ranging wireless issues
> >draft, such as has generated a lot of recent interest on this
> >mailing list.
> >
> >Regards,
> >Charlie P.
> >
> >PS. to [manet] working group readers: I'd be happy to reintroduce
> >    the old draft, or a revision of it, for reconsideration.
> >
> >
> >
> >
> >Nakhjiri Madjid-MNAKHJI1 wrote:
> >>
> >> Jukka,
> >>
> >> Thanks for taking charge on this. Did you do a diff on your
> >> definitions and CT problem statement draft? Since you were
> >> intimately involved with CT PS draft, I assume you did that.
> >> I think we did a good job of defining CT related terminology,
> >> but I don't know how it differred from MM or Paging terminology,
> >> it would be nice to do a diff with those as well to have a WG
> >> wide common terminology draft.
> >>
> >> Thanks again,
> >> Madjid
> >>
> >> -----Original Message-----
> >> From: Jukka Manner [mailto:[email-masked]]
> >> Sent: Tuesday, May 15, 2001 1:25 AM
> >> To: Hamid Syed
> >> Cc: 'James Kempf'; [email-masked]
> >> Subject: RE: Wireless Terminology Draft( was: Re: [seamoby] Seamoby
> >> Charter Last Call)
> >>
> >>         Hamid,
> >>
> >>         Thank you for suggesting it. The draft was originally meant to
> >> support the work in Seamoby, but it would be an even better idea to make it
> >> a more thorough document for use in more or less all work relating to mobile
> >> and
> >> wireless environments, including Seamoby, Mobile-IP, and possibly MANET.
> >>
> >>         I would be happy to continue the work on the terminology taking as
> >> basis
> >> the mentioned draft.
> >>
> >>         BR,
> >>
> >>         Jukka
> >>
> >> On Mon, 14 May 2001, Hamid Syed wrote:
> >>
> >> > Hello james,
> >> >
> >> > A draft was submitted to seamoby early this year that attempted to capture
> >> > the wireless terminology. her eis the link:
> >> > http://search.ietf.org/internet-drafts/draft-manner-seamoby-terms-01.txt
> >> >
> >> > br
> >> >
> >> > -Hamid
> >> >
> >> > > -----Original Message-----
> >> > > From:       James Kempf [SMTP:[email-masked]]
> >> > > Sent:       Monday, May 14, 2001 1:47 PM
> >> > > To: [email-masked]
> >> > > Subject:    Wireless Terminology Draft( was: Re: [seamoby] Seamoby
> >> > > Charter Last  Call)
> >> > >
> >> > >
> >> > > ------------- Begin Forwarded Message -------------
> >> > >
> >> > > Date: Mon, 14 May 2001 10:43:47 -0700 (PDT)
> >> > > From: James Kempf <[email-masked]>
> >> > > Subject: Re: [seamoby] Seamoby Charter Last Call
> >> > > To: [email-masked], [email-masked]
> >> > > Content-MD5: 6F7Vl9kYVVbqr66TeEQyRw==
> >> > >
> >> > > Hi Charlie,
> >> > >
> >> > >
> >> > > >> Maybe we need a terminology draft, or at least, define this term
> >> > > >> somewhere so that it can be referred to. I'm suprised nobody
> >> > > >> has done a generalized terminology draft for wireless terms before in
> >> > > the MIP
> >> > > >> group.
> >> > > >
> >> > > >RFC 2002 does start off with a long list of terminology.
> >> > > >
> >> > > >It is questionable whether any specific wireless terms are
> >> > > >needed for a protocol running over IP.  What is needed is
> >> > > >a list of useful terms.  For instance, one might care about
> >> > > >error rate or bandwidth even if the medium were not wireless.
> >> > > >I don't think that chip rate, for instance, should be part
> >> > > >of the [seamoby] terminology list.
> >> > > >
> >> > >
> >> > > Actually, there are plenty of wireless terms that need definition.
> >> > > Access point, handoff (or handover IETF should select which one
> >> > > it wants to use), context transfer, paging, etc. etc.
> >> > >
> >> > > >Do you think that there are terms which SHOULD have been defined
> >> > > >for RFC 2002?  If so, now would be a good time to mention them
> >> > > >before RFC 2002bis goes to the RFC editor's desk.
> >> > > >
> >> > >
> >> > > No, I think they have wider applicability. More and more wireless
> >> > > stuff is going on. There are now two working groups associated
> >> > > with wireless, and others that have a big wireless component. I think
> >> > > having a
> >> > > terminology draft that collects all terminology that could be referred
> >> to
> >> > > by
> >> > > drafts would be a benefit.
> >> > >
> >> > >             jak
> >> > >
> >> > >
> >> > >
> >> > > ------------- End Forwarded Message -------------
> >> > >
> >> > >
> >> >
> >
>

---

From: James Kempf <[email-masked]>
Date: Wed, 6 Jun 2001 08:36:22 -0700 (PDT)

Jukka,

This sounds like a good plan, thank you for stepping up to do it. I intend to 
review the latest document in the URL Charlie sent out.

I agree that this is likely to be a cross working group document. I 
don't know of any specific IETF mechanism to address this procedurally,
but I think it will be important to get review by members of all
working groups, so we can get agreement on terminology going forward.
I think the document should definitely be "draft-ietf-..." if that
is possible, perhaps we can get guidance from the ADs on this. I
also think making it an informational RFC should be the goal. At this
point, I can't see this being a separate working group or even a BOF,
perhaps it could be assigned provisionally to one of the three
working groups with the least amount on its charter with the proviso
that the results pass through the other two.

		jak
		
>Date: Wed, 6 Jun 2001 13:14:02 +0300 (EEST)
>From: Jukka Manner <[email-masked]>
>To: James Kempf <[email-masked]>
>cc: <[email-masked]>, <[email-masked]>, 
<[email-masked]>, <[email-masked]>, <[email-masked]>
>Subject: Re: [seamoby] Re: Wireless Terminology Draft
>
>
>	Hi all,
>

---

From: [email-masked]
Date: Fri, 8 Jun 2001 17:49:15 +0300

I think that also pilc should be included on the same reason as ROHC.

- Kimmo Raatikaien

> From: ext Pat Calhoun [mailto:[email-masked]]
> Sent: 08. June 2001 17:30
> To: Charles E. Perkins
> Cc: Pat Calhoun; Seamless Mobility Working Group
> Subject: Re: [seamoby] Wireless Terminology Draft
> 
> 
> On Fri, Jun 08, 2001 at 07:36:47AM -0700, Charles E. Perkins wrote:
> > That sounds like a good plan.
> 
> Good.
> 
> > 
> > What working groups will be contacted besides [manet]?
> 
> I'd propose seamoby, manet, mobile-ip and (perhaps) ROHC (since their
> charter is very wireless centric).
> 
> Any other WGs you'd like to propose?
> 
> Thanks,
> 
> PatC
>

---

From: James Kempf <[email-masked]>
Date: Fri, 8 Jun 2001 09:21:35 -0700 (PDT)

What about pilc?

		jak
		
>Delivered-To: [email-masked]
>Date: Fri, 8 Jun 2001 07:30:23 -0700
>From: Pat Calhoun <[email-masked]>
>To: "Charles E. Perkins" <[email-masked]>
>Cc: Pat Calhoun <[email-masked]>, Seamless Mobility Working Group 
<[email-masked]>
>Mail-Followup-To: "Charles E. Perkins" <[email-masked]>, Pat Calhoun 
<[email-masked]>, Seamless Mobility Working Group <[email-masked]>
>Content-Disposition: inline
>User-Agent: Mutt/1.2.5i
>

---

From: [email-masked]
Date: Mon, 11 Jun 2001 07:25:22 +0300

Hi Pat,

> Having discussed this over with our AD, the best approach would be to
> run the document through WG last call in the Working Groups that work
> in this area. All last calls would work in parallel, and the editor
> would have to address all comments received.
> 
> The document would be informational, but recognized as having 
> consensus.
> 
> If this works with the WG, I can discuss this with other relevant WG
> chairs.

I think that this is a great idea.

John