Subject: RE: [seamoby] Issue 2: Make IP messages uniform

From: Kulwinder Atwal <[email-masked]>
Date: Mon, 25 Jun 2001 23:23:06 -0400

> -----Original Message-----
> From: Rajeev Koodli [mailto:[email-masked]]
> Sent: Monday, June 25, 2001 9:00 PM
> To: Kulwinder Atwal
> Cc: 'Pat Calhoun'; [email-masked]
> Subject: Re: [seamoby] Issue 2: Make IP messages uniform
> 
> 
> Kulwinder Atwal wrote:
> 
> >
> > Additionally, a MN message on a high bandwidth link could 
> be forwarded by
> > the currentAR to the oldAR to request CT, and at the _same_ 
> time a MN
> > message could be forwarded by the currentAR to the ParentAR 
> to affect a
> > route change.
> >
> > The route change message may travel to a different entity 
> along a different
> > link, than the Context Transfer request message.  Having 
> them happen in
> > parrallel could significantly reduce Reactive Context Transfer.
> >
> >
> 
> Exactly. As soon as the MN detects that it has undergone 
> handover, it sends a
> message which includes BU as an encapsulation. The new AR 
> sends the CT message
> towards the old AR and the BU towards the mobility agent.
> We proposed this (the message is SHIN) in our -smoothv6-.txt draft (in
> Pittsburgh IETF).

Post-Connection Context Transfer:

Yes, I think it would take less time for the newAR to process a message from
the MN that contained the necessary info.  The newAR will need to ask the MN
some indentity info anyway like:

- Who are you?
- Where is your Context located?  
- Where is your CoA located?

Why can't the MN send the info needed to start a route change request and a
CT request in the same packet as its identity?

The MN is already there at the newAR with all the needed info.

With Post-Connection CT the newAR knows nothing about the MN, so it cannot
use an L2 Trigger, becuase it does not know who the MN is, where its Context
may be, where its CoA maybe.

It may turn out that the Context, and CoA are just too far away to attempt a
CT (Maybe the MN was moving while experiencing a loss in connectivity).

- Kulwinder.

> Regards,
> -Rajeev

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 26 Jun 2001 15:53:00 -0700

Hello Kulwinder,

Kulwinder Atwal wrote:

...

> - Where is your CoA located?

Rajeev: Basically, you need previous Router address, previous IP address and
authentication data that the previous router can verify (to ensure that the
request came from the MN). This is the structure of the SHIN message, also
available from --ctv6--.txt draft. We hope to present a newer version for the
London IETF.

> CT request in the same packet as its identity?

Rajeev: I guess you mean it can use MIP message to request CT as well. This
should be possible.

> may be, where its CoA maybe.

Rajeev: You can again use SHIN.

Regards,

-Rajeev