Subject: RE: [seamoby] proactive and reactive CT definitions

From: "Gary Kenward" <[email-masked]>
Date: Wed, 20 Jun 2001 16:40:29 -0400

This is essentially the same definitions I proposed during
the discussion over proactive and reactive a few months back.
And, as someone pointed out, it was mistaken.

The first question that was asked then, and is still apropos: 
what benefit is derived from focussing on the specific arrival 
event as the delineator?

To explain further, let me illustrate with a scenario: suppose that
it takes 10ms to complete a context transfer; now suppose
that the ct trigger event happens  in less then 10ms from the 
actual first packet arrival, say 9 ms - is this a proactive or 
reactive ct? The ct that occurs fulfills neither of the offered 
definitions.

The only definitive goal is for proactive CT: by definition,
the context must be in place before the AR has to forward 
the first packet (I really could not care less about when that first 
packet arrives at the AR, for I do not really need context to process 
an arrival, only to forward the packet). 

Proactive CT is a highly desirable goal to ensure that handover
happens seamlessly - surely, from a ct p.o.v, there can be no less impact
on handover then to have the context in place before it is needed for
the first packet.

If the context is not in place for the first packet forwarding, then
the transfer is reactive; meaning that at this point, the goal is to
complete the transfer as fast as possible to minimize the delay in
forwarding that first packet.

Reactive CT is when I either choose not to perform proactive CT, or
I fail to meet the goal of being proactive. 

To me, this is very crisp.

Gary

> -----Original Message-----
> From: Rajeev Koodli [mailto:[email-masked]]
> Sent: Wednesday, June 20, 2001 2:49 PM
> To: [email-masked]
> Subject: [seamoby] proactive and reactive CT definitions
> 
> 
> 
> Description of issue :Clear, unambiguous definitions are missing.
> 
> Submitter name: Rajeev Koodli
> 
> Submitter email address: [email-masked]
> 
> Date first submitted: June 20, 2001
> 
> Comment type: 'T'echnical
> 
> Priority:  ''S'/MUST fix
> 
> Section:  4.5
> 
> Rationale/Explanation of issue:
> 
> The section provides the description of proactive and reactive
> CT without properly defining what they are. We need the definitions.
> 
> Requested Change:
> 
> Reactive CT: The context transfer process which takes place subsequent
> to arrival of a MN's packet at the target AR
> 
> Proactive (I prfer Charlie's Predictive better) CT: The 
> context transfer
> process in which the required contexts are in place at the target AR
> prior to the arrival of MN's packet at target AR.
> 
> 
> 
>

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 20 Jun 2001 14:40:25 -0700

> what benefit is derived from focussing on the specific arrival

Rajeev: The benefit is a clear starting point for the CT process. (i.e.,
when to initiate CT)

> reactive ct? The ct that occurs fulfills neither of the offered

Rajeev: The offered definition does not say anything about how long
context transfer takes place. The _start_ of CT request is the issue. A
packet arrives at the new AR (e.g., a MN request for CT), there is no
context there, then you fetch it.

> forwarding that first packet.

Rajeev: Exactly. This is what I am proposing to be added.

> I fail to meet the goal of being proactive.

Rajeev: Agreed.  Can we add the text then ? What do others think ?

Regards,

-Rajeev