Subject: RE: FW: [seamoby] CT trigger or CT completion? was: proactive an d re active CT definitions

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Mon, 25 Jun 2001 16:08:15 -0500

Hello Charlie,

Sorry, If I am answering to your emails in the wrong order.
I was going through the email to not to miss any conclusions.
See some comments below.

 If you don't mind, I added some numbers to your scenario (see 
your own email at the bottom).
your scenario  is much closer to reality now. However, there
are a couple of things I am fuzzy about.

1-I thought your point in reactive was that the CT is done
after link establishment. Now you say you call the scenario
reactive because newAR is reacting to MN's move.
What if in step 4 oldAR sends a CT start notification (if there was a msg
like that) to newAR, saying now I am starting CT?
Then newAR does not have to "react" (initiate CT). I still
think it is not so important who starts CT messaging. 
Also your assumption is that newAR is asking for CT and 
until the reply for this request comes back, MN establishes
a link with newAR. If oldAR starts CT, then you might not
have that much time for link establishment.

2- What if CT starts before step 5 is completed, then it would
not be CT according to your definition. The point I am making
is that you should not have to wait for link establishment to 
complete, if you include that in the definition of proactive,
then, that is fine.

Bottomline, if you like to redefine the scenarios we should
not miss any cases.

Regards,
Madjid

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]]
Sent: Monday, June 25, 2001 11:27 AM
To: Kulwinder Atwal
Cc: [email-masked]'; Pat Calhoun
Subject: Re: FW: [seamoby] CT trigger or CT completion? was: proactive
and re active CT definitions

<snip>

HI agree with this, basically.  Please let me know how you think
it applies in the following scenario:

-1 Previous access router and new access router agree that the mobile
  node should move to the new access router.
-2 Mobile node is told to move (after this, connectivity between mobile
  node and previous access router may fail)
-3 Access network controller tells new access router to allocate
  spectrum for mobile node
-4 New access router asks previous access router for context
-5 At the same time, mobile node detects beacon from new access
  router and carries out operations for link establishment
-6 Before finalizing the process of link establishment and the
  installation of the transferred context features, the new
  access router verifies the credentials of the mobile node.

How do you think this scenario applies to your classification?

My answer, is that this is reactive.  The new access router is
reacting to the information that the mobile node has arrived.

<snip>

---

From: Kulwinder Atwal <[email-masked]>
Date: Mon, 25 Jun 2001 21:04:07 -0400

> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Monday, June 25, 2001 12:27 PM
> To: Kulwinder Atwal
> Hello Kulwinder,
> It seems to me that we are getting closer to some definitions
> that can work.
> 
> Kulwinder Atwal wrote:
> 
> > The viewpoint is the newAR.  Either the newAR is notified for a need
> > to CT from oldAR, or MN.
> > The difference is on what interface the newAR is notified.
> 
> I agree with this, basically.  Please let me know how you think
> - Previous access router and new access router agree that the mobile
> - Mobile node is told to move (after this, connectivity between mobile
> - Access network controller tells new access router to allocate
>   spectrum for mobile node
> - New access router asks previous access router for context

For it to work well there needs to be an extra procedure.

-The new access router passes to the previous access router the new spectrum
allocation info over a wireless control channel.  

-The prevous access router passes sprectrum allocation info to the MN so
that the MN can tune the radio to the correct channel without having to go
through a lengthy connection setup phase.

> - At the same time, mobile node detects beacon from new access

> - Before finalizing the process of link establishment and the

To me this is proactive, because the MN does not need to go through a
lengthy connection setup phase.

> I hope we can make definitions to enable the protocol solution
> I have outlined, since it my favorite scenario and I believe it
> is compatible with 3G designs.
> 
> > It is up to the implementor to take into account particular 
> network and
> > inter-network characteristics and real-time flow 
> requirements to determine
> > how early Pre-Connection Context Transfer needs to be done 
> to guarrantee
> > seamless.
> 
> By previous discussion, we are unlikely to be able to make any
> such guarantees.  We can, however, make a darned good stab at it.

True.

- Kulwinder.

> Charlie P.

---

From: Kulwinder Atwal <[email-masked]>
Date: Thu, 28 Jun 2001 20:43:05 -0400

How is this:
 
 Pre-Discovery Context Transfer: The Context Transfer is 
 initiated prior to the newAR discovering the MN.
 
 Post-Discovery Transfer:  The Context Transfer is 
 initiated after the newAR discovers the MN.
 
Note that I am not saying anything about how, or at what layer the newAR
discovers the MN.

 -Kulwinder.