Subject: RE: [seamoby] L2 API (WAS: Ext. for FMIPv6 - comments) (SHOULD be , RE: Issue #4)

From: "Gary Kenward" <[email-masked]>
Date: Thu, 12 Jul 2001 15:02:08 -0400

-----Original Message-----
From: Phillip Neumiller [mailto:[email-masked]]
Sent: Thursday, July 12, 2001 2:42 PM
To: Kenward, Gary [WDLN2:AN10:EXCH]; Phillip Neumiller;
[email-masked]
Cc: [email-masked]
Subject: RE: [seamoby] L2 API (WAS: Ext. for FMIPv6 - comments) (SHOULD be ,
RE: Issue #4)

1).  Not using "seamless" in a draft is rule begging to be broken since it
is
      absolutely rediculous.  What is this Monty Python's flying IETF?
 
Well, if it was Monty Python's flying IETF, it would at least
be much more entertaining ;^}.
 
I should be more specific: the use of "seamless" was ruled
out of the problem statement by the ADs. The concern was,
I believe, that it was an overused, abused and collectively
misunderstood term (*shrug*, that would seem to me to 
describe the English language)/
 
2).  OK I finally understand what you are saying, and it makes sense and
      a statement based on what your wrote below REALLY NEEDS TO BE
      IN THE DRAFT.
 
i.e. Handovers that use CT MAY fall back to best effort handvovers in the
cases where CT fails.  My argument is that to make this whole thing clean
and more reliable we should add a requirement like 
 
Do you think? I mean, do we really need to be explicit about
every possible outcome? And how can we do this without
a design, even a use case analysis?
 
Right now, we are stumbling from one issue to another as
people identify issues that haven't been captured. When
will it end (he says rhetorically)?
 
I'm not saying the issues are unimportant; I am just concerned
that the requirements will never be done, or more importantly,
that the design will never start. 
 
To increase the reliability of handovers using CT, the designer MAY bundle
the CT packet with handover signalling such as that used in MIPv4 and MIPv6.

I don't see the need, but offer your suggestion to the list as an
issue.
 
Gary 

 I said that ct is not essential to an ordinary handover ("seamy
handover"?). 
And thus, a failure to complete ct on time must not cause an 
"ordinary handover" ("best effort handover"?) to fail. 

   Some designers want to be able to fall back to a "best effort" 
handover if the seamless handover fails, and yes, the seams will show.

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 13 Jul 2001 12:48:12 -0700

> that the design will never start. 

I share your concerns, but I'd argue that it would be difficult to
design a protocol around requirements that are moving targets. The
whole point behind the IETF meeting is to make sure that we get past
this point.

I am collecting a list of what I perceive are issues. I believe that
we have a couple:
1. Should CT be tied to a mobility management protocol
2. To what point does the requirements spec need to define
   the modes of operation (e.g. proactive, reactive).

Any others that I may have missed?

PatC