Subject: RE: [seamoby] Some proposed changes to the requirements draft.

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Tue, 13 Nov 2001 18:22:53 -0600

can we not use the word "encapsulating" context information, it
could be inpreted as tunneling, or maybe I am paranoid :)

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Monday, November 12, 2001 7:17 PM
To: Gary Kenward; Shahrier, Sharif M.; seamoby
Cc: Shahrier, Sharif M.
Subject: Re: [seamoby] Some proposed changes to the requirements draft.

Gary,

> The wording may need to be fixed, but the requirement is not as you
> are both interpreting it. The "standard representation"
> referred to is the representation of the data chunks, or objects,
> in the context transfer protocol that are used to contain the context.
> The actual context is encapsulated within these data chunks, and the
> representation of that context is opaque to context transfer. What is
> needed is a standard representation for these containers.
>
> The words do say "a standard representation for *conveying*"; the
> key words are "for conveying". They do not say "a standard
representation
> for the context" which is how you are both interpreting the
requirement.
>
> Again, we can clarify the wording, but the requirement still makes
sense.
> As for James proposal, this would be a new requirement.
>

I misunderstood the requirement. I think you need to reword it to avoid
the possibility of misunderstanding. How about:

    The context transfer protocol MUST define a standardized container
    format for encapsulating and conveying context information.
Interpretation
    of the context information within the container is the domain of the
application
    for which context is being transfered. Applications SHOULD define an
interoperable
    format for context information if they want to use the context
transfer protocol.

Or, you can simply include the first sentence if you feel that the rest
is too controversial
or would expand the requirement beyond what is currently agreed.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Wed, 14 Nov 2001 09:11:45 -0800

Well, how about "enclosing" then? I just think we need to clarify the
requirement text some, as I think it is unclear
as currently written.

        jak

----- Original Message -----
From: "Nakhjiri Madjid-MNAKHJI1" <[email-masked]>
To: "'James Kempf'" <[email-masked]>; "Gary Kenward"
<[email-masked]>; "Shahrier, Sharif M."
<[email-masked]>; "seamoby" <[email-masked]>
Cc: "Shahrier, Sharif M." <[email-masked]>
Sent: Tuesday, November 13, 2001 4:22 PM
Subject: RE: [seamoby] Some proposed changes to the requirements draft.