Subject: RE: [seamoby] Update to the requirements draft

From: "Shahrier, Sharif M." <[email-masked]>
Date: Mon, 19 Nov 2001 16:50:18 -0500

I would actually prefer "MUST" as opposed to "SHOULD" wrt scalability.
-Sharif.
 
As I said before, if there's an agreement to require that CT be 
scaleable, fine, then let's add the requirement that "CT MUST be 
scaleable" and leave it at that. We could spend a long time trying 
to find a suitable definition of scaleability, and I personally 
don't think it will stand the test of time. Mostly because we have 
no idea what suitable means. 
Gary 
> -----Original Message----- 
> From: Shahrier, Sharif M. [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: November 19, 2001 16:27 
> To: 'James Kempf'; Shahrier, Sharif M.; 'Nakhjiri Madjid-MNAKHJI1'; 
> Kenward, Gary [WDLN2:AN10:EXCH] 
> Cc: [email-masked] 
> Subject: RE: [seamoby] Update to the requirements draft 
> 
> 
> 
> I would support this. In addition, I would like to add: 
> 
> I think we should put it in subject to the comments. I don't think it 
> should say anything about numbers. 
> How about: 
> 
>         The CT protocol SHOULD be scalable at an acceptable 
> cost. The CT 
> protocol SHOULD scale at most linearly 
>         with the number of participating network nodes. 
> The CT protocol SHOULD scale at most linearly with the number 
> of contexts 
> and context features being transferred. 
> 
> -Sharif. 
> 
> 
>

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Mon, 19 Nov 2001 16:35:01 -0600

I agree with Rajeev. I still don't see a reason for a requirement
for which no compliance test exist, we have been through this extensively
long time ago and agreed it was not necessary.
If I write a proposal for CT, how can I prove it is scalable. It is like
asking a car company to make "nice" cars...

-----Original Message-----
From: Rajeev Koodli [mailto:[email-masked]]
Sent: Monday, November 19, 2001 4:29 PM
To: James Kempf
Cc: Shahrier, Sharif M.; 'Nakhjiri Madjid-MNAKHJI1';
[email-masked]; [email-masked]
Subject: Re: [seamoby] Update to the requirements draft

James,

while I strongly support the desire to move ahead, it is not a good idea
to incorporate a requirement without a clear sense of what it means.. As
Gary pointed out, having a criterion to evaluate scalability is tricky.
I can resonably understand what is "acceptable cost"; however, it is not
something we can use to evaluate alternatives.

Regards,

-Rajeev

James Kempf wrote:

> Fine with me.
>
> Any other objections? If not, can we call it done and have Gary update
> for submission before Wed.?
>
>         jak
>
> ----- Original Message -----
> From: "Shahrier, Sharif M." <[email-masked]>
> To: "'James Kempf'" <[email-masked]>; "Shahrier, Sharif M."
> <[email-masked]>; "'Nakhjiri Madjid-MNAKHJI1'"
> <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, November 19, 2001 1:27 PM
> >         The CT protocol SHOULD be scalable at an acceptable cost. The
> CT
> > The CT protocol SHOULD scale at most linearly with the number of
> contexts