Subject: RE: [seamoby] Some proposed changes to the requirements draft.

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Tue, 13 Nov 2001 14:50:33 -0600

I don't understand what authentication between MN and its context supposed
to mean?
context is just a piece of data that exists in a protocol unit and is being
transferred
(please look at the problem statement).
 
How can MN authenticate with a piece of data??????????????
 
And why does the authentication has to happen after context transfer, could
you define
context transfer here?
 
Maybe you mean that the MN should authenticate the received context data,
but
then why does the MN should do this. The context is going to the new AR,
anyway.
If authentication of data is needed, new AR does it on behalf of MN.
 
Why are we dragging MN into the authentication process.
 
these issues are attacking the basic framework of CT, IMHO
 
Madjid
-----Original Message-----
From: Shahrier, Sharif M. [mailto:[email-masked]]
Sent: Tuesday, November 13, 2001 10:44 AM
To: 'Gary Kenward'; Shahrier, Sharif M.
Cc: [email-masked]
Subject: RE: [seamoby] Some proposed changes to the requirements draft.

Gary,
 
                Understood. However, the requirements contains nothing (?)
about the mobile authenticating with its context, after the context 
Has been transferred. 
 
I think a requirement should be there for this, otherwise, without
authentication, the MN can "get at" any context, or context feature that its
not authorized access to.
 
How about:
 
                There MUST be mutual authentication between the MN and its
context, after the context transfer has occurred.
 
-Sharif.
 
-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Tuesday, November 13, 2001 11:07 AM
To: 'Shahrier, Sharif M.'
Cc: [email-masked]'
Subject: RE: [seamoby] Some proposed changes to the requirements draft.
 
Sharif:
 
  This requirement is for the ARs to authenticate each other so that a ct
exchange can
be trusted. It has nothing to do with the MN and handoff per se.
 
Gary
-----Original Message-----
From: Shahrier, Sharif M. [mailto:[email-masked]]
Sent: November 13, 2001 09:51
To: Shahrier, Sharif M.
Cc: [email-masked]'
Subject: RE: [seamoby] Some proposed changes to the requirements draft.

I have some issues with the following requirement in the CT draft.
 
4.9 The entities transferring context MUST have completed a mutual
authentication process prior to
      initiating the transfer.
 
I don't support this requirement.
 
It appears to me this may not fit the case for "break-before-make" handover
.  For instance, the mobile may break connection with the old
AP, and re-establish connection with the new AP. 
 
Assuming that the context is transferred prior to re-establishing the new
connection.
 
The mobile will need to re-authenticate after it makes a new connection at
its new AP.
 
I have seen several practical cases that supports this scanario, thus I feel
it is necessary for authentication after the transfer of context 
in "break-before-make".
 
-Sharif.

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 13 Nov 2001 14:02:19 -0800

ok, just to put a cap on this one. We are talking about two edge devices exchanging
state in a secure (read: authenticated) manner. We have consensus on this 
requirement, and I don't see the need to re-open this one.

Now let's move on.

PatC