Subject: RE: [seamoby] Some proposed changes to the requirements draft.

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Tue, 13 Nov 2001 18:26:58 -0600

John, others:

The centralized approach to context transfer was dismissed
very early on. Is this still an issues?

Something like 5.6.1 is included, don't remember if it says
"any" IETF protocols or not.

For 5.6.2 I am not quite sure if some non-IETF protocols even
have the same definition for context as we do (PDP context is one
example), any idea??

Madjid

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, November 13, 2001 1:22 AM
To: [email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: RE: [seamoby] Some proposed changes to the requirements draft.

Hi James,

> Comments included, marked with jak>.
> 
> Section 5.1.2 "The context transfer protocol MUST define a stanard
> representation for coveying context information that will be 
> interpreted
> uniformly and perspicuously by different implementations"
> 
> I would like this to be deleted, because it has nothing to do with the
> actual "transfer" of the context.
> 
> jak> Agreed. This requirement is in the domain of the individual
> applications that use the protocol. Perhaps
> it should say:
> 
>     Any application area that utilizes the context transfer protocol
>     MUST define a standard representation for conveying context 
>     information.

I agree, but SHOULD might be more applicable than MUST, as I 
see this as more of a recommendation as opposed to an 
absolute requirement.

Then a general comment on Sharif's proposals:

> 4.18 "The context transfer protocol MUST support both centralized and
> distributed location of context information."
> 
> 5.6.1 "The context transfer protocol MUST include methods for
> interworking with any IETF IP handover solutions".
> 
> 5.6.2 "The context transfer solution MAY include methods for
> interworking with non-IETF handover solutions".
> contexts or sub-divisions thereof".

Unless we have a reason why these are requirements,
I don't think we can support adding these into the document.

br,
John

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 13 Nov 2001 20:08:22 -0800

You are correct that centralized state did not have rough consensus. The
archives do show this.

PatC