Subject: RE: [seamoby] Some proposed changes to the requirements draft.

From: "Gary Kenward" <[email-masked]>
Date: Mon, 12 Nov 2001 15:29:17 -0500

James, Sharif:

  Just to clarify:

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: November 12, 2001 13:04
> To: Shahrier, Sharif M.; seamoby
> Cc: Shahrier, Sharif M.
> Subject: Re: [seamoby] Some proposed changes to the 
> requirements draft.
> 
> 
> Sharif,
> 
> Comments included, marked with jak>.
> 
> Section 5.1.2 "The context transfer protocol MUST define a stanard
> representation for coveying context information that will be 
> interpreted
> uniformly and perspicuously by different implementations"
> 
> I would like this to be deleted, because it has nothing to do with the
> actual "transfer" of the context.
> 
> jak> Agreed. This requirement is in the domain of the individual
> applications that use the protocol. Perhaps
> it should say:
> 
>     Any application area that utilizes the context transfer protocol
> MUST define a standard representation
>     for conveying context information.

The wording may need to be fixed, but the requirement is not as you
are both interpreting it. The "standard representation"
referred to is the representation of the data chunks, or objects,
in the context transfer protocol that are used to contain the context.
The actual context is encapsulated within these data chunks, and the 
representation of that context is opaque to context transfer. What is
needed is a standard representation for these containers.

The words do say "a standard representation for *conveying*"; the
key words are "for conveying". They do not say "a standard representation
for the context" which is how you are both interpreting the requirement.

Again, we can clarify the wording, but the requirement still makes sense.
As for James proposal, this would be a new requirement.

Gary

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 12 Nov 2001 16:03:17 -0800

I agree with Gary.

PatC

---

From: "James Kempf" <[email-masked]>
Date: Mon, 12 Nov 2001 17:16:32 -0800

Gary,

> As for James proposal, this would be a new requirement.

I misunderstood the requirement. I think you need to reword it to avoid
the possibility of misunderstanding. How about:

    The context transfer protocol MUST define a standardized container
    format for encapsulating and conveying context information.
Interpretation
    of the context information within the container is the domain of the
application
    for which context is being transfered. Applications SHOULD define an
interoperable
    format for context information if they want to use the context
transfer protocol.

Or, you can simply include the first sentence if you feel that the rest
is too controversial
or would expand the requirement beyond what is currently agreed.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Mon, 12 Nov 2001 17:37:22 -0800

Re. Pat's email, how about just:

    The context transfer protocol MUST define a standardized container
    format for encapsulating and conveying context information.
   Interpretation of the context information within the container is the
domain of the
   feature  for which context is being transfered.

This should avoid the kind of misunderstanding that I apparently had.

        jak

----- Original Message -----
From: "James Kempf" <[email-masked]>
To: "Gary Kenward" <[email-masked]>; "Shahrier, Sharif M."
<[email-masked]>; "seamoby" <[email-masked]>
Cc: "Shahrier, Sharif M." <[email-masked]>
Sent: Monday, November 12, 2001 5:16 PM
Subject: Re: [seamoby] Some proposed changes to the requirements draft.