Subject: RE: [seamoby] Update to the requirements draft

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Mon, 19 Nov 2001 14:04:05 -0600

I don't like the scalability requirement either.
It is obvious.

Madjid

-----Original Message-----
From: Shahrier, Sharif M. [mailto:[email-masked]]
Sent: Monday, November 19, 2001 10:57 AM
To: 'James Kempf'; Shahrier, Sharif M.; [email-masked]
Cc: [email-masked]
Subject: RE: [seamoby] Update to the requirements draft

James,

	It appears that no one really opposed the requirement that "CT
solution MUST be scalable". It was suggested to shorten  the wording,
without elaborating on it.. I have some extracts of comments.

Unless there is a large disagreement at this time, perhaps it would not hurt
to include it.
I have noted that "scalability" is a major issue that props up, time and
again, in protocols in the IETF.

-Sharif.

============================================================================
=====================
> 4.16 "The context transfer protocol MUST be scalable. It MUST be 
> scalable to millions of hosts".

This is 'motherhood & apple pie' text (i.e. - noone would really
disagree). I don't know how this adds anything to the text.  
Additionally, I would suggest SHOULD rather than MUST is
what you mean.

Finally, scaleability is desireable, as long as the requirement is for
scaleability 
at an acceptable cost. 
 Other then this, I do not know how one would word a requirement around
scaleability 
other then the motherhood of "ct must be scaleable at an acceptable cost". 

Gary, Sharif, John, 
if the requirement is a given, then let's not argue about/against it. It
cannot 
hurt to include it, and _technically_ there is consensus for it. 
As far as how to phrase it, usually scalability is described as the marginal
increase 
in complexity induced by adding users. So something along the lines: 
the processing complexity at each AR (and the burden on the wired network) 
SHOULD increase linearly with the number of MNs or the number of CT
requests. 
Also, you can check conformance there. 

 -----Original Message-----
From: 	James Kempf [mailto:[email-masked]] 
Sent:	Monday, November 19, 2001 11:34 AM
To:	Shahrier, Sharif M.; [email-masked]
Cc:	[email-masked]
Subject:	Re: [seamoby] Update to the requirements draft

Sharif,

My tracking of the list converstion was that there is  agreement on
adding *one* requirement, 5.6.1 for the CT protocol to support handover,
and modifying the wording on another, 5.1.2, to clarify what is meant by
supporting a standardized representation format.

            jak

----- Original Message -----
From: "Shahrier, Sharif M." <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, November 19, 2001 6:03 AM
Subject: [seamoby] Update to the requirements draft

> Gary,
>
> From our discussions last week, I just want to clarify that, that
> people had agreed to include two of the requirements that I had
suggested,
> also, some wording was changed to one of the existing requirements.
Can you
> please confirm that these are going to be updated?
>
> -Sharif.
>
> "The context transfer solution MUST be scalable".
>
> "The context transfer solution MUST include methods for interworking
with
> any IETF IP handover solutions".
>
> Also, the wording in section 5.1.2 was changed, I believe.
>
>
>

---

From: Pat Calhoun <[email-masked]>
Date: Sun, 25 Nov 2001 08:07:10 -0800

...and requirements that cannot be quantified are of dubious value.
When, and if, we have to evaluate protocols against requirements, how do
we determine whether a protocol scales (as per this requirement)?

I'm really not sure it's needed, unless it is more specific, and I believe
that the IETF mandates protocols that scales to the millions of hosts
anyways.

PatC