Subject: RE: [Seamoby] Summary of Discussion on CAR Discovery Requirements

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 23 Jan 2002 18:22:25 +0100

Dirk,

  > The requirement states that ARs SHOULD or MUST be discovered 
  > irrespectively of the domain to which they belong. This is a 
  > generic requirement which reflects one very fundamental nature 
  > of seamless mobility, namely seamlessly roaming between ARs 
  > irrespectively of the domain to which they belong. 
  > Apparently you want the focus of seamlessness more on time
  > (reducing the connectivity disruption) rather than on networks 
  > (roaming seamlessly between networks). 

=> Did I say that ? I don't think so, I simply 
said that a MN listening to ARs directly
(possibly multi-homes) would relatively easily
discover GAARs outside its current domain. 
On the other hand, for ARs to discover GAARs
outside their domain, several security issues and 
'agreements' between operators are needed. So 
It does seem more difficult for the AR - AR protocol
to work across domains. 
To conclude: If AR discovers GAARs then inter-domain
is more difficult.
If MN discovers GAARs then inter-domain discovery is 
not so difficult.

  > 
  > Furthermore, I have a problem what exactly you mean with 'MN-AR'
  > and 'AR-AR' interfaces. But let me interpret how I understood these
  > terms. Do you mean by 'MN-AR interface' an MN-based 
  > discovery scheme, 
  > hence 'AR-AR interface' is an AR-based scheme for discovery? 

=> Yes. I realise that AR-AR can also be relayed
to the MN (in some cases). 

  > 
  > If so, do you propose that if the MN is doing (mainly) the job, 
  > it MUST discover ARs irrespectively of the domain, while in the 
  > (mainly) AR-based scheme it should only (if at all), i.e., 
  > it doesn't
  > have to? 

=> It doesn't need to be a MUST. 

Does this make sense? 

=> Why don't we let the WG decide that.

With that, you fix the solution space
  > in a sense that seems inappropriate to me. 

=> Huh ? can you elaborate. I'm not fixing 
anything, I said one is simpler than the other.

This will open doors
  > for fights to which 'category' the solution belongs. What about
  > schemes that divide the tasks between AR and MN? MUST or SHOULD
  > they fulfill the requirement? What about a scheme that uses MN
  > for discovery but AR for capability exchange? 

=> I'm only interested in technical reasons. 

Do you really 
  > propose (which is the natural extension of demanding two 
  > categories of requirements) that we first define categories
  > for our solution space and then assign requirements (and their
  > strengths) to them?
  > 
  > If we want to enable seamlessness in the sense I described
  > above, namely between networks, reflected by the inter-domain
  > requirement, the requirement is a MUST. Probably, we should
  > think about the possibility that a solution that does not fulfill 
  > this requirement is one that shouldn't be considered.

=> I really think you're reading way too much
into my emails.

  > 
  > BTW, I see your scalability point. But again, if a solution that
  > tries to fulfill the inter-domain requirement doesn't scale, it
  > is probably simply not a good solution? 

=> Well there may not be a 'good' solution for this.
People make design choices and tradeoffs, what do you 
mean by 'good' ?

  > In conclusion, as a first step, it is necessary that you define
  > your terms 'MN-AR interface' and 'AR-AR interface' so that we

=> If communication between AR and GAARs exists e2e
then there is some AR - AR protocol. 

MN - AR : AR sends information to MN about itself 
and (possibly) GAARs. 

I hope this is clearer.

Hesham

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Wed, 23 Jan 2002 10:10:10 -0800

Dirk/Hesham,

So it sounds like there is a case for interdomain discovery, but it
might be mitigated by certain difficulties. Business considerations
shouldn't really be an issue here, but scalability certainly should,
and I can see an argument about technical difficulty integrating
the CAR discovery with interdomain routing, in both the MN
and AR cases.

There was really not much technical discussion on this issue
at SLC. Since then, there has been more, and the
outlines of possible problems are beginning to emerge.
I think we really need to do a deeper study to determine
whether or not this is technically doable.

How about if we keep the requirement a SHOULD? I
believe that is how Govind originally listed it.

            jak

----- Original Message -----
From: "Hesham Soliman (ERA)" <[email-masked]>
To: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Wednesday, January 23, 2002 9:22 AM
Subject: RE: [Seamoby] Summary of Discussion on CAR Discovery
Requirements