Subject: RE: [Seamoby] CAR Discovery Requirements

From: "Trossen Dirk (NRC/Boston)" <[email-masked]>
Date: Tue, 15 Jan 2002 09:47:55 -0500

Hi Hesham,

I guess Govind's point was (as I also outlined in my mail regarding
separation of requirements) that we don't see how the requirements
will change for an MN-based or AR-based scheme.

This is true in particular for the requirements you mentioned. Isn't
it the fundamental task of CAR discovery to resolve L2Ids to L3Ids?
Why would this be different for an MN-based or AR-based scheme?
And why is there a difference in the inter-domain support? Either
we agree that GAARs are discovered even if they are in different
administrative domains or not. Whether the MN is doing (most of) the
job or the AR, doesn't really matter.

So as I said in my previous email, please outline exactly WHAT
requirements you have in mind that justify this separation. Right now,
we are only discussing about the procedure without having the
meat to fill.

Regards,

Dirk

> -----Original Message-----
> From: ext Hesham Soliman (ERA) [mailto:[email-masked]]
> Sent: Tuesday, January 15, 2002 8:58 AM
> To: Govind Krishnamurthi; [email-masked]
> Subject: RE: [Seamoby] CAR Discovery Requirements
> 
> 
> Govind, 
> 
>   > Where does the current set of requirements preclude any 
>   > sort of mobile node 
>   > involvement. I think
>   > whether an MN is involved or not is implementation specific.. and
>   > not a requirements issue. I don't think the requirements 
>   > for CAR discovery 
>   > change whether a MN is involved or not. 
> 
> => What is this in response to exactly ? I didn't claim
> the opposite of what you said, I said 'separate' the 
> requirements so we know what you refer to when you 
> say 'support inter-domain discovery' 'support mapping 
> from L2 to L3'. 
> 
> Also letting the MN 
>   > or AR decide 
>   > where actually to handover is out of scope of CAR discovery.
>   > Just letting the MN also hear does not complete CAR 
>   > discovery.. CARs 
>   > comprise of GAARS + their capabilities.. What you say is 
> just GAARs.
> 
> => Ok, please respond to the statements I made, just so
> I can understand which parts you are referring to. 
> 
> Hesham
> 
>   > 
>   > -Govind.
>   > > >...
>   > >   > >6. Protocol applicability ? SHOULD (?)
>   > >   > >(show of hands indicated that this item should be changed
>   > >   > to a MUST)
>   > >   > >support inter-domain as well as Intra-domain scope
>   > >   >
>   > >   > Inter-domain discovery of access routers (which seems
>   > >   > implied by what
>   > >   > might otherwise seem an innocuous protocol design feature)
>   > >   > is problematic.
>   > >   >
>   > >   > It would require resolving which users are subscribers of
>   > >   > which domains,
>   > >   > or complex inter-domain roaming and billing reciprocity.
>   > >
>   > >=> This is exactly why I urge you (this wg) to clearly
>   > >explain which protocol you are talking about. AR - AR or
>   > >AR MN ???
>   > >Clearly AR - MN lis an obvious way to discover all routers
>   > >that the MN can hear. Inter/intra domain issues are
>   > >not relevant.
>   > >
>   > >So please make it clear which part of the protocol
>   > >you're referring to. We should not always assume
>   > >that we're discussing the AR - AR case.
>   > >
>   > >   > While it seems reasonable to avoid locking mobile stations
>   > >   > into a single
>   > >   > domain, the policy interactions of requiring
>   > >   > multiple-domain discovery
>   > >   > would make the task much more difficult at the start.
>   > >
>   > >=> Certainly. But there is an easy way of doing that:
>   > >Let the MN decide.
>   > >
>   > >Hesham
>   > >
>   > >   > _______________________________________________
>   > >   > Seamoby mailing list
>   > >   > [email-masked]
>   > >   > https://www1.ietf.org/mailman/listinfo/seamoby
>   > >   >
>   > >
>   > >_______________________________________________
>   > >Seamoby mailing list
>   > >[email-masked]
>   > >https://www1.ietf.org/mailman/listinfo/seamoby
>   > 
>   > 
>   > 
>   > 
>   > _________________________________________________________________
>   > Send and receive Hotmail on your mobile device: 
> http://mobile.msn.com
> 
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
> 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Tue, 15 Jan 2002 09:56:19 -0800

Dirk,

I understand, but I believe that Hesham, and perhaps some others, do
think that
there will be different requirements based on whether the MN or
the ARs are doing the discovery.

I agree that we need to have a clearer understanding of what the
differences in requirements are. Perhaps those who think
that there should be a difference can post specific requirements
that they believe do differ (and please post under the above
subject, so I can keep track of the thread). If we don't get a well
articulated list of such requirements by the end of the requirements
development
period, then I think we can be justified in not separating them.

            jak

----- Original Message -----
From: "Trossen Dirk (NRC/Boston)" <[email-masked]>
To: "'ext Hesham Soliman (ERA)'" <[email-masked]>;
"Govind Krishnamurthi" <[email-masked]>; <[email-masked]>
Sent: Tuesday, January 15, 2002 6:47 AM
Subject: RE: [Seamoby] CAR Discovery Requirements