Subject: RE: [Seamoby] CAR DiscoveryProtocol Requirements...

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 11 Jan 2002 17:41:32 +0100

Govind and all, 

Some comments below.

Generally I think it would be useful to identify
which protocol these requirements apply to. 
I.e. the protocol between the ARs or the one between
the MN and the AR?

  > >
  > >1. MUST translate L2 Ids (APs and ARs) to L3 Ids of ARs
  > >
  > >
  > >2. MUST support L2 devices of different technologies

=> What does this really mean ?

  > >
  > >6. Protocol applicability - SHOULD (show of hands 
  > indicated that a MUST
  > >is needed here) support inter-domain as well as Intra-domain scope
  > >

=> Definitely a MUST IMO. Also we should be clear on the 
meaning of 'domain'.

  > >8. SHOULD minimize involvement of ARs which are not GAARs in CAR
  > >discovery

=> Going to Phil's comment, how do we measure a SHOULD ?
What tradeoffs will be acceptable to exempt a solution
from following this requirement? 
I think it would be esaier to make it a MUST.

I'd like to also suggest that if the WG still wants to
keep section 4.1 of the problem statement draft, we 
should at least change the wording in the first
paragraph to reflect that the AR will _never_ 
guarantee to know _all_ neighbouring ARs. 
I think this is obvious. 

Also 'anticipation' is misleading, because it is seems
to imply that the MN does not signal. The MN can
certainly anticipate and that is explained in the 
low latency and FMIPv6 drafts referenced in the doc.

Regs,
Hesham 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Fri, 11 Jan 2002 09:22:43 -0800

Hesham,

The problem statement discusses a need for both, so we need requirements
for both.

I agree that it would be useful to distinguish if the requrirements
apply
to one or the other or both.

            jak