Subject: RE: [Seamoby] Examples of CAR discovery

From: [email-masked]
Date: Wed, 3 Apr 2002 12:24:48 -0500

Hi James,

see comment inline...

-----Original Message-----
From: ext James Kempf [mailto:[email-masked]]
Sent: Tuesday, April 02, 2002 6:40 PM
To: Perkins Charles (IPRG)
Cc: [email-masked]
Subject: Re: [Seamoby] Examples of CAR discovery

> I'm O.K. with your suggestion, except that if we don't have any
> data, we can't show interoperability.  We ought to pick out some
> reasonable contexts just to show that the seamoby protocol
> really works.  I've never heard of any working group standardizing
> a framework that didn't include some guts too.
>

I can think of cases where containers get standardized but their
contents don't. SLP is a good example. It defines the protocol and a way
to define services but does not define the services themselves. LDAP is
another.

[DOT] It is not only about the 'containers' to get standardized. Designing
a carrier protocol without considering the information to be carried might quickly serve as a 
bad example of engineering. In other words, making a decision about sending 
information from and to different entities without considering WHAT (semantics) 
and HOW MUCH (semantics plus syntax) is shuffled around might lead very soon 
after the actual standardization of CAR discovery to the proof of its uselessness 
rather than its usefulness, if the way the protocol is designed restricts the amount
of information that could be carried.

[DOT] In particular due to the involvement of mobile devices, this amount of information
is a crucial factor in designing the protocol. Hence, a proper consideration
of this information (what is this information and how is this information represented)
should be a must for us to study before we make decisions on the design of the 
final solution.

Regards,

Dirk

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Wed, 3 Apr 2002 11:23:45 -0800

Dirk,

> should be a must for us to study before we make decisions on the
design of the

I didn't say we shouldn't consider the contents, I just said that the
charter currently doesn't cover standardizing them. Of course, we do
need to consider the contents when doing the design. We did that with
SLP and I'm sure they did it with LDAP.

We do, however, need to say something in the RFCs on CT and CAR about
how we propose to standardize the contents if Seamoby won't do it. Or,
if Semaboy will, then we need to talk to Allison about rechartering. But
we are a long ways away from that right now, IMHO.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Wed, 3 Apr 2002 11:23:45 -0800

Dirk,

            jak