Subject: RE: [Seamoby] RE: [NSIS] Establishing QoS after handoff.

From: "Gary Kenward"<[email-masked]>
Date: Mon, 8 Apr 2002 14:02:15 -0400

Charlie:

  Agreed. But, as was discuss at length over the last year, 
the actual failure points and their frequency are very limited, 
and there are reasonable and not-so-reasonable mitigating responses.

  If someone really wants to provide CT over an all wireless
ad hoc network, for example, then, yes, additional reliability 
will probably be required. In most wired infrastructure scenarios, 
the link reliability is more then sufficient. 

To allow for this flexibility in reliability, this type of 
reliability needs to be provided in the transport layer, not 
with CT. Specific reasons for building additional reliability
into the CT protocol that are generally applicable to a majority
of scenarios, and cannot be resolved by substituting a more
robust transport protocol, have yet to be offered.

Gary

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: April 5, 2002 18:08
> To: Nakhjiri Madjid-MNAKHJI1
> Cc: 'James Kempf'; [email-masked]
> Subject: Re: [Seamoby] RE: [NSIS] Establishing QoS after handoff.
> 
> 
> 
> (I trimmed the mailing lists and some of the trailing messages)
> 
> 
> Hello Madjid,
> 
> The problem is that the reliability needs depend on the context
> feature type.   Some contexts should be transferred reliably, and
> some are not so crucial.  Reliable transfer for header compression
> context is not as crucial as, say, security context -- for
> various reasons, but at least because retransmission for the
> header compression state would take too long.
> 
> Regards,
> Charlie P.
> 
> 
> Nakhjiri Madjid-MNAKHJI1 wrote:
> > 
> > Well, you are opening a can of worm that took seamoby 3 months
> > to close without any results. People could not agree on the
> > reliability needs of CT. We added a reliability mechanism to our
> > CT proposal that covered both retransmission and updates.
> > 
> > Madjid
> > 
> > -----Original Message-----
> > From: James Kempf [mailto:[email-masked]]
> > Sent: Friday, April 05, 2002 12:22 PM
> > To: Rajeev Koodli
> > Cc: Gary Kenward; [email-masked]; [email-masked];
> > [email-masked]
> > Subject: Re: [Seamoby] RE: [NSIS] Establishing QoS after handoff.
> > 
> > Agree.
> > 
> > But I don't see anything in the CT requirements about handling CT
> > failure.
> > 
> > ???
> > 
> >             jak
> > 
> > ----- Original Message -----
> > From: "Rajeev Koodli" <[email-masked]>
> > To: "James Kempf" <[email-masked]>
> > Cc: "Gary Kenward" <[email-masked]>;
> > <[email-masked]>; <[email-masked]>; <[email-masked]>
> > Sent: Friday, April 05, 2002 10:02 AM
> > Subject: Re: [Seamoby] RE: [NSIS] Establishing QoS after handoff.
> > 
> > > James Kempf wrote:
> > >
> > > > Rajeev,
> > > >
> > > > I agree, but there is still an issue of how the AR 
> would notify the
> > MN
> > > > if CT fails. Is this covered by CT or not?
> > > >
> > >
> > > This notification should be covered by CT.  We should offer
> > > seamless handover to NSIS :-) Seriously, this concerns
> > > robustness of CT protocol.
> > >
> > > -Rajeev
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
>

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 8 Apr 2002 20:49:11 -0400

RE: [Seamoby] RE: [NSIS] Establishing QoS after handoff.
----- Original Message ----- 
From: Gary Kenward 

>the link reliability is more then sufficient. 

pdn> There is not that much difference between an ad hoc network and
a wireless network that doesn't support soft handover.  I would argue that
a wireless infrastructure network with hard handover is less reliable than
an ad hoc nework with hard handover.

>robust transport protocol, have yet to be offered. 

pdn>That's funny.  Why don't you like more robust handoffs to begin with???

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 8 Apr 2002 20:49:11 -0400

----- Original Message ----- 
From: Gary Kenward