Subject: [Seamoby] NSIS was:Examples of CAR discovery

From: [email-masked]
Date: Tue, 2 Apr 2002 11:12:48 +0300

Hi James,

> > If one access router has 5 Mb/s available, and another only has
> > 10 Kb/s available, I would like to get my streaming video from
> > the first access router.  I might be able to have the choice.
> >
> 
> Wouldn't it be better to let the IP QoS signaling protocol 
> handle this?
> I believe this is exactly what NSIS is working on,
> but John Loughny could say more.

NSIS will not be involved in the handoff, nor resource allocation.
There may be some longer term work which would handle signaling between
network elements that would look more like capability signaling,
but that is outside of the current scope of NSIS.

I think that NSIS and SeaMoby / Context Transfer may interwork to provide 
a good solution, in my opinion.

NSIS most likely will be using a 'on path' signaling model, where the 
QoS signaling takes the same path as the data.

> I was speaking of last hop link capacity. I agree that IP is the right
> place to handle next to last hop QoS (i.e. DiffServ). I believe the NSIS
> charter also speaks about last hop QoS signaling as well. There is some
> interest in NSIS to tie Layer 2 QoS and  IP QoS together on the last
> hop, but there has not yet been much work done on it.

Actually, this is current out of scope of NSIS.

What NSIS will be working on is a generalized framework, to enable 
end to edge signaling, end to end signaling and perhaps edge to edge
signaling.

For the end-to-edge signaling, the access network (maybe even the access
router) would/could be proxying QoS for network towards the end node.

John

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Tue, 2 Apr 2002 08:42:53 -0800

> router) would/could be proxying QoS for network towards the end node.

So it sounds to me the only issue is that NSIS would look at prehandoff
or posthandoff
end to edge (host to network?) signaling rather than at the time of
handoff, is that
right?

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 2 Apr 2002 08:42:53 -0800

jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 2 Apr 2002 09:02:51 -0800

John,

My concern here is that the right people may not be involved in Seamoby
to adequately address this issue.
People with QoS expertiese would not necessarily come to Seamoby.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 2 Apr 2002 09:02:51 -0800

John,

            jak

---

From: Marcus Brunner <[email-masked]>
Date: Wed, 03 Apr 2002 15:37:59 +0200

--On Tuesday, April 02, 2002 11:12 AM +0300 [email-masked] wrote:

[...]

> a good solution, in my opinion.

I agree that CT might help for a good solution. However, for the QoS part, 
it is not only about a CT from one acess to anouther, but also about the 
rest of the path providing guarantees involved, where (as far as I 
understood the CT work) context transfer itself does not help too much.

> QoS signaling takes the same path as the data.

I don't think we have this aggreement in the NSIS group.

Marcus

--------------------------------------
Marcus Brunner
Network Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.brubers.org/marcus

---

From: Marcus Brunner <[email-masked]>
Date: Wed, 03 Apr 2002 15:37:59 +0200

[...]

Marcus

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 03 Apr 2002 09:47:09 -0800

Hello Marcus,

> understood the CT work) context transfer itself does not help too much.

My first model of the access networks is that they are not
congested, and can move packets back and forth between access
routers without problems.  This isn't always true, of course,
but it is good enough to get us started.  Under this model,
then we can get good mileage out of using QoS as just another
context to be transferred, as long as the new access router
has enough spare capacity over the air to satisfy the QoS
needs of the mobile node.

If the access networks themselves are constrained, then the
CAR discovery operation would have to be augmented by operations
to insure availability of capacity between the old and new
access routers, but I don't see that we have to design for that
case right now.  Moreover, I think that whatever design we come
up with, will be easily extendible whenever it needs to be extended
to cover the more constrained access networks.

Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 03 Apr 2002 09:47:09 -0800

Hello Marcus,

Regards,
Charlie P.

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 5 Apr 2002 20:13:51 -0500

I hate to rear my "ugly head" again.  ..... but here goes.....  Soft
handover can work for
packet networks!!!!    The idea of adding a "leg" can work for IP
networks!!!!   The idea
that we are stuck with HARD handovers is a legacy concept.....   I think I
have been
trying to say this for about 3 years in the IETF.....    Frank Zappa once
wrote a song
"Shut up and play your Guitar".  That is the stage I am at with the IETF....
I just want to
go build stuff rather than talk about it or try and convince others of the
potential merrit.

:-)

Phil

---

From: "Phil Neumiller" <[email-masked]>
Date: Fri, 5 Apr 2002 20:13:51 -0500

:-)

Phil