Subject: RE: [Seamoby] Section 5.2 in CT Requirements

From: "Gary Kenward" <[email-masked]>
Date: Fri, 19 Jul 2002 10:00:46 -0400

The question is whether there is wg consensus. Which was not
reached at time of writing section 5. I'm not defending 
the situation, simply informing you. Perhaps this time it will 
not be an issue.

The *technical* problem with your requirement - and I am only
trying to recapture what others objected to - was that there
was a significant number of people who wanted to define a
transport solution for CT, based upon CTs unique needs. Some
wanted transport capabilities built into CT. The melt down came 
when the wg started debating these needs, as the CT solution was 
not (and is not) defined, the transport needs are pure speculation, 
or based upon individual approaches. Thus, the decision to defer the 
CT transport evaluation until a CT solution - and the transport needs 
- where better known.

BTW: the format you have used is not the standard format
     decided upon by the working group, which was to use
     section headers as the requirements (I believe this
     was Pat's suggestion). One requirement per section.

     We can, of course, change  the style, but all of
     the requirements would have to be re-written.

Gary

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: July 18, 2002 18:59
> To: Kenward, Gary [WDLN2:AN10:EXCH]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Seamoby] Section 5.2 in CT Requirements
> 
> 
> Gary,
> 
> It isn't a question of debate. We've been talking about these 
> requirements for a
> year and a half, it is time to complete them.
> We need to nail down this section.
> 
> Do you have any specific technical comments on the requirement?
> 
>             jak
> 
> ----- Original Message -----
> From: "Gary Kenward" <[email-masked]>
> To: "'James Kempf'" <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, July 18, 2002 8:16 AM
> Subject: RE: [Seamoby] Section 5.2 in CT Requirements
> 
> 
> > James:
> >
> >  There was a long and arduous debate over transport reliability.
> > The wording you are objecting to was, I believe, Allison's 
> suggestion.
> > At the very lease, it was inserted with her approval in 
> order to move
> > the requirements forward.
> >
> >  Of course, you can open the debate again, but I don't expect it to
> > be resolved any better then it was the last time through. 
> The problem
> > is that there seems to be some very different ideas in the wg as to
> > what the CT protocol looks like, with contradicting assumptions as
> > to what is needed from a transport layer.
> >
> > Gary
> >
> > > -----Original Message-----
> > > From: James Kempf [mailto:[email-masked]]
> > > Sent: July 18, 2002 07:14
> > > To: [email-masked]
> > > Cc: [email-masked]
> > > Subject: [Seamoby] Section 5.2 in CT Requirements
> > >
> > >
> > > Folks,
> > >
> > > So recently I had another look at the CT Requirements
> > > document and I was
> > > suprised to find Section 5.2. It says this:
> > >
> > >     5.2 Transport Reliability
> > >
> > >        This section is intentionally left blank as the
> > > working group is
> > >        waiting for a questionnaire from the transport
> > > directorate. The result
> > >        of the questionnaire will create requirements that
> > > will be added in this
> > >        section in a later revision of this specification.
> > >
> > > It is completely unacceptable that we sent this document to
> > > the IESG with this
> > > section in it. When a document passes through last call, it
> > > should be complete.
> > > As WG chairs, Pat and I naturally must accept responsibility
> > > for this, but this
> > > should really have been caught in WG Last Call.
> > >
> > > I would like suggest replacing Section 5.2 with the following:
> > >
> > >     5.2 Transport Requirements
> > >
> > >         This section contains requirements on the context
> > > transfer transport.
> > >
> > >     5.1 Independence of Underlying Transport
> > >
> > >         The context transfer solution MUST be independent of
> > > the underlying
> > > transport. It SHOULD be possible to transfer
> > >         context directly on top of reliable transports, such
> > > as TCP or SCTP,
> > > unreliable transports, such as UDP, or as an
> > >         option or extention on another protocol, such as
> > > handover signaling.
> > >
> > > Comments?
> > >
> > >
> > >             jak
> > >    u
> > >
> > >
> > >
> > > _______________________________________________
> > > Seamoby mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/seamoby
> > >
> >
> 
>

---

From: "James Kempf" <[email-masked]>
Date: Fri, 19 Jul 2002 15:26:40 -0700

Gary,

Thanx for the history. I wasn't in the original discussion.

I think we can might have an opportunity for concensus this time if we can agree
that the generic CT protocol consists of a container format and a description of
the rules for standardizing container contents. It would be up to the individual
feature context standards to describe the transport.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Fri, 19 Jul 2002 15:26:40 -0700

Gary,

            jak