Subject: RE: [Seamoby] New Section 5.8 - Requirements on Feature Context Specifications

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Wed, 24 Jul 2002 18:20:15 -0500

Rajeev,

sorry for the delay. see below.

-----Original Message-----
From: Rajeev Koodli [mailto:[email-masked]]
Sent: Tuesday, July 23, 2002 4:24 PM
To: Nakhjiri Madjid-MNAKHJI1
Cc: James Kempf; [email-masked]
Subject: Re: [Seamoby] New Section 5.8 - Requirements on Feature Context
Specifications

Hello Madjid,

Nakhjiri Madjid-MNAKHJI1 wrote:

> - regarding the transport text, if a particular feature indicates UDP/TCP
> or SCTP, isn't that sufficient ? Even if it can provide more information,
> how
> is that going to be useful if it is not supported by the underlying
> transport
> protocol ?
>
> Madjid>> First of all, not everybody and every feature need an advanced
> transport and I know we agree on this.
> However, say in 6 months we are debating an specific feature that does need
> reliability. This text is to protect us from sloppy design.
> If you remember Jeff Schiller saying: Don't come and say use
> IPSec if you want security, you need to work on the security details.
>
> Example of a case which even SCTP is not going to cut it (this is
> answer to your next question as well): say you are sending a very
> dynamic context (packet count or HC context) and you want reliability
> (and you got time to resend stuff...).
> You send the context, but due to do channel conditions don't get it through,
> next time, you have to send updates. This has to come from the feature unit
> and not from transport layer. If had just said use SCTP for reliability that
> would not be a robust design.
>

When you have to send an update, you do it whether or not SCTP failed to
get it through in the first case, right ? What SCTP or a reliable transport
protocol will offer you is the ability to send a message reliably. When you
have a new message or an update, I agree the feature code has to supply it
(and SCTP has to get to the destination reliably)!

Madjid>> True, furthermore, if you use a reliable protocol like
SCTP, you need to take extra care with CT, so the receiver doesn't mix up
updates from app. layer, with retx from transport.

I hope you are not indicating that each feature has to design its own reliable
transmission protocol. The way each feature uses SCTP or UDP is internal
to the feature, and is not a function of the CT protocol itself. The
CT protocol
should define a set of messages that can be carried over different transport
protocols.

Madjid>> No, No, however, If we add a set of minimal support (like
what I mentioned above) to the generic protocol, then provide the option
for the feature to use it or not we are covered. 
If we completely ignore reliability
completely, we will write off CT as a useful protocol, I think!

BR,

Madjid

Regards,

-Rajeev

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Wed, 31 Jul 2002 13:14:32 -0700

Madjid,

Do you have some specific text you would like to propose regarding the
transport?

            jak

----- Original Message -----
From: "Nakhjiri Madjid-MNAKHJI1" <[email-masked]>
To: "'Rajeev Koodli'" <[email-masked]>
Cc: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Wednesday, July 24, 2002 4:20 PM
Subject: RE: [Seamoby] New Section 5.8 - Requirements on Feature Context
Specifications

---

From: "James Kempf" <[email-masked]>
Date: Wed, 31 Jul 2002 13:14:32 -0700

Madjid,

            jak

----- Original Message -----
From: "Nakhjiri Madjid-MNAKHJI1" <[email-masked]>
To: "'Rajeev Koodli'" <[email-masked]>
Cc: "James Kempf" <[email-masked]>; <[email-masked]>
Sent: Wednesday, July 24, 2002 4:20 PM
Subject: RE: [Seamoby] New Section 5.8 - Requirements on Feature Context
Specifications