Subject: RE: [Seamoby] Proposal on Sync/NoSync Requirement

From: "Gary Kenward" <[email-masked]>
Date: Fri, 19 Jul 2002 10:51:18 -0400

James:

 So you are proposing now that there are also feature specific
CT protocols? If this is true, and we follow your argument,
the we need to revisit all the attributes stated for CT: reliability,
timeliness, etc., etc. to determine what capabilities should be
common, and what capabilities should be feature specific.

 As far as updates go, I think it is a common capability.

Gary

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: July 19, 2002 09:05
> To: Nakhjiri Madjid-MNAKHJI1; [email-masked]
> Subject: Re: [Seamoby] Proposal on Sync/NoSync Requirement
> 
> 
> Madjid,
> 
> 
> > Don't know if we can use NEED Not (certainly fits for the 
> first SHOULD NOT,
> since
> > that one sounds like we are advising against it).
> 
> We should (SHOULD? :-) use RFC language.
> 
> > How would you allow particular features get synch service, 
> if there is no
> inbuild
> > mechanisms in CT?
> 
> Because the CT protocol would be just a container format that 
> could be reused by
> many different feature specific protocols. For example, one 
> could use the CT
> container to define an option for use along with handover 
> signaling to transfer
> header compression context. Or, one could use SCTP to 
> transfer security, QoS,
> and AAA context not requiring any synchronization with the 
> handover signaling.
> The latter would require a separate protocol description for 
> how the container
> format is used with the particular transport. For most 
> protocols, the two are
> bundled, but they are conceptually separate and here I can 
> see reasons for
> separating them.
> 
> >
> > I think we can talk about synchronization when there are 
> two copies at
> > two different places. I think the solutions should 
> seriously avoid this,
> > as we did in our proposal. Care should be taken so that you 
> don't have to
> > update a context at both oldAR and newAR. I think as you 
> said for header
> compression
> > context, you should have the context updated only at one 
> location and when
> > it is only at one location, how can we call it synchronization?
> >
> 
> Because it is synchronized with an external event, namely 
> handover. With context
> that is not sync sensitive  there is no requirement for 
> synchronization with
> handover because the change in routing doesn't invalidate the 
> context on the old
> router. Conversely, if the non-sync sensitive context is sent 
> a bit early, there
> will similarly not be a problem.
> 
> This is not to state that the non-sync sensitive context 
> isn't dynamic, just
> that the event of handover doesn't invalidate it per se.
> 
> 
> >
> > You would on the other hand get problem with dynamic context, if
> > some context that you sent over, gets lost or corrupted. 
> Once this happen
> > then, you can see whether the context has changed (in which 
> case you need a
> refresh)
> > or not (you only need a retx).
> >
> 
> Dynamic context means that it is changing as the mobile's 
> traffic goes through
> the router, right? So I view that as requiring 
> synchronization with an external
> event, namely handover. Something like accounting information 
> would qualify, as
> well as header compression state. On the other hand, a user's 
> SLA would not,
> because handover wouldn't invalidate it.
> 
>                 jak
> 
> 
> 
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
>

---

From: "James Kempf" <[email-masked]>
Date: Fri, 19 Jul 2002 18:03:39 -0700

Gary,

> common, and what capabilities should be feature specific.

Do you really think this is necessary? I just looked through the requirements
and they all looked pretty general to me.
If you think there are some specific requirements that would need updating,
please post suggested modifications to the list. Best would be a separate thread
per requirement, so that people can follow.

>  As far as updates go, I think it is a common capability.

Others don't agree, and they have examples which are convincing, such as header
compression transfer (this one came up in coversations with the IESG this week).

I was not involved in the initial discusssions on CT so I do not have the
history on it. But I also don't have a lot invested in a particular outcome. I
would like the WG to achieve concensus on a set of requirements that are
specific enough to pass IESG muster, so that we can procced on to actually
designing the protocol. My observation, over the last couple weeks of mailing
list traffic and talking to some people involved, is that the requirements are
not sufficiently crisp in places where people have very different ideas about
what types of feature contexts they want to transfer. These include:

1) Update allowed v.s. prohibited.

2) Tight synchronization with external events v.s. no synchronization.

3) What transport to use.

Trying to specify requirements in these areas for a general context transfer
protocol when people have legitimate but very different notions of what they
want to use the protocol for that would result in very different feature
specific requirements can't succeed.

In a separate thread, I will propose a new section that specifies requirements
on specifications for individual feature contexts. Note that this proposal will
not contain requirements on the feature contexts themselves, but only on their
specifications. These will address the issues above.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Fri, 19 Jul 2002 18:03:39 -0700

Gary,

            jak