Subject: RE: [Seamoby] Section 5.2 in CT Requirements

From: "Gary Kenward" <[email-masked]>
Date: Thu, 18 Jul 2002 11:16:26 -0400

James:

 There was a long and arduous debate over transport reliability.
The wording you are objecting to was, I believe, Allison's suggestion.
At the very lease, it was inserted with her approval in order to move
the requirements forward.

 Of course, you can open the debate again, but I don't expect it to
be resolved any better then it was the last time through. The problem
is that there seems to be some very different ideas in the wg as to
what the CT protocol looks like, with contradicting assumptions as
to what is needed from a transport layer.

Gary

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: July 18, 2002 07:14
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Seamoby] Section 5.2 in CT Requirements
> 
> 
> Folks,
> 
> So recently I had another look at the CT Requirements 
> document and I was
> suprised to find Section 5.2. It says this:
> 
>     5.2 Transport Reliability
> 
>        This section is intentionally left blank as the 
> working group is
>        waiting for a questionnaire from the transport 
> directorate. The result
>        of the questionnaire will create requirements that 
> will be added in this
>        section in a later revision of this specification.
> 
> It is completely unacceptable that we sent this document to 
> the IESG with this
> section in it. When a document passes through last call, it 
> should be complete.
> As WG chairs, Pat and I naturally must accept responsibility 
> for this, but this
> should really have been caught in WG Last Call.
> 
> I would like suggest replacing Section 5.2 with the following:
> 
>     5.2 Transport Requirements
> 
>         This section contains requirements on the context 
> transfer transport.
> 
>     5.1 Independence of Underlying Transport
> 
>         The context transfer solution MUST be independent of 
> the underlying
> transport. It SHOULD be possible to transfer
>         context directly on top of reliable transports, such 
> as TCP or SCTP,
> unreliable transports, such as UDP, or as an
>         option or extention on another protocol, such as 
> handover signaling.
> 
> Comments?
> 
> 
>             jak
>    u
> 
> 
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
>

---

From: "James Kempf" <[email-masked]>
Date: Thu, 18 Jul 2002 15:59:10 -0700

Gary,

It isn't a question of debate. We've been talking about these requirements for a
year and a half, it is time to complete them.
We need to nail down this section.

Do you have any specific technical comments on the requirement?

            jak

---

From: "James Kempf" <[email-masked]>
Date: Thu, 18 Jul 2002 15:59:10 -0700

Gary,

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 23 Jul 2002 14:13:24 -0700

I pretty much agree with 5.2.1 (not 5.1  I suppose)

-Rajeev

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 23 Jul 2002 14:13:24 -0700

-Rajeev