Subject: RE: [Seamoby] CT Requirements Comments from IESG

From: "Gary Kenward" <[email-masked]>
Date: Thu, 11 Jul 2002 10:34:04 -0400

I understand your intentions James, but as a requirement,
preserving "intended usability" does not make any sense to
me. How does on test that a solution is in conformance to 
this requirement? 

Just to be clear, I don't believe that "preserving meaning"
is a real requirement either. It is also not testable.

I am not just arguing semantics here, if we are going to 
revise these requirements, let's make sure that they are
real requirements.

Perhaps the actual answer is to state exactly what was intended
originally: that the bit order and bit values have to arrive exactly
as they were transmitted.

gary

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: July 10, 2002 18:12
> To: Kenward, Gary [WDLN2:AN10:EXCH]; [email-masked]
> Subject: Re: [Seamoby] CT Requirements Comments from IESG
> 
> 
> It's not the same definition
> 
> I suggest:
> 
> 5.5.2 A context update MUST preserve the integrity, and thus the
>       intended useability, of the context at each receiving AR.
> 
>             jak
> 
> 
> 
> ----- Original Message ----- 
> From: "Gary Kenward" <[email-masked]>
> To: "'James Kempf'" <[email-masked]>; <[email-masked]>
> Sent: Wednesday, July 10, 2002 11:31 AM
> Subject: RE: [Seamoby] CT Requirements Comments from IESG
> 
> 
> > A word is often defined as 4 bytes, or 32 bits :-) in many
> > computational architectures and programming languages.
> > 
> > Neither here nor there, really. I'll wait for further
> > suggestions/comments on the working of 5.5.2 from the wg.
> > 
> > Gary
> > 
> > > -----Original Message-----
> > > From: James Kempf [mailto:[email-masked]]
> > > Sent: July 10, 2002 14:12
> > > To: Kenward, Gary [WDLN2:AN10:EXCH]; [email-masked]
> > > Subject: Re: [Seamoby] CT Requirements Comments from IESG
> > > 
> > > 
> > > "Word" or "phrase", from the definition you cite, typically 
> > > applies to natural language. I have not heard anyone use that
> > > terminology for machine readable information, even in 
> > > programming languages.
> > > 
> > >             jak
> > > 
> > > ----- Original Message -----
> > > From: "Gary Kenward" <[email-masked]>
> > > To: "'James Kempf'" <[email-masked]>; <[email-masked]>
> > > Sent: Wednesday, July 10, 2002 9:58 AM
> > > Subject: RE: [Seamoby] CT Requirements Comments from IESG
> > > 
> > > 
> > 
> > *snip*
> > 
> > > 
> > 
> 
>

---

From: "James Kempf" <[email-masked]>
Date: Thu, 11 Jul 2002 09:22:22 -0700

> as they were transmitted.

So this requirement is talking about transmission fidelity? I sure would not have guessed that from reading it. I thought it
intended to talk about usability.

I would suggest that the wording you have above is really a lot more precise that what is currently in the spec.

Any other comments? Could we substitute Gary's wording above for "meaning" in the current requirement.

            jak

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Thu, 11 Jul 2002 09:22:22 -0700

jak