Subject: RE: [Seamoby] CT Requirements Comments from IESG

From: "Gary Kenward" <[email-masked]>
Date: Wed, 10 Jul 2002 12:58:34 -0400

What does natural language have to do with it?
I am not a linguist, but information representations have 
syntax and semantics (and as a result, they have meaning,
at the very least one would assume, to the originator of 
the information).

'useable' on the other hand, is a wide open term, that could
be interpreted strictly (i.e. the information has to exactly
conformant to the requirements for configuration of the destination
router), or very loosely (i.e. "null" information could be
interpreted as "useable", in the trivial sense). In other words,
there would be no requirement.

The intent of this requirement, which went through much debate
over the meaning of "integrity", is that the CT protocol must 
preserve what was sent by the source. For me, stating that the integrity 
of the information was preserved was enough. The wg decided that
"meaning" had to be preserved.

I cannot think of an example where, if one preserves the syntax and 
the symbol values (i.e. the "bits") of a given piece of information,
the semantics would be lost. But then, I'm not a linguist.

Said another way, the bits of the payload of the CT protocol must 
arrive in the order they were sent, and without any errors. Whether
the receiving AR can understand what the sender sent is not a CT
issue. CT just transfers the context, it does not define it. Thus, it
is not required that the CT protocol ensure "useability" at the destination.
That is a problem for the source. The analogy would be a requirement that
TCP ensure that the application could interpret the payload delivered to it.

It's always perplexed me why this simple, and somewhat obvious requirement,
has been subject to so much controversy.

Gary

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: July 10, 2002 12:09
> To: Kenward, Gary [WDLN2:AN10:EXCH]; [email-masked]
> Subject: Re: [Seamoby] CT Requirements Comments from IESG
> 
> 
> Hmm.
> 
> So since there is no natural language conversation going on 
> between these two routers, may I suggest that "meaning" is not a
> sufficiently precise word to use in this context?
> 
> How about something along the lines of "usable to establish 
> services on the new router" or something like that.
> 
>             jak
> 
> ----- Original Message -----
> From: "Gary Kenward" <[email-masked]>
> To: "'James Kempf'" <[email-masked]>; <[email-masked]>
> Sent: Wednesday, July 10, 2002 7:08 AM
> Subject: RE: [Seamoby] CT Requirements Comments from IESG
> 
> 
> Main Entry: mean·ing
> Pronunciation: 'mE-ni[ng]
> Function: noun
> 
> 4 a : the logical connotation of a word or phrase
> 
> ------------
> 
> I propose, for section 5.5.2, to replace "meaning" with
> "original syntax and semantics", unless someone has a better
> idea.
> 
> Gary
> 
*snip*
> > >
> >
> > I suspect that is it. What is "meaning"?
> >
> >             jak
> >
> >
> 
> 
>

---

From: "James Kempf" <[email-masked]>
Date: Wed, 10 Jul 2002 11:12:07 -0700

"Word" or "phrase", from the definition you cite, typically applies to natural language. I have not heard anyone use that
terminology for machine readable information, even in programming languages.

            jak

----- Original Message -----
From: "Gary Kenward" <[email-masked]>
To: "'James Kempf'" <[email-masked]>; <[email-masked]>
Sent: Wednesday, July 10, 2002 9:58 AM
Subject: RE: [Seamoby] CT Requirements Comments from IESG

Gary

*snip*
> > I suspect that is it. What is "meaning"?

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Wed, 10 Jul 2002 11:12:07 -0700

jak

----- Original Message -----
From: "Gary Kenward" <[email-masked]>
To: "'James Kempf'" <[email-masked]>; <[email-masked]>
Sent: Wednesday, July 10, 2002 9:58 AM
Subject: RE: [Seamoby] CT Requirements Comments from IESG

Gary

*snip*