Subject: RE: [Seamoby] Next Steps for the terminology draft

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 21 Oct 2002 17:44:00 +0200

If the intention is to use HAs as examples of routing proxies then I 
don't think we can say that they are stateless. 
 
Hesham

-----Original Message-----
From: Behcet Sarikaya [mailto:[email-masked]]
Sent: Monday, October 21, 2002 5:24 PM
To: Jukka MJ Manner
Cc: Seamoby Working Group
Subject: Re: [Seamoby] Next Steps for the terminology draft

Jukka, what about:

Routing proxies are the network nodes that receive datagrams, decide

based on a lookup to which server to forward the datagram. The forwarding

is stateless.

The Home Agent and Foreign Agent are examples of routing

proxies, in that they receive packets destined for the mobile node, do a lookup in the binding cache and

tunnel them to the current address of the the correct mobile node.

This would clarify forwarding by tunneling and other concepts.

Regards, 

Jukka MJ Manner wrote:

	Hi all,

	So far I have seen only one comment to the terminology draft, to 

replace our proposed definition of "Routing Proxy"

"A node that routes packets by overlays, eg. by tunneling, between

communicating partners and without doing any non-routing related

processing. The Home Agent and Foreign Agent are examples of routing

proxies, in that they receive packets destined for the mobile node and

tunnel them to the current address of the mobile node."

	with the following:

"Routing proxies are the network nodes that receive datagrams, decide

based on a lookup to which server to forward the datagram. The forwarding

is stateless."

	I would keep the existing definition... it says a little more.

	In addition, we had the following TODO items mentioned in the 

draft:

1) Add basic terminology about mobile networks. 

Question: what terms should be considered?

2) Add more terms, eg. MPR (Multipoint Relay), "Reverse Routability", BU, 

FBU.

Question: would these be needed? What else?

3) Compare to the definitions in FMIPv6 (and other MIP drafts) and add 

missing parts.

Question: This draft does not have any mention of various care of

addresses, should it? What else?

4) Compare against definitions in the LMM documents of the IRTF MM-

subgroup (taxonomy draft expired).  See if there is some harmonization to

be done. Can be found at: 

http://www.yegin.org/alper/draft-irtf-mm-taxonomy-00.txt <http://www.yegin.org/alper/draft-irtf-mm-taxonomy-00.txt> 

Question: is there something someone would like to have in the Seamoby 

terminology draft, to better cover the world on IP mobility?

5) Re-write the Network Components section

Question: How should the present version be changed?

	We would like to get the comments from the Working Group this

week, so that we may prepare a new version for Atlanta.

	Regards,

	Jukka

-- 

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 21 Oct 2002 10:54:40 -0500

Hello Hesham,
  Forwarding is stateless

here means that RP forwards the packet and then forgets about it, i.e. 
no sequence numbering/retransmissions, etc.

Hesham Soliman (EAB) wrote:

>>http://www.yegin.org/alper/draft-irtf-mm-taxonomy-00.txt
>>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 21 Oct 2002 10:54:40 -0500

Hello Hesham,
  Forwarding is stateless

---

From: "James Kempf" <[email-masked]>
Date: Mon, 21 Oct 2002 10:15:39 -0700

> no sequence numbering/retransmissions, etc.

Why is this important? The point should be that these network elements operate
like routers, but they do not exchange information with the routing fabric via
an IGP. Routers typically do no sequence numbering or retransmissions.

            jak

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Mon, 21 Oct 2002 10:15:39 -0700

jak

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 21 Oct 2002 13:04:51 -0500

So binding cache state you mentioned in your previous message
was not the state mentioned here, hope you agree with this.

--more below.

James Kempf wrote:

>_________

because
1. Jukka was asking the members' opinion,
2. It does matter to have a good definition rather than an average one.

-- 
Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 21 Oct 2002 13:04:51 -0500

--more below.

because

-- 
Behcet