Subject: RE: [Seamoby] a CTAR response ?

From: [email-masked]
Date: Fri, 6 Jun 2003 14:40:58 +0300

Yusef & Julien,

Could you supply some text?

thanks,
John

> -----Original Message-----
> From: ext Motiwala, Yusuf [mailto:[email-masked]]
> Sent: 06 June, 2003 10:10
> To: 'Rajeev Koodli'; Julien Bournelle
> Cc: [email-masked]
> Subject: RE: [Seamoby] a CTAR response ?
> 
> 
> Rajeev,
> 
> Even if MN has moved, will mandatory response help in 
> detecting any DoS
> attempt by fake CTAR?
> 
> Regards,
> Yusuf
> 
> 
> > -----Original Message-----
> > From: Rajeev Koodli [mailto:[email-masked]]
> > Sent: Friday, June 06, 2003 7:48 AM
> > To: Julien Bournelle
> > Cc: [email-masked]
> > Subject: Re: [Seamoby] a CTAR response ?
> > 
> > 
> > 
> > Hello Julian,
> > 
> > yes, an optional response to CTAR could be
> > defined. This might be useful as a response to the
> > MN.
> > 
> > Regards,
> > 
> > -Rajeev
> > 
> > 
> > Regards,
> > 
> > Julien Bournelle wrote:
> > 
> > > Hi,
> > >
> > >  I was reading the draft about Context Transfer protocol and I was
> > > wondering why there is no message in response to the CTAR message.
> > >
> > > Basically, I think that in some cases, the nAR or pAR may 
> > want to send
> > > some data (e.g. a Co@ or something else). I'm not sure that 
> > it is always
> > > necessary but as it does not exist any documents 
> specifying specific
> > > context transfer (e.g IPsec), some problems may raise later.
> > >
> > > Thanks,
> > > --
> > > [email-masked]
> > > _______________________________________________
> > > Seamoby mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/seamoby
> > 
> > _______________________________________________
> > Seamoby mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/seamoby
> > 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
> 
_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Julien Bournelle <[email-masked]>
Date: Tue, 10 Jun 2003 15:29:33 +0200

hi all,

> Could you supply some text?

I guess that you mean a text to add in the draft, if I'm not wrong, this
is some comments/questions to clarify:

1/ in part 2/ protocol overview, we have the text:

 "Recall that the MN always sends CTAR message to nAR regardless of
   whether it sent the CTAR message to pAR. The reason for this is that
   there is no means for the MN to ascertain that context transfer
   reliably took place. By always sending the CTAR message to nAR, the
   Context Transfer Request (see below) can be sent to pAR whenever
   necessary.
"

I guess that this text should be updated/deleted if we introduce a new
message in response to CTAR.

2/ if we introduce this message, does MN always send a message to
nAR as specified in 2.4.1 ?

I think that if it sends a CTAR to pAR and receives a response before
the handover takes place, this is not necessary.

3/ how do we call this message ?
Maybe "Context Transfer Activate Answer (CTAA)" because use of "Reply"
could be confusing :-)

4/ What does this message must content ?

 - MN's Previous Co@ ? 

 - OverallStatus Ctx-1 Status ...like in CTDR ?

 - An authentication Token ?

 - Optionnal data in response to a specific extension (e.g. IPsec/QoS..)

5/ For the optionnal data, how do we "format" them ?

6/ Others ?

---

From: Rajeev Koodli <[email-masked]>
Date: Mon, 16 Jun 2003 14:26:19 -0700

> the handover takes place, this is not necessary.

No. You still need it. How does nAR know that the legitimate
MN has attached and is requesting the contexts? Even if the MN
has received some sort of notification that the CT has taken place,
the nAR needs to verify that the auth-token matcges before making
the contexts available.

-Rajeev

---

From: Julien Bournelle <[email-masked]>
Date: Mon, 23 Jun 2003 13:38:08 +0200

hi,

> the nAR needs to verify that the auth-token matcges before making

you're right, in this case I have a question:

Is the CTAR message (sent by MN to nAR) still contain Requested Context
Type ?