Subject: [Seamoby] Issue 12: Inclusion of MN's nCoA in CTAR or CTD

From: "James Kempf" <[email-masked]>
Date: Thu, 26 Jun 2003 14:29:47 -0700

Issue 12 questions including the MN's nCoA in CTAR or CTD. If MN has not yet
completed DAD, then the address is not confirmed and it may not be if there
is a conflict (note however that exactly how to quickly confirm a nCoA is
currently a topic of heavy discussion on the MIP list, RFC 2462 DAD may not
be done). There seems to be an assumption built in that predictive handover
is occuring, and the MN will know its CoA prior to moving to the new link
or, if not predictive, then immediately on coming on link.

Was this intended as an identifier for the MN on the new link? If so,
wouldn't a more stable identifier be the MN's link layer address?

And what is the purpoe of old CoA?

            jak

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Paine, Richard H" <[email-masked]>
Date: Mon, 30 Jun 2003 12:37:05 -0700

You guys continue to have this same discussion and with the same result.  The Internet will always be fundamentally flawed until you have an identity based on the host identity (HIP-like).  All the rest are patches.  The host identity may even mean a host identity for a router. 

Boeing has an open source HIP implementation and is getting ready to include it in a prototype called the Secure Mobile Architecture (SMA). The Open Group published the SMA.  

http://citeseer.nj.nec.com/context/1203155/0
http://homebase.htt-consult.com/~hip/

Richard H. Paine
Success is getting what you want, happiness is liking what you get!
Work: 425-865-4921
Pager: 206-797-4580
Cell:  206-854-8199
IPPhone:  425-373-8964
Email:  [email-masked] 

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]] 
Sent: Monday, June 30, 2003 8:40 AM
To: Soliman Hesham; John Loughney (NRC/Helsinki)
Cc: [email-masked]
Subject: Re: [Seamoby] Issue 12: Inclusion of MN's nCoA in CTAR or CTD

Hello Hesham and John,

Soliman Hesham wrote:

> The MN's identifier should not be tied to its
> IP address or, as you correctly point out, its
> MAC address. If the MN needs to be identified,
> then a more abstract identifier should be used.
> For example, a NAI, IMSI, TMSI, FQDN (?) ...etc.

I don't think this is true.  I think that the means
by which the identification is carried out, should
be the same as the means used for the original
purpose of the particular protocol.  For instance,
if a security association is based on IP address,
then the identification ought to be by IP address.
If PAR knows the mobile node by its MAC address,
then that would be useful.  I think since we're in
the IETF, the IP address will be very handy.

> Neither the IP address nor the MAC address are
> useful as generic identifiers.

All we have to do is identify the mobile node for
the purpose of context transfer, not for generic
purposes.  In fact, the word "identify" is tricky
enough.  Surely you won't suggest that every context
tranfer requires an identity verification with some
certificate authority...?

Regarding the question:

> Do we need to have a stable Session ID of some sort that is used?

I sincerely hope this approach is not taken.  It amounts
to excess baggage and almost a license for bloat (if not
a mandate for bloat).

Also, please remember that contexts come and go, but the
mobile node stays "the same".  Would you need a session
ID per context?  Yecch!  What, exactly, is the session?

Regards,
Charlie P.

>  > Hi James,
>  >
>  > > Issue 12 questions including the MN's nCoA in CTAR or CTD.  > If
> MN has not yet  > > completed DAD, then the address is not confirmed 
> and it  > may not be if there
>  > Thinking about this a bit more - this is a tricky issue.
>  > link layer address
>  > may not be good, in the case of vertical handovers.  Also,
>  > what to do with
>  > IPv4 & possibly NATed addresses?
>  >
>  > Do we need to have a stable Session ID of some sort that is used?
>  >
>  > John
>  >
> [email-masked] https://www1.ietf.org/mailman/listinfo/seamoby

---

From: [email-masked]
Date: Tue, 1 Jul 2003 06:15:47 +0300

Hi James,

> No, we want to minimize state in the network.
> 
> I suppose sticking with the IP addresses is probably the only possible
> solution at this point. In some cases (viz IPv6 reactive handover) there may
> be no new CoA yet. Something like HIP would certainly help here, but we
> can't depend on having it at this point.

Sounds fine with me.

John