Subject: [Seamoby] Some comments on CTP

From: [email-masked]
Date: Tue, 10 Jun 2003 09:25:21 -0400

Hi Folks,

I hope its not too late for a comment.

In section 2, paragraph 5 it says
>... "Such a trigger must be capable of providing the
>necessary information, such as the MN's IP address with
>which the contexts are associated, the IP addresses of
>the access routers, and authorization to transfer context.

The way this is written may lead to some confusion in the
future.  Recall that IP addresses are assigned to interfaces,
not nodes.  So the "MN's IP address" should be specifically
described as its mobile IP home address, or the IP address
assigned to a particular air interface (COA) or Link Local
or whatever type of address is being used.  The rest of
document seems to do this, but front part doesn't.

Also in section 2,
>The messages (CTD and CTDR) which perform the context transfer
>between the access routers need to be authenticated, so that the
>access routers can be certain that the data has not been tampered
>with during delivery.

Authentication of the end points does not provide tamper resistance.
Each message needs to be signed somehow (i.e. message digest etc).
I see that in the appendix IPsec is talked about.  Why not mandate
IPsec as the minimal supported SA between pAR and nAR?  If something
else is used it must provide privacy (encryption), authentication,
replay protection, etc.

It also occurred to me that at least with 802.11, we have this
802.1x stuff going on, where port based authorization may be
required when wandering across administrative domains (currently
RADIUS servers).  In this case a mobile may be authenticated but
unauthorized to access a network until roaming credentials have
been verified via AAA.  What advantage does CTP provide here?
Should it not also trigger the back-office AAA to do something
too?  Where would the AAA hooks be added to CTP?

Thanks,

Phil

--
"NOTICE:  The information contained in this electronic mail transmission is
intended by Convergys Corporation for the use of the named individual or
entity to which it is directed and may contain information that is
privileged or otherwise confidential.  If you have received this electronic
mail transmission in error, please delete it from your system without
copying or forwarding it, and notify the sender of the error by reply email
or by telephone (collect), so that the sender's address records can be
corrected."

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: [email-masked]
Date: Fri, 13 Jun 2003 15:31:27 +0300

Phil,

> document seems to do this, but front part doesn't.

Could you provide a re-write? 

> else is used it must provide privacy (encryption), authentication,

Do folks think that mandatory IPsec is reasonable here?

> too?  Where would the AAA hooks be added to CTP?

Good point, I think that is outside of the scope of this
document.  I think a follow-on document covering this would
be potentially useful.

br,
John

---

From: Soliman Hesham <[email-masked]>
Date: Sat, 14 Jun 2003 21:17:55 -0400

> Do folks think that mandatory IPsec is reasonable here?

=> Yes. And you need to specify how to do that. I mean, 
a side effect of this would be that all UDP traffic will
be secure (from a quick read I saw that UDP is the transport
protocol for CTP).

Hesham

---

From: Soliman Hesham <[email-masked]>
Date: Mon, 16 Jun 2003 22:34:57 -0400

I'm not sure how this is relevant to our discussion. 
We need confidentiality and integrity protection between
the 2 ARs. There is already a solution: IPsec.

Hesham

 > -----Original Message-----
 > From: Paine, Richard H [mailto:[email-masked]]
 > Sent: Monday, June 16, 2003 10:11 AM
 > To: Soliman Hesham; [email-masked];
 > [email-masked]; [email-masked]
 > Cc: Henderson, Thomas R
 > Subject: RE: [Seamoby] Some comments on CTP
 > 
 > 
 > The Host Identity Payload (HIP) offers this per-packet 
 > authentication.  The group working HIP in the IETF includes 
 > Bob Moskowitz and Tom Henderson of Boeing.  Why not include 
 > HIP as part of the Seamoby specs?  
 > 
 > Richard H. Paine
 > Success is getting what you want, happiness is liking what you get!
 > Work: 425-865-4921
 > Pager: 206-797-4580
 > Cell:  206-854-8199
 > IPPhone:  425-373-8964
 > Email:  [email-masked] 
 > 
 > 
 > -----Original Message-----
 > From: Soliman Hesham [mailto:[email-masked]] 
 > Sent: Saturday, June 14, 2003 6:18 PM
 > To: [email-masked]'; [email-masked]; 
 > [email-masked]
 > Subject: RE: [Seamoby] Some comments on CTP
 > 
 > 
 > 
 >  > > Each message needs to be signed somehow (i.e. message 
 > digest etc).  > > I see that in the appendix IPsec is talked 
 > about.  Why not mandate  > > IPsec as the minimal supported 
 > SA between pAR and nAR?  If 
 >  > something
 >  > > else is used it must provide privacy (encryption), 
 > authentication,  > > replay protection, etc.  >

---

From: [email-masked]
Date: Tue, 17 Jun 2003 08:06:49 +0300

Richard,

HIP has been proposed, in one form or another, for some time.
There has been at least one BOF, that I remember.  I worry
that including an unapproved spec into CTP makes CTP's
continued existance less likely.  What would be a better
scenario is for someone more familiar with HIP to propose
a follow-on draft how HIP could be used with CTP, if there
is interest.

br,
John

> From: ext Paine, Richard H [mailto:[email-masked]]
> Sent: 16 June, 2003 17:11
> To: Soliman Hesham; Loughney John (NRC/Helsinki);

---

From: [email-masked]
Date: Tue, 17 Jun 2003 13:28:34 +0300

Assigned to issue 3.

http://danforsberg.info:8080/draft-ietf-seamoby-ctp/issue3

> From: ext Soliman Hesham [mailto:[email-masked]]
> Sent: 15 June, 2003 04:18
> To: Loughney John (NRC/Helsinki); [email-masked];
> [email-masked]
> digest etc).
> authentication,

---

From: [email-masked]
Date: Wed, 18 Jun 2003 08:44:57 -0400

When I took a peak at the DIAMETER base protocol draft, I noticed that
TLS is suggest for inter-domain security and IPsec for intra-domain
security.  It has occurred to me that CTP could occur either within or
between administrative domains.  Now, in the future, it may be necessary
to involve DIAMETER in the CTP protocol, so perhaps it would be
best to pattern SeaMoby CT after DIAMETER SAs?  Eventually,
maybe the same SA can be reused by both???  Just a stray thought...

-Phil

---

From: [email-masked]
Date: Wed, 18 Jun 2003 09:04:18 -0400

just another random thought....  Should the SA between pAR and nAR be
optionally
longer lived?  I could see where an SCPT association could be useful and
allow
multiple independent CT streams between the pAR and nAR.  Once you went
through the pain of setting up the SA, it might be useful to keep it up on
a idle
timer until the "border crossings" stop.

Thanks,

Phil

---

From: [email-masked]
Date: Wed, 18 Jun 2003 17:55:38 +0300

Hi Phil,

> maybe the same SA can be reused by both???  Just a stray thought...

I think that you could consider that an AR has a Diameter connection
towards a AAA server.  However, as CTP is specified to run over
UDP, TLS is not an option.

John

---

From: [email-masked]
Date: Wed, 18 Jun 2003 18:00:42 +0300

Hi Phil,

> just another random thought....  Should the SA between pAR and nAR be optionally
> allow multiple independent CT streams between the pAR and nAR.  Once you went
> a idle timer until the "border crossings" stop.

Having pre-established SAs between ARs would be reasonable, but I think this
would be something to actually test, so I hesitate to put anything in
the draft with regards to this.

John