Subject: RE: [Seamoby] [issue 2] comments/questions on the CTAR response

From: [email-masked]
Date: Tue, 17 Jun 2003 13:30:13 +0300

Rajeev,

From your response, I am unsure what your position is on Julien's
comments.  Do you feel a CTAR response is needed, possibly
useful or not needed?

thanks,
John

> -----Original Message-----
> From: ext Rajeev Koodli [mailto:[email-masked]]
> Sent: 17 June, 2003 00:26
> To: Julien Bournelle
> Cc: Loughney John (NRC/Helsinki); [email-masked]; [email-masked]
> Subject: Re: [Seamoby] [issue 2] comments/questions on the 
> CTAR response
> 
> 
> Julien Bournelle wrote:
> 
> > hi all,
> >
> > On Fri, Jun 06, 2003 at 02:40:58PM +0300, 
> [email-masked] wrote:
> > > Yusef & Julien,
> > >
> > > Could you supply some text?
> >
> > I guess that you mean a text to add in the draft, if I'm 
> not wrong, this
> > is some comments/questions to clarify:
> >
> > 1/ in part 2/ protocol overview, we have the text:
> >
> >  "Recall that the MN always sends CTAR message to nAR regardless of
> >    whether it sent the CTAR message to pAR. The reason for 
> this is that
> >    there is no means for the MN to ascertain that context transfer
> >    reliably took place. By always sending the CTAR message 
> to nAR, the
> >    Context Transfer Request (see below) can be sent to pAR whenever
> >    necessary.
> > "
> >
> > I guess that this text should be updated/deleted if we 
> introduce a new
> > message in response to CTAR.
> 
> >
> > 2/ if we introduce this message, does MN always send a message to
> > nAR as specified in 2.4.1 ?
> >
> > I think that if it sends a CTAR to pAR and receives a 
> response before
> > the handover takes place, this is not necessary.
> >
> 
> No. You still need it. How does nAR know that the legitimate
> MN has attached and is requesting the contexts? Even if the MN
> has received some sort of notification that the CT has taken place,
> the nAR needs to verify that the auth-token matcges before making
> the contexts available.
> 
> -Rajeev
> 
> 
> >
> > 3/ how do we call this message ?
> > Maybe "Context Transfer Activate Answer (CTAA)" because use 
> of "Reply"
> > could be confusing :-)
> >
> > 4/ What does this message must content ?
> >
> >  - MN's Previous Co@ ?
> >
> >  - OverallStatus Ctx-1 Status ...like in CTDR ?
> >
> >  - An authentication Token ?
> >
> >  - Optionnal data in response to a specific extension (e.g. 
> IPsec/QoS..)
> >
> > 5/ For the optionnal data, how do we "format" them ?
> >
> > 6/ Others ?
> >
> > --
> > [email-masked]
> > _______________________________________________
> > Seamoby mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/seamoby
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
> 
_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 17 Jun 2003 13:51:14 -0700

John,

my position is that regardless of whether a
response to CTAR is received or not, the MN needs
to always send CTAR upon attaching to nAR (for reasons
specified below in my response).

Regards,

-Rajeev