Subject: RE: [Seamoby] New Issue: Interoperability with other Handover Protocols

From: [email-masked]
Date: Sat, 28 Jun 2003 07:45:20 +0300

James,

While you suggestion is a good one, I feel adding it to the
current draft will add more complexity; more error cases,
etc.  

My prefered solution is to get the simple (& basic CTP done).
If bundling CTP messages with FMIP BUs are seen as a good
thing, a seperate extension could be writen up in a draft.

That would be something that could be handled in one of the
MIP WGs ...

John

> -----Original Message-----
> From: ext James Kempf [mailto:[email-masked]]
> Sent: 28 June, 2003 02:04
> To: [email-masked]
> Subject: [Seamoby] New Issue: Interoperability with other Handover
> Protocols
> 
> 
> Issue:
> 
> Section 3 specifies that CTP runs to a dedicated UDP port.  
> There may be
> cases where one would want to optimize wireless signaling (MN 
> to AR) to
> avoid multiple messages from various protocols associated 
> with different
> aspects of handover (for example, mobility mangement and 
> context transfer).
> For this reason, it might be useful to allow the MN to bundle 
> the CTAR with
> other handover signaling. For example, if FMIP is being used 
> for mobility
> management, it might be useful to bundle CTAR with the FMIP 
> BU (details are
> left as an exercise for the researcher).
> 
> Suggested Resolution:
> 
> Add the following paragraph at the end of Section 3:
> 
>     In some cases, may be advantageous to bundle the context transfer
> signaling between the MN and network, or between access 
> routers, together
> with other handover signaling. For this purpose, the MN may 
> bundle the CTAR
> message and the NAR may bundle the CTARR with other handover signaling
> rather than use dedicated UDP port for the protocol. 
> Similarly, the PAR and
> NAR may bundle the CTD/CTDR/CTR with other handover signaling.
> 
> Comments?
> 
>             jak
> 
> 
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby
> 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Mon, 30 Jun 2003 08:16:56 -0700

John,

Since Rajeev and Charlie seem to agree that the current design should work
together with FMIP, I agree that we should keep the text as is for
simplicity. I think there will probably be a period of adjustment after CTP
and FMIP are completed in which we investigate interoperability and tune the
designs so that they work well together. Probably better to wait until we
have the empirical evidence rather than try to figure out everything up
front without any.

            jak

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Friday, June 27, 2003 9:45 PM
Subject: RE: [Seamoby] New Issue: Interoperability with other Handover
Protocols