Subject: RE: [Seamoby] Review of draft-ietf-semoby-card-protocol-02.txt

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Mon, 14 Jul 2003 12:30:19 -0500

Hello Henrik,
Thanks for your review comments. I would like to 
reply to one of your questions/comments. Please 
see my inline reply. 
regards,
ajoy 

4.3.1 Current access router operation
-------------------------------------

Is it necessary to include the capabilities of current AR in
AR-AR CARD request message?

AJOY-> Yes. it helps please see my reply below. 

If the data in a current AR for a CAR is not up to date, it still does
not mean that the data for the current AR is not up to date in the
CAR. 

AJOY-> I agree. 

Including the AR-AR CARD reply automatically in the CARD request
creates unnecessary load in both routers when they authenticate /
encrypt extra data.

AJOY-> Well, it helps to reduce the number of messages processed 
by CAR in the long run. Processing extra new messages may be 
more expensive than adding some additional processing overhead in 
the existing messages.  

This optimization also adds extra complexity to the protocol, and it is
not clear to me whether it is worth it.

AJOY-> I am not clear how it will complicate the implementation of CARD protocol. 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Henrik Petander <[email-masked]>
Date: Tue, 15 Jul 2003 13:36:15 +0300 (EEST)

Hello Ajoy,

> AJOY-> I am not clear how it will complicate the implementation of CARD protocol.

Not much, but it still changes the simple request-reply nature to optimize
the protocol. I am not sure whether this optimization is generally useful.
The usefulness depends on the amount of MNs, MN mobility patterns and the
lifetimes of the capabilities. I agree that in some situations this could
reduce the load on the ARs, so I am fine with the MAY for this.

Henrik

		----------------------------------
		Henrik Petander
		Helsinki University of Technology,
		GO/Core Project
		[email-masked]
		Office: +358 (0)9 451 5846
		GSM: +358 (0)40 741 5248
		----------------------------------