Subject: [Seamoby] CARD issue#30: L2 type indicators to be assigned by IANA

From: Marco Liebsch <[email-masked]>
Date: Thu, 24 Jul 2003 16:04:35 +0200

One of the comments to the L2 ID sub-option was that
"L2-type" identifiers need to be assigned by IANA.
Now, I assume that in case we ask IANA for type
identifiers, we need to give also a list of interface
types. This lists needs then to be extended later for
future technologies...
I am not sure if this is really required for the
experimental protocol. Take into account that using
the L2-type identifier has been indicated to be
optional.

Comments?

marco 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "James Kempf" <[email-masked]>
Date: Sat, 26 Jul 2003 21:53:20 +0200

Experimental protocols also may request IANA assignments. W.r.t. whether an
L2 identifier is needed or not, I would suggest checking to see if there is
one already that can be reused, and, if not, put in a request for one.

            jak

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 28 Jul 2003 12:21:33 -0700

I dont see any other option. IANA assignment is needed.
otherwise how can the AR and the MN agree to the same
type values for different types of interfaces?

> types. This lists needs then to be extended later for

this means there is a fundamental problem. maybe you
should remove the L2 type field from the L2_ID suboption.
it is considered optional already. the Sub-Option Len
can indicate the length of the L2 ID field.