Subject: [Seamoby] [CARD Editorial Issue] Standards Language

From: "James Kempf" <[email-masked]>
Date: Tue, 1 Jul 2003 11:16:55 -0700

This draft is meant to be an experimental RFC. Therefore, it should not use
standards language (MUST/SHALL, etc.).

            jak

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Eunsoo Shim" <[email-masked]>
Date: Tue, 1 Jul 2003 16:40:49 -0400

Even though the protocol is not a standard, wouldn't it make the protocol
clearer?

Eunsoo

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 01 Jul 2003 14:05:30 -0700

Hello Jim,

I am sure this is not right.

A protocol specification within the IETF needs to use RFC 2119
language even if it's an individual contribution, not on the standards
track, designated as Experimental, whatever.

It's a property of protocol metalanguage, not state of standardization.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 01 Jul 2003 16:37:53 -0700

Hello again Jim,

While I believe that a _protocol specification_ should use the
capitalized language, I do _not_ believe that language is at
all appropriate for a requirements document.  So, I cringe
a bit when I read a sentence like "A protocol satisfying the
requirement in this section MUST have a security feature".
It seems quite out of place for me.

And, again, it doesn't matter whether the requirements
document is standards track or not.

The same considerations appy even more strongly in the
context of a problem statement, in my opinion.

Regards,
Charlie P.

---

From: "James Kempf" <[email-masked]>
Date: Tue, 1 Jul 2003 13:43:48 -0700

I had an experimental draft returned to me by the IESG several years ago
because it contained excessive standards track language. I would prefer not
to have to go through another round of editing due to IESG comments (if that
is at all possible).

            jak