Subject: Re: Draft comments...

From: Darren Moffat <[email-masked]>
Date: Tue, 20 Nov 2001 11:46:44 -0800 (PST)

>On Mon, Nov 19, 2001 at 10:27:56AM -0700, Joseph Galbraith wrote:
>>   3. Specify that SSH_MSG_REQUEST_SUCCESS has the format:
>> 
>>      byte SSH_MSG_REQUEST_SUCCESS
>>      ... response specific data
>> 
>>      where the response specific data is usually non-existent.
>> 
>>      And specify for "tcpip-forward" request, that
>>      if and only if the request port is 0, the
>>      response look like:
>> 
>>      byte   SSH_MSG_REQUEST_SUCCESS
>>      uint32 port that was bound on the server
>> 
>>   I would prefer 3; Markus has expressed a strong
>>   preference for 1.
>
>well, i agree with #3.

So do we have consensus that requesting port 0 with the symantics defined
above is acceptable for now rather that some later revision ?

>then we can change:
>   The recipient will respond to this message with
>   SSH_MSG_REQUEST_SUCCESS, SSH_MSG_REQUEST_FAILURE, or some request-
>   specific continuation messages if `want reply' is TRUE.
>to
>   The recipient will respond to this message with
>   SSH_MSG_REQUEST_SUCCESS or SSH_MSG_REQUEST_FAILURE
>   if `want reply' is TRUE.

agreed.

>>   I would like to have this included, but more than
>>   that, I would love to have a version of the
>>   draft that we can go to last call with.
>
>so do i. we really should move on.

So am I to put it in and resubmit again ?  Wednesday 21st at 1200 EST
is the cut of for changes before the meeting, so I must know today if
I need to change the docs again.

--
Darren J Moffat

---

From: "Joseph Galbraith" <[email-masked]>
Date: Tue, 20 Nov 2001 15:06:22 -0700

> I need to change the docs again.

I'm all for it --

- Joseph