Subject: terminal server draft

From: "Joseph Galbraith" <[email-masked]>
Date: Mon, 7 Oct 2002 09:40:41 -0600

I think I'm on tap for a terminal server draft
(I think this is Console Server options in the
last WG status message.)

I wrote something, but the more I thought about it,
the more I realized I didn't have a clue what I was
supposed to be writing.  This was naturally the cause
for some consternation and dismay on my part and also
the cause of a missing draft :-)

So, here is my understanding of the way a terminal server
works.

You connect to it using telnet / SSH1 / SSH2.  Then,
using TS's command line interface, you configure a
given port and then connect to it.

If this is accurate, what draft do we need?

Now, there might be another draft that could be written,
that would allow the client and server to communicate
about changes in the tty configuration after pty
creation.

For example:

server->client: I just entered raw mode
server->client: I just entered line mode
server->client: Echo was turned off
client->server: Change the tty type to vt220
client->server: Change the erase character to 'del'

The client might use the raw mode / line mode / echo mode
to decide to use a local line mode buffer that would
perfrom better under high latency situations (satellite link)
Or to enchance security by buffering characters in
no-echo/line mode until a newline is sent.

But, this is not the terminal server draft :-)

So, the big question is, what is the terminal server draft
suppose to do?

Thanks,

- Joseph

---

From: "Phillip Remaker" <[email-masked]>
Date: Mon, 7 Oct 2002 11:36:46 -0700

> (I think this is Console Server options in the

I'm extremely interested in helping 8-)  You may want to look at
www.conserver.com/consoles for ideas.

> If this is accurate, what draft do we need?

- Control of the attributes of the serial port a-la RFC 2217
- Ability to pass a BREAK signal (similar to telnet IAC break)
- EOL/Duplex/Echo handling (How is that handled today?)

> So, the big question is, what is the terminal server draft

Minimally break handling and RFC2217.