Subject: Latest sftp draft-draft...

From: "Joseph Galbraith" <[email-masked]>
Date: Mon, 7 Oct 2002 08:26:39 -0600

I believe we are getting close to submitting.

Changes since the previous draft-draft:

o Change ctime to create-time.
o Reorder permissions and time fields back to their
  original order in attribute packet.
o Clarify that partial new-line sequences should
  be ignored.
o Clarify that size field represents that size
  of the file on disk, and for text mode operations,
  it does not necessarily represent the size of the
  file on the wire.
o Clarify that the offset parameter to write
  will be ignored when FXF_APPEND is specified.
o Introduce 'text-seek' extension request, and specify
  that offset fields in read and write packets are to
  be ignored when FXF_TEXT is specified.
o Add clarifying text indicating that 'parallel' read and
  write operations must be processed successfully
  on FXF_TEXT files.
o Clean up formatting and break up description of parameters
  for MKDIR & RMDIR.  Also, revise text describing when
  a RMDIR can fail.
o Run through spell checker.

- Joseph

---

From: Richard Whalen <[email-masked]>
Date: Mon, 7 Oct 2002 11:05:36 -0400

I suspect that the name of the flag for the times in previous version was
designed to convey that the ACcess and MODification times were present.
Since there are now separate flags, plus an additional flag for create time,
how about a renaming of them to make them more readable:

   	#define SSH_FILEXFER_ATTR_ACCESSTIME      0x00000008
   	#define SSH_FILEXFER_ATTR_CREATETIME      0x00000010
   	#define SSH_FILEXFER_ATTR_MODIFYTIME      0x00000020

---

From: Richard Whalen <[email-masked]>
Date: Mon, 7 Oct 2002 11:38:03 -0400

I think that's good.

> -----Original Message-----
> From: Joseph Galbraith [mailto:[email-masked]]
> Sent: Monday, October 07, 2002 11:35 AM
> To: Richard Whalen; [email-masked]
> Subject: Re: Latest sftp draft-draft...
> 
> 
> I suppose it might make implemenation easier.  It
> isn't really depreciated though, because using it
> undefined.  (There is no specification of what the
> structure would look like if it was specified.)
> 
> What I have done is move OWNERGROUP to the
> end and give it value 0x0000080, which leaves
> 0x00000002 undefined.  I added the following
> paragraph:
> 
>     In previous versions of this protocol flags value
>     0x00000002 was SSH_FILEXFER_ATTR_UIDGID.  This value
>     is now unused, and OWNERGROUP was given a new value
>     in order to ease implementation burden.  0x00000002
>     MUST NOT appear in the mask.  Some future version of
>     this protocol may reuse flag 0x00000002.
> 
> 
> Does this work for you?
> 
> Thanks,
> 
> - Joseph
> 
> ----- Original Message -----
> From: "Richard Whalen" <[email-masked]>
> To: "'Joseph Galbraith'" <[email-masked]>; 
> <[email-masked]>
> Sent: Monday, October 07, 2002 09:25
> Subject: RE: Latest sftp draft-draft...
> 
> 
> > I like the new text names for OWNER and GROUP, but I don't 
> think that we
> > should reuse the old UIDGID flag value since the 
> representation of the
> data
> > present has changed significantly.  I think a better choice 
> would be to
> > deprecate the UIDGID bit and use a previously unused on for 
> OWNERGROUP.
> >
> > ----------------------
> > Richard Whalen
> > Process Software
> >
> >
> >
> >
> 
>

---

From: Richard Whalen <[email-masked]>
Date: Tue, 8 Oct 2002 09:40:07 -0400

I had misinterpreted it as an extended command, rather than as information
from server to client.

> Sent: Monday, October 07, 2002 5:34 PM
> Since the "newline" extension is sent as part of the
> servers version packet to the client, there is not
> response.
> 
> Since it is sent to the client, there is no request
> id to put in a status or SSH_FXP_EXTENDED_REPLY.
> 
> So basically, extensions sent as part of the
> server version packet are always "informational".
> 
> Any other extension must be initiated by the client.
> (Well, excpect ATTR extensions.)
> 
> - Joseph
>