Subject: RE: Latest sftp draft-draft...

From: Richard Whalen <[email-masked]>
Date: Tue, 15 Oct 2002 13:49:54 -0400

The response message to a "text-seek" is not specified.
A SSH_FXP_STATUS message with SSH_FX_OK or SSH_FX_OP_UNSUPPORTED seems like
the appropriate response.

-----Original Message-----
From: Joseph Galbraith [mailto:[email-masked]]
Sent: Monday, October 07, 2002 10:27 AM
To: [email-masked]
Subject: Latest sftp draft-draft...

I believe we are getting close to submitting.

Changes since the previous draft-draft:

o Change ctime to create-time.
o Reorder permissions and time fields back to their
  original order in attribute packet.
o Clarify that partial new-line sequences should
  be ignored.
o Clarify that size field represents that size
  of the file on disk, and for text mode operations,
  it does not necessarily represent the size of the
  file on the wire.
o Clarify that the offset parameter to write
  will be ignored when FXF_APPEND is specified.
o Introduce 'text-seek' extension request, and specify
  that offset fields in read and write packets are to
  be ignored when FXF_TEXT is specified.
o Add clarifying text indicating that 'parallel' read and
  write operations must be processed successfully
  on FXF_TEXT files.
o Clean up formatting and break up description of parameters
  for MKDIR & RMDIR.  Also, revise text describing when
  a RMDIR can fail.
o Run through spell checker.

- Joseph

---

From: "Joseph Galbraith" <[email-masked]>
Date: Wed, 16 Oct 2002 16:25:40 -0600

I've included the following text:

     <t>
     The response to a "text-seek" request is an
     SSH_FXP_STATUS message.
     </t>

     <t>
     An attempt to seek past the end-of-file should
     result in a SSH_FX_EOF status.
     </t>

- Joseph