Subject: sftp changes...

From: "Joseph Galbraith" <[email-masked]>
Date: Mon, 7 Oct 2002 07:50:02 -0600

One important thing to note is the change
to the way version information is sent.

I talked to many of the implementation authors
directly about this change at connectathon, but
realized it had been brought up here on the list.

Previously, when the server sent its version
packet, it sent the lower of its version and
the clients version (so if the client supported
a lesser version, it echoed the clients version.)

In the current draft, the server responds with
its protocol version, and then both the client
and server use the lower of the two version numbers
sent on the wire.

This is mostly useful for debugging, where knowing
what the servers version is might be useful.

(Though I will admit, it is a bug in our implementation
as well...)

Is this going to cause problems for implmentators?  Do
currently shipping clients check the server response
to make sure it isn't higher than what they sent?

Thanks,

- Joseph

---

From: Simon Tatham <[email-masked]>
Date: Mon, 07 Oct 2002 15:29:52 +0100

> to make sure it isn't higher than what they sent?

PuTTY does, at the moment.

Cheers,
Simon
-- 
Simon Tatham         "That all men should be brothers is a
<[email-masked]>    dream of people who have no brothers."

---

From: "Joseph Galbraith" <[email-masked]>
Date: Mon, 7 Oct 2002 08:33:51 -0600

Well, perhaps we should back out this change then.

If I understand you correctly, an old putty would
disconnect or otherwise misbehave with a server
implementing the new draft, because the server
would send '4' instead of putty's version?

If this is the case (which is perfectly reasonable,
since the old draft specified that the server should
return putty's version in this case), I think we should
not make this change.

I mostly wanted to make it because it seemed more useful
to me for the client to know the version the server implements
(for debugging, or, for example to issue a warning to the
user.)

Thanks,

- Joseph

---

From: Simon Tatham <[email-masked]>
Date: Mon, 07 Oct 2002 15:41:54 +0100

"Joseph Galbraith" <[email-masked]> wrote:

> If I understand you correctly, an old putty would disconnect or
> otherwise misbehave with a server implementing the new draft,
> because the server would send '4' instead of putty's version?

Yes. It should disconnect cleanly, giving the user an error message
`remote protocol is more advanced than we support'.

Cheers,
Simon
-- 
Simon Tatham         What do we want?        ROT13!
<[email-masked]>   When do we want it?     ABJ!

---

From: "Joseph Galbraith" <[email-masked]>
Date: Mon, 7 Oct 2002 08:44:48 -0600

All right, I will revert this change.

Thanks,

Joseph