Subject: RE: Latest sftp draft-draft...

From: Richard Whalen <[email-masked]>
Date: Mon, 7 Oct 2002 11:25:59 -0400

I like the new text names for OWNER and GROUP, but I don't think that we
should reuse the old UIDGID flag value since the representation of the data
present has changed significantly.  I think a better choice would be to
deprecate the UIDGID bit and use a previously unused on for OWNERGROUP.

----------------------
Richard Whalen
Process Software

---

From: "Joseph Galbraith" <[email-masked]>
Date: Mon, 7 Oct 2002 09:35:20 -0600

I suppose it might make implemenation easier.  It
isn't really depreciated though, because using it
undefined.  (There is no specification of what the
structure would look like if it was specified.)

What I have done is move OWNERGROUP to the
end and give it value 0x0000080, which leaves
0x00000002 undefined.  I added the following
paragraph:

    In previous versions of this protocol flags value
    0x00000002 was SSH_FILEXFER_ATTR_UIDGID.  This value
    is now unused, and OWNERGROUP was given a new value
    in order to ease implementation burden.  0x00000002
    MUST NOT appear in the mask.  Some future version of
    this protocol may reuse flag 0x00000002.

Does this work for you?

Thanks,

- Joseph