Subject: Changes to SFTP v6: new error messages

From: Joseph Galbraith <[email-masked]>
Date: Tue, 30 Aug 2005 07:57:06 -0600

I know we have people implementing a number of the extensions
that shipped with the latest draft, and so changes to those
are not ok.

Do we have people that have shipped other portions of the
SFTP v6 draft yet?

I would like to add two more error codes, and language that
requires implementations to interpret errors that aren't
defined by the spec as if they were SFTP_E_GENERAL_FAILURE
in order to facilitate adding addition errors in a backwards
compatible way.

I proposing adding the following text:

> Implemenations MUST map unrecognized error codes to
> SSH_FX_GENERAL_FAILURE.  Future revisions of the
> protocol will add additional error codes without
> bumping the version number.

And the following two error codes:

 > SSH_FX_OWNER_INVALID    29
 >    The principle specified can not be assigned
 >    as an owner of a file.
 >
 > SSH_FX_GROUP_INVALID    30
 >    The principle specified can not be assigned
 >    as the primary group of a file.

Thanks,

Joseph

---

From: der Mouse <[email-masked]>
Date: Tue, 30 Aug 2005 11:12:58 -0400 (EDT)

>> SSH_FX_GENERAL_FAILURE.  Future revisions of the protocol will add
>> additional error codes without bumping the version number.

I'm not sure I like making it a MUST; for example, this would seem to
prohibit using different text when reporting failure to the user
("unrecognized error #29" versus "generic FAILURE", for example).

How about
	Implementations MUST be prepared to receive unexpected error
	codes and handle them sensibly (such as by treating them as
	equivalent to SSH_FX_FAILURE).  Future protocol revisions will
	add additional error codes without changing the version number.

>>    as the primary group of a file.

They sound reasonable, but need s/principle/principal/ in the text.

/~\ The ASCII				der Mouse
\ / Ribbon Campaign
 X  Against HTML	       [email-masked]
/ \ Email!	     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B

---

From: Joseph Galbraith <[email-masked]>
Date: Tue, 30 Aug 2005 09:40:19 -0600

> 	add additional error codes without changing the version number.

This works for me.

> They sound reasonable, but need s/principle/principal/ in the text.

Thanks as always for the spelling.  (In case you hadn't noticed,
I have a problem with spelling.)

Thanks,

Joseph