Subject: RE: Changes to SFTP v6: new error messages

From: "Richard Whalen" <[email-masked]>
Date: Tue, 30 Aug 2005 09:59:59 -0400

I count 3 new error codes below - SSH_FX_GENERAL_FAILURE is not listed in the current draft, did you mean SSH_FX_FAILURE?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Joseph Galbraith
Sent: Tuesday, August 30, 2005 9:57 AM
To: [email-masked]
Subject: Changes to SFTP v6: new error messages

I know we have people implementing a number of the extensions
that shipped with the latest draft, and so changes to those
are not ok.

Do we have people that have shipped other portions of the
SFTP v6 draft yet?

I would like to add two more error codes, and language that
requires implementations to interpret errors that aren't
defined by the spec as if they were SFTP_E_GENERAL_FAILURE
in order to facilitate adding addition errors in a backwards
compatible way.

I proposing adding the following text:

> Implemenations MUST map unrecognized error codes to
> SSH_FX_GENERAL_FAILURE.  Future revisions of the
> protocol will add additional error codes without
> bumping the version number.

And the following two error codes:

 > SSH_FX_OWNER_INVALID    29
 >    The principle specified can not be assigned
 >    as an owner of a file.
 >
 > SSH_FX_GROUP_INVALID    30
 >    The principle specified can not be assigned
 >    as the primary group of a file.

Thanks,

Joseph

---

From: Joseph Galbraith <[email-masked]>
Date: Tue, 30 Aug 2005 08:23:00 -0600

> I count 3 new error codes below - SSH_FX_GENERAL_FAILURE is not listed in the current draft, did you mean SSH_FX_FAILURE?

Yep!

Thanks for the good catch.

Joseph