Subject: filexfer: Proposed revision

From: Joseph Galbraith <[email-masked]>
Date: Mon, 22 Aug 2005 22:14:16 -0600

In Section 3.3, we have the following text:

> The use of additional packet types in the non-extension
> range MUST be introduced through IETF consensus. New
> packet types to be sent from the client to the server
> MAY be introduced without changing the protocol
> version (Section 4). Because the client has no way
> to respond to unrecognized packet types, new packet
> types to be sent from the server to the client the
> client MUST not used unless the protocol version is
> changed or the client has negotiated to received them.
> This negotiation MAY be explicit, through the use of
> extensions, or MAY be implicit, by the client itself
> using a packet type not defined above.

Do we really need this much verbosity, or would the
following paragraph do:

 > The use of additional packet types in the non-extension
 > range MUST be introduced through IETF consensus.  New
 > packet types MAY be introduced without changing the
 > version where this can be done in a backwards compatible
 > way.

What do people think?

Thanks,

Joseph

---

From: "Richard Whalen" <[email-masked]>
Date: Tue, 23 Aug 2005 09:01:55 -0400

The simplified paragraph works for me.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Joseph Galbraith
Sent: Tuesday, August 23, 2005 12:14 AM
To: [email-masked]
Subject: filexfer: Proposed revision

What do people think?

Thanks,

Joseph