Subject: Re: Call for Review on draft-kanno-secsh-camellia-00

From: Simon Josefsson <[email-masked]>
Date: Mon, 26 Apr 2010 12:23:26 +0200

Satoru Kanno <[email-masked]> writes:

> Dear List,
>
> We have submitted draft of Camellia for secure shell as an individual
> draft, because we found the Camellia patch for OpenSSH.
>
> Camellia draft:
>  http://www.ietf.org/id/draft-kanno-secsh-camellia-00.txt
> Camellia patch:
>  https://bugzilla.mindrot.org/show_bug.cgi?id=1340
>
> Comments about our document would be welcome.

Thanks for writing the document.  My comments:

1) As you know, Camellia is patented by your organization, and you need
to file a patent disclosure to the IETF.  The earlier disclosures
related to Camellia are not relevant: they don't permit use for Secure
Shell.

2) It is not possible to implement your document without also reading
RFC 5646, thus I believe that document has to be a normative reference.
Alternatively, you could duplicate the necessary text.

/Simon

---

From: "Henry B. Hotz" <[email-masked]>
Date: Mon, 26 Apr 2010 14:19:19 -0700

I also note that if ssh implements gssapi-keyex then ssh can use Camellia if Kerberos implements Camellia.  In other words, this draft is not strictly necessary (though it may be desirable).

On Apr 26, 2010, at 3:23 AM, Simon Josefsson wrote:

> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

------------------------------------------------------
The opinions expressed in this message are mine,
not those of Caltech, JPL, NASA, or the US Government.
[email-masked], or [email-masked]

---

From: Nicolas Williams <[email-masked]>
Date: Mon, 26 Apr 2010 18:08:59 -0500

On Mon, Apr 26, 2010 at 02:19:19PM -0700, Henry B. Hotz wrote:
> I also note that if ssh implements gssapi-keyex then ssh can use
> Camellia if Kerberos implements Camellia.  In other words, this draft
> is not strictly necessary (though it may be desirable).

Not really.  SSHv2 uses the GSS-API only for authentication (and,
effectively, channel binding of authentication to key exchange), not for
transport portection.

Nico
--

---

From: Simon Wilkinson <[email-masked]>
Date: Mon, 26 Apr 2010 23:44:48 +0100

> I also note that if ssh implements gssapi-keyex then ssh can use Camellia if Kerberos implements Camellia.  In other words, this draft is not strictly necessary (though it may be desirable).

gssapi-keyex only authenticates the initial connection handshake. It isn't involved at all in encryption of the ssh session.

S.

---

From: Satoru Kanno <[email-masked]>
Date: Mon, 26 Apr 2010 18:29:07 +0900

Dear List,

Camellia draft:

Best regards,
Satoru

----------------------------------------------------------------------
Filename:	 draft-kanno-secsh-camellia
Revision:	 00
Title:		 The Camellia for the Secure Shell Transport Layer Protocol
Creation_date:	 2010-04-26
WG ID:		 Independent Submission
Number_of_pages: 10

Abstract:
Secure shell (SSH) is a secure remote-login protocol.  SSH provides
for algorithms that provide authentication, key agreement,
confidentiality, and data-integrity services.  The purpose of this
document is to specify the Camellia cipher as symmetric encryption
algorithm for the SSH Transport Layer Protocol.

The IETF Secretariat.
------------------------------------------------------------------------

-- 
Satoru Kanno

Security Business Unit
Mobile and Security Solution Business Group
NTT Software Corporation

e-mail: [email-masked]