Subject: [sfc] SFC Problem Statement to IESG

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 8 Aug 2014 19:48:47 +0000

Dear WG:

http://datatracker.ietf.org/doc/draft-ietf-sfc-problem-statement/ has been updated in accordance with the comments and suggestions made on the mailing list and during our recent face-to-face meeting in Toronto. The next step is to send the document to the IESG for review and approval.

For the authors of this document, please confirm to the mailing list that all relevant IPR you are aware of has been properly disclosed.

If you are on the SFC WG mailing list but are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.

Jim

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Fri, 8 Aug 2014 19:54:32 +0000

On Aug 8, 2014, at 3:48 PM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Dear WG:

As an editor, I am not aware of any IPR related to the problem statement.

Jim

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Lucy yong <[email-masked]>
Date: Fri, 8 Aug 2014 20:58:48 +0000

This definition in new version is not right.
   Network Overlay:  Locally instantiated policy and customer/network/
      service profile matching of traffic flows for identification of
      appropriate outbound forwarding actions.
Editing error?

This definition:

Service Function Chain (SFC):  A service Function chain defines an

      abstract set of service functions and their ordering constraints

      that must be applied to packets and/or frames selected as a result

      of classification.  The implied order may not be a linear

      progression as the architecture allows for nodes that copy to more

      than one branch, and also allows for cases where there is

      flexibility in the order in which services need to be applied.

      The term service chain is often used as shorthand for service

      function chain.

The marked text seems conflict each other.   Does a SFC need the flexibility in the order of abstract set of SFs?

Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, August 08, 2014 2:49 PM
To: [email-masked]
Subject: [sfc] SFC Problem Statement to IESG

Dear WG:

Jim

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Fri, 8 Aug 2014 21:05:57 +0000

On Aug 8, 2014, at 4:58 PM, Lucy yong <[email-masked]<mailto:[email-masked]>> wrote:

Yes indeed, thanks for catching that.

This definition:

      function chain.

That is the same defn used in the arch draft.  I don’t see a conflict: the first sentence states there might be a constraints.  The 2nd simply allows for loose constraints.

Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, August 08, 2014 2:49 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] SFC Problem Statement to IESG

Dear WG:

Jim

---

From: Lucy yong <[email-masked]>
Date: Fri, 8 Aug 2014 21:18:13 +0000

[snip]
This definition:

      function chain.

That is the same defn used in the arch draft.  I don't see a conflict: the first sentence states there might be a constraints.  The 2nd simply allows for loose constraints.
[Lucy] OK, I see latest version arch doc having the same definition. Then I question: do we need that? What does the SFC graph in figure 1 mean in the second case? The order of SFs can be changed in any way? Don't know if people read the new ver. of arch doc yet and realize this change from last ver.. Is there a use case to drive this flexibility?

Lucy

Lucy

Dear WG:

Jim

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Sun, 10 Aug 2014 09:20:52 -0400

No IPR from me.

On Aug 8, 2014:3:48 PM, at 3:48 PM, Jim Guichard (jguichar) <[email-masked]> wrote:

> [email-masked]

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 13 Aug 2014 09:04:22 +0000

Hi Jim and all,

I had posted some comments on PS draft, and did not see any response from the authors:
http://www.ietf.org/mail-archive/web/sfc/current/msg02201.html

I would like to see them be resolved in the WG, or at least some reasons why they could not be resolved.

Thanks,
Yuanlong

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Saturday, August 09, 2014 3:49 AM
To: [email-masked]
Subject: [sfc] SFC Problem Statement to IESG

Dear WG:

Jim