Subject: [sfc] Minutes of the SFC Control Plane side meeting

From: Linda Dunbar <[email-masked]>
Date: Wed, 25 Mar 2015 15:43:06 +0000

Minutes of the SFC Control Plane side meeting
March 25, 8am-9am

Participants:
Joel Halpern, Jim Guichard, Paul Quinn, Andy Malis, Walter Haeffner, Mohamed Boucadair, Qin Wu, James Huang, Seungik Lee, and Linda Dunbar

Agreed:
SFC WG needs to document the overall interfaces for controlling service function path.
Agreed the following interfaces for control plane.

SFC  Control Plane  Architecture

                         +-------------+
                         | SF Client   |
                         +------+------+
                                | M1: interface to clients
+--------------------------------------------------------------------+
|SFC Management, compute, and control  components                    |
|                                                                    |                                                                    +---------+--------------------------+------------------------------++
          C1                         |C2                            |F2
   +------|--------------------------|---------------------------+  |
   |      |                          |                           |  |
   |      |              +-----------+-------------+             |  |
   |      |              |           |             |             |  |
   | +----+--- --+       |           |             |             |  |
   | |   SFC     |     +----+      +-|--+        +----+          |  |
   | |Classifier |---->|SFF |----->|SFF |------->|SFF |          |  |
   | |   Node    |<----|    |<-----|    |<-------|    |          |  |
   | +-----------+     +----+      +----+        +----+          |  |
   |                     |           |              |            |  |
   |                     |        -------           |            |  |
   |                     |       |       |     +-----------+ F1  |  |
   |                     V     +----+ +----+   | SF  Proxy |-----+  |
   |                           | SF | |SF  |   +-----------+     |  |
   |                           +-+--+ +-+--+                     |  |
   |                             |F     |F                       |  |
   |  SFC Data Plane Components  +------+------------------------+--+
   |                                                             |
   |-------------------------------------------------------------+

The SFC control plane architecture will specify the interfaces for

-          Classifier

-          SFF

-          Service functions (and SF proxy)
And will specify the content to be exchanged over each interface for controlling Service Function Path establishment and alternation due to SFC policy change or SF/network failures.

We are looking for comments from the community with regard to this proposed SFC control plane architecture.

Agreed that IETF 93 Prague meeting will allocate a dedicated slot for control plane discussion.

Cheers,

Linda Dunbar

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Sun, 29 Mar 2015 01:18:32 +0000

Hi Linda,

Thank you for these minutes. However, a couple of clarification.

  1.  We agreed that our charter calls for "Informational document defining the control plane requirements for conveying information between control or management elements and SFC implementation points”. This means we need to work on the requirements for any interfaces and not work on the interfaces themselves.
  2.  We agreed to document what information might need to be exchanged but did not agree to actually define specific content.

Jim

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 25, 2015 at 11:43 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Jim Guichard <[email-masked]<mailto:[email-masked]>>, Thomas Narten <[email-masked]<mailto:[email-masked]>>
Subject: Minutes of the SFC Control Plane side meeting

Participants:

Agreed:

                         +-------------+
                         | SF Client   |
                         +------+------+

-          Classifier

-          SFF

Cheers,

Linda Dunbar