Subject: [sfc] SFC Traceroute

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Mon, 23 Mar 2015 23:05:56 +0000

New version of SFC Traceroute.

Thanks to those in the hackathon that tested it.

On 3/23/15, 6:03 PM, "[email-masked]" <[email-masked]>
wrote:

>
>A new version of I-D, draft-penno-sfc-trace-02.txt
>has been successfully submitted by Reinaldo Penno and posted to the
>IETF repository.
>
>Name:		draft-penno-sfc-trace
>Revision:	02
>Title:		Services Function Chaining Traceroute
>Document date:	2015-03-23
>Group:		Individual Submission
>Pages:		9
>URL:            
>http://www.ietf.org/internet-drafts/draft-penno-sfc-trace-02.txt
>Status:         https://datatracker.ietf.org/doc/draft-penno-sfc-trace/
>Htmlized:       http://tools.ietf.org/html/draft-penno-sfc-trace-02
>Diff:           http://www.ietf.org/rfcdiff?url2=draft-penno-sfc-trace-02
>
>Abstract:
>   This document defines a protocol that checks the liveness and report
>   the service-hops of a service path. .
>
>
>                  
>        
>
>
>Please note that it may take a couple of minutes from the time of
>submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>The IETF Secretariat
>

---

From: Jiangyuanlong <[email-masked]>
Date: Thu, 26 Mar 2015 19:30:53 +0000

Hi authors,

SFC Tracing is quite an important topic if SFC is to be deployed with any monitoring capability. So we are glad to see more interests in this field.

Some issues in this I-D:
1. No discussion or references are given with regard to SFC tracing requirements. 
2. There are some inconsistencies between the texts regarding Service Function Forwarder Behavior in Section 5 and the ODL trace implementation as described in Section 6. For example, "Address of Reporting SFF" is reported in the implementation, but when and how this address is carried in the trace report is not mentioned in the document.

We happened to have posted draft-jxc-sfc-fm almost a year ago, and described a mechanism similar to the ODL trace implementation in Section 3.2 "SFC Route Tracing" of draft-jxc-sfc-fm, that is, both SFs and SFFs are recorded in a trace reply message. 

Maybe we can work together to move it forward.

Thanks,
Yuanlong

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Reinaldo Penno (repenno)
Sent: Tuesday, March 24, 2015 7:06 AM
To: [email-masked]
Subject: [sfc] SFC Traceroute

On 3/23/15, 6:03 PM, "[email-masked]" <[email-masked]>
wrote:

>
>A new version of I-D, draft-penno-sfc-trace-02.txt has been 
>successfully submitted by Reinaldo Penno and posted to the IETF 
>repository.
>
>submission until the htmlized version and diff are available at 
>tools.ietf.org.
>
>The IETF Secretariat
>

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc