Subject: Re: [sfc] New Version Notification for draft-wu-pce-traffic-steering-sfc-06.txt

From: "Hao Wang" <[email-masked]>
Date: Fri, 13 Mar 2015 21:05:44 +0800

Hi:
  I have read this draft and think it's useful for this PCEP extensions, which can allow stateful PCE to compute and instantiate SFP.
  Several commets below:
  1. How about multi-SFP instantiate maintainance, can this stateful PCE be handled？
  2. As figure 1 show, what's the relationship between SFC control plane and stateful PCE Policy？
  3. Is there any way to manage or configue the process of instantiation of SFP?

Best Regards,
Hao

2015-03-13

Hao

---

From: Qin Wu <[email-masked]>
Date: Mon, 16 Mar 2015 02:36:56 +0000

Hi, Hao:
Thanks for your interests and valuable cmments. See my reply inline below.
-Qin
发件人: sfc [mailto:[email-masked]] 代表 Hao Wang
发送时间: 2015年3月13日 21:06
收件人: sfc
主题: Re: [sfc] New Version Notification for draft-wu-pce-traffic-steering-sfc-06.txt
Hi:
  I have read this draft and think it's useful for this PCEP extensions, which can allow stateful PCE to compute and instantiate SFP.
  Several commets below:

1.  How about multi-SFP instantiate maintainance, can this stateful PCE be handled？
[Qin]: Good question, the simply solution is to carry multiple SFP Identifier TLVs to indicate multi-SFP instantiate from stateful PCE server.
If we look for more generic way for multi-SFP handling, we may reference draft-dhody-pce-association-attr-01
http://tools.ietf.org/id/draft-dhody-pce-association-attr-01.txt
and define generic group id to do this.

2.  As figure 1 show, what's the relationship between SFC control plane and stateful PCE Policy？
[Qin]: SFC control plane is more about policy driven, In each interaction between SFC control plane and SFC data plane,
Policy will be installed or populated at data plane node. For example, each interaction between PCE server and SFC Classifier
Will lead to classification rules being installed which enable SFP selection for the traffic, each interaction between SFC controller and SFC data plane node(e.g., SFF) will lead to forwarding policy being populated at the corresponding nodes.

3.  Is there any way to manage or configue the process of instantiation of SFP?
[Qin]: This is what we try to solve in this draft and proposes a way to manage or configure of SFP instantiation process.
The basic idea is to use PCE initiated mechanism proposed in draft-ietf-pce-pce-initiated-lsp-02 and combine with SFP Identifier TLV proposed in this draft to provide SFP instantiation management.

Best Regards,
Hao

2015-03-13
________________________________
Hao