Subject: Re: [sfc] draft-quinn-sfc-nsh: relatniship with the use cases drafts

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Mon, 2 Mar 2015 15:13:46 +0000

Hi Med,

Are you suggesting that the use cases be included as references, or explicit referenced?  Perhaps a logical path forward, if NSH is adopted, that perhaps the use cases can be updated to reflect the “SFC encap”.

Paul

On Feb 25, 2015, at 10:13 AM, [email-masked]<mailto:[email-masked]> wrote:

Re-,

It is unfortunate the current NSH specification does not rely on the SFC use cases as documented by the WG.

Does this mean that those are useless? That no (common) requirements can be derived from those I-Ds to guide the specification of the NSH header?

Cheers,
Med
_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Mon, 2 Mar 2015 16:15:25 +0000

Hi Paul, Med,

In the mobile use case draft we mentioned usage and impact of metadata on SFC. We also mentioned that a NSH may be appropriate. Because at time of writing NSH was not (and is not by today) implemented in SFs, we couldn’t give an explicit example. And we were asked not to include requirements in the draft.

Walter
Von: sfc [mailto:[email-masked]] Im Auftrag von Paul Quinn (paulq)
Gesendet: Montag, 2. März 2015 16:14
An: [email-masked]
Cc: [email-masked]
Betreff: Re: [sfc] draft-quinn-sfc-nsh: relatniship with the use cases drafts

Hi Med,

Paul

Re-,

Cheers,
Med

---

From: <[email-masked]>
Date: Thu, 5 Mar 2015 07:49:00 +0000

Hi Walter, Paul,

What I'm expecting is to derive requirements from the use cases, exactly in line with what was mentioned by Stewart Bryant here: http://www.ietf.org/mail-archive/web/sfc/current/msg01751.html, especially this part:

"I assume that the plan is to write down the use cases, then to distill from

the use cases the requirements, to write the architecture (or framework)

based on the the requirements and the to write the solutions to satisfy the

requirements consistent with the architecture."

The use case I-Ds should not cite the header specification draft but the other way around: the nsh should at least include pointers to the use case I-Ds produced by the WG, and preferably motivate some of its design choices by explicit requirements derived from those use cases I-Ds.

Cheers,

Med

De : Haeffner, Walter, Vodafone DE [mailto:[email-masked]]
Envoyé : lundi 2 mars 2015 17:15
À : Paul Quinn (paulq); BOUCADAIR Mohamed IMT/OLN
Cc : [email-masked]
Objet : AW: [sfc] draft-quinn-sfc-nsh: relatniship with the use cases drafts

Hi Paul, Med,

Walter
Von: sfc [mailto:[email-masked]] Im Auftrag von Paul Quinn (paulq)
Gesendet: Montag, 2. März 2015 16:14
An: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Betreff: Re: [sfc] draft-quinn-sfc-nsh: relatniship with the use cases drafts

Hi Med,

Paul

Re-,

Cheers,
Med

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Thu, 5 Mar 2015 10:31:20 +0000

Hi,

As said, originally we had requirements derived from the individual use cases included in the mobility use case draft itself.

1) We could add these again in the use case draft. But this requires agreement by the WG (Chairs). Personally I prefer this approach.

Jim, Tom, what is your position?

2) We could check how derived requirements and functional design recommendations would fit into the requirements draft. But this may be more time consuming.

Wrt references to use cases I am fully in line with Med.

Cheers,
Walter

Gesendet mit meinem HTC

----- Reply message -----
Von: "[email-masked]" <[email-masked]>
An: "Haeffner, Walter, Vodafone DE" <[email-masked]>, "Paul Quinn (paulq)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Betreff: [sfc] draft-quinn-sfc-nsh: relatniship with the use cases drafts
Datum: Do., Mär 5, 2015 08:49

Hi Walter, Paul,

Cheers,

Med

Hi Paul, Med,

Walter

Hi Med,

Paul

Re-,

Cheers,
Med

---

From: <[email-masked]>
Date: Thu, 5 Mar 2015 12:09:41 +0000

Hi Walter,

Looks like a good plan to me.

Thank you.

Cheers,
Med

De : Haeffner, Walter, Vodafone DE [mailto:[email-masked]]
Envoyé : jeudi 5 mars 2015 11:31
À : BOUCADAIR Mohamed IMT/OLN; Paul Quinn (paulq); Jim Guichard; Thomas Narten; Jeff Napper; Martin Stiemerling; Surendra Kumar (smkumar)
Cc : [email-masked]; [email-masked]
Objet : AW: [sfc] draft-quinn-sfc-nsh: relatniship with the use cases drafts

Hi,

Cheers,
Walter

Gesendet mit meinem HTC

----- Reply message -----
Von: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
An: "Haeffner, Walter, Vodafone DE" <[email-masked]<mailto:[email-masked]>>, "Paul Quinn (paulq)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Betreff: [sfc] draft-quinn-sfc-nsh: relatniship with the use cases drafts
Datum: Do., Mär 5, 2015 08:49

Hi Walter, Paul,

Cheers,

Med

Cc : [email-masked]<mailto:[email-masked]>

Hi Paul, Med,

In the mobile use case draft we mentioned usage and impact of metadata on SFC. We also mentioned that a NSH may be appropriate. Because at time of writing NSH was not (and is not by today) implemented in SFs, we couldn't give an explicit example. And we were asked not to include requirements in the draft.

Walter

Hi Med,

Are you suggesting that the use cases be included as references, or explicit referenced?  Perhaps a logical path forward, if NSH is adopted, that perhaps the use cases can be updated to reflect the "SFC encap".

Paul

Re-,

Cheers,
Med